Prohledat stránky podpory

Vyhněte se podvodům. Za účelem poskytnutí podpory vás nikdy nežádáme, abyste zavolali nebo poslali SMS na nějaké telefonní číslo nebo abyste sdělili své osobní údaje. Jakékoliv podezřelé chování nám prosím nahlaste pomocí odkazu „Nahlásit zneužití“.

Learn More

Search engine keeps changing to firefox logo with "Search The Web", and takes me to different search engines, either Bing or Google so far. I don't want this. It used to be always set to Google, and I want it back permanently on Google. Help?

  • 4 odpovědi
  • 91 má tento problém
  • 5 zobrazení
  • Poslední odpověď od MoJo40Design

more options

Just as the above states. This is referring to the search bar on the right. I do not want to remove it, I like using it. I want it back permanently set to Google. Even if I switch it to Google in the drop-down menu, when I restart Firefox, it changes it back. Again, instead of any other search engine logo, it has a little Firefox logo, saying "Search the web" next to it in gray when no text is entered. It often gives search results with Bing, even though I've removed Bing from the installed search engines.

I've also checked the default search engine in about:config, and despite what I describe above, the default is still set to Google.

Why is this happening, and how do I fix it???? It didn't happen until the other day here, so this would be after the Firefox 6 update.

Just as the above states. This is referring to the search bar on the right. I do not want to remove it, I like using it. I want it back permanently set to Google. Even if I switch it to Google in the drop-down menu, when I restart Firefox, it changes it back. Again, instead of any other search engine logo, it has a little Firefox logo, saying "Search the web" next to it in gray when no text is entered. It often gives search results with Bing, even though I've removed Bing from the installed search engines. I've also checked the default search engine in about:config, and despite what I describe above, the default is still set to Google. Why is this happening, and how do I fix it???? It didn't happen until the other day here, so this would be after the Firefox 6 update.

Zvolené řešení

Go into your Add-ons Manager and disable the Test Pilot extensions.

Problem fixed. Someone should pay me now!

Přečíst dotaz v kontextu 👍 9

Všechny odpovědi (4)

more options

Zvolené řešení

Go into your Add-ons Manager and disable the Test Pilot extensions.

Problem fixed. Someone should pay me now!

Upravil uživatel knigitz dne

more options

Pay you for one answer?? I have answered tens of thousands of support questions without getting paid one thin dime. The only reward for helping Firefox users is emotional satisfaction.

more options

That indeed fixes it. What this tells me, however, is that Firefox is perhaps intending to include that as a permanent "feature", which will annoy the hell out of me if they do.

As such, I'll use this opportunity to send feedback to them, telling them to cut that forced "feature" off, or at least make it possible to disable it.

Upravil uživatel teh_dude dne

more options

Sometime Bing is not located in the Add/Remove programs section of the control panel.

6 Easy Steps to Remove Bing from Mozilla Firefox:

1. Click on the "inverted triangle" located to the right of the orange Bing icon.

2. Select the option "Manage Search Engines...". (A pop-up window will appear titled "Manage Search Engine List.)

3. Select "Bing".

4. Click the "Remove" button.

5. Select the desired search engine from the list.

6. Click "OK"

All Done.... :-)

Happy Searching...

Long version: https://support.mozilla.com/en-US/kb/Search%20bar?s=bing&as=s