The Firefox logo is missing from HTML file icons

After a recent migration of everything from an old PC to a new one, the Firefox logo does not appear in any of the HTML file icons on my new computer. They are all blank.… (read more)

After a recent migration of everything from an old PC to a new one, the Firefox logo does not appear in any of the HTML file icons on my new computer. They are all blank.

It apparently a problem unique to Firefox, and only involves the display of the Firefox logo. Although the icon is blank, when it is clicked, the document is opened by Firefox.

If I right-click on a blank HTML document icon and select "Properties", to the right of "Opens with:" is the Firefox logo. If I then click "OK", the Firefox logo remains in the "Properties" window, but the icon remains blank.

If I click on "Change", select "Microsoft Edge" and click "OK", the "Microsoft Edge" logo appears to the right of "Opens with:", and the HTML document icon also displays the Microsoft Edge logo.

There is a similar result when I select "Google Chrome", "Internet Explorer", or even "Notepad". The corresponding logo appears in the HTML document icons.

Any and all suggestions are welcomed.

Asked by gordonljohnson 2 days ago

Last reply by gordonljohnson 1 day ago

How to keep profiles on the same account separate

I'm trying to setup different profiles for simultaneous use (Work, Personal, Study, etc) on the same Firefox Account since I want to take advantage of the sync feature fo… (read more)

I'm trying to setup different profiles for simultaneous use (Work, Personal, Study, etc) on the same Firefox Account since I want to take advantage of the sync feature for Linux/Windows dual boot.

But I am having an issue where opening a different profile where one is already open 'bleeds', or merges, their bookmarks and themes (and probably other stuff but those are the immediately visible). The bookmarks I save in one appear in the other

I read these related issues:

https://support.mozilla.org/en-US/questions/1184891 https://support.mozilla.org/en-US/questions/1262935

and added the -no-remote flag, and indeed I get a dialogue screen to select the profile I want, but this merge keeps happening and I don't know why.

The console command I use to launch firefox is

nohup firefox -no-remote > /dev/null 2>&1 &1>/dev/null &'

and all my profile directories are located in: root directory: `/home/user/.cache/mozilla/firefox/` local directory: `/home/user/.mozilla/firefox/` in different directories with their own names.

What I am looking for, is being able to open different instances of the browser with different profiles simultaneously, and each of them having their own bookmarks/history/etc, while also syncing those so when I change the boot to Windows.

I am trying this on Linux (Lubuntu) Any help will be appreciated.

Asked by agustinmarcelodominguez 3 days ago

Last reply by agustinmarcelodominguez 2 days ago

PC vs. Tablet switches randomly

Everytime I go to my bank, it's a crapshoot as to whether it thinks I'm a tablet / phone or a PC. And, I'm using a PC. I can't do things in tablet mode that I can do when… (read more)

Everytime I go to my bank, it's a crapshoot as to whether it thinks I'm a tablet / phone or a PC. And, I'm using a PC. I can't do things in tablet mode that I can do when I get it to see if I'm a PC. I know I'm screwed when it suggests that I download the app because I can do more there.  :(

And, I am still trying to figure out why, and how I'm able to get it to change it's mind! And, there's no "desktop mode" on the menu anymore, so I can't force it that way. It's really frustrating when I'm trying to reconcile my bank. I can't click on the Cleared button in "tablet" mode. I used to see it on my 360 convertible, and figured it was hardware based. But, now it's a straight laptop, no tablet mode.

Help? --Jan

Asked by jdelucien 7 hours ago

Last reply by jdelucien 5 hours ago

Firefox Default screen(Linux)

Using Firefox default screen for Linux, how do I prevent search characters from being automatically entered on address bar when typing search characters on search bar. I … (read more)

Using Firefox default screen for Linux, how do I prevent search characters from being automatically entered on address bar when typing search characters on search bar. I only want search letters entered on search bar. I like to search with search bar only, not address bar. Is there a way to fix that or is it just something you have to live with?

Asked by jogger60 6 days ago

Last reply by jogger60 6 days ago

Firefox stops working after a few minutes or open tabs

I have used Firefox for many years, but last year it started to stop working for no obvious reason and after playing around with it for a while I started using another br… (read more)

I have used Firefox for many years, but last year it started to stop working for no obvious reason and after playing around with it for a while I started using another browser. However, I am Firefox user at heart and so recently installed the latest version (89). However, the same problem exists. I have:

- started in safe mode - eliminated all extensions - I am using a completely new profile

I can start up Firefox and it works for a few minutes , then with 4+ tabs open (not sure if that is relevant) it stops work - tabs don't load. I can write in the address bar, but nothing will then load up.

When I close the browser down it appears to close down normally, but when I restart (immediately or minutes later) I get a box saying an "Firefox is already running but not responding. The old Firefox process must be closed to open a new window."

Is it a sync problem?

Look forward to getting any help/suggestions.

Rob

Asked by robdover 1 week ago

Last reply by robdover 6 days ago

New Floating Tab Look

Hello My desktop Firefox (iMac) did an automatic update and now I have the floaty tab redesign and I intensely dislike it. Is there a way to make the tabs look like how t… (read more)

Hello My desktop Firefox (iMac) did an automatic update and now I have the floaty tab redesign and I intensely dislike it. Is there a way to make the tabs look like how they did before? I am so unhappy. It's ugly and I can't tell the tabs apart very well (they have no dividing graphics). I am this close ---><--- to Time Machining myself back to the previous Firefox version. Help? Thanks Elizabeth

Asked by realityminus3 1 week ago

Last reply by realityminus3 6 days ago

2FA Encrypted account forgotten password

I started a Authy 2FA account. I forgot my backup password so can't access the token. Authy said i should request that you delete the 2FA from my account. Can you please … (read more)

I started a Authy 2FA account. I forgot my backup password so can't access the token. Authy said i should request that you delete the 2FA from my account. Can you please delete. or can you point me in direction of where i need to go to resolve it as i can't find a contact form or email anywhere Thank you

Asked by PsYAuM 6 days ago

Last reply by PsYAuM 5 days ago

youtube not loading correctly

For the last week or so I've been having a frequent problem with YouTube not loading-see attached screen shot. Sometimes reloading the page works, but, not all the time.… (read more)

For the last week or so I've been having a frequent problem with YouTube not loading-see attached screen shot. Sometimes reloading the page works, but, not all the time. Cookies and cache are cleaned several times a day. I have the same issue, but, much less frequently in Chrome. So I'm not sure if this is a browser problem or a YouTube problem. I appreciate anyone's comments. Thanks

Asked by arejfour 1 week ago

Last reply by arejfour 5 days ago

How to detect x-frame-options when loading a website in iframe

Loading external website in an iframe is getting blocked because of x-frame-options in response headers. I want to detect what is the value for x-frame-options and based … (read more)

Loading external website in an iframe is getting blocked because of x-frame-options in response headers. I want to detect what is the value for x-frame-options and based on that value i want to show an alert to the user. How can we detect/extract x-frame-options from the response headers for the given url even if it has redirects?

Asked by Naresh Gunda 3 days ago

Last reply by Naresh Gunda 2 days ago

HDMI Audio Not Woring in Firefox.

Here's the problem: when I try to play a Youtube or other video in Firefox, the sound cuts out after 1 second. Then silence. I have tried everything. I updated drivers.… (read more)

Here's the problem: when I try to play a Youtube or other video in Firefox, the sound cuts out after 1 second. Then silence.

I have tried everything. I updated drivers. I tried fixing sound in the sound settings. Nothing works.

This seems only to be a problem with the HDMI output, as it seems fine when I use Bluetooth. However, it is only a problem with Firefox, because it works fine in Chrome and Edge.

Asked by r.thomas.wright 2 days ago

Last reply by r.thomas.wright 1 day ago

Disabling "mute tab" icon doesn't work.

I read this article: https://support.mozilla.org/en-US/questions/1092509 And i switch "browser.tabs.showAudioPlayingIcon" to "false" and restart the browser. But I am st… (read more)

I read this article: https://support.mozilla.org/en-US/questions/1092509

And i switch "browser.tabs.showAudioPlayingIcon" to "false" and restart the browser. But I am still able to turn off the sound by clicking the icon on the tab. The config option is still set to "false".

What is the proper way to disable mute icon on tabs?

Firefox 89.0.1 (64 bit)

Asked by Baal101 1 day ago

Last reply by Baal101 1 day ago

cannot search in address bar

Hello everyone, I have been having an annoying problem in Fireforx (v.89.0) running on Fedora 33. In the past when I clicked in the address bar and typed in words to sear… (read more)

Hello everyone,

I have been having an annoying problem in Fireforx (v.89.0) running on Fedora 33. In the past when I clicked in the address bar and typed in words to search for Firefox used Google and returned with search results. Now, when I try to do the same the search does not do anything, it just stays on the same page. This is in spite that the search setting is being set: "Use the address bar for search and navigation" and the default search engine is set to: "Google"

Any help with how can I get back the correct behaviour would be appreciated.

Thank you, Lel

Asked by eorylel 3 days ago

Last reply by eorylel 1 day ago

Stop inactive tabs from throttling down/ timing out

Hi I run a program called nodered on a raspberry pi in docker. I use a browser to reach the user interface via lan. If that tab sits in the background too long (~5 min) t… (read more)

Hi I run a program called nodered on a raspberry pi in docker. I use a browser to reach the user interface via lan. If that tab sits in the background too long (~5 min) the connection with the server resets and resets the gui.

I lose all current debugging information and any unsaved changes. Saving the page will stop the lost progress but not the current debugging. In other words just saving the page each time will only solve 1/2 of the problem.

Is there anyway to keep a background page active so it doesn't reset after a few minutes?

https://nodered.org/

Asked by mikeyfila 23 hours ago

Last reply by mikeyfila 20 hours ago

After 89.0.1 update on Windows, Firefox will not release the audio device, not allowing the computer to sleep.

Since the 89.0.1 update on Windows 10 21H1 (Build 19043.1055), Firefox will not let my PC sleep, unless I quit and re-open Firefox. There is no audio playing on any tabs,… (read more)

Since the 89.0.1 update on Windows 10 21H1 (Build 19043.1055), Firefox will not let my PC sleep, unless I quit and re-open Firefox. There is no audio playing on any tabs, but after a while of using Firefox on YouTube or whatnot, it will not release the audio device to let Windows put my monitors to sleep even though all playback has ended.

This can clearly be seen by running "powercfg /requests" as an administrator.

With videos playing, as expected Firefox reserves the audio device, as well as an Execution request.

Output: [ PS C:\WINDOWS\system32> powercfg /requests DISPLAY: [PROCESS] \Device\HarddiskVolume6\Program Files\Mozilla Firefox\firefox.exe display request

SYSTEM: [DRIVER] High Definition Audio Device (HDAUDIO\FUNC_01&VEN_10EC&DEV_0900&SUBSYS_10438581&REV_1000\4&2d156fef&0&0001) An audio stream is currently in use.

AWAYMODE: None.

EXECUTION: [PROCESS] \Device\HarddiskVolume6\Program Files\Mozilla Firefox\firefox.exe non-display request

PERFBOOST: None.

ACTIVELOCKSCREEN: None. ]

But after you stop playing the video the output becomes: [ PS C:\WINDOWS\system32> powercfg /requests DISPLAY: [PROCESS] \Device\HarddiskVolume6\Program Files\Mozilla Firefox\firefox.exe display request

SYSTEM: [DRIVER] High Definition Audio Device (HDAUDIO\FUNC_01&VEN_10EC&DEV_0900&SUBSYS_10438581&REV_1000\4&2d156fef&0&0001) An audio stream is currently in use.

AWAYMODE: None.

EXECUTION: None.

PERFBOOST: None.

ACTIVELOCKSCREEN: None. ]

You can see the audio device doesn't get released, and the only resolution is to quit and restart Firefox.

This doesn't always happen, but does happen after a while.

Asked by Nabeel Rahimpour 3 days ago

Last reply by Nabeel Rahimpour 16 hours ago

Please remove, delete and deactivate account

I have and account called Leorkoche@gmail.com on my Firefox account that I’m not using anymore. Can anyone please delete the account for me? It says that it needs a verif… (read more)

I have and account called Leorkoche@gmail.com on my Firefox account that I’m not using anymore. Can anyone please delete the account for me?

It says that it needs a verification code and my Email is no longer accessible. Can someone please delete and deactivate the account for me please?

Here are some images for proof

Asked by LeoBeyene 1 day ago

Last reply by LeoBeyene 15 hours ago

Videos offered on the web.de site do not play under Firefox

Hello, I am using Windows 10 and the current version of Firefox. The videos offered on the web.de site do not play under Firefox. They start, but after about 2 seconds th… (read more)

Hello, I am using Windows 10 and the current version of Firefox. The videos offered on the web.de site do not play under Firefox. They start, but after about 2 seconds the video stops. Videos from other providers work with Firefox without problems Under Microsoft Edge the videos from web.de are played without problems. Maybe someone can help me? That would be nice!

Many greetings to the forum, Peter


Translated with www.DeepL.com/Translator (free version)

Asked by peter_goeppert 5 hours ago

Last reply by peter_goeppert 30 minutes ago

On the macbook pro 16 2019, the sound is wheezing

On the macbook pro 16 2019, the sound is wheezing On youtoobe and any other sites. When I use a different browser or any apps everithing is okey. But mozilla have this pr… (read more)

On the macbook pro 16 2019, the sound is wheezing On youtoobe and any other sites. When I use a different browser or any apps everithing is okey. But mozilla have this problem. How can I fix it? Thanks

Asked by shehdh43sgg 6 days ago

Last reply by shehdh43sgg 6 days ago

Не работают локальные сертификаты безопасности

Перестали работать сертификаты безопасности. Опция "Запрашивать у OCSP-серверов подтверждение текущего статуса сертификатов" включена, сертификаты установлены, действуют … (read more)

Перестали работать сертификаты безопасности. Опция "Запрашивать у OCSP-серверов подтверждение текущего статуса сертификатов" включена, сертификаты установлены, действуют до 2030 года. Запроса при открытии сайтов не происходит. Ранее помогало удаление сохраненных данных (например zabbix.yarteleservice.ru и тп), после чего выходил запрос на сертификат, при этом если сертификат был выбран не верно, либо был отказ - повторного запроса не было, даже после перезапуска браузера. На днях браузер обновился, и теперь я никак не могу запустить свои ресурсы, требующие локальных сертификатов. Страницы выдают одно и то же сообщение:

Ошибка при установлении защищённого соединения При соединении с noc.yarteleservice.ru произошла ошибка. PR_CONNECT_RESET_ERROR Страница, которую вы пытаетесь просмотреть, не может быть отображена, так как достоверность полученных данных не может быть проверена."

Как мне вернуть запросы сертификатов?

Asked by fasinfo 2 days ago

Last reply by fasinfo 2 days ago