Kukhonjiswa imibuzo ethegiwe: Veza yonke imibuzo
  • Kusonjululiwe
  • Okugcinwe kunqolobane

Gmail's upcoming OAuth2 requirement

I've been running TB38/linux for a long time and have many extensions and .css entries. In order to comply with gmail's upcoming OAuth2 requirement, I just installed TB9… (funda kabanzi)

I've been running TB38/linux for a long time and have many extensions and .css entries. In order to comply with gmail's upcoming OAuth2 requirement, I just installed TB91 and copied over the contents of my TB38 profile into the newly-created profile.

Imagine my disgust to find that none of my .css entries (mostly involving fonts not dealt with in the preferences) and most of my extensions and colors are inoperative. I've been tweaking TB since it was Netscape .9 and appearance and LEGIBILITY (Arial bold) is really important for something that I use for many hours per day. Quite frankly, I hate this new version. If I have to I will use it in order to avoid losing my SORTED email going back to 1995, but I'll do it resentfully.

It has been my experience that with each update I lose something of value to me -- hence my stop at V38. What is the oldest version of Thunderbird/linux that will satisfy gmail's OAuth2 requirement?

I'm sure I'm not the only one wondering...

Asked by bashley101 2 iminyaka edlule

Answered by bashley101 2 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Gmail with Thunderbird using OAUTH2 - not Connecting nor creating a Cookie

This is my first post. But I have been reading and benefiting from all the expertise I have found here for many years! Thanks to all! Trying to plan ahead for the Gmai… (funda kabanzi)

This is my first post. But I have been reading and benefiting from all the expertise I have found here for many years! Thanks to all!

Trying to plan ahead for the Gmail OAUTH2 change, I upgraded to Tbird 91.9.0.

My Account Settings all transferred to the new version. I do have multi Gmail accounts, as well as other email accounts, but from other posts here, this should matter.

While I am a long term Tbird user, I am a newbie with OAUTH2. I can't seem to connect. So I am writing here for help!

My setup: - Dell notebook running W10 - internet connection strong - am using a Netgear Nighthawk Hotspot Router, which works great with

    everything else, so I really doubt that is an issue

- testing without a firewall; running McAfee - resetting Tbird account back to "Normal Password", then Gmail connects

Incoming Server set to IMAP: imap.gmail.com:993 w SSL/TLS and OAuth2 Outgoing: smtp.gmail.com:465 w SSL/TLS and OAuth2

I have been consistently testing with the same gmail account: - YES, I know my password; it works with both the Gmail web interface,

   or after going back to "Normal Password" instead of OAUTH2

- allow any Alert emails via Gmail Web Interface, repeatedly. - Ran Captcha ... many times! In case someone else reading here needs this, it is here: https://accounts.google.com/b/0/DisplayUnlockCaptcha and you must be logged into the Gmail Web Interface when running this. I have learned to take a pause after running this, for it do its thing.

If Toad-Hall is reading this, I found your list of steps here very helpful: https://support.mozilla.org/en-US/questions/1375558 Worth repeating for others who are struggling, like me.

As recommended here: https://support.mozilla.org/en-US/questions/1373706 Cookies: all cleared Remembered Passwords: all cleared

Also looked at this: https://support.mozilla.org/en-US/questions/1375702 Originally, my cookies WERE blocked. I did need to change my Web Content as recommended in this post:

   Selected: Remember web sites and links I've visited
   Selected: Accept cookies from sites
   Accept third-party cookies: Always
   Keep until : they expire
   Not selected: 'Send web sites 'Do not track'..... 

Also: In Privacy and Security -> Web content -> Exceptions, added: https://accounts.google.com set to 'Allow' and Saved Changes. Then exit Tbird, took a short pause, started Tbird again, per the advice to properly update the files.

Should I be doing BOTH of these? This post shows options: https://support.mozilla.org/en-US/kb/automatic-conversion-google-mail-accounts-oauth20 So if I Select to accept cookies, should I also set the Exception??? I have tested various combinations of these settings, but not seeing a cookie.

In Tbird, when testing to connect, I see:

"Sign in with your Google Account" Enter my account password (I see an error msg here when I typo the password, no error when entered correctly) Also, have checked "Stay Signed In" while trying to Authorize, as recommended. then click Allow on the second screen.

After a few seconds, keep seeing popup in lower right corner of screen: "Authentication failure while connecting to server imap.gmail.com" Sometimes, this msg does not popup, which seems odd to me, but it still fails: Cookies: still empty Password: still empty

I keep updating and reading and updating the setups and testing again, but no cookies for me!


I admit I have gotten off track, testing and reading posts:

Thought my problem might involve Certificates for a while, but now do not think OAUTH2 is using Certificates. Right?

Thought for a bit it might be Javascript disabled, but I am NOT seeing the popup window that shows this error, from this post: https://support.mozilla.org/en-US/questions/1373379 refers to: https://support.mozilla.org/en-US/questions/1286410 Did find my way to Config editor: https://support.mozilla.org/en-US/questions/1349136 Followed this advice: "Click the 3-bar menu icon, Preferences, and find Config. editor at the bottom of the General section. Or, type editor in the search box at the top of Preferences." Then searched for "Javascript" and found most of settings were true, like javascript.enabled is "true". Should everything that a search for javascript finds be set to true? Since I do not see the error msg, I believe this is not my problem.


Stans posted another helpful summary here: https://support.mozilla.org/en-US/questions/1375538 "After you've changed your accounts to OAuth2, delete all records of your Google Account passwords from Thunderbird's password vault (Saved Passwords). With OAuth2, your passwords are not stored by Tbird. Instead, an OAuth2 token (a long string of meaningless characters) is stored in the password field. That's what you should see after completing the OAuth2 process for each of your accounts. You have to do it twice, once for incoming and once for outgoing server. Also, you must allow cookies in Thunderbird's Preferences, otherwise it won't work."

If I am following this correctly, after testing to try and authenticate, I should see a Cookie and a Saved Password being created but they are not.

Think this is my problem!


In Gmail web interface, I am not sure of some settings:

In Manage Your Google Account -> Security:

1. Should Sign-in 2-step verification be on/off? (its off) 2. Third Party apps w access shows Tbird (think this is new, don't recall it before) 3. Allow Less Secure App: turn off (was On for normal pswd; either way fails w OAUTH2) (think I have tested all combinations of the above, with no success) I welcome suggestions on how I should set these to connect with OAUTH2.

I feel like I am getting close here, but I am stuck. Is there anything else, maybe something I have not heard about, like Captcha, that I should try?

Have I missed a setting somewhere? Suggestions???

Meadowlark13

Asked by Meadowlark13 2 iminyaka edlule

Answered by Toad-Hall 2 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Password missing for default outgoing SMTP server

Network Solutions upgraded their email, and I multiply-checked all my settings in Thunderbird (102.3.2) and can retrieve mail but the outgoing mail hangs and time out wit… (funda kabanzi)

Network Solutions upgraded their email, and I multiply-checked all my settings in Thunderbird (102.3.2) and can retrieve mail but the outgoing mail hangs and time out with an error. I just discovered it's not my settings, but there's no password listed for the default outgoing SMTP server (my own domain). (I have 2 email accounts, and listed in the "Saved Passwords" are 2 passwords for incoming IMAP plus one the other account outgoing SMTP, 3 total.)

Is there any way to add a password without deleting the default server and then adding it back in, or some other solution?

Thanks

Asked by bnruben 1 unyaka odlule

Answered by david 1 unyaka odlule

  • Ikhiyiwe
  • Okugcinwe kunqolobane

Thunderbird keeps saying the Network Solutions email certificates are bad

TB 102.5.0 (64-bit) on Win10 I'm getting repeated notices that my e-mail accounts with Network Solutions don't have a proper "certificate" when I try to send an email. I… (funda kabanzi)

TB 102.5.0 (64-bit) on Win10 I'm getting repeated notices that my e-mail accounts with Network Solutions don't have a proper "certificate" when I try to send an email. I get a popup window stating so, and asking me to "permanently" choose the exception. It doesn't matter how many times I tell the fool thing to accept the exception "permanently". I still keep getting the notice every few times. Since the glitch is not consistent, I don't have an image of one to put here. Not only that, I have to send the email twice after doing so. TB refuses to send the email the first time after choosing the exception, but allows it the second. I don't know anything about "certificates" and am sick of getting popup notices about them. I doubt that the problem is with Network Solutions email accounts. This reminds me of years ago, when I tried to upgrade to WinXP. It kept interrupting my work to give me popup security notices that I didn't understand and couldn't do anything about. If I remember correctly, I took it back to Sam's Club and replaced it with Win2000. Problem solved. Never mind that XP was supposed to be better. If it ain't broke, don't fix it.

Asked by business11 1 unyaka odlule

Last reply by Wayne Mery 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Unable to send messages

2 days ago i could send messages. now I cant. I removed the smtp address like the help section told me to after getting the "Login to account "Google Mail" " dialog bo… (funda kabanzi)

2 days ago i could send messages. now I cant. I removed the smtp address like the help section told me to after getting the "Login to account "Google Mail" " dialog box and subsequent retrying of a good password had failed... I havent changed my password and am able to login directly to gmail no problem. thunderbird has the correct /same password but still the dialog box shows. I see the 0auth password ( also attached) but its too long to copy and paste so must be gernerated by google. I tried this after I got the send message error ( also attached) and tried what it said...

Also attached are the current saved logins etc minus the smtp I deleted.... The authentication method is set to 0Auth2.

what am I missing? thanks

Asked by quanton 1 unyaka odlule

Answered by quanton 1 unyaka odlule

  • Kusonjululiwe

Thunderbird Spam Filters Question

I have Thunderbird 115.8.0 installed on my MacBook Pro with two email accounts, Yahoo and Gmail. I have set up the Tools/Message Filters/Block Filters as well. When I fir… (funda kabanzi)

I have Thunderbird 115.8.0 installed on my MacBook Pro with two email accounts, Yahoo and Gmail. I have set up the Tools/Message Filters/Block Filters as well. When I first launch Thunderbird all the spam shows up in my inbox, and just sits there. What I have to do is go to Tools/Message Filters at which point I'm asked to select an account. I select Yahoo (my primary account) and then "Run Filters" before anything actually happens. Then if I go back to my inbox, the spam emails start disappearing. It seems that Thunderbird does not remember the "Yahoo" selection in filters in between launches. Is there a setting I am missing, or is this just the product of having two different email accounts? Thank you.

Asked by Homer712 2 izinyanga ezidlule

Answered by Googlethunderbird 2 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Microsoft Outlook Password

Hello, I am using the latest stable release of Thunderbird client on Windows 11 and just today it's been asking me multiple times for a password to my Outlook account. I… (funda kabanzi)

Hello,

I am using the latest stable release of Thunderbird client on Windows 11 and just today it's been asking me multiple times for a password to my Outlook account. I have kept adding a one time app password through the official Microsoft website under account management but it's been asking a few times that it needs a password.

Do you know if there's been any outages to the Microsoft servers or what this issue could be related to? Is there a way I can send any logs directly to you that might help find the issue?

Thank you for your time.

Asked by Elite911 10 izinyanga ezidlule

Answered by sfhowes 10 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Can't add my bellsouth.net email address to Thunderbird

I have a bellsouth.net email account which is actually att.net hosted on yahoo.com. I'm sure that's a large part of my problem. I can't get Thunderbird to accept the ac… (funda kabanzi)

I have a bellsouth.net email account which is actually att.net hosted on yahoo.com. I'm sure that's a large part of my problem. I can't get Thunderbird to accept the account...seems to be either a credentials or server setting issue. AT&T and Yahoo support has not been able to help. And I'm all out of ideas.

Asked by jrprochaska 1 unyaka odlule

Answered by Toad-Hall 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Passwords erased and no longer remembered

I recently installed Thunderbird on a Windows 10 desktop and setup a brand new profile from scratch with multiple email accounts. It worked fine for 24hrs, with all pass… (funda kabanzi)

I recently installed Thunderbird on a Windows 10 desktop and setup a brand new profile from scratch with multiple email accounts.

It worked fine for 24hrs, with all passwords saved. Following an install of some other software (CorelDraw and Adobe Suite) the computer was rebooted. On starting Thunderbird it asked for all the account passwords again. Having entered them all, and ticked the box for password manager to remember them, none of them were saved.

I tried deleting parent.lock (which I didn't think should be present once the program has been shut down), key4.db, cert9.db and pkcs.11.txt from the profile and restarted Thunderbird. It requested all of the passwords again and again none were saved.

If anyone has any further ideas as to what could be causing the problem I would be grateful.

Asked by allan55 1 unyaka odlule

Answered by Toad-Hall 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

OAuth 2.0

Gmail is going to require OAuth 2.0 sign-in SFAIK, that means I will no longer be able to access gmail with Thunderbird. Are there plans for Thunderbird to meet the OAuth… (funda kabanzi)

Gmail is going to require OAuth 2.0 sign-in SFAIK, that means I will no longer be able to access gmail with Thunderbird. Are there plans for Thunderbird to meet the OAuth 2.0 requirement?

Asked by car-nuts 2 iminyaka edlule

Answered by christ1 2 iminyaka edlule

  • Kusonjululiwe

Password problem

Suddenly today my Thunderbird email account on my desktop won't send or receive mails until I enter the password. When I add in the correct password it doesn't accept it … (funda kabanzi)

Suddenly today my Thunderbird email account on my desktop won't send or receive mails until I enter the password. When I add in the correct password it doesn't accept it but just comes back asking for it again. I suspect it is best to change my password but don't know how to do that. Incidentally the account is working fine on my phone and tablet with the same password but not on my desktop. Can anyone help? Thanks.

Asked by Mike Gibb 4 izinyanga ezidlule

Answered by Matt 4 izinyanga ezidlule

  • Kusonjululiwe

Thunderbird is blocking my outgoing emails

Thunderbird continues to block my outgoing emails despite my best efforts. Please check my outgoing smpt server settings (attached) and let me know what I need to change.… (funda kabanzi)

Thunderbird continues to block my outgoing emails despite my best efforts. Please check my outgoing smpt server settings (attached) and let me know what I need to change. Thanks.

Asked by Bill Washburn 1 inyanga edlule

Answered by david 1 inyanga edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Account setup: Unable to log in at server. Probably wrong configuration, username or password

My PC died last week and I now have it back with a new hard drive (SSD). It's running Windows 10 and so far I have installed Firefox and Kaspersky Total Security, all of … (funda kabanzi)

My PC died last week and I now have it back with a new hard drive (SSD). It's running Windows 10 and so far I have installed Firefox and Kaspersky Total Security, all of which I used previously. I have now installed Thunderbird but am unable to access my account. The password and configuration settings have been triple checked. Any suggestions re what I can try next please?

Asked by GeoffB 1 unyaka odlule

Answered by GeoffB 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

How to remove primary access password in Thunderbird?

Hi, I have a fire2wire.com account. I use Thunderbird for all of my email correspondence. About six months ago, I started having to put my password in every time I op… (funda kabanzi)

Hi,

I have a fire2wire.com account. I use Thunderbird for all of my email correspondence. About six months ago, I started having to put my password in every time I open Thunderbird, and again when I try to send out an email. Can you tell me how to remove the password requirement?

Don djordan@fire2wire.com

Asked by djordan53 1 unyaka odlule

Answered by Matt 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

After Thunderbird update to 102 from 93, I can't receive message from some provider.

I get a message: "This POP3 server does not seem to support encrypted passwords ..." My provider use only TLS 1. In the pas I have to set security.tls.version.min to 1. … (funda kabanzi)

I get a message: "This POP3 server does not seem to support encrypted passwords ..." My provider use only TLS 1. In the pas I have to set security.tls.version.min to 1. This trick doesn't work with 102.

I also try to set security.tls.version.enable-deprecated to true : no good result.

With security.tls.version.fallback-limit set to 1 : no good result.

Any idea?

Asked by chebrou 1 unyaka odlule

Answered by chebrou 1 unyaka odlule

  • Kusonjululiwe

Having issues with Thunderbird not retaining mail account and password

I am having issues with Thunderbird not retaining my email server and passwords. Each time I want to send an email, it prompts me for the password and then tells me that … (funda kabanzi)

I am having issues with Thunderbird not retaining my email server and passwords. Each time I want to send an email, it prompts me for the password and then tells me that the email address and server don't match. I have tried numerous times to correct this, but it doesn't hold the information. It also switches the server info between accounts. I have 3 different email account and sometimes only one works correctly

Asked by tasman27 2 emasontweni adlule

Answered by sfhowes 2 emasontweni adlule

  • Kusonjululiwe

Beta SMTP Password Error

I updated my comcast password recently. Now when I try to send an email I get error about password - dialog comes up one option being reset password. When I click this … (funda kabanzi)

I updated my comcast password recently. Now when I try to send an email I get error about password - dialog comes up one option being reset password. When I click this I expect a dialog to open allowing me to enter the correct password but nothing happens.

I went to saved password dialog and removed the entries there hoping that would force Thunderbird to ask me for password - no joy.

In the Beta version how do I update SMTP password? I do not want to recreate the profile because then I lose lots of stuff - I JUST want to update the SMTP password. None of the pages I find are helping me.

Asked by Ed Fultz 4 izinyanga ezidlule

Answered by david 4 izinyanga ezidlule

  • Kusonjululiwe

Thunderbird doesn't save SMTP passwords for multiple accounts using same server, windows 11.

After changing passwords at the email provider, it asked for and saved the passwords for the incoming server. It asked for the SMTP password for the first account and sav… (funda kabanzi)

After changing passwords at the email provider, it asked for and saved the passwords for the incoming server. It asked for the SMTP password for the first account and saved that (using that username) but did not ask for or save passwords for the other accounts using the same SMTP server.

So... email can be received on three accounts but can be only sent from one. Is there some way to add the passwords?

Asked by mrpetep 4 izinyanga ezidlule

Answered by mrpetep 4 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Thunderbird does not remember passwords after upgrading old version (24.3.0) to 91.8.1

Hello! After upgrading from a very old (but perfectly working) version of Thunderbird (24.3.0 on Windows 7) to 91.8.1 (on the same Windows 7 system), Thunderbird can no … (funda kabanzi)

Hello!

After upgrading from a very old (but perfectly working) version of Thunderbird (24.3.0 on Windows 7) to 91.8.1 (on the same Windows 7 system), Thunderbird can no longer remember my passwords.

Apart from this everything in the new version works. Emails are retrieved fine when I enter the passwords manually.

Symptoms:

  • always asks me for my passwords, even when I have checked the "Use Password Manager to remember this password" checkbox.
  • no stored passwords show up in "Saved Passwords ..."
  • When I try to set a primary password (I did not use one so far), I get an error "Unable to change Primary Password".

What I tried after searching for solutions:

  • Remove files cert*.db and key*.db from my profile. Does not make any difference.

best regards

Edwin

Asked by edwin.steiner 2 iminyaka edlule

Answered by edwin.steiner 2 iminyaka edlule