Kukhonjiswa imibuzo ethegiwe: Veza yonke imibuzo
  • Kusonjululiwe

Firefox saving to /run/user/1000/docs

This morning there was an Ubuntu software update and afterwards Firefox wouldn't work, it just opened and hung without ever connecting to a website. So I uninstalled, pur… (funda kabanzi)

This morning there was an Ubuntu software update and afterwards Firefox wouldn't work, it just opened and hung without ever connecting to a website. So I uninstalled, purged and reinstalled from Ubuntu Software and everything seemed ok. However, whenever I now try to save something, for instance images, the save to directory will default to /run/user/1000/docs even though I have my downloads folder selected in settings. I can change to the directory I want to save to and it will save there, but when I next save something it will again want to go to the /run/user/1000/docs folder. Further, I find that a copy of anything I save has also been saved into that folder, creating a new sub-directory to do so. I tried clear data in settings but that didn't delete those files and they are protected in file manager so I can't delete them myself. This will fill my hard drive pretty quickly as well as being really annoying having to change the save directory every time. What can I do to rectify this? I've now got version 96.0 (64 bit) installed.

Asked by paulhurford 4 ezinsukwini ezidlule

Answered by jonzn4SUSE 3 ezinsukwini ezidlule

The display turns on when a push notification is received

When a push notification is received, the display turns on (via DPMS). Is it possible to get rid of this behavior? Is there some configuration option in Firefox in about:… (funda kabanzi)

When a push notification is received, the display turns on (via DPMS). Is it possible to get rid of this behavior? Is there some configuration option in Firefox in about:config? I can't exclude that it's not Firefox doing this, but I'm guessing it is.

Asked by zostajekni 4 ezinsukwini ezidlule

Last reply by zostajekni 3 ezinsukwini ezidlule

Please stop forcing me to restart firefox on Linux

This is pissing me off so much! I'm working and in the middle of everything I have no other option than to completely restart my browser, which can easily resolve into lo… (funda kabanzi)

This is pissing me off so much! I'm working and in the middle of everything I have no other option than to completely restart my browser, which can easily resolve into losing what I was doing, not to mention that it completely kills my workflow. STOP DOING THIS! I don't care what the reason is, you're severely hindering the usage of the app. I will decide when to restart, not the app! I have a fresh start of my system every single day, I'm sure whatever unimportant update it was this time can wait a few hours.

Asked by Lynn 4 ezinsukwini ezidlule

Last reply by jscher2000 3 ezinsukwini ezidlule

Firefox dark mode

Please I just have read lots of people here with the same problem: I want to get rid of this dark mode and there's no help at all to solve this....how can this be possib… (funda kabanzi)

Please I just have read lots of people here with the same problem: I want to get rid of this dark mode and there's no help at all to solve this....how can this be possible? Help me please, please, please !!!!

Asked by giuseppeaquino 3 ezinsukwini ezidlule

Last reply by cor-el 3 ezinsukwini ezidlule

HTTPS-Only mode setting using admx file

Hello, I am deploying Firefox to Windows 10 devices using Mozilla's latest template and I want to enable HTTPS-Only mode under "Privacy & Security" when I deploy Fire… (funda kabanzi)

Hello,

I am deploying Firefox to Windows 10 devices using Mozilla's latest template and I want to enable HTTPS-Only mode under "Privacy & Security" when I deploy Firefox using Intune. I have gone through all the options available here, but I did not find such an option.

Firefox is deployed and it takes other customization and settings changes I make. Which means my admx file is working fine.

If the option to enable HTTPS-Only mode via Intune using admx is not yet possible, I would like to know if there is a way to deploy HTTPS-Everywhere with the option "Encrypt All Sites Eligible" ON.

Thanks.

Asked by redmkzpf 3 ezinsukwini ezidlule

Last reply by redmkzpf 3 ezinsukwini ezidlule

Firefox always connected to an amazonaws server

Firefox on ubuntu 20.04 Whenever firefox is running it's always connected to some amazonaws server lsof -i GeckoMain 450324 shi 199u IPv4 5430371 0t0 TCP 10.10.10… (funda kabanzi)

Firefox on ubuntu 20.04

Whenever firefox is running it's always connected to some amazonaws server

lsof -i

GeckoMain 450324 shi 199u IPv4 5430371 0t0 TCP 10.10.100.6:39824->ec2-35-161-207-165.us-west-2.compute.amazonaws.com:https (ESTABLISHED)

I created a new profile and it's still there. I have never used sync.

Asked by extra692-red 4 ezinsukwini ezidlule

Last reply by extra692-red 3 ezinsukwini ezidlule

  • Kusonjululiwe

Some extensions not working after update to 96.0 on Linux

After upgrading to firefox-bin-96.0 on Gentoo Linux, I found that a number of extensions are malfunctioning. uBlock Origin: 1) Not blocking content. All ads appear. I see… (funda kabanzi)

After upgrading to firefox-bin-96.0 on Gentoo Linux, I found that a number of extensions are malfunctioning.

uBlock Origin: 1) Not blocking content. All ads appear. I see this error message in the console: Error: Could not establish connection. Receiving end does not exist. | content_script.js

2) Toolbar icon does not show blocked items count (probably due to above)

3) Clicking toolbar icon causes resulting popup to appear as a vertical line (normal height but just a couple of pixels wide) with no content.

4) Going to Add-on settings and choosing "Preferences" from the add-on's 3-dot menu, the resulting tab crashes.

5) After removing and re-installing the add-on, its button does not appear on the toolbar.

6) After creating a blank profile and installing the add-on, all the above still happens.

7) After downgrading to firefox-bin-95.0.1, all the above still happens.

Ghostery: 1) Works on first install (did not previously have this installed); but after restarting Firefox, no longer works.

2) Breakage symptoms similar to uBlock Origin: No blocked items counter (and no blocking). Preferences tab still works though.

Multi-Account Containers: 1) Clicking on toolbar icon opens normally-sized but empty popup.

2) Opening a site that's configured to open in a container from a New Tab page tile, the site opens but *not* in the configured container (tab edge is not highlighed in container's colour-code).

Asked by ffx3 4 ezinsukwini ezidlule

Answered by ffx3 4 ezinsukwini ezidlule

  • Kusonjululiwe

An extension installed globally for all users (in /usr/share/mozilla/extensions) does not load for an unobvious reason

I need to automate the deployment of Firefox along with the extensions. I put three extensions (uBlock, Translate Web Pages, and Auto Tab Discard) in the /usr/share/mozil… (funda kabanzi)

I need to automate the deployment of Firefox along with the extensions. I put three extensions (uBlock, Translate Web Pages, and Auto Tab Discard) in the /usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/. All extensions load normally, except Auto Tab Discard. When running firefox with the -jsconsole option, I see what the screenshot shows (the message "Invalid addon ID"). But the installation to user profile is successful. I add the extension ID to manifest.json, and get the following output in the console: addons.xpi-utils WARN addMetadata: Add-on {c2c003ee-bd69-42a2-b0e9-6f34222cb046} is invalid: Error: File /usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/{c2c003ee-bd69-42a2-b0e9-6f34222cb046} does not contain a valid manifest(resource://gre/modules/addons/XPIInstall.jsm:669:11) What can go wrong?

System: Debian 11 (bullseye) Firefox version: 91.4.1esr (amd64)

If you need any other information, please ask, I will write it down.

Asked by zostajekni 5 ezinsukwini ezidlule

Answered by zostajekni 4 ezinsukwini ezidlule

Edits can cause restart at top of large lists

When copying data from a site which contains a long list (= one requiring scrolling down), any list item which references a large jpg file causes the site to reset to its… (funda kabanzi)

When copying data from a site which contains a long list (= one requiring scrolling down), any list item which references a large jpg file causes the site to reset to its top when editing of that file is completed.

Firefox should have an option which holds a long-list file at the item most recently edited or copied. It is bothersome and unnecessary to keep scrolling down a long list every time a complex copy or edit is performed.

Example: https://species.wikimedia.org/wiki/Charaxes is a typical long list. See the figure for Charaxes boueti, for an example of a figure which, when copied as a jpg, causes the list to reset to its top.

If an edit option is not added, at least ALL edits of a long list should keep the edit location displayed. Currently, this holds only for editing of simple images, not complex, multi-item images requiring jpg formatting.

Asked by jwill1000000 4 ezinsukwini ezidlule

[LINUX] GeckoMain crazy CPU usage, behavior as if no internet access

A few days ago there was a Firefox update and this morning suddenly GeckoMain started (out of nowhere) using the CPU at 80% (which lead to the CPU fan going nuts). I open… (funda kabanzi)

A few days ago there was a Firefox update and this morning suddenly GeckoMain started (out of nowhere) using the CPU at 80% (which lead to the CPU fan going nuts). I opened the gnome system monitor and it showed that GeckoMain was overusing the CPU. There's also a process running called "Privileged Content". For as long as this additional process is running, Firefox is behaving as if there were no internet access - infinite time to load any page and if left undisturbed, after a while Firefox closes with a crash message. Also, for as long as this problem is happening, simply closing Firefox with the X button doesn't close it - GeckoMain is still running and the only way to actually close the browser is "killall GeckoMain". So I removed all extensions one by one in order to make sure it's not an extension causing this. It's not. Even after removing all extensions the problem continued which lead me to believe something in my prefs.js is causing it. There were so many things modified in about:config over the years that I have no idea which one might be causing the problem. I have uploaded the prefs.js file here, so that you can review it, if needed: https://drive.google.com/file/d/1j-EAaeBrcawRfzrIr4n9Pg6IyvM9zROV/view?usp=sharing

At the moment I'm writing this question through Waterfox bc Firefox is unuseable with this problem.

Asked by rado84 5 ezinsukwini ezidlule

Last reply by rado84 4 ezinsukwini ezidlule

Frequent crashes during videos

Firefox or the tab almost always crashes when I try to watch a video. I have already tried Memtest86 and it turned up with no problems. I went into troubleshoot mode, but… (funda kabanzi)

Firefox or the tab almost always crashes when I try to watch a video. I have already tried Memtest86 and it turned up with no problems. I went into troubleshoot mode, but now the tab crashes instead of the whole window. Help!

Asked by phsand07 4 ezinsukwini ezidlule

Last reply by Seburo 4 ezinsukwini ezidlule

why webgl on firefox is disabled?

when i searched for " WebglAllowWindowsNativeGl:false restricts context creation on this system " in google, without quotes, i saw that at certain firefox version it has … (funda kabanzi)

when i searched for " WebglAllowWindowsNativeGl:false restricts context creation on this system " in google, without quotes, i saw that at certain firefox version it has become disabled. but there is no explanation, why it was disabled.

https://support.mozilla.org/en-US/questions/1334668 "WebGL stopped working after the Firefox 88 upgrade"

https://www.reddit.com/r/firefox/comments/ky3m4l/accelerated_graphics_stopped_working_after_an/ "Accelerated graphics stopped working after an update ... firefox 84.0.1-2 -> 84.0.2-1"

somebody answers that users can enable it from about:config. i am responsible if i manually enable it. i want to know, why it become disabled.

Asked by dinar qurbanov 5 ezinsukwini ezidlule

Last reply by TyDraniu 5 ezinsukwini ezidlule

Firefox 95.0.1 "new-window" consuming all CPU

I have a problem with running Firefox v95.0.1 on Ubuntu 20.04 operating system. When I first open Firefox, process with command /usr/lib/firefox/firefox -new-window start… (funda kabanzi)

I have a problem with running Firefox v95.0.1 on Ubuntu 20.04 operating system. When I first open Firefox, process with command /usr/lib/firefox/firefox -new-window starts and taking up 100% CPU. This process doesn't stop even if after closing Firefox and after a while crash reporters says that Firefox is crashed. While the browser is open and the mentioned process is running, I can't open any web page, since it's loading infinitely. I attached here screenshots of both process details and crash reporter.

Asked by cahangirove 5 ezinsukwini ezidlule

Last reply by cahangirove 5 ezinsukwini ezidlule

Verification emails will not send to address with non-standard TLD

I tried multiple times to sign up using my email address that uses the domain @sleepy.fish. I was slightly tipped off when firefox attempted to ask if I had made a mistak… (funda kabanzi)

I tried multiple times to sign up using my email address that uses the domain @sleepy.fish. I was slightly tipped off when firefox attempted to ask if I had made a mistake entering my email... i tried multiple ways to get the verification emails send both via web client and ios app and it simply would not send. To sanity check I created a new account using an old @gmail.com address and immediately got the verification email.

I'm kinda migrating off of mega corp google products though, hence the signing up for firefox sync haha. Would be great if I could figure out how to ensure delivery of the verification email so I can complete account setup with my custom domain email

Asked by jrileyharrington 5 ezinsukwini ezidlule

DIsable HTTPS-only for unqualified hostnames?

How do I disable or add an exception for unqualified hostnames on my local LAN? e.g., LOCALHOST or HOST in HOST.EXAMPLE.COM where EXAMPLE.COM is automatically appended? … (funda kabanzi)

How do I disable or add an exception for unqualified hostnames on my local LAN? e.g., LOCALHOST or HOST in HOST.EXAMPLE.COM where EXAMPLE.COM is automatically appended? What about disabling HTTPS for a subnet, such as 198.51.100.0/24 ?

I tried adding HTTP://*.example.com and it bizarrely added two entries: HTTP://HTTP HTTP://HTTP

Asked by ldillon 5 ezinsukwini ezidlule

unable to access files from hidden directory.

Hello, Recently, I updated ubuntu to the latest version, and had set Firefox as my primary browser (as I normally did). I, however, could no longer access to the local hi… (funda kabanzi)

Hello,

Recently, I updated ubuntu to the latest version, and had set Firefox as my primary browser (as I normally did).

I, however, could no longer access to the local hidden directories, i.e.: .local, etc., with this version. I even tried to disable Firefox sandbox security, security.sandbox.content.level = 0, and changed chown/chmod to the lowest levels, but those didn't help.

The issue can be repeated via the URL in Firefox as followed:

file:///home/y2021x/.local

or any other hidden directory. I could open these files/directories in the older versions of Firefox.

Am I overlooking something? I appreciate very much if you could help me find out the solution to this problem. Thank you very much.

Asked by y2010x 6 ezinsukwini ezidlule

Last reply by jonzn4SUSE 6 ezinsukwini ezidlule

Crashes don't leave crash report

I'm struggling with firefox crashing every few days or so. Unfortunately, pretty often there is no crash report. Is there a way I can sanely get to the bottom of this? … (funda kabanzi)

I'm struggling with firefox crashing every few days or so. Unfortunately, pretty often there is no crash report. Is there a way I can sanely get to the bottom of this?

It happens to me more often with Cisco Webex than other scenarios, but there are also completely unrelated crashes.

This is Ubuntu 20.04 and standard firefox package installation. I haven't yet turned off the extensions:

 feedbro
 gnome shell integration
 stylus
 uBlock origin

I hesitate to disable them since most are important to my work.

Any help is appreciated.

Asked by quinnj 6 ezinsukwini ezidlule

Last reply by jonzn4SUSE 6 ezinsukwini ezidlule

localhost webapp development

I'm using Firefox on Ubuntu, Linux. Recently, when launching a webapp of mine on localhost (port 4200 for the record, but I don't think that's relevant to the issue), an… (funda kabanzi)

I'm using Firefox on Ubuntu, Linux. Recently, when launching a webapp of mine on localhost (port 4200 for the record, but I don't think that's relevant to the issue), and opening it in Firefox, the browser asks me in what application I want to open the localhost link. I just want to open it as a webpage, but I am forced to type "http://localhost:<port>" rather than just "localhost:<port>". It's not a major problem, but it is inconvenient to have to type "http://" everytime I want to open a local webapp in a browser window. I've looked around in Settings, and I found that "localhost" is listed as a content type under "Applications", but I'm not able to tell Firefox to not open the content in an external app. Is there a way to resolve this?

Asked by matbronk 6 ezinsukwini ezidlule

Firefox sets process sound to 100% on every new tab, new youtube video, podcast, etc

Running fedora 34, gnome. Firefox sets the process volume to 100% whenever a new youtube video plays, whenever sound on a new tab plays, even when I forward on a player … (funda kabanzi)

Running fedora 34, gnome.

Firefox sets the process volume to 100% whenever a new youtube video plays, whenever sound on a new tab plays, even when I forward on a player on website in a tab.

This is very painful on my ears at times, is there anything I can do about it?

Thank you!

Asked by lordfoom 2 emasontweni adlule

Last reply by lordfoom 6 ezinsukwini ezidlule

Firefox Theme "switches" after startup

I have this theme installed in my firefox browser (95.0.2). https://addons.mozilla.org/en-US/firefox/addon/arctic-nord-theme/ When the browser starts, the theme works for… (funda kabanzi)

I have this theme installed in my firefox browser (95.0.2). https://addons.mozilla.org/en-US/firefox/addon/arctic-nord-theme/

When the browser starts, the theme works for a second, then swithes to some darker theme automatically. If I go to Preferences and disable, then enable the theme again, it work as expectet. I have set `layout.css.prefers-color-scheme.content-override` to `1` hoping that it would pin the light theme, but it has no effect on the issue.

How can I make firefox not change to some dark theme on startup?

Asked by L 1 isonto elidlule

Last reply by L 1 isonto elidlule