Kukhonjiswa imibuzo ethegiwe: Veza yonke imibuzo
  • Kusonjululiwe

Japanese characters are not appearing. (SOLVED)

I just installed Firefox to my laptop and noticed that Japanese characters are not working. I tried to change the language from english to japanese because I thought it w… (funda kabanzi)

I just installed Firefox to my laptop and noticed that Japanese characters are not working. I tried to change the language from english to japanese because I thought it would install the characters but didn't work and rolled back to english. I need to read japanese texts in webpages.... I also checked text decoding from settings > more > text decoding. Unicode is selected and I cannot change to anything else, it is unselectible. What should I do to be able to use the browser properly?

Asked by Bond 4 izinyanga ezidlule

Answered by Bond 4 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Fonts incorrectly displaying in all bold text on some websites

On some websites the fonts are all displaying in a large bold text instead of whatever font that page is meant to use. It will revert to a default font if i turn off the … (funda kabanzi)

On some websites the fonts are all displaying in a large bold text instead of whatever font that page is meant to use. It will revert to a default font if i turn off the ability for sites to choose their own fonts, but this interferes with the functionality of a lot of sites' icons so its not a great solution. This also stops when i go into troubleshooting mode, but when i went through hardware acceleration and my extensions one by one, none of them were the cause.

images in order: my roll20 homepage with the incorrect font display, the same page with fonts disabled (note the notification icons in the upper right are broken now though), the same page in troubleshoot mode with the correct font display

Asked by Arthur 9 izinyanga ezidlule

Answered by FredMcD 9 izinyanga ezidlule

  • Okugcinwe kunqolobane

Font rendering broken for some fonts - 78.12.0esr/MacOS 110.11

Noticed a weird problem - some sites don't render their fonts, just empty space in place of text. Tried to debug it: 1. Safe mode and disabling hardware acceleration does… (funda kabanzi)

Noticed a weird problem - some sites don't render their fonts, just empty space in place of text.

Tried to debug it: 1. Safe mode and disabling hardware acceleration doesn't fix it 2. Sandbox values don't change anything 3. Tried other Mac with the same Firefox version and macOS version - same issue 4. Experimented with CSS in dev tools - issue is related to the specific font (InterVariable in this case, also saw it with OpenSans before).

As you can see on screenshots - we have InterVariable font for this specific block. If I change CSS and remove this font, replacing it with some other one like Roboto - font starts rendering fine. Interestingly enough - font preview in the dev tools works completely fine - font renders, it just is not rendering in the page itself.

As it is a Variable font and me having older MacOS 10.11 - I was suspecting that it is a bug with Variable font support, but why does it render in dev tools and why doesn't it fall back to the other supported font, if this one is not rendered?

Disallowing pages 'to use their fonts' obviously fixes it - as it activates fallback to fixed fonts, but it is not a proper fix, as it obviously messes up designs for sites and their custom fonts.

This side renders completely fine in Chrome, so it must be a Firefox issue. Upgrading macOS is not an option, so I would be fine with a fixed ESR version that works correctly.

Attaching screenshots showing debug info.

Asked by nkth 11 izinyanga ezidlule

Last reply by nkth 10 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Symbols not displayed correctly

When I open a website using special symbols, the symbols are replaced by a sign with 6 hex symbols in it. It even happens when the symbol is used in the page title (see i… (funda kabanzi)

When I open a website using special symbols, the symbols are replaced by a sign with 6 hex symbols in it.

It even happens when the symbol is used in the page title (see image). Site used: https://emojipedia.org/yawning-face/).

Interestingly, other emojis from the same site are displayed correctly (means the '01F971'-type symbol is replaced by the emoji, in all occurrences on the site and title)

I have seen multiple threads about this, even on this site. However, I could not solve it with the suggested solutions. What I have tried so far:

1. Disable addons 2. Make sure fonts are downloaded through settings 3. about:config -> gfx.downloadable_fonts.enabled -> make sure its true (4. no-script is not installed)


Any ideas?

Asked by holzweg 1 unyaka odlule

Answered by holzweg 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Numbers displaying sideways

So recently, when I open web pages, any numbers will display sideways. I reinstalled firefox, but this did not resolve. They appear correctly in other browsers (i.e., c… (funda kabanzi)

So recently, when I open web pages, any numbers will display sideways. I reinstalled firefox, but this did not resolve. They appear correctly in other browsers (i.e., chrome). Does anyone know what I can do to resolve this? Thanks!

Asked by rdaufan 11 izinyanga ezidlule

Answered by rdaufan 11 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Mozilla-provided font (I think) is just annoying/hard to read

I've read some complaints about the font that FF desktop uses on some websites. I'm seeing a very annoying font with some letters thicker (almost bold) and other letters … (funda kabanzi)

I've read some complaints about the font that FF desktop uses on some websites. I'm seeing a very annoying font with some letters thicker (almost bold) and other letters thin. This occurs, for example, on the mozilla.org website and when FF is displaying a PDF.

I have "allow pages to choose their own fonts" checked, and I am not using hardware acceleration.

I went into the developer console and turned off the Mozilla-supplied font for a support webpage, and it then used something like a Times New Roman, but it was uniform in letter thickness.

I have attached screen snips.

If I display the same page using Chrome, the font looks great, so I don't know exactly what the problem is, but it's clearly a FF problem.

Notice in Chrome that the word "garbled" is in bold, and it does not appear in bold in either of the FF font examples.

Asked by van.knowles 1 unyaka odlule

Answered by van.knowles 1 unyaka odlule

  • Okugcinwe kunqolobane

Displays Strange Characters

It displays strange characters on pages including Yahoo mail. The attached screen shot shows a bank email, but it happens with other non-secure stuff too like general web… (funda kabanzi)

It displays strange characters on pages including Yahoo mail. The attached screen shot shows a bank email, but it happens with other non-secure stuff too like general web pages. This has been happening with version 81.0 and the previous version. If I open the same page in Chrome, it will display the characters normally. I did see the strange characters appear in Chrome one time, but it happens in FF quite frequently.

Asked by Geeky1 1 unyaka odlule

Last reply by cor-el 1 unyaka odlule

  • Okugcinwe kunqolobane

Files containing Japanese characters are garbled in Firefox 68.6.0esr

After upgrading to Firefox 68.6.0esr, when we open a Japanese file with [File]->[Open], it becomes garbled and unreadable. Before upgrading, we could read the Japanes… (funda kabanzi)

After upgrading to Firefox 68.6.0esr, when we open a Japanese file with [File]->[Open], it becomes garbled and unreadable. Before upgrading, we could read the Japanese file. This file is a plain text file and the character code is ISO-2022-JP. The character code is not specified in the file. I tried to change the character code with Text Encoding menu of Firefox, but the menu is grayed out and we cannot select it. It seems that files with character codes UTF and EUC can be displayed without problems. Is there a way to correctly display a Japanese file in which no character code is specified?

Regards,


Regards,

Asked by HAYASHI Tomoko 1 unyaka odlule

Last reply by HAYASHI Tomoko 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Hexadecimal characters in Firefox, NOT in Chrome

When I open Wunderground in FF I get hexadecimal character maps for many buttons. https://www.dropbox.com/s/ci3v1ag7ppynkbw/Screen%20Shot%202020-11-22%20at%209.35.59%20P… (funda kabanzi)

When I open Wunderground in FF I get hexadecimal character maps for many buttons. https://www.dropbox.com/s/ci3v1ag7ppynkbw/Screen%20Shot%202020-11-22%20at%209.35.59%20PM.jpg?dl=0

In Chrome, they're fine: https://www.dropbox.com/s/zj855hxep7mx7rs/Screen%20Shot%202020-11-22%20at%209.30.49%20PM.jpg?dl=0

HUH?? With the Wunderground page open, the "text encoding" under the View menu is grayed out so I can't change the encoding. Suggestions?? THANKS!!!

Asked by RobertL39 1 unyaka odlule

Answered by cor-el 1 unyaka odlule

  • Okugcinwe kunqolobane

Strange look

Hi, To start with I love your browser been using and recommending it for many years. I am a service provider and have a customer that started getting this in her Firefox … (funda kabanzi)

Hi, To start with I love your browser been using and recommending it for many years. I am a service provider and have a customer that started getting this in her Firefox browser. Started a few weeks ago. Hard to describe the attachment will show more. There is a image box link. No image shows in any of them but clicked on it does go to the url. The url address is right after it. They are partially imposed over part of the description of the web site. Now my Firefox browser on my machine does not look like this. Is this a setting I need to disable to return it to normal and remove this little image box at the beginning? Or is there a problem with the browser? Thank you for your time and help. SEBassman

Asked by SERocks 9 izinyanga ezidlule

Last reply by FredMcD 9 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

WWebpage tab shows only symbols

When I visit https://online.kasikornbankgroup.com/K-Online/indexHome.jsp, and click the K-Cyber Banking tab, all I see is what is shown in attachment 1 - symbols and the … (funda kabanzi)

When I visit https://online.kasikornbankgroup.com/K-Online/indexHome.jsp, and click the K-Cyber Banking tab, all I see is what is shown in attachment 1 - symbols and the View | Text encoding is greyed out. I am unable to see my accounts. This issue started with Firefox 83.0 and people on some other forums have reported the same issue.

The tab should look more like attachment 2.

Does anyone know what is causing this, whether it is a browser problem or bank problem, and if there is a fix for it?

Asked by howiem 1 unyaka odlule

Answered by howiem 1 unyaka odlule

Appearance of Gmail in Firefox

HI After using Chrom for num of years I have now reverted (upgarded!?) for Firefox. However what's casuing me to regret my decision is the layout og Gmail in the browswer… (funda kabanzi)

HI After using Chrom for num of years I have now reverted (upgarded!?) for Firefox. However what's casuing me to regret my decision is the layout og Gmail in the browswer. Most of the labels and text are surround by a white Highlight or box which looks ugly. I have exhauste dverything I know to get the text to look like Gmail in Chrome with no success. See attached screen shot of comparison. Could you please give some idea so That I can stay with Firefox Kind regards Chris

Asked by xxchrishillxx 5 izinyanga ezidlule

Last reply by xxchrishillxx 5 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Caracter with accent does not appear on specific websites

Hello, since quite some time now, I've got a problem with some websites, https://www.20minutes.fr/ among them. With other website, it's all good. In safe mode, the displa… (funda kabanzi)

Hello, since quite some time now, I've got a problem with some websites, https://www.20minutes.fr/ among them. With other website, it's all good.

In safe mode, the display is good, but I can't seem to find the responsible for this problem. Here's two picture to show you the problem. It's the same article, one in safe mode, the other one in normal mode

I've tried to run Firefox without any add-on, but, it's the same. My é and è, and à are gone... And it's not on every website, just a few ones.

I've also tried to clean firefox, the problem remains.


Thanks in advance for your time.

Asked by Chipou 10 izinyanga ezidlule

Answered by cor-el 10 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Master password problem.

Can anyone help me with a master password issue? The box appears at the appropriate time but I am unable to enter any text into the box. I point and click in the text spa… (funda kabanzi)

Can anyone help me with a master password issue?

The box appears at the appropriate time but I am unable to enter any text into the box. I point and click in the text space but the cursor does not appear and nothing happens when I start typing.

The sign in button is grey although I can click on it and the box briefly disappears then reappears asking for the password again. The cancel button works and closes the box.

I do not have the same problem on my Android mobile and I can access my passwords on my phone but not on my Windows laptop.

Thanks in advance, Grant.

Asked by Mr G 8 izinyanga ezidlule

Answered by Mr G 8 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox blank error window, does not start

Hello, It is not the first time I got that error. I have no idea why. When I want to start Firefox, this blank window appears (see image). When I click the button or clos… (funda kabanzi)

Hello,

It is not the first time I got that error. I have no idea why.

When I want to start Firefox, this blank window appears (see image). When I click the button or close the window, nothing happens except the window being closed.

I tried to reinstall Firefox, and the autolaucher after the installation opens a Firefox window but, if I close it, I see the error window again when I try to open the program later.

I tried to reset the taskbar's shortcut with the new-one-time-only-working-window-following-the-reinstallation but this did not work.

Please, check for this error. I can not just wait for the program to be ok to run without any logical reason/explanation.

Asked by kaji 6 izinyanga ezidlule

Answered by kaji 5 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Font won't change in Gmail

The font displayed in gmail won't change using the firefox browser. It works fine in other browsers. I tried to select sans-serif normal size and it stays with a serif … (funda kabanzi)

The font displayed in gmail won't change using the firefox browser. It works fine in other browsers. I tried to select sans-serif normal size and it stays with a serif font and small size.

Asked by rjnolfe 7 izinyanga ezidlule

Answered by FredMcD 7 izinyanga ezidlule

  • Okugcinwe kunqolobane

Fonts on certain sites are odd

Certain websites font's have gone weird in Firefox, it's not reproducable on other computers just my own. I have looked through this community and run through: Set gfx… (funda kabanzi)

Certain websites font's have gone weird in Firefox, it's not reproducable on other computers just my own.

I have looked through this community and run through:

   Set gfx.canvas.azure.backends & gfx.content.azure.backends to direct2d1.1,skia,cairo
   Set gfx.font_rendering.cleartype_params.rendering_mode to 0
   Set gfx.downloadable_fonts.otl_validation to true
   Disabled hardware acceleration

Firefox Version is: 90.0.2 64-bit Windows 10 21H1 All drivers are up to date

Attached are screenshots from Chrome (what the website is meant to look like) & Firefox - I prefer Firefox over Chrome so I would rather not move.

Asked by kris0089 11 izinyanga ezidlule

Last reply by cor-el 11 izinyanga ezidlule

  • Okugcinwe kunqolobane

Font rendering issues

Hi, i have font rendering issues on some websites. I found out it has something to do with the Hardware Acceleration. When I turn it off, everyting is ok. However, th… (funda kabanzi)

Hi, i have font rendering issues on some websites.

I found out it has something to do with the Hardware Acceleration.

When I turn it off, everyting is ok.

However, then other websites which require more performance are really slow.

How can I fix the big without turning off hardware acceleration?

This website among others causes font issues with hardware acceleration ON:

https://www.lazada.vn/

Asked by Tom N 1 unyaka odlule

Last reply by FredMcD 1 unyaka odlule

  • Okugcinwe kunqolobane

Some text is covered with black diamonds and question marks

On FoxNews.com, some articles include a section at the bottom for user comments. First-level comments frequently receive additional second- and third-level comments. Fir… (funda kabanzi)

On FoxNews.com, some articles include a section at the bottom for user comments. First-level comments frequently receive additional second- and third-level comments.

First-level comments are working fine, but lower-level comments are partially obliterated with a string of black diamonds with question marks �?U��N�@?�.

This is not an issue when I use Safari, but it is on Firefox.

Asked by Prentice3 1 unyaka odlule

Last reply by Prentice3 1 unyaka odlule