Kukhonjiswa imibuzo ethegiwe: Veza yonke imibuzo

Upload speed limited on iCloud, GDrive, etc.

Hello everyone! Since the release of the new Firefox version 90 afterwards I have been using Firefox as I simply love surfing the internet with it as an alternative to ch… (funda kabanzi)

Hello everyone!

Since the release of the new Firefox version 90 afterwards I have been using Firefox as I simply love surfing the internet with it as an alternative to chrome or chromium based browsers.

However, a small problem is annoying me: when I try to upload to iCloud.com or Google Drive, especially large ones, the upload speed is limited to 10 mbps, whereas I have an upload speed of 50 mbps.

On the other hand, when I try to upload on Chrome Browser or Edge Browser to both websites, the speed gets maxed out, literally maxed out by even 55 mbps!

I even tried to upload similar sized files simultaneously to Chrome, Edge and Firefox. Chrome and Edge finished while Firefox is still stuck on one third of the upload!

The strange thing though: when I open speedtest.net and measure the upload speed, it gives me on Firefox a speed of 50 mbps!

Any idea where the problem is? Any ideas how to speed up the upload and benefit from the max speed?

I am using latest Firefox on Windows 10.

Thank you!

Asked by Anmar 5 ezinsukwini ezidlule

Firefox Detect's CTRL key depressed, when it's not.

When using Firefox, seemingly randomly the web browser will detect that the control button is pressed on the keyboard. There is nothing around the keyboard that has falle… (funda kabanzi)

When using Firefox, seemingly randomly the web browser will detect that the control button is pressed on the keyboard. There is nothing around the keyboard that has fallen on the control button, nor are sticky keys enabled in Windows 10. There been a few times now where I have been sitting back using the mouse only and Firefox to text at the control button is pressed and starts to zoom in or out because of that. The only way that I can stop it from happening is to click outside of Firefox on a different application and then go back. To attempt to fix this I've tried the following:

  1. restart firefox
  2. clear the cache, both manually and with ccleaner
  3. restarted windows
  4. checked for an update of firefox (I am at the latest version currently)
  5. diabled sticky keys in windows 10 completely
  6. tried a different keyboard

None of the above fixes have solved the problem that I am encountering. This issue does not happen in Google Chrome or any other application that I use it is specific to only Firefox. I looked for similar fixes before posting on here, and found two. One individual said that they fix this by changing their Wi-Fi adapter. I had tried to enable and disable this which had no effect. The second fix they said that they tried to restart the computer, which I have done no less than five times now in order try to solve is extremely irritating and functionality killing issue. Thanks guys.

Asked by reservesteel9 5 ezinsukwini ezidlule

Last reply by reservesteel9 5 ezinsukwini ezidlule

Firefox only slow on my website; fine on other browsers

Okay, this has been happening for months now. My site has been intermittently slow on one of my office computers. Thought is was a host issue so fought with them for we… (funda kabanzi)

Okay, this has been happening for months now. My site has been intermittently slow on one of my office computers. Thought is was a host issue so fought with them for weeks on trying new setting on the server but they could never see the issue on their end. Main problem is in the admin area of my shopping cart (CS-cart) being super slow but would also occasionally appear on the front end. Sometimes it may only happen for a few minutes, other times would happen all day (or now all week). Then office computer number 2 started having problems with my site. It was so bad (like took minutes to even pull up my site) that I had to install Chrome so orders could be printed. Been running it for a few weeks now without issue but just tried FF again and the problem still persists. I have tried clearing the cache/history on both computers and even on computer 2 completely uninstalled without storing data but still have the issue. What is more frustrating is it happens only occasionally on one computer, pretty consistent on the other and computer number 3 on the same network has no problems. Was even thinking it may be Cloudflare (browser console listings) so disabled using it but that just seemed to have fixed the issue on one computer but not the other. But everything is so random I really don't know where the problem is. All I know is using another browser for a few weeks now has fixed the issue on both computers. I should note that I am on my site constantly so I may see a few hundred pages a week (history was a 6300 on one computer when I cleared it) Anyone have any suggestions?

Asked by jacydjames 5 ezinsukwini ezidlule

Last reply by jacydjames 5 ezinsukwini ezidlule

Firefox slow: FIXED!

For my system, I went to Settings and scrolled all the way to the bottom to Network Settings and clicked Settings. This opened a Connection Settings window and the first … (funda kabanzi)

For my system, I went to Settings and scrolled all the way to the bottom to Network Settings and clicked Settings. This opened a Connection Settings window and the first section is titled Configure Proxy Access to the Internet. My installation of FF had four proxy options to choose from and mine was set to Use System Proxy Setting. I decided to check "Auto-detect proxy settings for this network" and I clicked OK at the bottom and closed the Settings tab. FF took off like a rocket! After months of using Chrome because of the extreme slowness FF had, I can now continue on with FF and zip around the internet at warp speed. I am very happy!!

Asked by Michael3442 5 ezinsukwini ezidlule

VSYNC problems (tearing) | Win 7 | Intel Extreme Graphics 2

Hi! Every online video I watch with Mozilla Firefox (92.0, 32-bit) has serious vsync/tearing problems. I tried Chrome - it doesn't have such problems. Local video player… (funda kabanzi)

Hi!

Every online video I watch with Mozilla Firefox (92.0, 32-bit) has serious vsync/tearing problems. I tried Chrome - it doesn't have such problems. Local video players (VLC, MPC etc) also do not have such problems.

Specs: Windows 7 Ultimate SP1 32-bit Intel Pentium 4 2.66 GHz D1 (no SSE3) GPU: Integrated Intel Extreme Graphics 2, Springdale-G (865G) (82865G) DirectX: SW: 11, HW: 7.0 OpenGL: SW: GLDirect, HW: 1.3 System HDD speed: 76 MB/s read, 77 MB/s write

I tried changing various related (or not) values in about:config to no luck.

Thank you in advance for any help provided! (Not for the phrases "change your specs" :))

Best regards, MBentefor

Asked by mbentefor 4 ezinsukwini ezidlule

Repeatedly reloads the workspace in MemoQWeb

As a freelance translator, my clients often assign me work through online translation software interfaces like Wordfast and MemoQWeb. I've never had trouble using these s… (funda kabanzi)

As a freelance translator, my clients often assign me work through online translation software interfaces like Wordfast and MemoQWeb. I've never had trouble using these services before. Since the update on September 7, I've been unable to work normally in MemoQWeb. When I open up a file and start translating, the workspace repeatedly reloads (every few minutes) as if I'd just opened the file. Every time this happens, it boots me back up to the first segment in the file and loses any unconfirmed input I'd been in the process of typing into the open segment at the moment of reloading. I don't have this problem in Edge (I checked), but Edge is my emergency fallback browser and isn't set up with useful translation add-ons like my Firefox account. This is slowing down my workflow a lot, and I would deeply appreciate help getting it resolved. <3

https://fuji.memoq.com/sunflare/webpm/webtrans/online-tasks/ongoing

Asked by tobuishi 4 ezinsukwini ezidlule

Linux: Small window flickering after restart

Hello there, so I usually have two Firefox windows open, both in fullscreen. When I than shutdown and restart my computer, and open Firefox again, it will create two wind… (funda kabanzi)

Hello there,

so I usually have two Firefox windows open, both in fullscreen. When I than shutdown and restart my computer, and open Firefox again, it will create two windows with the tabs I had opened before (although I didn't check "Restore previous session" in my settings), but one of those windows will be small and flickering while the other is working normally. A solution I found to stop it from flickering is to press "F11" two times to maximize it and than get it back to normal fullscreen mode.

Firefox: Version 92.0 (64-bit) Ubuntu: 20.04.2 LTS (Focal Fossa)

Thank you in advance.

Asked by simeon2 4 ezinsukwini ezidlule

Closed captions on HBOMax are appearing 50-60 seconds before the actual audio

When streaming "Cry Macho" on Windows 10, Firefox 92, with closed captions turned on, the captions appear on the screen 50-60 seconds prior to the actual audio. Tried the… (funda kabanzi)

When streaming "Cry Macho" on Windows 10, Firefox 92, with closed captions turned on, the captions appear on the screen 50-60 seconds prior to the actual audio. Tried the same with Chrome and it worked as it should so I guess it is a Firefox problem. Please advise.

Asked by pbsawin 3 ezinsukwini ezidlule

Error on every page

I keep getting errors on pages like Secure Connection Failed An error occurred during a connection to www.amazon.com. SSL received a malformed Alert record. Error code: S… (funda kabanzi)

I keep getting errors on pages like Secure Connection Failed

An error occurred during a connection to www.amazon.com. SSL received a malformed Alert record.

Error code: SSL_ERROR_RX_MALFORMED_ALERT

I have HTTPS only mode turned off but it keeps setting everything to https.

{

 "application": {
   "name": "Firefox",
   "osVersion": "Windows_NT 10.0 19043",
   "version": "92.0.1",
   "buildID": "20210922161155",
   "distributionID": "",
   "userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:92.0) Gecko/20100101 Firefox/92.0",
   "safeMode": false,
   "updateChannel": "release",
   "supportURL": "https://support.mozilla.org/1/firefox/92.0.1/WINNT/en-US/",
   "osTheme": "",
   "numTotalWindows": 1,
   "numFissionWindows": 0,
   "numRemoteWindows": 1,
   "launcherProcessState": 0,
   "fissionAutoStart": false,
   "fissionDecisionStatus": "disabledByDefault",
   "remoteAutoStart": true,
   "policiesStatus": 1,
   "keyLocationServiceGoogleFound": true,
   "keySafebrowsingGoogleFound": true,
   "keyMozillaFound": true
 },
 "securitySoftware": {
   "registeredAntiVirus": "Avast Antivirus",
   "registeredAntiSpyware": "",
   "registeredFirewall": "Avast Antivirus"
 },
 "processes": {
   "remoteTypes": {
     "web": 5,
     "extension": 1,
     "privilegedabout": 1,
     "prealloc": 1,
     "gpu": 1
   },
   "maxWebContentProcesses": 8
 },
 "environmentVariables": {
   "MOZ_CRASHREPORTER_DATA_DIRECTORY": "C:\\Users\\madwo\\AppData\\Roaming\\Mozilla\\Firefox\\Crash Reports",
   "MOZ_CRASHREPORTER_EVENTS_DIRECTORY": "C:\\Users\\madwo\\AppData\\Roaming\\Mozilla\\Firefox\\Crash Reports\\events",
   "MOZ_CRASHREPORTER_PING_DIRECTORY": "C:\\Users\\madwo\\AppData\\Roaming\\Mozilla\\Firefox\\Pending Pings",
   "MOZ_CRASHREPORTER_RESTART_ARG_0": "C:\\Program Files\\Mozilla Firefox\\firefox.exe",
   "MOZ_CRASHREPORTER_STRINGS_OVERRIDE": "C:\\Program Files\\Mozilla Firefox\\browser\\crashreporter-override.ini"
 },
 "lockedPreferences": {
   "fission.autostart.session": false,
   "security.enterprise_roots.enabled": true
 },
 "media": {
   "currentAudioBackend": "wasapi",
   "currentMaxAudioChannels": 2,
   "currentPreferredSampleRate": 48000,
   "audioOutputDevices": [
     
 "addons": [
   {
     "name": "AdBlocker for YouTube™",
     "type": "extension",
     "version": "0.3.4",
     "isActive": true,
     "id": "jid1-q4sG8pYhq8KGHs@jetpack"
   },
   {
     "name": "AdBlocker Ultimate",
     "type": "extension",
     "version": "3.7.11",
     "isActive": true,
     "id": "adblockultimate@adblockultimate.net"
   },
   {
     "name": "Amazon.com",
     "type": "extension",
     "version": "1.3",
     "isActive": true,
     "id": "amazondotcom@search.mozilla.org"
   },
   {
     "name": "Avast AntiTrack Premium",
     "type": "extension",
     "version": "1.6",
     "isActive": true,
     "id": "antitrack@avast.com"
   },
   {
     "name": "Bing",
     "type": "extension",
     "version": "1.3",
     "isActive": true,
     "id": "bing@search.mozilla.org"
   },
   {
     "name": "DuckDuckGo",
     "type": "extension",
     "version": "1.1",
     "isActive": true,
     "id": "ddg@search.mozilla.org"
   },
   {
     "name": "eBay",
     "type": "extension",
     "version": "1.3",
     "isActive": true,
     "id": "ebay@search.mozilla.org"
   },
   {
     "name": "Google",
     "type": "extension",
     "version": "1.1",
     "isActive": true,
     "id": "google@search.mozilla.org"
   },
   {
     "name": "Hoxx VPN Proxy",
     "type": "extension",
     "version": "3.11.0",
     "isActive": true,
     "id": "@hoxx-vpn"
   },
   {
     "name": "Touch VPN - Secure and unlimited VPN proxy",
     "type": "extension",
     "version": "4.2.1",
     "isActive": true,
     "id": "touch-vpn@anchorfree.com"
   },
   {
     "name": "Video Downloader Prime",
     "type": "extension",
     "version": "0.2.5",
     "isActive": true,
     "id": "jid1-i6dUGvCrz2WZu8@jetpack"
   },
   {
     "name": "Video DownloadHelper",
     "type": "extension",
     "version": "7.6.0",
     "isActive": true,
     "id": "{b9db16a4-6edc-47ec-a1f4-b86292ed211d}"
   },
   {
     "name": "Watch2Gether",
     "type": "extension",
     "version": "8.1",
     "isActive": true,
     "id": "{6ea0a676-b3ef-48aa-b23d-24c8876945fb}"
   },
   {
     "name": "Wikipedia (en)",
     "type": "extension",
     "version": "1.1",
     "isActive": true,
     "id": "wikipedia@search.mozilla.org"
   }
 ],
 "features": [
   {
     "name": "DoH Roll-Out",
     "version": "2.0.0",
     "id": "doh-rollout@mozilla.org"
   },
   {
     "name": "Firefox Screenshots",
     "version": "39.0.1",
     "id": "screenshots@mozilla.org"
   },
   {
     "name": "Form Autofill",
     "version": "1.0.1",
     "id": "formautofill@mozilla.org"
   },
   {
     "name": "Picture-In-Picture",
     "version": "1.0.0",
     "id": "pictureinpicture@mozilla.org"
   },
   {
     "name": "Web Compatibility Interventions",
     "version": "25.4.0",
     "id": "webcompat@mozilla.org"
   },
   {
     "name": "WebCompat Reporter",
     "version": "1.4.2",
     "id": "webcompat-reporter@mozilla.org"
   }
 ],
 "normandy": {
   "addonStudies": [],
   "prefRollouts": [],
   "prefStudies": [],
   "nimbusExperiments": [],
   "remoteConfigs": []
 },
 "modifiedPreferences": {}

}

Asked by ijones_fall12 3 ezinsukwini ezidlule

Last reply by ijones_fall12 2 ezinsukwini ezidlule

Bookmarks menu slow to load/respond since last update

Since the last Firefox update (92.0.1 64-bit), my bookmarks menu is slow to load, and also slow for navigating. It's slow to load the list when I open Bookmarks tab. And … (funda kabanzi)

Since the last Firefox update (92.0.1 64-bit), my bookmarks menu is slow to load, and also slow for navigating. It's slow to load the list when I open Bookmarks tab. And it's slow when I move my cursor up/down the bookmarks, it takes a bit for the highlighted bookmarks to catch up. It's very odd. I don't really have a lot of Bookmarks, I would guess ~500 total. Plus I am using plenty of RAM with Windows 7 on a SSD.

Bookmarks loading and accessing was lightning-fast prior to this last Firefox update. I have searched on this Forum for answers, plus Google.... no luck yet. I'm sure there is an answer. Does anyone have it?? Thanks for any help. Dave F.

PS - I LOVE Firefox. Many thanks to Mozilla for a terrific product! ;-)

Asked by Chevy-SS 2 ezinsukwini ezidlule

Last reply by Chevy-SS 1 usuku oludlule

cannot record on Facebook massenger cause firefox doesn't allow it

hi there is a problem with Firefox in its latest version... I want to record massages but i'm getting an error massage that i must go into firefox and allow it to use the… (funda kabanzi)

hi

there is a problem with Firefox in its latest version...

I want to record massages but i'm getting an error massage that i must go into firefox and allow it to use the microphone but i cant! i cannot put the facebook address into it. My friend also tried doing it and there is a problem. Before i'm moving to another browser can you help me?

Asked by oria-amir 1 usuku oludlule

Last reply by oria-amir 1 usuku oludlule

Youtube video pauses, audio continues

When playing a video pauses but the audio continues. The video will then continue but has jumped ahead to where the audio is. So, audio plays uninterrupted, but video wil… (funda kabanzi)

When playing a video pauses but the audio continues. The video will then continue but has jumped ahead to where the audio is. So, audio plays uninterrupted, but video will pause, resume, pause, resume multiple times and each time it resumes, it jumps ahead so it is synced with the audio. This occurs most often in Youtube videos. However, I've noticed it playing other videos when in the browser.

Asked by smith.dennisw.jr 22 amahora adlule

Last reply by smith.dennisw.jr 22 amahora adlule

Firefox crashed contantly!

I return to my hibernating iMac, and 40% of the time, all open windows are closed. Often, the browser has also reset my search engine and no longer loads my default web … (funda kabanzi)

I return to my hibernating iMac, and 40% of the time, all open windows are closed. Often, the browser has also reset my search engine and no longer loads my default web page.

Asked by John Felock 9 amahora adlule

Firefox browser for Catalina OS 10.15

I'm having a problem with Firefox. I can't quit or force quit the browser. I used the red button on the browser window to close it; but, still can't get it to quit and … (funda kabanzi)

I'm having a problem with Firefox. I can't quit or force quit the browser. I used the red button on the browser window to close it; but, still can't get it to quit and now I can't reopen the browser. I tried to restart my computer thinking that might force Firefox to quit; but, it did not work and the computer canceled the shut down process. I've never had this issue with Firefox before. I can't even say which version of Firefox I have. It is a newer version, though.

I did find a similar problem in a different thread; but, the thread was closed; so, I'm starting this one. Please let me know what I can do to fix this.

Asked by pnwfemale 8 amahora adlule

PDF preview in Outlook Web App

When previewing a PDF attachment in Outlook Web App, the preview screen shows the message 'something went wrong while the document preview was being created' and no previ… (funda kabanzi)

When previewing a PDF attachment in Outlook Web App, the preview screen shows the message 'something went wrong while the document preview was being created' and no preview shows.

  • the exact same account and email shows fine in both Edge and Chrome
  • the preview looks fine for Word and Excel files
  • the problem persists in private mode
  • the problem persists after clearing cache and cookies
  • changing Firefox 'actions for applications' settings for PDF makes no difference
  • the problem has been tested and confirmed on two computers using different connections in different locations.

Firefox version 92.01 64-bit

Asked by john655 3 amahora adlule

Certain downloads repeatedly fail when in Incognito mode, and succeed in Regular mode, even when the requests sent by the browser are 100% word-for-word identical. Request logs provided.

SHORT SUMMARY: A few specific direct downloads from a third-party server successfully finish in Regular browsing mode but fail half-way in Incognito mode. This is reprodu… (funda kabanzi)

SHORT SUMMARY:

A few specific direct downloads from a third-party server successfully finish in Regular browsing mode but fail half-way in Incognito mode. This is reproducable on numerous tries and persists between Firefox restarts, system reboots, and ISP changes. This difference between Regular and Incognito remains even when the requests that the browser sends are fully word-for-word identical, down to the DNT=1 in the request. There are no issues with downloads in Google Chrome on the same machine, and similarly no issues in Incognito mode an old ESR Firefox (v52) on a really old laptop with WinXP. This problem ONLY appears in Firefox 92. ========================================

FULL DETAILS:

I'm using the latest public release of Firefox, 92.0.1, on Windows 8. I have a habit of using Incognito mode most of the time, and I found out that certain downloads fail in Incognito tabs - but succeed in Regular tabs. A few examples:

http://down.360safe.com/cse/360cse_official.exe http://down.360safe.com/cse/360cse_9.5.0.122.exe http://down.360safe.com/cse/360cse_9.5.0.114.exe http://down.360safe.com/cse/360cse_9.0.1.162.exe

They are direct links to the .exe setups of various versions of an obscure browser called 360 Extreme Browser, recommended for use with WinXP on obsolete hardware since it's supposedly very lightweight. You can run them through VirusTotal if you want. The first link always points to the latest release, the other links are specific releases.

When I open any of them, I am first presented with the regular download dialog box, while Firefox automatically starts downloading the file to %TEMP% in the background, without waiting for my decision (as it always does):

https://i.imgur.com/0D6pH4Z.png

... then, a couple seconds later, I'm presented with the "source file could not be read" error.

https://i.imgur.com/3f6StGQ.png

When I click OK, the first dialog box also disappears, and there is no trace of the (failed) download left in the download widget in the top right.

Alternatively, I can try to be very fast, and as soon as the first dialog box appears, I can quickly click "Save File" and press Enter in the folder selection window that appears. That way, I can confirm the download before it gets a chance to fail. But it fails anyway, except this time I can see the incomplete file in my destination folder, and the failed download in the list of downloads in the top right corner of Firefox. This download fails about 5-15 MBs into the file - it's different between different attempts.

It is my understanding that the "nature" or "mechanism" of the fail is the same, but if it happens while it's downloading to %TEMP% and I haven't selected the folder yet, then I'm presented with an explicit error message and there is no trace of it in the download history, and if it happens when I've already selected the folder, then there is no explicit error message and the failed download is displayed in the download history.

In the latter case, I can then press "Retry download" in the download history. Then, the download will successfully restart (not from zero, but from the percentage that it failed at) and will successfully complete. But the FIRST try, initiated by the tab ("by the page"?) and not by the "download history" widget in the corner, ALWAYS fails at some point between 5-15 MBs.

========================================

INVESTIGATION AND LOGS AND LOTS OF TECHNICAL DETAILS

So you might say, that third-party server is acting weird and is probably misconfigured. But:

  • This download ALWAYS SUCCEEDS without any problems in Regular (not Incognito) tabs. It ALWAYS FAILS in Incognito.
  • This download ALWAYS SUCCEEDS in Google Chrome that I have on this same machine, both in Regular and in Incognito.
  • This download ALWAYS SUCCEEDS in Firefox 52.9 ESR on a really obsolete laptop with WinXP that I have, connected to the same network(s), both in Regular and in Incognito.

To sum up, this fails VERY SPECIFICALLY in Incognito mode in Firefox 92 (current modern version) and NOWHERE ELSE.

All download attempts that are successful (non-Incognito FF 92, Google Chrome, FF 52.9 ESR...) result in a downloaded file with the same correct size and checksum. The download that is successfully RESTARTED after failing in Incognito (read details above) also results in a file with the same size and checksum.

I am not aware of any software on this machine that would be interrupting the download, such as antivirus. In any case, it's interrupted when it reaches a different random size on each different attempt, and it only affects Incognito Firefox and nothing else - not Regular tabs of FF and not Chrome. I have also tried two different ISPs - one that provides me with Ethernet at my place, and my mobile phone ISP. Same behavior between them. The only third-party plugin that I have in Firefox is uBlock. I disabled it completely and this didn't change anything.

I've inspected the requests and responses, using Firefox's own dev tools.

REGULAR TAB (not incognito) = SUCCESSFUL DOWNLOAD

GET http://down.360safe.com/cse/360cse_9.5.0.122.exe

GET /cse/360cse_9.5.0.122.exe HTTP/1.1 Host: down.360safe.com User-Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:92.0) Gecko/20100101 Firefox/92.0 Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8 Accept-Language: en-US,en;q=0.5 Accept-Encoding: gzip, deflate Connection: keep-alive Upgrade-Insecure-Requests: 1

Response:

HTTP/1.1 200 OK Date: Tue, 28 Sep 2021 06:38:12 GMT Content-Type: application/octet-stream Content-Length: 45846432 Connection: keep-alive Expires: Tue, 28 Sep 2021 06:48:12 GMT Last-Modified: Fri, 02 Feb 2018 12:20:52 GMT Cache-Control: max-age=600 ETag: "5a7457a4-2bb8fa0" KCS-Via: REVALIDATED from w-f03.lato;MISS from back-f01.dl.lato;REVALIDATED from w-subsrc02.lato;MISS from back-subsrc01.dl.lato K-Cache-status: MISS Accept-Ranges: bytes

INCOGNITO TAB: FAILED DOWNLOAD

GET https://down.360safe.com/cse/360cse_9.5.0.122.exe <- notice the forced switch to HTTPS, caused by Incognito mode

GET /cse/360cse_9.5.0.122.exe HTTP/1.1 Host: down.360safe.com User-Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:92.0) Gecko/20100101 Firefox/92.0 Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8 Accept-Language: en-US,en;q=0.5 Accept-Encoding: gzip, deflate, br DNT: 1 Upgrade-Insecure-Requests: 1 Connection: keep-alive Sec-Fetch-Dest: document Sec-Fetch-Mode: navigate Sec-Fetch-Site: none Sec-Fetch-User: ?1

Response:

HTTP/1.1 200 OK Date: Tue, 28 Sep 2021 06:40:54 GMT Content-Type: application/octet-stream Content-Length: 45846432 Connection: keep-alive Expires: Tue, 28 Sep 2021 06:50:54 GMT Last-Modified: Fri, 02 Feb 2018 12:20:52 GMT Cache-Control: max-age=600 ETag: "5a7457a4-2bb8fa0" KCS-Via: REVALIDATED from w-f01.lato;MISS from back-f01.dl.lato;REVALIDATED from w-subsrc01.lato K-Cache-status: MISS Accept-Ranges: bytes

The differences are: Incognito mode forces HTTPS, sends Sec-Fetch- entries in the GET request, and also sends DNT = 1. Everything else is the same.

I then went to Firefox settings and enabled sending DNT *all the time*, even in Regular (non-incognito) tabs. I also tried to download explicitly from the https:// URL in Regular (non-incognito) mode, just like Incognito mode forces https. This resulted in a request that is sent from a Regular tab but is 100% identical to the request sent from Incognito mode. Read below:

GET https://down.360safe.com/cse/360cse_9.5.0.122.exe

GET /cse/360cse_9.5.0.122.exe HTTP/1.1 Host: down.360safe.com User-Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:92.0) Gecko/20100101 Firefox/92.0 Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8 Accept-Language: en-US,en;q=0.5 Accept-Encoding: gzip, deflate, br DNT: 1 Connection: keep-alive Upgrade-Insecure-Requests: 1 Sec-Fetch-Dest: document Sec-Fetch-Mode: navigate Sec-Fetch-Site: none Sec-Fetch-User: ?1

Response:

HTTP/1.1 200 OK Date: Tue, 28 Sep 2021 06:45:17 GMT Content-Type: application/octet-stream Content-Length: 45846432 Connection: keep-alive Expires: Tue, 28 Sep 2021 06:55:17 GMT Last-Modified: Fri, 02 Feb 2018 12:20:52 GMT Cache-Control: max-age=600 ETag: "5a7457a4-2bb8fa0" KCS-Via: HIT from w-f05.lato;MISS from back-f03.dl.lato;REVALIDATED from w-subsrc01.lato K-Cache-status: MISS Accept-Ranges: bytes

You can check that this request from a Regular (non-incognito) tab is now word-for-word identical to the request from an Incognito tab. Yet, the download from Incognito STILL fails at ~10 MBs into the file, and the download from Regular STILL succeeds. I fail to see any difference between the requests, whatsoever.

In the Cookies tab, there are "No cookies for this request" for both Regular and Incognito downloads. The Security tab looks 100% identical for Regular and Incognito downloads, and looks like this: https://i.imgur.com/SAhzquW.png (idk how to copy this in plaintext form).

In another online discussion elsewhere while I was troubleshooting this, I was advised to see if network.dns.echconfig.enabled was set to TRUE and to try setting it to FALSE. Not sure what this would change, but I went to check and found that it was already FALSE.

Also, in that discussion elsewhere, I had one more user running Firefox on Windows 10 (according to his publicly displayed user agent) confirm this. But I don't know how to reach him to ask for extensive troubleshooting like mine.

========================================

FINAL SUMMARY:

  • Some specific downloads fail halfway in Incognito Mode in latest Firefox
  • There are no issues in Regular (non-incognito) mode, or in Google Chrome on this same machine, or in obsolete Firefox 52 on another machine
  • This persists across Firefox restarts, reboots, ISP changes
  • This difference between Regular and Incognito modes persists even when you change settings so that the sent GET requests are 100% word-for-word identical

Help me troubleshoot this further? Even if this is caused by that third-party server acting up (for whatever reason), how does it tell between my Regular firefox tab and my Incognito firefox tab when the sent requests are the same? And even if this is caused by something else on my machine or in my network, then the same question applies, how can this "something" tell between my Regular and Incognito tabs?

Asked by jagev53494 1 ihora elidlule

language

again after an update the language settings are not working. I change to Dutch(Nederlands belgie) and i got a mix of english and dutch. It's not the first time after an u… (funda kabanzi)

again after an update the language settings are not working. I change to Dutch(Nederlands belgie) and i got a mix of english and dutch. It's not the first time after an uopdat that this problem occures.

Asked by pagre2213 55 imizuzu edlule

firefox "screenshot" command line option

in previous versions of firefox, I was able to create screenshots with the following command line options: /firefox.exe" -P headless --purgecaches --screenshot raw_weathe… (funda kabanzi)

in previous versions of firefox, I was able to create screenshots with the following command line options:

/firefox.exe" -P headless --purgecaches --screenshot raw_weather.png --window-size=1920,1080 -browser "https://www.google.com/search?&q=weather+in+Washington+DC"

however, with the latest version 92.0.1, the "--screenshot" option no longer works. what has changed? what am I doing wrong?

Asked by nealelliott1 17 amahora adlule

Last reply by nealelliott1 44 imizuzu edlule