Kukhonjiswa imibuzo ethegiwe: Veza yonke imibuzo
  • Kusonjululiwe
  • Okugcinwe kunqolobane

mp4 color is different on Firefox

We're experiencing a strange bug. We created a page with an embedded mp4. Both of them have the same background color. On Chrome and IE the background color stays the sam… (funda kabanzi)

We're experiencing a strange bug. We created a page with an embedded mp4. Both of them have the same background color. On Chrome and IE the background color stays the same, but on Firefox, the video has different colors.

We created this demo so you can view the bug as well: http://downloads.perplex.eu/firefox/index.html


Hope you can help.

Kind regards,

Henk van der Velden

Asked by henkvandervelden 4 iminyaka edlule

Answered by henkvandervelden 3 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

unable to register service worker

I am developing a web application that requires the use of service worker from firebase messaging, before updating to firefox quantum version this was working fine, local… (funda kabanzi)

I am developing a web application that requires the use of service worker from firebase messaging, before updating to firefox quantum version this was working fine, localhost was the url for testing and i also saw the correct results on the production url site, just after doing the update for quantum this stopped working and i don't quite know why it isn't working as firebase only throws a messaging saying that it is unable to register.

OS: Linux Debian/Ubuntu 16.04 x64 Browser: Firefox quantum 57.0 (64-bit)

Asked by nosthertus 3 iminyaka edlule

Answered by nosthertus 3 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Temporarily block Firefox updates by URL/IP

We have an Add-On that will no longer work with FireFox once it updates version 60.2. It will heavily impact our stores ability to use certain functions/integration with … (funda kabanzi)

We have an Add-On that will no longer work with FireFox once it updates version 60.2. It will heavily impact our stores ability to use certain functions/integration with our website until we get either a new add-on released or make a change to the site. We had planned on disabling updates for FireFox temporarily on each PC at each store but I am hoping for a workaround. I am curious if there is a list somewhere of the server IP’s/URLs that FireFox would use to update. This way I can just blacklist those IP’s for the time being until we get a new add-on released or an update to our website. This way they would not be able to download the latest update. It would prevent me from having to alter settings on each PC at each store (we have close to 70 locations and 4 computers at each). Is there such a list? And if so can someone point me there? Thanks!

Asked by ar550n1c 3 iminyaka edlule

Answered by ar550n1c 3 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox isn't showing forms on our website created with Formidable Forms

Hi there, I work for a small UK based charity and we use our website to take orders for our programmes, we deliver DARE programmes in the UK. Our website is https://lifes… (funda kabanzi)

Hi there,

I work for a small UK based charity and we use our website to take orders for our programmes, we deliver DARE programmes in the UK.

Our website is https://lifeskills-education.co.uk.

We use WordPress as our CMS and use Formidable Forms to create forms for people to place orders; these forms work fine in Chrome and Edge, but will not display in Firefox. I have tried everything, disabling third party scripts, all plugins, themes and more, but Firefox refuses to show them. It sees the HTML, but when inspected the HTML is greyed out. It is not greyed out on Chrome.

https://lifeskills-education.co.uk/resources/the-dare-primary-programme/ is the page where an order form should show on the left above the fold. It is titled Place an Order.

There is nothing I can find anywhere that can help me with this issue, Google has come up blank and I am not a web developer so don't have the tech chops to track this down.

Any help appreciated. Thanks.

Stuart

Asked by thebastion 1 unyaka odlule

Answered by cor-el 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

The address wasn’t understood (how to redirect URL to software on computer?)

When I click on a link which is: osu://b/1006632 Firefox says: The address wasn’t understood Firefox doesn’t know how to open this address, because one of the following … (funda kabanzi)

When I click on a link which is: osu://b/1006632

Firefox says:

The address wasn’t understood

Firefox doesn’t know how to open this address, because one of the following protocols (osu) isn’t associated with any program or is not allowed in this context.

You might need to install other software to open this address.

I have the program osu installed on my computer. How do I make the address in Firefox redirect to the osu program?

Asked by daigo1 4 iminyaka edlule

Answered by jscher2000 4 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Header image and text for website does not load properly on Firefox - image partially visible, some text squished.

First off, thanks to everyone who pitches in to help resolve this headache. Sheesh! Problem: The Header image and text do not display properly in Firefox: The content doe… (funda kabanzi)

First off, thanks to everyone who pitches in to help resolve this headache. Sheesh!

Problem: The Header image and text do not display properly in Firefox: The content does displays properly in Chrome, Opera and Safari. By the way: I have read and attempted all the applicable troubleshooting suggestions Firefox has supplied without success.

Website: www.twoworlds.ca The page in question is www.twoworlds.ca/other-world.html

Note: I coded the site myself using largely a w3.css framework. Admittedly, the source code is messy. I'm still chimpin' around (experimenting) with things.

Incredibly, am unable to upload two 137 kb screen captures of the problem for visual reference - an endless spin wheel for 12-minutes. Wha..? In that case, please visit my site in Chrome and then Firefox to see the difference. the site again: www.twoworlds.ca/other-world.html

Thanks.

Asked by lance-uppercut 3 iminyaka edlule

Answered by TyDraniu 3 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Install extension silently in Firefox 41

I'm making automatic installer for special Firefox extensions. I have read couple of articles about that, but none of the described methods are not helped. What I trie… (funda kabanzi)

I'm making automatic installer for special Firefox extensions. I have read couple of articles about that, but none of the described methods are not helped. What I tried to do:

- Placed .xpi file and unpacked unpacked extension directory in %FF_DIR%\browser\extensions
- Placed .xpi file and unpacked unpacked extension directory in %FF_DIR%\extensions
- Placed unpacked extension directory in another directory and added record in registry (`HKLM\Software\Mozilla\Firefox\extensions`, key is extension id and value is full path to unpacked extension)

In all ways name of unpacked extension directory was:

- Random name
- ID from install.rdf #1 (`{ec8030f7-c20a-464f-9b0e-13a3a9e97384}` for example)
- ID from install.rdf #2 (`prism@developer.mozilla.org` for example)  

And, as i said, all methods don't give me expectable result. Firefox don't show extensions in list and don't show any notification. How can i solve it? What actual method using in current version of FF? Target browser is Firefox 41, system - Windows 7 x64 Thanks!

Asked by iRomul 5 iminyaka edlule

Answered by cor-el 5 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox 51.0.1 not displaying the pop screen for htaccess protected folders

The latest version of Firefox 51.0.1 does not display the login screen for htaccess protected folders for my website. I've cleared the cache, cookies and browser history … (funda kabanzi)

The latest version of Firefox 51.0.1 does not display the login screen for htaccess protected folders for my website. I've cleared the cache, cookies and browser history and the website is in the block pop-up window exceptions list.

Asked by UKModelShops 4 iminyaka edlule

Answered by UKModelShops 4 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox doesn't randomly load webpages

Hi, I use Firefox v590.0.2 (64 bits) with Windows 10. I use Firefox at my work, only for browsing our intranet. I'm a web developer so I load many pages on our intranet. … (funda kabanzi)

Hi,

I use Firefox v590.0.2 (64 bits) with Windows 10.

I use Firefox at my work, only for browsing our intranet. I'm a web developer so I load many pages on our intranet. Since a few weeks, I noticed that the pages are not always loaded correctly: the page starts to be loaded, and then it stops and it's loading forever (with the "Waiting for XXX" message at the bottom left). If I refresh the page it will eventually load as expected.

I tried to install a new Firefox on *another* computer, and I use it to browse the same website. And the same behavior appears: it works very fast and well for some pages, and then randomly stops working for some random pages.

On my main computer I tried to create new profiles, delete everything, without success.

I also tried to deactivate the hardware acceleration on both Firefox, without success.

When I check the Network tab from the web developer bar, I can see that some CSS files (it's not always the same, and it can be 1 or several CSS files) are not loaded (see the attachment) and appears with a grey dot, just like if the browser was trying to load them but it cannot, blocking the page. (I've also noticed it could impact other resources, like, at least images)

Before v59 I've never seen this behavior.

Note :

 - our intranet is on Sharepoint, with NTLM auth
 - at home I use Firefox on my personal computer and it works normally (but I don't browser the work intranet)
 - at work, because it's on the intranet, the network doesn't go thru a proxy
 - I'm now using Chrome because of this issue with Firefox, and the problem doesn't occur in Chrome

Thanks for any help.

Asked by AymKdn 3 iminyaka edlule

Answered by AymKdn 3 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

The header picture is too large only on Firefox.

I'm building a new website which is http://tradingchannelsuk.ipage.com/ The header picture looks just fine on other browsers apart from Firefox and IE. The header is way … (funda kabanzi)

I'm building a new website which is http://tradingchannelsuk.ipage.com/ The header picture looks just fine on other browsers apart from Firefox and IE. The header is way too large and goes out of the margins of the page, i.e. more than %100. I tried

  1. logo img {
 width: 100% !important

} and some varieties of it but couldn't fix the problem. Can anyone please help me out? Thanks.

Asked by tttigra 6 iminyaka edlule

Answered by cor-el 6 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox won't load my new website - while other browsers do

Hi, I have uploaded a new version of my website, and though I can access it with other browsers (Internet Explorer, Chrome, Opera), Firefox will only load the old "under… (funda kabanzi)

Hi,

I have uploaded a new version of my website, and though I can access it with other browsers (Internet Explorer, Chrome, Opera), Firefox will only load the old "under construction" picture and not my new site. I have tried clearing the cache, to no effect.

I have tried access the site from link, and get the construction picture - it's ONLY Firefox that does this...!!

Please advise. Thanks.

Asked by focusonpurpose 4 iminyaka edlule

Answered by cor-el 4 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

How to prevent Firefox from removing my extension's data when I remove debug version?

I have an extension with id setup in manifest like this: ``` "browser_specific_settings": { "gecko": { "id": "{e3ec45ef-43ba-499d-8469-6d0e2f06921f}", "stric… (funda kabanzi)

I have an extension with id setup in manifest like this:

``` "browser_specific_settings": {

   "gecko": {
     "id": "{e3ec45ef-43ba-499d-8469-6d0e2f06921f}",
     "strict_min_version": "42.0"
   }
 },

```

which uses indexedDB(PouchDB). I installed that extension from addons.mozilla.org, disabled, installed temporarily version for developing and Firefox removes data of both extensions(cuz they have the same id) every time I remove only temporarily version.

This does not happen when I don't set id in manifest(temporarily version has random id in this case), but it's not a solution cuz some API's and Android version of Firefox requires id to be set manually

How to prevent Firefox from removing data of normal extension when I remove temporarily one?

Just in case someone wants to reproduce the issue:

1. Install this extension https://addons.mozilla.org/en-US/firefox/addon/tagit/?src=search
2. Go to extension's page (button with eyes on browser's panel)
3. Go to "Tags" page and create any tag(write something and press Enter)
4. Disable this extension on about:addons page
5. Clone its repository and checkout to commit where id is in manifest `git clone https://github.com/DevAlone/tagit.git; git checkout 8e0d04201865fd7b7543b167279a045c89408d5c`
6. Install dependencies and build `npm install; npm run build`
7. Install that temporarily extension(`build` dir) on about:debugging page
8. Remove that temporarily extension on about:debugging page
9. Enable normal extension on about:addons page
10. Go to the Tags page again to see that database is gone

Asked by SergeyDevZ 2 iminyaka edlule

Answered by TyDraniu 2 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Could you tell me the maximum supported version of Firefox in this OS environment?

Hello, I am a developer working on Red Hat Linux R5.10. Could you tell me the maximum supported version of Firefox in this OS environment? The current version of Red Hat … (funda kabanzi)

Hello, I am a developer working on Red Hat Linux R5.10.

Could you tell me the maximum supported version of Firefox in this OS environment? The current version of Red Hat Linux R5.10 is related to the following environment. gtk2, glib 2.0, pango 1.14

The latest version(66.0.3) of Firefox has requirements below

-GTK + 3.4 or higher
-GLib 2.22 or higher
-Pango 1.22 or higher

This OS does not meet all the requirements.

help please

Asked by namhun 2 iminyaka edlule

Answered by Balázs Meskó 2 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Can't enter login details on a website

Dear all On of the websites I have editors right on doesn't have SSL installed. Since I upgraded to Firefox Quantum, when I go to the login page, I can't enter my login d… (funda kabanzi)

Dear all

On of the websites I have editors right on doesn't have SSL installed.

Since I upgraded to Firefox Quantum, when I go to the login page, I can't enter my login details anymore. The field is not clickable. It works on other browsers.

Firefox does warn me that the website is insecure, but how can I go through anyway ?

Thank you !

Asked by manoucho 3 iminyaka edlule

Answered by FredMcD 3 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Strange dashed border is visible around column after clicking in website footer

Hi, We are developing a new website for a client. The client is seeing a strange issue when viewing the site in Firefox, where a thick dashed border appears around an ima… (funda kabanzi)

Hi,

We are developing a new website for a client. The client is seeing a strange issue when viewing the site in Firefox, where a thick dashed border appears around an image and column in the footer of the website. It happens when she clicks in the footer somehow. It seems inconsistent, and the client sent us 2 different screenshots where the border line looks different. (Screenshots attached.)

We haven't been able to re-create the issue on our end, even after testing on several machines and browsers. The client is using a Windows computer and is running the newest version of Firefox. She only sees the issue when using Firefox (it looks fine for her in Microsoft Edge). She has seen the issue on several different dates, and after disabling all her Firefox extensions.

Here is the link to the site: http://82a.de4.myftpupload.com/

Anyone seen something like this before, and have any idea what it is or how to fix it?

Thank you!!

Asked by Hana 2 iminyaka edlule

Answered by cor-el 2 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

How To Log A Webpage Out Of A Site?

I am testing my own site. Where I need to log in with different User Accounts in order to check that aspect of IIS. Firefox only allows me to log in with one account - v… (funda kabanzi)

I am testing my own site. Where I need to log in with different User Accounts in order to check that aspect of IIS.

Firefox only allows me to log in with one account - visiting that site again just automatically logs in with that same account. It doesn't present me with the log in fields. And, of course, a browser doesn't have a 'log out' button does it?

I want to be presented with the log in fields each time I go there, so's I can log in as a different user.

So I found a thread here that was similar, talking about someone with the opposite problem - constantly being logged out. And the answer was in about:preferences and such. Well I couldn't follow that trail because about:preferences didn't bring up the options that thread talked about.

I suppose the answer is a cookies thing. I'd like to resolve this without having to delete all cookies. If I can.



edit: removed spaces before each paragraph which caused horizontal scroll-bars.

Asked by abrogard 3 iminyaka edlule

Answered by cor-el 3 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Custom Local Plain HTML Page Does Not Display Correctly

My custom web page I've used on all computers does not display correctly in FireFox. It works in Chrome & Internet Explorer but not ForeFox. It is plain HTML with no … (funda kabanzi)

My custom web page I've used on all computers does not display correctly in FireFox.

It works in Chrome & Internet Explorer but not ForeFox.

It is plain HTML with no scripts or anything. Just links and some images for background etc.

Asked by caltrop 4 iminyaka edlule

Answered by caltrop 4 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Website formatting issue

Hey team, I hope you are doing great, I'm facing an issue with a table on my page, no matter what I do the image isn't sized correctly. They get compressed and look odd. … (funda kabanzi)

Hey team,

I hope you are doing great, I'm facing an issue with a table on my page, no matter what I do the image isn't sized correctly. They get compressed and look odd.

I'm not getting this issue on Chrome, can you please have a look at the table on this page and let me know what could be the issue.

I'll be really thankful as I have tried everything that I could think of. The image is also attached for your reference.

Thanks in advance

Asked by webbjason3 9 izinyanga ezidlule

Answered by FredMcD 9 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox 39 not downloading files in one particular server

Hi. This is my first question here and a weird one too. So please bear with me. My company has many individual servers, all running the same Java program with same enviro… (funda kabanzi)

Hi. This is my first question here and a weird one too. So please bear with me.

My company has many individual servers, all running the same Java program with same environment. We have a download button to download some data. However, the download link "DOES NOT POINT DIRECTLY TO THE FILE LOCATION". Instead we take the request, process it, write the data to a file in server, then read that file to the requesting browser.

In ONE of our servers, after our firefox upgraded, we are experiencing the issue that the download is not happening anymore for versions >=39. Previous versions are able to download the file correctly. Same behavior is seen in IE-11.

What's more confusing is that other servers are behaving normally even with firefox 39 and beyond. Only with this one server I am getting this issue.

Based on FF39 changelogs, can this bug-fix have some role to play in the observed behavior ? "Fix incomplete downloads being marked as complete by detecting broken HTTP1.1 transfers"

Attached are 3 images: Image 1: When download clicked, received the popup immediately though expecting some delay because of data processing. This possibly indicates that FF39 is not receiving any data from the server.

Image 2: When FF39 is not able to download the file it gives the warning shown.

Image 3: Trying to re-download the file using download manager downloads the underlying XHTML file instead which is EXPECTED BEHAVIOR because download is not a direct link to the file as mentioned before.

PS: I understand I am not giving enough information because I don't know how to reproduce this issue. Any pointer in some direction is appreciated. Thank you for your time.

Asked by rchaudhary 6 iminyaka edlule

Answered by rchaudhary 6 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Browser Console

Trying to debug very simple javascript in a small web page. I turned on the chrome javascript console when I run my file and then ctrl-shift-j I get an error report o… (funda kabanzi)

Trying to debug very simple javascript in a small web page. I turned on the chrome javascript console when I run my file and then ctrl-shift-j I get an error report on code that is not mine -- lots of references to recipebox -- and dont get any help with my own page.

Asked by jean01 3 iminyaka edlule

Answered by Shadow110 3 iminyaka edlule