Kukhonjiswa imibuzo ethegiwe: Veza yonke imibuzo
  • Kusonjululiwe
  • Okugcinwe kunqolobane

Can the Network Monitor preserve its log upon navigation?

Does the Network Monitoring component of the Firefox Developer Tools have a way to preserve its log upon navigation (which would otherwise be cleared), similar to the Chr… (funda kabanzi)

Does the Network Monitoring component of the Firefox Developer Tools have a way to preserve its log upon navigation (which would otherwise be cleared), similar to the Chrome or Safari Developer Tools "Preserve log upon navigation" button?

I've tried checking the "Enable persistent logs" option for the Web Console in settings, but it does not appear to affect the Network Monitoring tab. I also didn't see any bugs filed for it, so I just wanted to make sure I wasn't overlooking something obvious.

Thanks, Kevin

Asked by kevinoid 6 iminyaka edlule

Answered by guigs 6 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

How to disable web push notifications in Firefox?

Hi, how to completly remove/disable web push notifications in Firefox? about:config > dom.push.enabled > false Not help with notif sent from "cdn . sendpulse . com… (funda kabanzi)

Hi,

how to completly remove/disable web push notifications in Firefox?

about:config > dom.push.enabled > false

Not help with notif sent from "cdn . sendpulse . com"

demo here "thebadbuzz . com" (see attached screenshot).

The only alternative i have find is to block "sendpulse" using Adblock Plus.

Thank you.

Asked by smed79 3 iminyaka edlule

Answered by jscher2000 3 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox tab crashes at startup

I am on Linux, the kernel version is 3.10.0-663.el7.x86_64 (Red Hat 7.4 beta). I am working through ThinLinc version 4.8.0, Build 5456. When I start Firefox I get a tab i… (funda kabanzi)

I am on Linux, the kernel version is 3.10.0-663.el7.x86_64 (Red Hat 7.4 beta). I am working through ThinLinc version 4.8.0, Build 5456. When I start Firefox I get a tab indicating a crash. When I am logged directly on the machine, not through ThinLinc, it work fine. I copy the error message I get in my shell from the crash:

[root@cad1 ~]# [Parent 17786] WARNING: pipe error (7): Connection reset by peer: file /builddir/build/BUILD/firefox-52.2.0/firefox-52.2.0esr/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 322 [Parent 17786] WARNING: pipe error (50): Connection reset by peer: file /builddir/build/BUILD/firefox-52.2.0/firefox-52.2.0esr/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 322 [Parent 17786] WARNING: pipe error (48): Connection reset by peer: file /builddir/build/BUILD/firefox-52.2.0/firefox-52.2.0esr/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 322 [Parent 17786] WARNING: pipe error (46): Connection reset by peer: file /builddir/build/BUILD/firefox-52.2.0/firefox-52.2.0esr/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 322 [Parent 17786] WARNING: pipe error (47): Connection reset by peer: file /builddir/build/BUILD/firefox-52.2.0/firefox-52.2.0esr/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 322

      1. !!! [Parent][MessageChannel] Error: (msgtype=0x2C0085,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv

[Parent 17786] WARNING: pipe error (53): Connection reset by peer: file /builddir/build/BUILD/firefox-52.2.0/firefox-52.2.0esr/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 322 [Parent 17786] WARNING: pipe error (60): Connection reset by peer: file /builddir/build/BUILD/firefox-52.2.0/firefox-52.2.0esr/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 322 [Parent 17786] WARNING: pipe error (58): Connection reset by peer: file /builddir/build/BUILD/firefox-52.2.0/firefox-52.2.0esr/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 322 [Parent 17786] WARNING: pipe error (56): Connection reset by peer: file /builddir/build/BUILD/firefox-52.2.0/firefox-52.2.0esr/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 322 [Parent 17786] WARNING: pipe error (57): Connection reset by peer: file /builddir/build/BUILD/firefox-52.2.0/firefox-52.2.0esr/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 322

      1. !!! [Parent][MessageChannel] Error: (msgtype=0x2C0085,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv

[Parent 17786] WARNING: pipe error (64): Connection reset by peer: file /builddir/build/BUILD/firefox-52.2.0/firefox-52.2.0esr/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 322 [Parent 17786] WARNING: pipe error (74): Connection reset by peer: file /builddir/build/BUILD/firefox-52.2.0/firefox-52.2.0esr/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 322 [Parent 17786] WARNING: pipe error (72): Connection reset by peer: file /builddir/build/BUILD/firefox-52.2.0/firefox-52.2.0esr/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 322 [Parent 17786] WARNING: pipe error (70): Connection reset by peer: file /builddir/build/BUILD/firefox-52.2.0/firefox-52.2.0esr/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 322

      1. !!! [Parent][MessageChannel] Error: (msgtype=0x46001C,name=PContent::Msg_PreferenceUpdate) Channel error: cannot send/recv


      1. !!! [Parent][MessageChannel] Error: (msgtype=0x46001C,name=PContent::Msg_PreferenceUpdate) Channel error: cannot send/recv


      1. !!! [Parent][MessageChannel] Error: (msgtype=0x46001C,name=PContent::Msg_PreferenceUpdate) Channel error: cannot send/recv


      1. !!! [Parent][MessageChannel] Error: (msgtype=0x46001C,name=PContent::Msg_PreferenceUpdate) Channel error: cannot send/recv


      1. !!! [Parent][MessageChannel] Error: (msgtype=0x46001C,name=PContent::Msg_PreferenceUpdate) Channel error: cannot send/recv


      1. !!! [Parent][RunMessage] Error: Channel error: cannot send/recv


      1. !!! [Parent][MessageChannel] Error: (msgtype=0x2C0074,name=PBrowser::Msg_SynthMouseMoveEvent) Channel error: cannot send/recv

[Parent 17786] WARNING: FileDescriptorSet destroyed with unconsumed descriptors: file /builddir/build/BUILD/firefox-52.2.0/firefox-52.2.0esr/ipc/chromium/src/chrome/common/file_descriptor_set_posix.cc, line 22

      1. !!! [Parent][MessageChannel] Error: (msgtype=0x2C0085,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv

Asked by fredericdrapeau 2 iminyaka edlule

Answered by cor-el 2 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

How do I fix incorrectly displaying fonts?

Some fonts aren't displayin correctly on webpages. Most noteably, in code boxes and stuff. Instead of legible text, all I see are shapes of triangles, squares, and stars.… (funda kabanzi)

Some fonts aren't displayin correctly on webpages. Most noteably, in code boxes and stuff. Instead of legible text, all I see are shapes of triangles, squares, and stars.

Asked by jeff28 3 iminyaka edlule

Answered by jeff28 3 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

I can't bypass certificate warnings anymore (HSTS)

In short, I want to be able to bypass certificate warnings. Yes, I've seen this: https://support.mozilla.org/en-US/questions/1169632 "When there is HSTS(HTTPS Strict Tran… (funda kabanzi)

In short, I want to be able to bypass certificate warnings.

Yes, I've seen this: https://support.mozilla.org/en-US/questions/1169632 "When there is HSTS(HTTPS Strict Transport Security) set on the server, you cannot add a exception"

In less short, my case (because one needs to always justify one's methods), I set up a subdomain on a separate IP/host and I'm trying to test some project for which I use a webpage as a small visible part. However, the domain uses HSTS (HSTS == very nice).

However, I'm just casually testing something using a subdomain (or even a fake domain, or a real domain pointing to a new server being prepared, maybe using /etc/hosts) pointing to an external or internal IP on some old computer on my LAN or even on my own computer. And that's not possible anymore.

People should always have the option to bypass a warning, and I'm all for the warnings. If anything, there shouldn't have been a box with the option "always remember" ticked by default. There are other cases where this can be useful, some we don't even know yet.

Asked by BatManuel 2 iminyaka edlule

Answered by philipp 2 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox Dev can’t establish a connection to local server

I'm a web developer that setup a local environment under Linux Mint. For some reason, Firefox Developer Edition (59.0b7 64-bit) cannot access sites on my localhost. The i… (funda kabanzi)

I'm a web developer that setup a local environment under Linux Mint.

For some reason, Firefox Developer Edition (59.0b7 64-bit) cannot access sites on my localhost. The interesting thing is that Firefox Quantum 58.0.1 (64-bit) is showing these local sites perfectly fine. I've tested other browsers, including Konqueror and Lynx, and these work fine also.

I've setup my environment so that apache2 can serve pages from a 'wildcard' virtual host. Using symlinks, I can link my project files to another directory that functions as the web root. Thus:

/home/me/business/projects/client/index.html => /home/me/business/www/client/index.html

Navigating to http://client.dev brings up the page perfectly in Firefox 58, Konqueror, and Lynx.

However, Firefox Developer Edition, AND Google Chrome, both fail to load the page. The URL changes from http://client.dev to https://client.dev and throws this message:

"Unable to connect

Firefox can’t establish a connection to the server at client.dev."

I've played around with the about:config settings for Network.dns.* but nothing seems to help. Also, the apache logs do not produce anything useful.

Your input will be greatly appreciated.

Asked by Alan W 2 iminyaka edlule

Answered by Alan W 2 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

x-vlc plugin gives me a plugin is needed to display the content

I am trying to display streaming content from 4 webcams within my local network. This works properly on my Linux Mint box with Firefox 48.0, but does not work on My macbo… (funda kabanzi)

I am trying to display streaming content from 4 webcams within my local network. This works properly on my Linux Mint box with Firefox 48.0, but does not work on My macbook running OSX El Capitan 10.11.5 on Firefox 50.1.0. Also same problem on my IMac.

The html code is like this...

<object type="application/x-vlc-plugin" data="rtsp://LWK-????:????????@192.168.1.xx:554/img/video.sav" width="500" height="375" id="video1"> <param name="movie" value="rtsp://192.168.1.0/archive/xxxxxxxxxxx"/> <embed type="application/x-vlc-plugin" name="video1" autoplay="no" loop="no" width="500" height="375" target="rtsp://LWK-????:????????@192.168.1.???:554/img/video.sav" />

I downloaded Flip4mac, as was advised on a post I found on stackoveflow, but that made no difference.

How do I know which plugin is needed? Searching on extensions, I see nothing for x-vlc-plugin. Is extension same as plugin? What do I download if not Flip4mac?

Any help would be greatly appreciated, Thanks, Joe

Asked by Joe 3 iminyaka edlule

Answered by cor-el 3 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

How can I select a client certificate from a smartcard?

Hi, I have a spr532 card reader with a test smartcard with Firefox 50.1.0 on Ubuntu 16.04 up to date. I want to use the client certificate from the device to log in on a … (funda kabanzi)

Hi,

I have a spr532 card reader with a test smartcard with Firefox 50.1.0 on Ubuntu 16.04 up to date. I want to use the client certificate from the device to log in on a website that I am developing.

I also have a test certificate that I generated and it is not on the card. I can log in with the test certificate that I have but not with the one on the card. The problem is that in the "User identification request" page I cannot see the certificate from the smartcard. I can see my generated certificate but not the one on the smartcard. Firefox asks me for the pins for the smartcard (I have two certs on the card and they both have PINs). Firefox sees my certs from the smartcard in about:preferences#advanced > View Certificates > Your Certificates column. I have both the certs on the smartcard and the one I generated in that table. But when I try to log in, Firefox only shows me my generated cert and not the one from the smartcard.

What can I do? How can I debug this? This is a dev environment. I can change any configs on the server so I can decrypt the TLS session and see what is going on between my server and the browser.

PS: I tried to send this message with 2 other email accounts but I do not get the confirmation email.

Thank you!

Asked by andreiconnectis 3 iminyaka edlule

Answered by andreiconnectis 3 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

How to export login information from Firefox Quantum

I set up a Linux OS on my computer and wanted to export all my login data from Firefox Quantum in Windows to it. I tried looking everywhere for what to do, but can't find… (funda kabanzi)

I set up a Linux OS on my computer and wanted to export all my login data from Firefox Quantum in Windows to it. I tried looking everywhere for what to do, but can't find anything. I've tried syncing my Firefox account, copying then pasting everything from my Firefox profile in Windows into the Firefox profile in Linux, however it only imported my bookmarks and none of my login information. Is there a way that I am missing or may have overlooked that will allow me to export all the login information so I don't have to reconfigure everything?

Asked by UserUnavailable404 2 iminyaka edlule

Answered by cor-el 2 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Cannot click/select some password fields in firefox on Ubuntu

Hello I am currently using Ubuntu 18.04 and Firefox Quantum 59.0.2 64-bit. On some websites, I am unable to select the password field either using tab or a mouse click to… (funda kabanzi)

Hello

I am currently using Ubuntu 18.04 and Firefox Quantum 59.0.2 64-bit. On some websites, I am unable to select the password field either using tab or a mouse click to be able to enter a password. This leaves me unable to login. However, this doesnt seem to happen on all password fields.

For example on https://reddit.com I can enter username and password on the field on the right. However, if I click on Login hyperlink on 'Want to join? Log in or sign up in seconds.', I get a popup which I am unable to click the password field on.

I have also seen this problem on https://abnzb.com

I have tried to run in safe-mode but the problem persists.

My addons are Gnome shell integration, Enhanced Steam, HTTPS Everywhere, uBlock origin.

Also, to add to this. When I right click on the password text fields, I do not get a menu popup. I am not sure if this is related or not.

Asked by mattxo 2 iminyaka edlule

Answered by mattxo 2 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

I want Firefox to open in a maximized window

That used to happen for years. About 2 months ago Firefox began opening with a 'restored' (i.e. not maximised) window. For a few days in the last fortnight it resumed o… (funda kabanzi)

That used to happen for years. About 2 months ago Firefox began opening with a 'restored' (i.e. not maximised) window. For a few days in the last fortnight it resumed opening maximised. Now it is opening with a 'restored' window which is wider and shorter than the size used previously.

The localstore.rdf file is dated 09 May 2014.

Asked by ender21 3 iminyaka edlule

Answered by cor-el 3 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Will one finger touch scrolling be a feature in a future update of firefox for linux?

I just installed mint 18.3 and I'm still pretty green. I know there's a solution but I can't understand it. _______________________ Enable touchscreen gestures Make sure … (funda kabanzi)

I just installed mint 18.3 and I'm still pretty green. I know there's a solution but I can't understand it.

_______________________ Enable touchscreen gestures

Make sure dom.w3c_touch_events.enabled is either set to 1 (enabled) or 2 (default, auto-detect).

Add MOZ_USE_XINPUT2 DEFAULT=1 to /etc/security/pam_env.conf and then logout or reboot your system for the changes to take effect.


_______________________

I'd like to know what this means (sorry for being dum), otherwise I wouldn't mind waiting if there's plans to add scrolling in future updates.

Asked by spacemanultra 1 unyaka odlule

Answered by cor-el 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Grey padlock+yellow triangle instead of green one while browsing my webmail. How can I fix it?

Hello Techies, facts are these: Firefox + HTTPS Everywhere on Linux, updated once a day. I connect to my webmail, Yahoo.com, and often the padlock turns to grey+orange tr… (funda kabanzi)

Hello Techies, facts are these: Firefox + HTTPS Everywhere on Linux, updated once a day. I connect to my webmail, Yahoo.com, and often the padlock turns to grey+orange triangle. But https is still present in the URL bar (by the way, I've set browser.urlbar.trimURLs to false). So I try and refresh page (F5), positive result only every now and then. I tried and switched to Basic display (I guess it should be lighter), positive result only every now and then. I feel I can't do anything to fix this annoying and weird lack of security. This "instable green" only occours connecting to Yahoo. When I connect to Facebook, GMail, YouTube or whatever I do NOT have problems at all. No difference using a normal, super updated session rather than a Live one (as I'm doing right now). I've written to Yahoo Help Community to explain as above and I was told it depends on the way Firefox "sees" Yahoo, and to ask You. Thanks a lot... To me it actually IS a Yahoo problem (not the first time, though...), but still I ask you whether you can suggest how to fix the problem or you know more about it. Many thanks and best regard. Alberto

Asked by Alberto67 3 iminyaka edlule

Answered by cor-el 3 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

I keep getting this message in my twitter feed "We cannot play the video in this browser. Please try a different web browser."

I recently installed Ubuntu 18.04 LTS OS on my computer. it came with firefox installed and ive updated all software and packages. Everything seems to work fine except fo… (funda kabanzi)

I recently installed Ubuntu 18.04 LTS OS on my computer. it came with firefox installed and ive updated all software and packages. Everything seems to work fine except for this one persistent problem. my twitter feed won't display gif's and videos. I keep getting this message:"We cannot play the video in this browser. Please try a different web browser."

Asked by druan 1 unyaka odlule

Answered by James 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

cookies no longer seem to work for me in FireFox.

My proxy application server running under FireFox no longer is supporting cookies. The same script runs on Chrome fine. http://www.scriptbasic.org/home/echo What changed?… (funda kabanzi)

My proxy application server running under FireFox no longer is supporting cookies. The same script runs on Chrome fine.

http://www.scriptbasic.org/home/echo

What changed?

Asked by ScriptBASIC 2 iminyaka edlule

Answered by ScriptBASIC 2 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox crashes with certain websites in Ubuntu

I have not used my PC for three weeks and today I tried to log in to my Amazon account, but every time I tried to do the login it crashes, I also found it to crash in oth… (funda kabanzi)

I have not used my PC for three weeks and today I tried to log in to my Amazon account, but every time I tried to do the login it crashes, I also found it to crash in other websites like Reddit and the AMD Support Site. It is Firefox 58.0.1 64-bit in Ubuntu 16.04. I tried refreshing firefox and nothing, it also removed all extensions leaving only the default plug-ins: OpenH264 Video Codec provided by Cisco Systems, Inc & Shockwave Flash. If I disable them manually the websites will still crash. The only way Firefox will work normally is if I restart it in Safe Mode. I also tried installed the new 59 64-bit Beta version, but is causing the same problems.

The latest submitted crash reports are:

bp-5f7cae12-c429-4dd7-b794-8e4cf0180210 bp-8b31fc05-ede6-4d6c-8cd9-10efc0180210 bp-dd409298-45fb-43bb-8fa5-a02d00180210

Thanks for your help!

Asked by reves 2 iminyaka edlule

Answered by reves 2 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox makes no sound

I asked this question 2 years ago. It's closed so I have to ask again. Firefox makes no sound. I have a YouTube video playing, for example, and I can see the video, but… (funda kabanzi)

I asked this question 2 years ago. It's closed so I have to ask again. Firefox makes no sound. I have a YouTube video playing, for example, and I can see the video, but there's no sound. YouTube's unmuted, the volume is all the way up. If I download the video I can play it with mplayer and hear the sound. I can watch a DVD with xine and hear the sound. I can play an audio file at the same time and hear the sound. I've encountered some videos I can't download so I can't hear them - I have to go to the library to use their computers.

I see 'failed to init cubeb... AudioStream.cpp line 387' and 'OnMediaSinkAudioError... MediaDecoderStateMachine.cpp, line 3755'

if those mean anything.

Asked by RandomTroll 2 iminyaka edlule

Answered by RandomTroll 2 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

how do I move close,max,min buttons location

I am using CSD on gnome3 on Arch Linux with all my close max min buttons moved to the left as they are on the Mac. Is there a way to accomplish the same thing in FF with … (funda kabanzi)

I am using CSD on gnome3 on Arch Linux with all my close max min buttons moved to the left as they are on the Mac. Is there a way to accomplish the same thing in FF with CSD on? If I turn it off the button are where I expect them because it uses native decorations, but with it on they are on the right as is customary on MSWindows.

Asked by jjgalvez 1 unyaka odlule

Answered by jjgalvez 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

DRM not working in Firefox 50.0.2 for Linux

I am running Firefox 50.0.2 on Lubuntu 16.10 (32bit) The DRM feature with Widevine does not appear to be working. What I really want is to watch Amazon Video; however, no… (funda kabanzi)

I am running Firefox 50.0.2 on Lubuntu 16.10 (32bit)

The DRM feature with Widevine does not appear to be working.

What I really want is to watch Amazon Video; however, not even the demo videos found on http://demo.castlabs.com/ work. The one without DRM does play, the others do not. It does appear to recognize widevine [DRM: com.widevine.alpha (via Common Encryption)], but the circle just spins and spins.

On Amazon, the circle spins up, then it goes to a "Video unavailable" window. One time I tried it and it played for a second or two and then went to the error window, but usually, it goes straight there.

This is supposed to be working in Firefox 49 and later, right? What's wrong with mine?

Thanks for your help.

Asked by theredwagoneer 3 iminyaka edlule

Answered by theredwagoneer 3 iminyaka edlule