Kukhonjiswa imibuzo ethegiwe: Veza yonke imibuzo
  • Kusonjululiwe
  • Okugcinwe kunqolobane

Cloudflare hosted site complains about Firefox but works with Chrome

This site, Costco Instacart, worked perfectly with Firefox as recently as April 15, 2023 but today fails (see attached image): https://sameday.costco.com/store/costco/sto… (funda kabanzi)

This site, Costco Instacart, worked perfectly with Firefox as recently as April 15, 2023 but today fails (see attached image): https://sameday.costco.com/store/costco/storefront?zipcode=11021

Cloudflare believes it is protecting itself from online attacks when accessed by Firefox. The same site worked perfectly today, on the same computer, using Google Chrome.

Cloudflare is a major CDN and many important commercial sites, like Costco Instacart, have their content delivered by Cloudflare so this is a major issue with Firefox. For the moment there is a work-around, use Chrome instead, but it would be better to have Firefox address issues with Cloudflare.

Asked by em2jacks 11 izinyanga ezidlule

Answered by em2jacks 11 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Unicode Missing Characters

Expected: Firefox displaying all known Unicode characters. Result: Many characters missing. Failure page as an example: https://en.wikipedia.org/wiki/Religious_and_poli… (funda kabanzi)

Expected: Firefox displaying all known Unicode characters.

Result: Many characters missing.

Failure page as an example: https://en.wikipedia.org/wiki/Religious_and_political_symbols_in_Unicode

Description: I tried going through a Unicode list Unicode list and the extensive set of characters displayed correctly. However, when reaching further into character sets as shown in the failure page page, many are missing which are not new.

  • "Repair encoding. . ." button was not active.
  • An encoding switch extension was not able to resolve the issue.
  • Troubleshooting mode did not show changes.
  • Switched fronts available such as Noto Sans and Roboto Sans without success. Possibly a font failure?

Asked by mistry01 1 unyaka odlule

Answered by cor-el 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Error 3000 in twitch

Hello guys, I just got a new M2 SSD and I just decided to reinstall Windows and everything on it. However, when I installed Firefox I started getting this exact error me… (funda kabanzi)

Hello guys,

I just got a new M2 SSD and I just decided to reinstall Windows and everything on it. However, when I installed Firefox I started getting this exact error message on all twitch streams: "Your browser encountered an error while decoding the video. (Error #3000):. Keep in mind I have tried most if not every "fix" I've found. I've disabled the hardware acceleration, cleared cookies and cache, I've disabled the extensions, I've tried Incognito mode, I do not have a third-party anti-virus and I do not have a VPN. This works on all other browsers and it used to work on Firefox before I wiped my PC, so that I can install Windows again. I really do not want to use a different browser, I love everything about Firefox right now.

Any suggestions will do, thank you very much.

Asked by ae.dimitar 1 unyaka odlule

Answered by jscher2000 - Support Volunteer 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Expired cookie breaks Azure AD B2C auth (with Blazor and MSAL)

Hi all, is expired cookies management changed lately? Authentication doesn't work anymore in following use case. Question is all about FF for windows, while usually I'm o… (funda kabanzi)

Hi all, is expired cookies management changed lately? Authentication doesn't work anymore in following use case. Question is all about FF for windows, while usually I'm on FF Android, Edge and Chrome for Windows and all these browsers are working correctly.

My working web app (static blazor wasm standalone) is interactively authenticating in Azure AD B2C using Microsoft.Authentication.WebAssembly.Msal library (like MSAL.js), API is an Azure Function protected through AAD B2C.

Login request successfully invokes Signin/Signup B2C flow with popup to myb2ctenant.b2clogin.com but breaks navigating to auth protected pages or backend apis.

From DevTools I see that every request to following b2c endpoints sets an expired cookie (expired 10 years before, year is now 2012):

When user clicks login: GET /myb2ctenant.onmicrosoft.com/b2c_1_sinsup/v2.0/.well-known/openid-configuration

Returning from login confirmation: GET /myb2ctenant.onmicrosoft.com/B2C_1_SInSUp/api/CombinedSigninAndSignup/confirmed?rememberMe=false&csrf_token=xxx

for example: Set-Cookie: x-ms-cpim-trans=; domain=myb2ctenant.b2clogin.com; expires=Fri, 14-Sep-2012 12:46:46 GMT; path=/; SameSite=None; secure; HttpOnly

FF registers this warning in console:

Cookie “x-ms-cpim-trans” has been rejected because it is already expired

Following when MSAL execute a request to /myb2ctenant.onmicrosoft.com/b2c_1_sinsup/oauth2/v2.0/authorize?xxxx

Response always contains:

Location: https://blazorapp.xx.web.core.windows.net/authentication/login-callback#error= interaction_required&error_description=AADB2C90077%3a+User+does+not+have+an+existing+session+and+request+prompt+parameter+has+a+value+of+%27None%27.%0d%0a

All other browsers are working... Thanks in advance for any help

Asked by croma 1 unyaka odlule

Answered by jscher2000 - Support Volunteer 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Discord media not working

media like .gif files and .mp4 files are used very frequently in the Discord servers I'm in and for some reason whenever those specific file types are used won't load/fun… (funda kabanzi)

media like .gif files and .mp4 files are used very frequently in the Discord servers I'm in and for some reason whenever those specific file types are used won't load/function. I noticed that while the DRM icon was present in the discord tab, that those two file types worked just fine; but I have no clue how to set it to always turn on for specific sites.

Asked by Fleur 8 izinyanga ezidlule

Answered by Paul 8 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Secure Connection Failed

Hello. On some of my sites that i try to get onto with Firefox its says performing TLS handshake then it goes to Secure Connection Failed and says PR_End_Of_File_Error. I… (funda kabanzi)

Hello. On some of my sites that i try to get onto with Firefox its says performing TLS handshake then it goes to Secure Connection Failed and says PR_End_Of_File_Error. I am totally updated with Firefox, plus i cleared out everything in my history. That did not help. When i tried to get onto these websites with Chrome web browser i do not have this problem at all. Why is this? I have BitDefender Total Security newest version for home. My firewall is through them along with virus protections. So can you help me out with this ongoing problem getting on some websites?

Thanks Firefox [email removed from public]

Asked by raftman111 1 unyaka odlule

Answered by Bithiah 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

i can't play some (but not all) youtube videos with firefox 106.0.3

i can't play some (but not all) youtube videos. they do play on other web browsers. the message is "an error occured, please try again later. playback ID is ... " i'… (funda kabanzi)

i can't play some (but not all) youtube videos. they do play on other web browsers.

the message is "an error occured, please try again later. playback ID is ... " 

i'm using firefox 106.0.3 on linux suse tumbleweed. Before I upgraded to both of these the same videos were playing ok.

Asked by ruthtoby 1 unyaka odlule

Answered by ruthtoby 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Can no longer view YouTube videos while in Firefox browser

I can no longer view YouTube videos in Firefox browser because they think I have some kind of add blocker installed. I have never installed such a thing and have no idea … (funda kabanzi)

I can no longer view YouTube videos in Firefox browser because they think I have some kind of add blocker installed. I have never installed such a thing and have no idea how to fix what they are demanding I must fix in order to continue with YouTube in the FireFox browser. In the mean time I have to use some other unfamiliar browser just for YouTube. It appears that some kind of incompatibility has evolved in the recent two or three weeks between Firefox and YouTube.

Asked by timjurek 6 izinyanga ezidlule

Answered by zeroknight 6 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Making Card Payments Issues

Hi, I use Firefox daily, but since the last update I'm unable to make card payments on websites and I'm having to use Chrome as a backup. Up until the update everything … (funda kabanzi)

Hi,

I use Firefox daily, but since the last update I'm unable to make card payments on websites and I'm having to use Chrome as a backup. Up until the update everything was fine and there were no issues making payments on the Royal Mail and Asda websites. When I click the pay button on these sites, the payment window does not open up.

I've tried disabling all addons/extensions to no avail.

Regards Andrew

Asked by fair-trickit 12 izinyanga ezidlule

Answered by fair-trickit 11 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Google search pages not showing text after Mac OS 12.6 Monterey upgrade

Since upgrading to Monterey, Google search pages show almost no text in Firefox. Google searches in Safari and Google Chrome are completely fine. Only Firefox is showing … (funda kabanzi)

Since upgrading to Monterey, Google search pages show almost no text in Firefox. Google searches in Safari and Google Chrome are completely fine. Only Firefox is showing the problem. The blank text includes dropdown menus too - all options inside them are blank. Currently on Firefox v107.0, but the same problem happens with older versions.

If I go into Troubleshoot mode, the Google searches are working fine. I have refreshed Firefox, Cleared the startup cache. But the problem persists. I uninstalled Firefox from the machine, restarted the computer. Did a fresh download and install, haven't signed in so there are no addons/extensions to cause problems.

This is happening on both an Intel Mac and an M1 Mac running Mac OS 12.6 Monterey.

I attach one screenshot showing the same page with and without troubleshoot mode on. The second screenshot shows another page of results including what looks like weirdly encoded characters.

I've followed all the suggestions in the support page but nothing has helped. I'd really appreciate any advice on further troubleshooting. Thanks in advance for any help.

Asked by Pavi 1 unyaka odlule

Answered by cor-el 1 unyaka odlule

  • Kusonjululiwe

captcha not working...never ends

On a couple of websites, but in particular Rogers.com, the captcha just never ends. It asks to click on all the bicycles, I click on them one at a time until no more app… (funda kabanzi)

On a couple of websites, but in particular Rogers.com, the captcha just never ends. It asks to click on all the bicycles, I click on them one at a time until no more appear, hit verify, it brings up something else. It will do this dozens of times and just never ever end.

Switch over to Edge, does the same. Switched to chrome and it works fine. Has google done something to captcha to deny it working on other browsers?

I have checked to see firefox is up to date and it is. I have disabled all extensions/addons. I have run malware/virus scans. On the Rogers community forums there are all kinds of people having problems but there are no solutions on how to fix. Oddly (or not) the problems are similar...captcha won't work on Edge, Firefox but will work on Chrome.

Asked by Rye Encoke 3 izinyanga ezidlule

Answered by zeroknight 3 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox shows [object Object] on pages with code blocks

Since a couple of months I see only [object Object] instead of code blocks on (almost) all web pages. For example on StackOverflow. Any ideas what could cause this? … (funda kabanzi)

Since a couple of months I see only [object Object] instead of code blocks on (almost) all web pages. For example on StackOverflow.

Any ideas what could cause this?

Asked by witek 9 izinyanga ezidlule

Answered by witek 9 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Yoututbe comments not being displayed

Youtube comments are not showing up. Youtube live chat works fine. Issue started happening recently on both my PC and laptop. I checked other browsers and this issue does… (funda kabanzi)

Youtube comments are not showing up. Youtube live chat works fine. Issue started happening recently on both my PC and laptop. I checked other browsers and this issue doesn't exist there.

Asked by nihal.voldemot 1 unyaka odlule

Answered by jonzn4SUSE 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Youtube shorts broken (118.x)

Not exactly sure when it started, but youtube shorts are broken in Firefox now. You can scroll to the next video fine, but if you continue to scroll to the next after th… (funda kabanzi)

Not exactly sure when it started, but youtube shorts are broken in Firefox now.

You can scroll to the next video fine, but if you continue to scroll to the next after that (3rd consecutive video) you get redirected to the first video you started with.

I did try to restart FF in Safemode, but no change. In other browsers (Chrome, Edge) its still working.

Asked by cf0815 6 izinyanga ezidlule

Answered by cf0815 6 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Text overlapping on table content

I got this issue when tried to read some API document provided by a marketplace that i have project with. I tried on another browser and it shown normal, not a single tex… (funda kabanzi)

I got this issue when tried to read some API document provided by a marketplace that i have project with. I tried on another browser and it shown normal, not a single text is overlapping. I've tried some suggestion on another topic to pick No Style on Page Style menu (View -> Page Style -> No Style) but it got more messed up and tried changing font size but still got no improvement. Helpp me pls~

Asked by Gwick 1 unyaka odlule

Answered by cor-el 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Amazon webpage does not load properly using Firefox

I used to be able to get on Amazon with no problems using Firefox. Lately, the website is all chopped up. Blue words with underlining appears on the pages. I can view … (funda kabanzi)

I used to be able to get on Amazon with no problems using Firefox. Lately, the website is all chopped up. Blue words with underlining appears on the pages. I can view Amazon just fine under Safari.

Asked by pam_calhoun 1 unyaka odlule

Answered by jonzn4SUSE 1 unyaka odlule

  • Kusonjululiwe

Youtube playback is prevented on firefox but not on Chrome when using an ad blocker.

YouTube is blocking playback on Firefox due to my use of an ad blocker. However, playback is not blocked in the same circumstances when I use Chrome. Are they trying to s… (funda kabanzi)

YouTube is blocking playback on Firefox due to my use of an ad blocker. However, playback is not blocked in the same circumstances when I use Chrome. Are they trying to stop me from using an ad blocker or overturn my browser choice by forcing me to move from Firefox to Chrome for playback with an ad blocker enabled?

Asked by martinpugh2 5 izinyanga ezidlule

Answered by Terry 5 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

.pdf is always opening as a download and file in new version Windows 10, 104

Hi! In Windows 10 new version 104, .pdf are opening as a download as well as a file. I checked settings, and it still shows that .pdf should open as a file. How do I keep… (funda kabanzi)

Hi! In Windows 10 new version 104, .pdf are opening as a download as well as a file. I checked settings, and it still shows that .pdf should open as a file. How do I keep it from becoming a download?

See image to see what is happening. This did not happen with any of the older versions.

Thank you so very much for your help!! T.S.

Asked by ToSt 1 unyaka odlule

Answered by ToSt 1 unyaka odlule

  • Kusonjululiwe

Roblox website Shattered.

The layout on the Roblox website, https://www.roblox.com Has appeared to break, I've seen the website on Google chrome and Microsoft Edge and it's good to go. I am not aw… (funda kabanzi)

The layout on the Roblox website, https://www.roblox.com Has appeared to break, I've seen the website on Google chrome and Microsoft Edge and it's good to go. I am not aware as to how this has happened. I have disabled every Addon I have, This issue is not caused by the Addons I have installed.

CTRL + F5 has Fixed My Issue! Thank You cor-el!

Asked by aombi 2 izinyanga ezidlule

Answered by cor-el 2 izinyanga ezidlule