Kukhonjiswa imibuzo ethegiwe: Veza yonke imibuzo
  • Kusonjululiwe
  • Okugcinwe kunqolobane

Weird navigation behaviour for angular app

I am developing an Angular App which uses a web-socket for backend communication. Interestingly, whenever I open the app in firefox (localhost:4200) the navigation bar b… (funda kabanzi)

I am developing an Angular App which uses a web-socket for backend communication. Interestingly, whenever I open the app in firefox (localhost:4200) the navigation bar breaks. I can't change the URL manually anymore, but every time I submit a changed URL it first redirects to the specified page but then immediately overwrites the navigation with the previous URL.

Example:

  1. Call http://localhost:4200/
  2. Sometimes the first additional navigation works, but afterwards all manual changes using the address bar will result in the behavior shown in the below image.

Steps I have taken to narrow down the error cause:

  • I ruled out a device specific issue, since the problem occurs on both my machines.
  • It is specific to firefox, since both edge and chrome work perfectly fine
  • I don't think it is related to the angular router and the way I use it, since it would be quite weird that a website could force a user to stay on it.
  • It is not related to the Angular CLI since the error also occurs when I deploy the angular with nginx.

I haven't found any hints on what might cause this behavior or even how to debug the network traffic further to maybe see what is causing the navigation override.

Asked by Grimaldus12 9 izinyanga ezidlule

Answered by Grimaldus12 9 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Various things do not load anymore since the latest Firefox update today

I was using my computer and Firefox all day to watch videos, browse twitter and Tumblr and whatnot until around 15:30 my time, when suddenly Twitter stopped loading my ti… (funda kabanzi)

I was using my computer and Firefox all day to watch videos, browse twitter and Tumblr and whatnot until around 15:30 my time, when suddenly Twitter stopped loading my timeline. I thought it was an issue with Twitter or my computer. I restarted my PC twice so far and rebooted my modem (completely unplugged, left it alone for a min and plugged it in again).

I still cant load my twitter timeline, not even in private with all extensions turned off. It does load Tumblr, but like 80% of the pictures/gifs, even profile pictures do not load. When I search for something on Duck Duck Go it sometimes works but most times it just stays blank. Youtube videos either do not load at all, or stop loading/load endlessly at some point. I am still able to navigate the Youtube website tho.

I really do not want to use Chrome, but the latest update is just unusable. Am I the only one?

(I forgot the word for modem, dont judge me.)

Asked by knollamelie 9 izinyanga ezidlule

Answered by Paul 9 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

No decoder found for audio/mpeg

System: MacOS 13.5 Hardware: Apple M1 Max Firefox version: 116.0.1 about:support / Media Audio Backend: audiounit-rust Codec Support Information: Codec Name Software Deco… (funda kabanzi)

System: MacOS 13.5 Hardware: Apple M1 Max Firefox version: 116.0.1 about:support / Media Audio Backend: audiounit-rust Codec Support Information: Codec Name Software Decoding Hardware Decoding H264 Supported Unsupported AAC Supported Unsupported Opus Supported Unsupported Vorbis Supported Unsupported Wave Supported Unsupported


Having a problem with an mp3 content on all sites. In console I can see error: Error Code: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005) Details: Error no decoder found for audio/mpeg

The same error shows when starting firefox from terminal: [Child 1234, MediaDecoderStateMachine #1] WARNING: Decoder=11dddc400 Decode error: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005) - Error no decoder found for audio/mpeg: file /builds/worker/checkouts/gecko/dom/media/MediaDecoderStateMachineBase.cpp:166

It seems like not a system problem, because I can open and listen an mp3 files in quicktime. And chrome browser also not having any problems playing an mp3 content.

Firefox installed with dmg downloaded from site, but also tried install with brew - same result. The problem occurs in incognito mode too.

Asked by crazytushkan 9 izinyanga ezidlule

Answered by jscher2000 - Support Volunteer 9 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Cannot use firefox when vpn is on

When I use a vpn with firefox (not the firefox vpn), I cannot open normally blocked websites such as twitter or youtube, and instead they open in a sort of half-loaded st… (funda kabanzi)

When I use a vpn with firefox (not the firefox vpn), I cannot open normally blocked websites such as twitter or youtube, and instead they open in a sort of half-loaded state (see image). I don't face this problem with other browsers. I have tried deleting and reinstalling firefox, but it doesn't seem to work. Can anyone help out?

Asked by formod 9 izinyanga ezidlule

Answered by Paul 9 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

No Audio on firefox browser only

Audio on my PC works except on the firefox browser. The browser is not muted, I've checked the volume mixer, i've reinstalled firefox, but nothing seems to work. This jus… (funda kabanzi)

Audio on my PC works except on the firefox browser. The browser is not muted, I've checked the volume mixer, i've reinstalled firefox, but nothing seems to work. This just started occurring a couple days ago. When I restart the pc, i will get audio from firefox for a couple seconds then audio stops.

Asked by justin.c 9 izinyanga ezidlule

Answered by justin.c 9 izinyanga ezidlule

  • Kusonjululiwe
  • Ikhiyiwe
  • Okugcinwe kunqolobane

"Enter" don't execute search in Firefox

Today 05-08-2023 when useing Firefox, im no longer able to use enter key to execute a simple google search. But it works fine on Edge. I don't want to be forced to switch… (funda kabanzi)

Today 05-08-2023 when useing Firefox, im no longer able to use enter key to execute a simple google search. But it works fine on Edge. I don't want to be forced to switch to Edge, how to i fix it?? it just happened randomly. More precisely it's the center of screen search-bar that don't work. I can still use the standard (top) search-bar

I have already tried to update it, close it, nothing works. And i would really like to not lose all my settings by uninstalling it.

Asked by jesperbobbel 9 izinyanga ezidlule

Answered by valentinesire 9 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

google.com won't load

The google search bar on the homepage doesn't work, just does an infinite load, the same with google.com. The extensions I have are AVG Online Security, Malwarebytes, and… (funda kabanzi)

The google search bar on the homepage doesn't work, just does an infinite load, the same with google.com. The extensions I have are AVG Online Security, Malwarebytes, and AVG Anti-Tracking. The version is the latest version 116.0.1

Asked by anthonyjshaffer917 9 izinyanga ezidlule

Answered by anthonyjshaffer917 9 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Youtube videos won't load normally

I woke up this morning and realized my youtube wasn't working right. It was loading endlessly and wouldn't play right away when I clicked a video. I thought at first it w… (funda kabanzi)

I woke up this morning and realized my youtube wasn't working right. It was loading endlessly and wouldn't play right away when I clicked a video. I thought at first it was a computer issue so I restarted it; but that didn't change anything. Then I thought it was an internet thing, so I switched to my mobile hotspot; but still nothing changed.

I've restarted my computer 3 times, restarted firefox 9 times and done just about everything I could find online. I turned off the recommended hardware settings, went into troubleshoot mode (although I'm not tech savvy so I didn't really understand what to look for), made sure firefox was up to date, cleared my cache and cookies, made sure all my add-ons were up to date; and still nothing.

And it's the same for Twitch. It just loads endlessly and doesn't play anything. It doesn't give me an error or a bug notification; just shows the gracy spinning circle and nothing else.

The only way anything loads is if I turn the quality down to the lowest one possible and have it paused for a minute to let it load on its own.

It works fine in Microsoft Edge; but just not in firefox.

Asked by gcbozz00 9 izinyanga ezidlule

Answered by gcbozz00 9 izinyanga ezidlule