Kukhonjiswa imibuzo ethegiwe: Veza yonke imibuzo
  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox 107 userchrome behavior change --tab-lines

Prior to the last update, Firefox was auto resizing my tab background area (I don't know the technical name of this, but its the menu area behind the tabs) to fit more ta… (funda kabanzi)

Prior to the last update, Firefox was auto resizing my tab background area (I don't know the technical name of this, but its the menu area behind the tabs) to fit more tabs as I opened them, up to a certain number of open tabs. Now the tab background area remains at its full size from the start even if I have only 1 tab open. I prefer the old behavior and I'm not sure what userchrome setting I need to adjust in order to get back to it. The line that is causing the issue is as follows

  1. main-window {
 /*--tab-min-height: unset !important; */
 --tab-min-height: 38px;
 --tabs-lines: 8;     /* THIS LINE CAUSES THE PROBLEM */
 --tab_min_width_mlt: 186px;
 --tab_max_width_mlt: 186px;
 --tab-min-height_mlt: 38px;

}

I can reduce it to a lower number but when I do that I am stuck with the tab scrolling behavior that I don't want. Perhaps there is a setting to auto resize the tab area that I'm unaware of. I would appreciate any assistance. Thanks.

Asked by Zafaron 1 unyaka odlule

Answered by Zafaron 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

firefox tabs crash on kernel 6.0 (and following)

I have Firefox 107.0b5 (64-bits) Snap for Ubuntu canonical-002 - 1.0 I use Ubuntu Mainline to update to newer kernels. Never had any problem doing that. I am now on 5.19.… (funda kabanzi)

I have Firefox 107.0b5 (64-bits) Snap for Ubuntu canonical-002 - 1.0 I use Ubuntu Mainline to update to newer kernels. Never had any problem doing that. I am now on 5.19.15. But when I upgrade to kernel 6 (which is now at 6.0.5) Firefox tabs crash. Reloading doesn't help. Each new tab I open gives the same crash message. I have to restart to get Firefox going again. So I removed kernel 6 and reverted back to kernel 5.19 and have no problems any more. But question, what is the problem between kernel 6 and firefox? Does anybody else experience this problem?

I have no other problems with kernel 6 with other programs or hardware or whatever, only firefox tabs crash...

Asked by peterpov 1 unyaka odlule

Answered by peterpov 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox 107 disabled my floating search window.

I use the userChrome.css file to take the search bar from the bottom of the screen and have it float. Here's the instruction that I use ... .browserContainer > findba… (funda kabanzi)

I use the userChrome.css file to take the search bar from the bottom of the screen and have it float. Here's the instruction that I use ... .browserContainer > findbar {-moz-box-ordinal-group: 0; position: fixed !important; }. Firefox 107 has made that .css instruction non-executable. If I text out the instruction I now get the search box at the bottom of the screen. I want it back to a floating search box. Is there a fix in 107 so I can use my .css file or is there another way to get the search box floating. Regards

Asked by Wallytek 1 unyaka odlule

Answered by Wallytek 11 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

cannot find a window i closed today having multiple tabs, using "history" and recently closed tabs/windows (both).

tell me whether i can find a window i closed today having multiple tabs, using "history" and recently closed tabs/windows (both). i especially want to be able to restore … (funda kabanzi)

tell me whether i can find a window i closed today having multiple tabs, using "history" and recently closed tabs/windows (both). i especially want to be able to restore the tab for Institute for the Study of War and its companions. i hope you are warm and rested.


to do my regular research, i have lost three or four (or more) windows with multiple tabs, as a result of my reorganizing tabs. i think of each window with one of its tabs, so these would be, "Emma Loop" (which includes all federal court districts tabs and related info); "Kyle Griffin" (which includes various journalist/news tabs); "emptywheel" (which includes various journalist/news tabs); and other such similar windows whose name ID i don't remember.

restore scares me because it will apply to bookmarks.

i recently began migrating from twitter to mastadon, and wanted to add my regular tabs to mastadon. i moved tabs to keep track, but it seems the tab's parent windows disappeared. i cannot be more clear, because i had a total of about 15 windows with multiple tabs EACH. i regularly exited the program to install updates and because of my settings, all the windows/tabs were saved correctly. this is a great feature.

it takes time to create a window with multiple tabs, and i don't have much of a brain, so it's hard for me to learn new stuff. maybe we can work together to clarify what i need. i just want my "lost" windows/tabs to return to the others so i can continue going forward. i blame this guy - the "new twitter owner" - who has even made changes to UKRAINIANS' account performances. thank you.

Asked by notanotherhero 1 unyaka odlule

Answered by notanotherhero 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox Color Management/Profile Not Being Used

In FF 107.0 (64-bit) on Windows 11, I'm finding that FF is suddenly not honoring my color profile, so everything looks over-saturated. I've tried using gfx.color_manageme… (funda kabanzi)

In FF 107.0 (64-bit) on Windows 11, I'm finding that FF is suddenly not honoring my color profile, so everything looks over-saturated. I've tried using gfx.color_management.mode 1 (my typical setting) and 2 (the default), and neither seems to fix the issue. The same issue exists in a fresh profile. I'd roll back to test an earlier version of FF, but it seems that's no longer easily possible. Edge is displaying colors properly.

Any ideas or known bugs?

Asked by nrbelex 1 unyaka odlule

Answered by nrbelex 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Unknown process keeps running when I open Firefox.

Hi, Since about 2 weeks ago everytime I run Firefox a process with the name 'Hello World' runs as well. The text in the command line window reads: "This process runs at… (funda kabanzi)

Hi,

Since about 2 weeks ago everytime I run Firefox a process with the name 'Hello World' runs as well.

The text in the command line window reads: "This process runs at the full privileges of the user and has access to the entire public desktop API surface

Press any key to exit ... 15:16:48.6322622 (a)ThreadProc Start!! Connection established - waiting for requests"

Does anyone know what this is? I tried searching the net, but I could not find anything useful

I have tried a clean reinstall of Ffox and after running it for the first time, without signing in or installing any add-ons, the same process opened with it.

Thanks,

Mitch.

Asked by Mitch B 1 unyaka odlule

Answered by jonzn4SUSE 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Can't adjust or dismiss sidebar -

Normally I use side-berry to hold all of my tabs - the panel normally collapses and hides to the left of the screen - showing just the favicons of the website. After the… (funda kabanzi)

Normally I use side-berry to hold all of my tabs - the panel normally collapses and hides to the left of the screen - showing just the favicons of the website.

After the most recent firefox update 107.0 (20221110173214) there is now a large bar that i can't remove!

I have a CSS file for appearance, which i have included below.

any idea how to shrink this dead zone? I would really like to keep using my fun tabs.

****
#main-window[tabsintitlebar="true"]:not([extradragspace="true"]) #TabsToolbar > .toolbar-items {
  opacity: 0;
  pointer-events: none;
}


#main-window:not([tabsintitlebar="true"]) #TabsToolbar {
    visibility: collapse !important;
}
 
#nav-bar {
    margin-right:140px;
}
 
/* Some space on top to allow window dragging */
#titlebar {
    appearance: none !important;
    height: 20px;
}
 
/* Fix for main menu calling by Alt button */
#titlebar > #toolbar-menubar {
    margin-top: 10px;
}
 
.titlebar-buttonbox-container {
  display: block;
  height: 35px;
  margin-top: 0px;
}

:root {
  --sidebar-min-width: 50px;
  --sidebar-visible-width: 160px;
}

#sidebar-header {
  overflow: hidden !important;
}

#sidebar-box #sidebar-header {
  display: none !important;
}

#sidebar,
#sidebar-header {
  min-width: var(--sidebar-min-width) !important;
  max-width: var(--sidebar-min-width) !important;
  transition: .1s ease .05s;
  z-index:1;
}
.titlebar-buttonbox-container .titlebar-button {
  display: block;
  height: 45px;
}

#sidebar-box:hover :-moz-any(#sidebar,#sidebar-header) {
  background-color: var(--toolbar-bgcolor) !important;
  min-width: var(--sidebar-visible-width) !important;
  max-width: var(--sidebar-visible-width) !important;
  margin-right: calc((var(--sidebar-visible-width) - var(--sidebar-min-width)) * -1) !important;
  z-index:1;
  position: relative !important;
  transition: .1s ease .05s;
}

Asked by warmbloodedreptile 1 unyaka odlule

Answered by jscher2000 - Support Volunteer 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Most websites return "Server Not Found" but reloading the page fixes it.

When loading a page from a domain I haven't recently visited, it will almost always return the "Server Not Found - Hmm. We’re having trouble finding that site," error mes… (funda kabanzi)

When loading a page from a domain I haven't recently visited, it will almost always return the "Server Not Found - Hmm. We’re having trouble finding that site," error message. If I reload the page, however, it will load. Sometimes I have to reload 2-6 times before it works, but it always eventually succeeds. When it does work, it often times fails to load certain elements like fonts, images, embedded videos, and occasionally whole stylesheets--things that often require calls to third party domain. Again, reloading the page (sometimes multiple times) will cause the page to load properly.

I have already tried:

  • Different browsers on same computer (issue does not occur)
  • Firefox on different computers with different OS on same network (issue does not occur)
  • Cleared cache (issue persists)
  • Troubleshooting/safe mode (issue persists)
  • Deleted prefs file (issue persists)
  • Disabled DNS prefetching (issue persists)

Asked by Jordan 1 unyaka odlule

Answered by cor-el 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Bookmarks not showing in Bookmarks toolbar items anymore

Hi, Before updating Firefox yesterday, I was able to see my 2 bookmarks folders in the Firefox toolbar. Now after updating, I need to click a button with 2 chevrons poin… (funda kabanzi)

Hi,

Before updating Firefox yesterday, I was able to see my 2 bookmarks folders in the Firefox toolbar. Now after updating, I need to click a button with 2 chevrons pointing right which then shows me only 1 of my bookmarks folders.

There are actually 2 folders in here, which I can see if I go to the Bookmarks menu, but clicking the chevron button only shows a single folder. However the problem is that up until yesterday, those folders were right in the toolbar itself without any chevron button.

Has there been a change in the latest version? I don't see anything about this in the release notes.

Thanks,

- Tate

Asked by tate.mccormick 1 unyaka odlule

Answered by tate.mccormick 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Nexus website

Hi, this site when trying to login keeps looping, it has only happened recently and I've cleared cookies and disabled all the addons for it, the site works, but when tryi… (funda kabanzi)

Hi, this site when trying to login keeps looping, it has only happened recently and I've cleared cookies and disabled all the addons for it, the site works, but when trying to login it loops https://www.nexusmods.com and says in the loop-

users.nexusmods.com

Checking if the site connection is secure users.nexusmods.com needs to review the security of your connection before proceeding.

even tried in private browsing, cannot use any other web browser. Please help thanks.

Asked by Mangekyo Sharringan 1 unyaka odlule

Answered by Terry 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Developer Console colours and Folder Icons

hello 1) I've been trying to change the console colours for the web developer console using userChrome.css, but I have failed. I want to set the background for console.i… (funda kabanzi)

hello

1) I've been trying to change the console colours for the web developer console using userChrome.css, but I have failed. I want to set the background for console.info text to be light blue while the text color to be bold dark blue font. I would like to have it only in light theme. Also I would like to change the font size of the console for both themes.

2) Is it possible to change the folders of bookmarks to yellow. I read there are SVG. I tried to solution that are meant to change the folders to yellow, but failed. Can someone point me to a dummies guide for a solution.

The first one is the more important issue.

Thank you in advance

Asked by ProfessorLayman 1 unyaka odlule

Answered by jscher2000 - Support Volunteer 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

(MacOS) Full Screen Removes Tabs even when hovering to the top of Browser

As Title, Whenever I try to go full screen and hover to the top of the browser, It originally showed all my tabs, but recently it has not been doing that. When I hover … (funda kabanzi)

As Title,

Whenever I try to go full screen and hover to the top of the browser, It originally showed all my tabs, but recently it has not been doing that. When I hover over and over, the tabs maybe appear 10% of the time, but whenever I click somewhere else other than the Tab Bar, it disappears.

I think this bug happened ever since I enabled "Hide bookmark toolbar". I have since reverted it back, but the error is still the same. Weird, since my tabs disappear since it has nothing to do with bookmarks.

Asked by Iha7 1 unyaka odlule

Answered by cor-el 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox will not play certain videos, such as youtube live streams, or entire other sites do not play.

Specifically this is interesting because regular youtube content *will play just fine* This is something I can readily reproduce for testing, diagnosis, and troubleshoot… (funda kabanzi)

Specifically this is interesting because regular youtube content *will play just fine*

This is something I can readily reproduce for testing, diagnosis, and troubleshooting.

Please note: I have literally completed all fundamental troubleshooting several times. I respect due diligence and double checking, its just that I wish to be clear I've spent a few hours today on this and am thus far unable to impact the situation at all. --Note on Note: This includes disabling settings/features in firefox. Everything having to do with privacy, networking, hardware accel, and probably another category has been toggled multiple ways. This does not include mucking about in the detailed settings page ( about:config, etc etc). I do not memorize about:config settings I just use reference material to achieve a goal then promptly move on in life, and I am not a professional web developer though I can program so I haven't attempted to fiddle there at all. All that is to say consider any suggestions involving about:config or similar depth of settings to be *untested by myself on this matter* and therefore ripe for suggestions!

Oh, I also have not tested this in a VM. Although I certainly can if requested. I can note that a VPN does not impact this described behavior.

Well, I am able to get teh Ads to play prior to a live stream, sometimes. Note: Ads are not always displayed anyway so I cannot really know the statistics on this for sure.

At this point I have reinstalled Windows10 several times and can still reproduce this problem. All windows security settings have been toggled without impact on core issue. This has been reproduced through multiple win10 reinstalls.

Other browsers, other operating systems will function. I can use firefox on my various linux systems. I can use several versions of firefox to play these same videos on my linux systems.

However win10 at whatever patch level is unable to utilize firefox to play youtube live streams. Again, nothing I've done has impacted this behavior ( reg yt vids OK w/ preview and chats, live stream vids NOT OK, though ads and chats display fine )

I'm several varieties of engineer (Electrical, Networking, Security, Systems - whatever other varieties HR departments decide to use ) and can happily grab whatever data, or create whatever testing conditions that can be asked of me.

Thank you,

Asked by syroth 1 unyaka odlule

Answered by syroth 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Preventing Google from accessing home IP address

Hello, Q1: Is there a way to prevent Google search engine from accessing and sharing the city I live in via my IP address? Q2: Can I block my IP address from Amazon, Goo… (funda kabanzi)

Hello, Q1: Is there a way to prevent Google search engine from accessing and sharing the city I live in via my IP address?

Q2: Can I block my IP address from Amazon, Google and other shareware/spyware garbage AND still access and use the internet?

At the bottom of a Google search result page I can read the city I live in based on my IP address. I would rather not have this shared as I search for products in different stores. I am signed into Google.

When I ran the "Privacy tab" in Firefox the Google search results still showed the city I live in.

I use a VPN, three security extensions("No-Script, Privacy-Badger & FaceBook Container) and Mozilla Firefox set at the "Strict" Browser Privacy level.

Thank you for reviewing these questions, Oliver

Asked by eternalbeach 1 unyaka odlule

Answered by jscher2000 - Support Volunteer 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Save as PDF fails

When I try to print, or Save As PDF, the preview is not acceptable, and varies between landscape and portrait. See attached images. I have had this difficulty for awhile.… (funda kabanzi)

When I try to print, or Save As PDF, the preview is not acceptable, and varies between landscape and portrait. See attached images. I have had this difficulty for awhile. I have been opening up another browser, Edge or Chrome, if I needed a WYSIWYG image. I forget when this began - it's been more than two updates. Thank you.

Win 11 Pro v.21H2 64-bit HP Spectre x360 2-in-1 laptop 16x10, 11th Gen i7, 16 GB RAM

Asked by dried_squid 1 unyaka odlule

Answered by jscher2000 - Support Volunteer 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

What is the CTMsgHostFirefox (32 bit) process? [High CPU usage]

Hi, The highlighted process sometimes goes up to as high as 55% ish CPU for hours on end, making my computer lag for no reason. If I individually close the process, noth… (funda kabanzi)

Hi,

The highlighted process sometimes goes up to as high as 55% ish CPU for hours on end, making my computer lag for no reason. If I individually close the process, nothing happens, and the issue fixes itself (firefox runs fine with it closed).

It is concerning since I could not find anything on google about this process, is this some kind of malware? I did run a MalwareBytes scan on my entire computer, and nothing turned up.

Please let me know what that process is.

Asked by pocketfootprints 1 unyaka odlule

Answered by TyDraniu 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Unexpected padding around HTML document on all pages

Running FF 107.0.1 on Mac 10.15.7 and there is unexpected padding around each website I visit. I've disabled all browser extensions. I'm using the default theme. I've tri… (funda kabanzi)

Running FF 107.0.1 on Mac 10.15.7 and there is unexpected padding around each website I visit. I've disabled all browser extensions. I'm using the default theme. I've tried restarting Firefox. I've tried restarting the computer but the issues seems to persist. I do not see the same rendering behavior when loading these websites on Google Chrome. I'm including screenshots of what I'm seeing.

Asked by Mike Grace 1 unyaka odlule

Answered by jscher2000 - Support Volunteer 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Autocomplete won't stop suggesting google

Whenever i start typing a "g" in the address bar, Google is recommended first. I would prefer for it to be something i commonly search for starting with g, but I can't se… (funda kabanzi)

Whenever i start typing a "g" in the address bar, Google is recommended first. I would prefer for it to be something i commonly search for starting with g, but I can't seem to remove it. Using the usual shift+del doesn't remove it for some reason.

Thanks!

Asked by matistjati 1 unyaka odlule

Answered by jscher2000 - Support Volunteer 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Google ads don't display well

Hi, my google ads don't display correctly in google searches - can anyone help please? Mac M1 / Latest Firefox Formatting is fine for the first second after the search, … (funda kabanzi)

Hi, my google ads don't display correctly in google searches - can anyone help please? Mac M1 / Latest Firefox

Formatting is fine for the first second after the search, then chanegs and text displays over the images in the ades and is unreadble, unless I hover my moude over the ad.

With thanks

Asked by jonnydonovan 1 unyaka odlule

Answered by jonzn4SUSE 1 unyaka odlule