Kukhonjiswa imibuzo ethegiwe: Veza yonke imibuzo

Enable pop-ups on a case-by-case basis

I have run into an annoyance where I am trying to click on a link in my email to open a new page. Clicking on the link makes a bar show up telling me that Firefox has pre… (funda kabanzi)

I have run into an annoyance where I am trying to click on a link in my email to open a new page. Clicking on the link makes a bar show up telling me that Firefox has prevented a popup from being opened (see attached image). I am given the option of managing my preferences / Firefox settings, where I can either go through multiple steps to permanently allow all pop-ups from that website until I restore my original settings, or uncheck a box to permanently allow all pop-ups from all sites until I check that box again. This is annoying because I have no interest in either allowing or disallowing all pop-ups from all websites, or all pop-ups from this specific website, every time I want to open a single pop-up from a specific site. I would rather that the warning bar which tells me that Firefox has blocked a pop-up also display a button allowing me to allow ONLY THIS SPECIFIC POP-UP IN THIS SPECIFIC CASE.

Is this a setting that exists in Firefox? Alternatively, is there a version of Firefox which does have a setting which would allow this? Or is this simply not a functionality that exists for this browser?

Asked by Tiggy Chen 4 izinyanga ezidlule

Last reply by zeroknight 4 izinyanga ezidlule

Live video reproduction isssues.

Hello, I've got a reproduction issue on France TV live programs which I watch through nordvpn. The picture keeps "jumping" fast up and down in a very bothering way. This … (funda kabanzi)

Hello, I've got a reproduction issue on France TV live programs which I watch through nordvpn. The picture keeps "jumping" fast up and down in a very bothering way. This doesn't happen when the video is NOT live. I run the latest version of LINUX MINT. What can I do to fix it? The only way I found to stop the issue is to take down the resolution of the live video to its minimum which gives me a disastrous picture but stops the "jumping". I guess you might say there is something wrong with my GPU. The point is that my PC is brand new with an AMD 5600G, new MB, 16Gb of RAM and 500w of PSU. BUT more than anything I have to say that everything WORKS FINE with CHROME. I like FIREFOX I have been using it literally for decades now. (I'm 75). Is there a solution? Looking forward to hearing from you. Thanks in advance. François.

Asked by Frank Rassiga 3 izinyanga ezidlule

Last reply by zeroknight 3 izinyanga ezidlule

How completely disable firefox activity in background?

Firefox consumes a lot of processor time in background. How to disable it? Following options do nothing: Use recommended performance settings - dasabled Use hardware ac… (funda kabanzi)

Firefox consumes a lot of processor time in background. How to disable it?

Following options do nothing: Use recommended performance settings - dasabled Use hardware acceleration when available - disabled browser.tabs.remote.autostart = false

Asked by Andrey Sherstobitov 2 izinyanga ezidlule

Last reply by Terry 2 emasontweni adlule

YouTube no longer always to play video resolution above 360p in FireFox anymore.

Why does FireFox not allow me to play videos in Youtube above the resolution 360p. Since now FireFox won't allow me to play YouTube videos from 720p or 1080p anymore. Whi… (funda kabanzi)

Why does FireFox not allow me to play videos in Youtube above the resolution 360p. Since now FireFox won't allow me to play YouTube videos from 720p or 1080p anymore. While other browser's allow me to play above 360p up to 4K resolution. What is going on with FireFox this never happen before until the upgrade of FireFox in Manajaro ARM.

Asked by ltheocha 4 izinyanga ezidlule

Last reply by zeroknight 4 izinyanga ezidlule

Won't connect to the internet and doesn't load pages at all

Hello, this is a problem I've been dealing with for nearly 2 months now. Currently using Linux Mint Cinnamon The browser won't connect to any websites or even try to loa… (funda kabanzi)

Hello, this is a problem I've been dealing with for nearly 2 months now. Currently using Linux Mint Cinnamon

The browser won't connect to any websites or even try to load them, anytime I search for something it immediately goes to the error page. I've been struggling with internet on my PC for months and all was fixed when I hooked up ethernet, except for Firefox.

I've gone into about:config countless times. I've restarted it twice, I've tried installing the flatpak version and it's exactly the same result. I've deleted it and reinstalled, nothing. I've unchecked everything I've changed in about:config, once again nothing.

I can't update it as for some reason it says it's disabled by system administrator, which I don't remember enabling. I checked the firewall and it's perfectly fine. No infections were found when I scanned as well.

It's starting to become frustrating and I can't even do anything on my PC because it's acting up. Any and all help is more than appreciated and welcome. Thank you.

Asked by lotzzzzzzz 1 inyanga edlule

Last reply by jonzn4SUSE 1 inyanga edlule

Rpg Mo doesnt work right in my browser, how can i fix that?

when I try to click drop down menus on rpg mo, like settings/game options or anything in the gear drop down menu it wont let me click. I can't play rpg mo is there a reas… (funda kabanzi)

when I try to click drop down menus on rpg mo, like settings/game options or anything in the gear drop down menu it wont let me click. I can't play rpg mo is there a reason for this like is it not html they are using but it works on windows? I am using suse linux leap.

Asked by eric.justin.allan 3 izinyanga ezidlule

Last reply by zeroknight 3 izinyanga ezidlule

restore session failure

Today when I closed Firefox and reopened it the option to restore previous session was not shown, as a result I have lost half my pinned tabs (I managed to redo the rest … (funda kabanzi)

Today when I closed Firefox and reopened it the option to restore previous session was not shown, as a result I have lost half my pinned tabs (I managed to redo the rest from bookmarks) which were vital. I tried going into history but the option was greyed out.

This happened yesterday too but after redoing half my tabs I went to open gmail and it restored all my tabs, I tried the sane today but it failed so am stuck with half my tabs.

Please do not suggest I use synch as I only use one device.

Asked by a.frayed.knot.mate 5 izinyanga ezidlule

Last reply by cor-el 5 izinyanga ezidlule

Update Firefox Browser

When trying to update Firefox on my Linux Mint system, I saw this in settings: Updates disabled by your system administrator. Well, I am the administrator. I checked and… (funda kabanzi)

When trying to update Firefox on my Linux Mint system, I saw this in settings:

Updates disabled by your system administrator. Well, I am the administrator. I checked and I have administrator privilege, and I would not have disabled updates. How to I convey that to Firefox so I can update my browser?

Please email me: [removed email from public support forum] with a response.

Thanks.

Asked by murphy.al 4 izinyanga ezidlule

Last reply by James 4 izinyanga ezidlule

Firefox v122 --profile option is not working properly

Hi, I am running the latest Firefox v122 (firefox_122.0+build1-0ubuntu0.22.04.1~mt1_amd64.deb not snap) and when using the --profile option to specify the startup pr… (funda kabanzi)

Hi,

  I am running the latest Firefox v122 (firefox_122.0+build1-0ubuntu0.22.04.1~mt1_amd64.deb not snap)

and when using the --profile option to specify the startup profile it fails to start even on a NEW system that never ran Firefox if I give it a directory that resides on a mounted ext3 filesystem.

  All the permissions are OK and yet running strace I see an error and after a few second will get the

generic pop-up with the error message: (after a few seconds)

Firefox is already running, but is not responding. To use Firefox, you must first close the existing Firefox process, restart your device, or use a different profile.

 Running the SAME from /tmp works fine, but I need the profile to reside on a persistent storage area

so if the LIVE distro restarts then it can restore the previous session, bookmarks, options, etc...


============================================================
 The 2 directories were created identically and have the exact same permissions:

xubuntu@xubuntu:~$ mkdir /tmp/firefox3

xubuntu@xubuntu:~$ mkdir /media/xubuntu/sys_n01_home/mozilla/firefox3

xubuntu@xubuntu:~$ ls -ald /tmp/firefox3 drwxrwxr-x 17 xubuntu xubuntu 1080 Jan 21 22:05 /tmp/firefox3

xubuntu@xubuntu:~$ ls -ald /media/xubuntu/sys_n01_home/mozilla/firefox3 drwxrwxr-x 17 xubuntu xubuntu 4096 Jan 21 21:13 /media/xubuntu/sys_n01_home/mozilla/firefox3

============================================================

The only difference is that one is mounted on tmpfs and the other is on /dev/nvme0n1p2:

xubuntu@xubuntu:~$ df -k /tmp/firefox3 Filesystem 1K-blocks Used Available Use% Mounted on tmpfs 32560016 351528 32208488 2% /tmp

xubuntu@xubuntu:~$ df -k /media/xubuntu/sys_n01_home/mozilla/firefox3 Filesystem 1K-blocks Used Available Use% Mounted on /dev/nvme0n1p2 195751828 51056068 142695768 27% /media/xubuntu/sys_n01_home


============================================================

When starting firefox with the /tmp/firefox3 profile directory it works fine and starts up:

xubuntu@xubuntu:~$ firefox --profile /tmp/firefox3

newfstatat(AT_FDCWD, "/tmp/firefox3", {st_mode=S_IFDIR|0775, st_size=1040, ...}, 0) = 0 newfstatat(AT_FDCWD, "/tmp/firefox3/.parentlock", {st_mode=S_IFREG|0664, st_size=0, ...}, 0) = 0 openat(AT_FDCWD, "/tmp/firefox3/.parentlock", O_WRONLY|O_CREAT|O_TRUNC, 0666) = 11 fcntl(11, F_GETLK, {l_type=F_UNLCK, l_whence=SEEK_SET, l_start=0, l_len=0, l_pid=-487933736}) = 0 fcntl(11, F_SETLK, {l_type=F_WRLCK, l_whence=SEEK_SET, l_start=0, l_len=0}) = 0 uname({sysname="Linux", nodename="xubuntu", ...}) = 0


BUT when using the persistent storage on the real filesystem (but SAME exact permissions) it fails:

newfstatat(AT_FDCWD, "/media/xubuntu/sys_n01_home/mozilla/firefox3", {st_mode=S_IFDIR|0775, st_size=4096, ...}, 0) = 0 newfstatat(AT_FDCWD, "/media/xubuntu/sys_n01_home/mozilla/firefox3/.parentlock", {st_mode=S_IFREG|0664, st_size=0, ...}, 0) = 0 openat(AT_FDCWD, "/media/xubuntu/sys_n01_home/mozilla/firefox3/.parentlock", O_WRONLY|O_CREAT|O_TRUNC, 0666) = 11 fcntl(11, F_GETLK, {l_type=F_UNLCK, l_whence=SEEK_SET, l_start=0, l_len=0, l_pid=1519466008}) = 0 fcntl(11, F_SETLK, {l_type=F_WRLCK, l_whence=SEEK_SET, l_start=0, l_len=0}) = -1 EACCES (Permission denied) close(11) = 0

Am I doing anything wrong or is this some weird startup issue / race condition in the parentlock management?

Thank you for looking into this.

  -Sanjiyan

PS: I can upload the full strace file for both scenarios if needed. Thanks again.

     running on an xubuntu distribution "22.04.2 LTS (Jammy Jellyfish)"

Asked by Sanjiyan 1 inyanga edlule

Last reply by zeroknight 1 inyanga edlule

Firefox does not play videos on after Ubuntu upgrade

A few days ago Ubuntu (22.04 LTS) showed me a message saying I can upgrade my OS (or something along those lines). I click on agree (any button that would let me proceed)… (funda kabanzi)

A few days ago Ubuntu (22.04 LTS) showed me a message saying I can upgrade my OS (or something along those lines). I click on agree (any button that would let me proceed) and the upgrade took place (without restarting). Along with the upgrade Firefox was also updated to its latest version at the time (119.0). Since then, videos on Twitter play but without sound. On some other websites also none of the videos play. On YouTube, Firefox shows me a message saying "To play video, you may need to install the required video codecs" but the videos play fine; I haven't tried other websites but I assume all would have some issues. Google Chrome however doesn't have this issue and all videos play without any issues.

Note that I have not restarted my computer since the upgrade. I doubt this could be an issue but please let me know if you think this could be the issue.

I did the followings and restarted Firefox but none have worked so far for Twitter and some other random websites that I come across, but they resolved the issue for YouTube and now YouTube videos play, although I still get that codec message at the top of the tab:

sudo apt-get install ffmpeg sudo apt install ubuntu-restricted-extras sudo apt install libavcodec-extra

Someone told me this is because the default Firefox on Ubuntu 22 comes as a snap package and I should install the APT package manually instead so that it works. I prefer not to do this because I have lots of tabs open and have manually changed lots of the settings (including in about:config) that I want to preserve. I would also like to preserve the history of visited websites and keep the current cookies (don't really want to keep entering username/password on the same websites again). So the best way for me is to fix the issue for the default Firefox on Ubuntu 22.

Could you help me figure out what I should do to fix this issue?

Asked by Warrior 3 izinyanga ezidlule

Last reply by zeroknight 3 izinyanga ezidlule

Scrolling is jittery in Firfox, but not other browsers

When I scroll up or down on the touchpad in firefox, it is like I scroll past a certain threshold, and it then sends a "scroll up" or "scroll down" command. When I do th… (funda kabanzi)

When I scroll up or down on the touchpad in firefox, it is like I scroll past a certain threshold, and it then sends a "scroll up" or "scroll down" command.

When I do this is Chromium, it's like I'm moving the website with my fingers. Similar to how it would be on a touch screen. In other browsers, the scrolling is not discrete, but continuous.

I love firefox, but this is driving me mad when I'm browsing. Is there any fix for this?

Asked by L M 1 isonto elidlule

Last reply by TyDraniu 1 isonto elidlule

Firefox crashing repeatedly

Firefox seems to crash repeatedly and generates no crash reports, just freezes up my pc. It works in troubleshooting mode but even after refreshing, the problem persists.… (funda kabanzi)

Firefox seems to crash repeatedly and generates no crash reports, just freezes up my pc. It works in troubleshooting mode but even after refreshing, the problem persists. Surprisingly, it will consistently crash if I go to `about:support` (except in troubleshooting mode). Any help would be appreciated!

Asked by Bilal Musani 5 izinyanga ezidlule

Last reply by zeroknight 5 izinyanga ezidlule

frequent crashes of firefox running on fedora 38 workstation

As the title says, after a certain update(I'm not sure which, probably within the last few months or so), firefox on my machine starts crashing randomly. Some crash repor… (funda kabanzi)

Asked by Bee Rath 3 emasontweni adlule

Last reply by cor-el 3 emasontweni adlule

Lost Passwords

Ubuntu 22... Firefox was frozen, i closed it. couldnt open it again. Restarted pc.. kys.db last edited by firefox 1 week ago. I lost all my passwords, bookmarks, places..… (funda kabanzi)

Ubuntu 22... Firefox was frozen, i closed it. couldnt open it again. Restarted pc.. kys.db last edited by firefox 1 week ago. I lost all my passwords, bookmarks, places... Files are changed 1 week ago.. No copies on mozilla folder... No fucking nothins... There is no copy of them, i changed it 3 days ago and Fx crashed...

Some companies gonna ask me for my personal id, finger print and photos.... Are you fucking serios? Where are my passwords?

I need them, now!

Asked by SonDevrim 5 izinyanga ezidlule

Last reply by Dropa 5 izinyanga ezidlule

Blocking Youtube Ads

Dear Friends, Trust all is well... PLEEZE put an end to this mystery. Can you BLOCK YOUTUBE ADS or not? If so, how is that accomplished. Many of the extension are not … (funda kabanzi)

Dear Friends,

Trust all is well...

PLEEZE put an end to this mystery. Can you BLOCK YOUTUBE ADS or not? If so, how is that accomplished.

Many of the extension are not safe even dangerous to use.

Thank You!

Best, Ralph

Asked by felix85 3 izinyanga ezidlule

Last reply by cor-el 3 izinyanga ezidlule

Firefox won't start after updating. How to restore the previous version without losing profile data?

Firefox won't start after updating to version 123.0 on Ubuntu OS. At the same time, no errors will appear, and there is also no specific crash report that would help und… (funda kabanzi)

Firefox won't start after updating to version 123.0 on Ubuntu OS.

At the same time, no errors will appear, and there is also no specific crash report that would help understand the reason.

How to restore the previous version without losing profile data?

Asked by MarkR 6 ezinsukwini ezidlule

Last reply by zeroknight 5 ezinsukwini ezidlule

Video Playback Issue on Fedora 38 - "Media Playback Aborted due to Corruption"

I'm encountering consistent video playback issues on Firefox while running Fedora 38. The error message I receive when attempting to play videos from certain sites, notab… (funda kabanzi)

I'm encountering consistent video playback issues on Firefox while running Fedora 38. The error message I receive when attempting to play videos from certain sites, notably LinkedIn and Twitter (now X), is:

  • The media playback was aborted due to a corruption problem or because the media used features your browser did not support.*

Furthermore, when examining Firefox's console while attempting to play a video, I observed the following error:

  • [Child 5999, MediaDecoderStateMachine #1] WARNING: Decoder=7fdb3c55a100 Decode error: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005) - mozilla::MediaResult mozilla::FFmpegDataDecoder<60>::InitDecoder(AVDictionary**): Couldn't open avcodec: file /builddir/build/BUILD/firefox-118.0/dom/media/MediaDecoderStateMachineBase.cpp:166*

Steps to Reproduce: 1. Navigate to LinkedIn or X (previously Twitter). 2. Attempt to play any video content. 3. Observe the aforementioned error.

Additional Details: - OS: Fedora 38 - Firefox version: Initially 117.0.1, then updated to 118, both 64-bit. - This issue does not occur on Google Chrome on the same system. - I have attempted the following troubleshooting steps without success:

 1. Updated Firefox to the latest version.
 2. Enabled DRM content.
 3. Booted Firefox in Safe Mode.
 4. Disabled hardware acceleration.
 5. Cleared cache and cookies.
 6. Used a Flatpak version of Firefox.

This issue has significantly impacted my user experience, and I hope to find a resolution soon. Any assistance or guidance would be greatly appreciated.

Thank you!

Asked by rusty_python 5 izinyanga ezidlule

Last reply by Luiz Felipe F M Costa 4 izinyanga ezidlule