Kukhonjiswa imibuzo ethegiwe: Veza yonke imibuzo
  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox ESR crashes at watching videos with "alsa_stream_get_position: Assertion `delay >= 0' failed"

hello, i have a Raspberry Pi 4 with 4GB and Raspberry Pi OS installed. (2020-05-27-raspios-buster-armhf.zip) when i use the stock Firefox ESR (installed via sudo apt inst… (funda kabanzi)

hello, i have a Raspberry Pi 4 with 4GB and Raspberry Pi OS installed. (2020-05-27-raspios-buster-armhf.zip)

when i use the stock Firefox ESR (installed via sudo apt install firefox-esr) and watch videos (e.g. on Youtube, Vimeo, ...), Firefox does crash some times. according about:crashes, i already have submitted about 60 crash reports.

but watching the reports one thing is missing. when i open firefox from the console i can see some output, that is not appearing in the reports.

... firefox-esr: /build/firefox-esr-RgOFaD/firefox-esr-68.11.0esr/media/libcubeb/src/cubeb_alsa.c:1255: alsa_stream_get_position: Assertion `delay >= 0' failed. ExceptionHandler::GenerateDump cloned child 3366 ExceptionHandler::SendContinueSignalToChild sent continue signal to child ExceptionHandler::WaitForContinueSignal waiting for continue signal... Exiting due to channel error. Exiting due to channel error. Exiting due to channel error. Exiting due to channel error. Failed to open curl lib from binary, use libcurl.so instead Firefox ESR crashes when playing videos on Raspberry Pi OS (Debian)

during watching videos in firefox there is more different output to see that seems to be harmless. but always and only this line is printed to console, just befor Firefox crashes: firefox-esr: /build/firefox-esr-RgOFaD/firefox-esr-68.11.0esr/media/libcubeb/src/cubeb_alsa.c:1255: alsa_stream_get_position: Assertion `delay >= 0' failed. so i assume this is the main reason, why Firefox crashes on my system.

any idea how i can get these issue fixed? at the moment when i want to watch videos reliable i am be forces to use the external VLC Player by copy the url to VLC - at least for Youtube videos. but i want to watch videos from other web pages as well and i prefer to watch videos in firefox directly.

Asked by beta-tester 1 unyaka odlule

Answered by beta-tester 11 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

I have updated my O/S from Ubuntu 18.04 to 20.10. Nothing else. Now Firefox is nearly useless

This is basically a copy of what I put in the Ubuntu forum. The problem is the same, no matter where I post it. Originally I was using Ubuntu 18.04 LTS. I thought it woul… (funda kabanzi)

This is basically a copy of what I put in the Ubuntu forum. The problem is the same, no matter where I post it.

Originally I was using Ubuntu 18.04 LTS.

I thought it would be good to update to GG (20.10) though I did briefly try FF (20.04).

As the install was done on an existing 18.04 version things remained the same for programs, book marks, etc.

Ok, now the crunch: I USE Firefox ""A LOT"". When it loads, there are...... 8 x 6 windows of FireFox and each of those have anywhere from one to ""THIRTY"" tabs loading.

Believe me: ""It worked!!""

I could use it, also run other tasks as well - though a VM was pushing it with the RAM. But the entire machine worked.

Now, I am lucky if FireFox loads at all. Let alone let me browse.

When it loads some of the window's tops are flashing. A screen shot does not really show this. (I tried)

All that has changed is the O/S from 18.04 and Firefox from (what ever it was) to 83.0

I don't want this to be a finger pointing exercise between Mozilla and Ubuntu. I would prefer it is helpful to all.

What have I tried? I've tried starting FireFox with all addons disabled. Still happens.

I am going to try to remember to (next time) launch FireFox from a Terminal and pipe the output to a file to look for things.

The machine I am using has shown it is well up to being able to have this running. I have had it working for a few years like this.

This post is (for now) to establish there is a problem. I will post more information when I get it, rather than waiting to get it then post, as I feel there are a lot of people who have very similar problems and I want it known: ""You are not alone!""


Now a bit of extra stuff.

Other things which are weird: When I am watching stuff - youtube for example - the playback is/WAS jerky. I hadn't touched anything in the settings.

After digging around, I discovered that I had to turn ""OFF"" the hardware acceleration for the graphics. Question: How did it get turned on? (Semi rhetorical)

I have a lot of local pages I open with passwords. When I load them the CPU load goes through the roof and nearly invariably the program just exits. No crash report.

Which is a good 50% of how it happens. The other 50% is the machine just locks up and I have to power it down.

Asked by teeny_weeny 1 unyaka odlule

Answered by teeny_weeny 11 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Speckled Visual Glitch

Hello. In any firefox windows, the glitch (see attached images) is present, Any time i mouse over an interactive elelment, all of the speckles change position, and someti… (funda kabanzi)

Hello. In any firefox windows, the glitch (see attached images) is present, Any time i mouse over an interactive elelment, all of the speckles change position, and sometimes color. they look to be very random, sometimes being absent from a large part of the page, and other times being very thick throughout it's entirety. the only way i have found fix it is by downgrading version, however i still would like to know if there is a solution for fixing this version. in chromium browser, this glitch isn't present, it also only, in the past, displayed on pdfs, and some iframes (HTML term for embedded websites in windows), but now it covers the whole page, it isn't unusable but sometimes is hard to look at. This glitch has been present for at least a week (current date is march 1st) but definitely longer. Thanks.

Asked by evjackeden06 9 izinyanga ezidlule

Answered by cor-el 9 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

firefox opens off screen

On new laptop with Windows 10, with an external monitor in extended desktop mode, Firefox is opening partially off screen such that the top bar is inaccessible so I canno… (funda kabanzi)

On new laptop with Windows 10, with an external monitor in extended desktop mode, Firefox is opening partially off screen such that the top bar is inaccessible so I cannot drag it back on screen. If I close it and reopen, it will usually be back on screen. How can I fix this?

Perhaps related: tabs are not reopened and Restore Previous Session does not work.

There are no extensions open.

Thank you for assistance.

Asked by David400 11 izinyanga ezidlule

Answered by Colin M 11 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Viewing google Gmail causes crash during page load

When viewing gmail with my personal account, Firefox is crashing after it loads the conversations in the sidebar. I have tried resetting, using a private window, and runn… (funda kabanzi)

When viewing gmail with my personal account, Firefox is crashing after it loads the conversations in the sidebar.

I have tried resetting, using a private window, and running in Safe Mode

Here is the crash report Id: bp-b36c8ee9-37cb-4dec-9380-2f6320210228

I can repeat this at will. I will try disabling the conversations bar using another browser and then update to see if that helps (it's not crashing when I view my work gmail).

Thanks for your help ;-)

Asked by milohax 9 izinyanga ezidlule

Answered by FredMcD 9 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Two Versions of Firefox Installed

My wife has both Firefox 86.0 NS Firefox 86.0.1 installed on her computer. She continues to experience tab crashes and other problems when playing casino games on Facebo… (funda kabanzi)

My wife has both Firefox 86.0 NS Firefox 86.0.1 installed on her computer. She continues to experience tab crashes and other problems when playing casino games on Facebook. I don't know if the fact that 2 versions are installed is causing the problems, but I only have 86.0.1 on my computer and don't have any problems. The problem is, I tried to remove 86.0, but it will only allow me to refresh. The same is true for 86.0.1. Does she need to get rid of 86.0 and how can she do it? Thanks for any help you can give me.

Asked by mittenwald 8 izinyanga ezidlule

Answered by FredMcD 8 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

How do I restore Firefox to a previous state from Time Machine?

Somehow I managed to lose all of my windows, search history, addins, etc. It would appear that a new profile was created. I tried about:profiles and selecting the old pro… (funda kabanzi)

Somehow I managed to lose all of my windows, search history, addins, etc. It would appear that a new profile was created. I tried about:profiles and selecting the old profile (1.4GB) but while FIrefox starts, the places.sqlite file is now place.sqlite.corrupt. I followed the Mozilla instructions to try to fix the sqlite file but that did not help. I restored the full Firefox Application Support folder from Time Machine but that also starts with a fresh profile and selecting the old one gets me to a corrupt places.sqlite file. Given that I have TIme Machine backups, Is there no way to get back to a previous state with my windows, history, addins, etc. I am faced with losing a lot of work if I can't get back to where I was at least since a recent backup.

Thanks in advance for any assistance you can offer.

Asked by irafuchs 9 izinyanga ezidlule

Answered by cor-el 9 izinyanga ezidlule

  • Kusonjululiwe

Youtube videos lags at random times (didn't tried with other video platforms)

I am on arch linux with firefox version 91.0 and I recently left firefox (i think at version 89) tried out some other browsers for a while but came back to it and now it … (funda kabanzi)

I am on arch linux with firefox version 91.0 and I recently left firefox (i think at version 89) tried out some other browsers for a while but came back to it and now it was version 91.0 and now I am noticing some lags/frame rate degrade at random times and I didn't found a relevant solution any where

I also tried h264ify as I read about the video codec youtube uses but that didn't fixed it and also tried a solution on the forum that said to disable H264 plugin and enable h264ify but that didn't worked as well

Processor: Intel i3-4130 (4) @ 3.400GHz GPU: Intel 4th Generation Core Processor Family RAM: 4gb


here is some more information about my processor and gpu fetched from lspci:


00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (rev 06) Subsystem: Lenovo Device 367d Flags: bus master, fast devsel, latency 0 Capabilities: [e0] Vendor Specific Information: Len=0c Kernel driver in use: hsw_uncore


00:02.0 VGA compatible controller: Intel Corporation 4th Generation Core Processor Family Integrated Graphics Controller (rev 06) (prog-if 00 [VGA controller]) DeviceName: Onboard IGD Subsystem: Lenovo Device 367d Flags: bus master, fast devsel, latency 0, IRQ 28 Memory at f7800000 (64-bit, non-prefetchable) [size=4M] Memory at e0000000 (64-bit, prefetchable) [size=256M] I/O ports at f000 [size=64] Expansion ROM at 000c0000 [virtual] [disabled] [size=128K] Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit- Capabilities: [d0] Power Management version 2 Capabilities: [a4] PCI Advanced Features Kernel driver in use: i915 Kernel modules: i915


edit: fixed formatting a bit as it was causing horizontal scroll.

Asked by Unnat 3 izinyanga ezidlule

Answered by Unnat 3 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Jagged lines appear horizontal in middle of screen when scrolling or watching videos on Youtube

Hi, I have a weird issue if I scroll with my mouse down a webpage I'll get these jagged horizontal lines in the middle of the screen but go away when I stop. Also, whe… (funda kabanzi)

Hi, I have a weird issue if I scroll with my mouse down a webpage I'll get these jagged horizontal lines in the middle of the screen but go away when I stop. Also, when I watch a video where a lot of moving is happening like if it's a hockey game the middle of the screen just that jagged line across in just the middle. What causes this and how do I get rid of it I don't notice on Internet Explorer browser and I've tried disabling hardware and stuff but doesn't work.

Asked by Yizee24 10 izinyanga ezidlule

Answered by Yizee24 10 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

More firefox tab crashes (and more BSOD instances as well)

Recently started having tab crashes again after fixing similar crashes about a month and a half ago. I mostly started noticing them after an Avast and Windows 10 update I… (funda kabanzi)

Recently started having tab crashes again after fixing similar crashes about a month and a half ago. I mostly started noticing them after an Avast and Windows 10 update I did on the same day. I've had some blue screens as well since then. Most of the problems seem to occur at least once daily.

Firefox Crash Reports: bp-ed498fdb-fd9f-435f-a79c-0d4f30201214 bp-b0a3ae32-6fe1-41d7-8f38-31de90201212

So far I've tried: - Making sure my Nvidia drivers, OS, and Antivirus were up to date - Running a system file check which did find some corrupted files but claims to have repaired them.

Asked by Hikki 11 izinyanga ezidlule

Answered by FredMcD 11 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

It became so UNBEARABLE that I sadly MUST stop using Firefox; AND RIGHT NOW!

Hello As others have said recently, Firefox has become unusually greedy in RAM! I love Firefox and it's been my favorite browser for years and years. But there it becam… (funda kabanzi)

Hello As others have said recently, Firefox has become unusually greedy in RAM!

I love Firefox and it's been my favorite browser for years and years. But there it became unmanageable for me!

I'm absolutely not going to spend money to add more RAM to my PC tower, which is only three years old, and otherwise performs perfectly well for my use with all my other apps. There is 8 GB of RAM in my PC, a fast model of RAM, very fast, and expensive. You have to stop, guys, and face the truth! There is a real problem and there is no point in denying it, and saying that it takes more than 8 GB on a PC at the end of 2020.

The CONCRETE result is that we are all going to change the browser we use, it's super sad, and it is happening NOW. I don't want to change, but I have no choice. It's kind of heartbreaking for me, believe me.

Asked by misterpascal 11 izinyanga ezidlule

Answered by NoahSUMO 11 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

White bar on the sides and bottom after newest update(80.0)

Hello Some days ago my Firefox automatically updated to version 80.0 and with that came an annoying white outline to my windows. Whenever I full-screen my browser window… (funda kabanzi)

Hello

Some days ago my Firefox automatically updated to version 80.0 and with that came an annoying white outline to my windows.

Whenever I full-screen my browser window there are white borders on the sides and bottom, a few millimetres wide. The only way to make them disappear is to scale the window down to about 50% of my screen resolution. This is especially annoying because I enjoy my dark themed Firefox. Below I have added a link to the image.

Safe Mode did not make it disappear, refreshing Firefox did not make it disappear, disabling extensions did not make it disappear. Any help is welcome.

Image

Asked by hardo 1 unyaka odlule

Answered by philipp 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox + Windows 7 : Some tabs/sites crashes regularly

This has been going for a couple of days. I have tried starting in safe mode, didn't help. I have tried disabling JavaScript, didn't help. Two "main sites" affected, Fee… (funda kabanzi)

This has been going for a couple of days.

I have tried starting in safe mode, didn't help.

I have tried disabling JavaScript, didn't help.

Two "main sites" affected, Feedly and Gmail. Feedly had this problem but it disappeared after a while. Now Gmail is having problems. I can move around and read mails but not respond to them.

Other sites affected "seems" to have in common that they are blog-type, perhaps like WordPress or similar.

I have a Windows 10 computer with the same browser setup and there have been no problems there so far.

The version is 86.0.1 (64-bit).

I'm not technically advanced so please be gentle with me.

Asked by ArneStockholm 8 izinyanga ezidlule

Answered by ArneStockholm 8 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox no longer starts on Xubuntu

This is a question I am migrating from LQ - the original question (with a bunch of details) is here: https://www.linuxquestions.org/questions/linux-software-2/firefox-won… (funda kabanzi)

This is a question I am migrating from LQ - the original question (with a bunch of details) is here: https://www.linuxquestions.org/questions/linux-software-2/firefox-won%27t-start-on-xubuntu-4175691712/

The issue is that Firefox will not start on my Ubuntu 20.04. This started randomly a few weeks ago - it might be related to an update, but I did not noticed anything specific. Here's the error messages:

$ firefox -safe-mode
ExceptionHandler::GenerateDump cloned child 3792
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...

As detailed in that post, I have tried many variations of reinstalling, scrubbing my system, making sure I am updated, and looking at the systemd logs.

Since then, I have also tried to run firefox with gdb, and I get a seg fault:

 $ firefox -g
GNU gdb (Ubuntu 9.2-0ubuntu1~20.04) 9.2
....
[New Thread 0x7fffe52e3700 (LWP 3166)]
[New Thread 0x7fffe52a2700 (LWP 3167)]
--Type <RET> for more, q to quit, c to continue without paging--
Thread 1 "firefox" received signal SIGSEGV, Segmentation fault.
0x00007ffff2719c5b in ?? () from /usr/lib/firefox/libxul.so

I have found some suggestions that errors relating to libxul may be memory related, but I passed a memtest86 this morning, so back to zero. Anyone here have any thoughts?

Asked by cduston 8 izinyanga ezidlule

Answered by TyDraniu 8 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Backspace keyboard button no longer emulates "Back" browser button

I think the title covers it. Until recently, pressing the <Backspace> key on the keyboard would take me back to the previous webpage. Now it doesn't. Using FF v87 i… (funda kabanzi)

I think the title covers it. Until recently, pressing the <Backspace> key on the keyboard would take me back to the previous webpage. Now it doesn't.

Using FF v87 in Win10 Home.

Asked by MyUsernameHere 8 izinyanga ezidlule

Answered by TyDraniu 8 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox 86 crashes in Debian Buster x86_64

After updating to Firefox 86 it always crashes at launch: ExceptionHandler::GenerateDump cloned child 14439 ExceptionHandler::SendContinueSignalToChild sent continue sign… (funda kabanzi)

After updating to Firefox 86 it always crashes at launch:

ExceptionHandler::GenerateDump cloned child 14439 ExceptionHandler::SendContinueSignalToChild sent continue signal to child ExceptionHandler::WaitForContinueSignal waiting for continue signal...

And Crash Report dialog appears. This is the "Details" dialog content:

AdapterDeviceID: 0x0126 AdapterDriverVendor: mesa/i965 AdapterDriverVersion: 18.3.6.0 AdapterVendorID: 0x8086 AvailablePageFile: 0 AvailablePhysicalMemory: 127062016 AvailableSwapMemory: 4183494656 AvailableVirtualMemory: 2200952832 BuildID: 20210222142601 CrashTime: 1614250267 DesktopEnvironment: unknown EMCheckCompatibility: true FramePoisonBase: 9223372036600930304 FramePoisonSize: 4096 InstallTime: 1614249624 IsWayland: 0 IsWaylandDRM: 0 MozCrashReason: OOB Notes: Debian GNU/Linux 10 (buster)FP(D00-L1000-W00000000-T000) WR? WR- OMTP? OMTP- ProductID: {ec8030f7-c20a-464f-9b0e-13a3a9e97384} ProductName: Firefox ReleaseChannel: release SafeMode: 1 SecondsSinceLastCrash: 641 StartupCrash: 1 StartupTime: 1614250265 ThreadIdNameMapping: 14784:"IPC I/O Parent",14785:"Timer",14786:"Netlink Monitor",14787:"Socket Thread",14788:"Permission",14793:"JS Watchdog",14794:"JS Helper",14795:"JS Helper",14796:"JS Helper",14797:"JS Helper",14799:"Cache2 I/O",14800:"Cookie",14802:"DOM Worker",14803:"IPDL Background",14807:"BackgroundThreadPool #2",14808:"QuotaManager IO",14809:"IndexedDB #1",14811:"StreamTrans #5",14815:"StreamTrans #9",14817:"StreamTrans #11",14819:"StreamTrans #13",14821:"StreamTrans #15",14822:"Worker Launcher",14823:"SoftwareVsyncThread",14824:"Compositor", Throttleable: 1 TotalPageFile: 8249114624 TotalPhysicalMemory: 4046426112 UptimeTS: 1.8864044 Vendor: Mozilla Version: 86.0

Safe mode also crashes. Headless mode is the only way I found to make it not to crash.


Thanks in advance!!

Asked by ociu 9 izinyanga ezidlule

Answered by ociu 9 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Slow video playback on

Hello, I've got a laptop Dell XPS 9380 that comes with an Intel UHD Graphics 620 as Video Chipset. I run in under Fedora 33 with the distro provided package (as of now ve… (funda kabanzi)

Hello,

I've got a laptop Dell XPS 9380 that comes with an Intel UHD Graphics 620 as Video Chipset. I run in under Fedora 33 with the distro provided package (as of now version 84). The playback on some videos is choppy, I have one picture on 10 I'd say.

How can I fix that, can you point me some solution ?

thanks

Asked by Baptiste (Perso) 10 izinyanga ezidlule

Answered by jonzn4SUSE 10 izinyanga ezidlule

  • Kusonjululiwe

Firefox is already running but not responding. The old firefox process must be closed to open a new window

Hello Team, Firefox is already running but not responding. The old firefox process must be closed to open a new window. I'm running a windows 10 laptop. I tried to resolv… (funda kabanzi)

Hello Team, Firefox is already running but not responding. The old firefox process must be closed to open a new window. I'm running a windows 10 laptop. I tried to resolve this issue 1) through task manager, but the issue didn't resolve mentioned in the browser 2) Remove the profile lock file, but it didn't show any folders/files.

However I'm able to install and use other browsers like edge, chrome and opera. Can someone help me to resolve this issue and use firefox browser?

Asked by harishedamad 3 izinyanga ezidlule

Answered by harishedamad 3 izinyanga ezidlule