'data:image' data links in page info. How to identify location/allow retrieval without turning off tracker blocking?

One of the sites I regularly use (tesco.com) seems to have changed the way it gets thumbnail images of products, so that they no longer show up unless I turn off script b… (funda kabanzi)

One of the sites I regularly use (tesco.com) seems to have changed the way it gets thumbnail images of products, so that they no longer show up unless I turn off script blocking for a whole page. (Once I've got one page working, it continues working for the other pages, even if scripts are 'blocked' on those!?)

In the page info I see that the non showing images are only represented by 'data:image' followed by gif.64 and a long string of letters. I understand that this is an html link converted to data, but I don't know why, and have never seen this before. If I copy the 'link' into a new tab, it just goes to a black page. One time I did get a warning pop up from 'NoScript' that the page was doing some dodgy sort of call out, and 'did I want to disable it on this site'. I think it said the call out was to one of the Google sites, but I can't find any way to show this information when NoScript isn't warning me about it; and I can't seem to make 'NoScript' do the pop up every time I try to search with the data link: most times it just goes to the black page: only once or twice has it showed me the warning. I don't understand what's going on.  :/

First time 'NoScript' gave the warning, I opted to 'allow this linking for this page', and the thumbnails then showed up, and the 'data:image' link info was replaced with a normal link to a jpg picture (odd because the data link had been prefixed 'gif;64' ?). I then wanted to know which script to enable for future use, but, when I disabled all the page scripts again, the thumbnails stayed there, and continued to work on the whole site: not just the current page!

When I logged out, and came back to continue shopping later, whatever the setting was, had been lost, and I had to go through the rigmarole of allowing all scripts, to get the thumbnails to show, and then turning off all but the main domain permission afterwards.

Can someone please explain what these data links are, and how to see where they are really aimed/what site a picture is actually on, before just letting them connect. And so how to allow just the exception that's needed to show the thumbnails.

Sorry if this sounds dumb, but it's all new to me.

Many thanks for any enlightenment.

Asked by Spamlet 3 ezinsukwini ezidlule

Last reply by Spamlet 2 ezinsukwini ezidlule

Emails not filling out correctly in forms

When I fill in blanks for emails on website forms, half the time Firefox tells me the email is not valid. These same websites are working fine in Chrome. This problem s… (funda kabanzi)

When I fill in blanks for emails on website forms, half the time Firefox tells me the email is not valid. These same websites are working fine in Chrome. This problem started around 2 weeks ago for me.

I have attached an image from Gradescope to show what I mean.

Asked by isleofnonconformity 3 ezinsukwini ezidlule

Last reply by isleofnonconformity 2 ezinsukwini ezidlule

no sound on Blitzortung.org

When I view the blitzortung.org (live lightning map) website I do not hear any sounds associated with the lightning strikes. The normal sound is a very short duration "cl… (funda kabanzi)

When I view the blitzortung.org (live lightning map) website I do not hear any sounds associated with the lightning strikes. The normal sound is a very short duration "click". The sound is present when using other browsers but I really hate using Chromium (don't like Google). I am running Debian Linus 10 and I nominally use Firefox ESR. I have downloaded the regular Firefox and the problem occurs with Firefox 80 as well as with ESR 68.12.0.

By opening the PulseAudio mixer while the blitzortung site is opened I have observed that there is a brief flash of the AudioIPC server that coincides with the lightning strike "clicks". My guess is that the AudioIPC server response time is the issue.

Is there any way to get around this issue.

Sound works fine for every other web site.

Asked by jsamcr 2 ezinsukwini ezidlule

Last reply by jsamcr 2 ezinsukwini ezidlule

Firefox will not respond

Issue:  Firefox installed fine, but when I try to access the internet through it nothing happens.    I enter Google on the address bar and got no response.   Chrome and E… (funda kabanzi)

Issue:  Firefox installed fine, but when I try to access the internet through it nothing happens.   

I enter Google on the address bar and got no response.   Chrome and Edge work fine only Firefox is unresponsive.   

I have uninstalled it, reinstalled it, refreshed it noting makes it work!

I miss my firefox!

Thanks

Asked by Nodakman 4 ezinsukwini ezidlule

Last reply by Nodakman 2 ezinsukwini ezidlule

How can I disconnect multiple devices at once from my Firefox Account?

On https://accounts.firefox.com/settings/clients?context=fx_desktop_v3&entrypoint=syncedtabs-menupanel I see a very long list of devices connected to my Firefox accou… (funda kabanzi)

On https://accounts.firefox.com/settings/clients?context=fx_desktop_v3&entrypoint=syncedtabs-menupanel I see a very long list of devices connected to my Firefox account. There's 97 of them.

How can I do disconnect from many devices at one time? Disconnecting one by one takes a long time.

Asked by Mozilla cheese 2 ezinsukwini ezidlule

Last reply by Mozilla cheese 2 ezinsukwini ezidlule

When using letter "A" I have issues and weird dot lines

So recently I've noticed that I get lots of problems with firefox and one of them being that when I use letter "A" in my brower it acts as tabulation or simply direct me … (funda kabanzi)

So recently I've noticed that I get lots of problems with firefox and one of them being that when I use letter "A" in my brower it acts as tabulation or simply direct me to search engine front page instead of letting me write the search.

Also I've noticed that on some sites when I'm interracting with input boxes or otherwise browsing I get some kind of dotted lines going criss cross on my browser which is really weird but so far have not caused any major issues. But regarless would be nice to not be there.

Any ideas what's wrong and what I can do to fix it?

Asked by S. 3 ezinsukwini ezidlule

Last reply by S. 2 ezinsukwini ezidlule

Firefox tabs not saved on restart

The subject line says it all. Firefox version 80.0.1 (64-bit) running on Ubuntu. The Preferences / Startup / Restore previous session is ticked. Deleting sessionstore fil… (funda kabanzi)

The subject line says it all. Firefox version 80.0.1 (64-bit) running on Ubuntu.

The Preferences / Startup / Restore previous session is ticked. Deleting sessionstore files (as per https://support.mozilla.org/en-US/questions/1185765) doesn't fix this. There are no Restore Previous Session item available anywhere (https://support.mozilla.org/en-US/questions/1261571)

This appears to have happened only since the latest update. I typically work with 20-30 opened tabs at a time, so this is very annoying, and it it wasn't for the Session History Scrounger for Firefox I'd be totally screwed. (The latest Firefox version also runs cripplingly slow at times, often consuming 100% of CPU according to 'top'.)

Asked by firefox474 3 ezinsukwini ezidlule

Last reply by firefox474 3 ezinsukwini ezidlule

Does any way exist to delete private browsing cookies (without restarting)?

Very often I need to delete cookies from web sites so the sites won't remember me. The cookies in private tabs never show up in "Privacy & Security / Cookies and Site… (funda kabanzi)

Very often I need to delete cookies from web sites so the sites won't remember me. The cookies in private tabs never show up in "Privacy & Security / Cookies and Site Data" (so I can't delete them from there), and they don't go away when I close the tabs or windows. It seems that I can only get rid of them by shutting down Firefox - a horrible solution when I have many other tabs and windows open.

I can't believe that no way exists to delete cookies (and local storage) in private windows and tabs. Does anyone know some way to do that?

Asked by n.p. 5 ezinsukwini ezidlule

Last reply by n.p. 3 ezinsukwini ezidlule

Search failed to match sound

When searching within a web page using CTRL-F, as soon as you type enough characters that don't match anything in the page, as in string not found, it makes a loud annoyi… (funda kabanzi)

When searching within a web page using CTRL-F, as soon as you type enough characters that don't match anything in the page, as in string not found, it makes a loud annoying sound much like Win98 booting. How DO I TURN THAT OFF?

Asked by hazelwood.matthew 5 ezinsukwini ezidlule

Last reply by hazelwood.matthew 3 ezinsukwini ezidlule

Blue screen crashes when playing music or voice messages (Вылетает синий экран при воспроизведении музыки или голосовых сообщений.)

Такое происходит только при работе в вашем браузере. Ошибка whea uncorrectable error

Asked by vityatyniadec 3 ezinsukwini ezidlule

Last reply by vityatyniadec 3 ezinsukwini ezidlule

Firefox updating two profiles with places files

I run Firefox 52.9.0 32bit ESR as main browser - for reasons to do with our server I also run under a separate profile Firefox 68.12.0 ESR 32 bit for testing When using 5… (funda kabanzi)

I run Firefox 52.9.0 32bit ESR as main browser - for reasons to do with our server I also run under a separate profile Firefox 68.12.0 ESR 32 bit for testing

When using 52.9.0 whenever I change a bookmark, it ALSO updates the file in the V68 profile folder! I have no idea why as both profiles should be separate. The time stamps are the same.

I need to keep the V68 profile completely isolated from the V52 so need to try and stop this unusual updating!

Both profiles are NOT local and located in F:drive under different folders. Both versions are started as:- "I:\Firefox New\firefox.exe" -P "Firefox New" and "I:\Firefox\firefox.exe" -P "Firefox Old" and the profiles.ini file points correctly

Any suggestions please - and no I can not update them as needed for specific purposes!

rgds

Asked by firefox982 4 ezinsukwini ezidlule

Last reply by firefox982 3 ezinsukwini ezidlule

add-on icons disappearing from customize controls evernote web clipper, keeper, zoom scheduler

Evernote web-clipper, Keeper and Zoom scheduler icons have all disappeared but appear to be installed. I have removed and reinstalled the add-ons, and restored my custom … (funda kabanzi)

Evernote web-clipper, Keeper and Zoom scheduler icons have all disappeared but appear to be installed. I have removed and reinstalled the add-ons, and restored my custom controls to default and they are still not appearing. Please help.

Asked by underskirt 5 ezinsukwini ezidlule

Last reply by underskirt 4 ezinsukwini ezidlule

Firefox Account Does Not Prompt for Password

In order to get support for Firefox for Android, I had to create a Firefox account. I was surprised to find that in spite of creating a robust password, I have yet to be… (funda kabanzi)

In order to get support for Firefox for Android, I had to create a Firefox account. I was surprised to find that in spite of creating a robust password, I have yet to be prompted for it. If I sign out and close Firefox, then go to http://support.mozilla.org, I click on Sign In and it takes me to Firefox Accounts and shows my email address in the sign-in box. When I click continue, it logs me in without a password. When I checked "Logins and Passwords", it displays "No logins found", so it didn't store the password there. Did Firefox store the password without asking? Is it encrypted? Where is it stored? Is this another shortcoming/omission of the new Firefox?

Thank you for any guidance you can provide.

Asked by ccwilson1 4 ezinsukwini ezidlule

Last reply by ccwilson1 4 ezinsukwini ezidlule

Add-ons not showing in toolbar

Hello When it comes to add-ons, then I add three of four at once or the same purpose, I try them all out, decide if I want to keep any of them, and then remove the ones … (funda kabanzi)

Hello


When it comes to add-ons, then I add three of four at once or the same purpose, I try them all out, decide if I want to keep any of them, and then remove the ones I see that do not serve my target. All normal.


I know that it requires permission in order to have an add-on show in Private Browsing, that's done.

Now I had 8 add-ons on the toolbar, I disabled two or three of them so I can try two new ones. I did not like the new ones, so I just enabled the ones I had disabled, which where previously showing in the toolbar, all of this in Private Browsing having the permission of showing them.


As I enabled the add-ons again, they are not showing anymore in the toolbar..!!

Okay, I removed them and re-added them..not showing. I also did: not allow in Private Mode, then re-allowed..not showing. I simply restarted the browser in both normal and Private Mode, and yet not showing.. I also restarted my pc, and retried all previous steps again

  • This mainly happened as I removed the extension from toolbar, then added it again.

Still also 90% of the time, just disable then enable again, and only a few are showing again. Either when disabled then re-enabled or when removed then re-added*


So, what to do ?

Asked by Mark 4 ezinsukwini ezidlule

Last reply by Mark 4 ezinsukwini ezidlule

OneTab

OneTab has not be repopulating with all of my saved websites lately (last 5-6 days). It has eventually come back but today, its not happening. I have a tab that is my On… (funda kabanzi)

OneTab has not be repopulating with all of my saved websites lately (last 5-6 days). It has eventually come back but today, its not happening. I have a tab that is my OneTab tab that has my saved websites in it. That tab exists still but it is empty. None of my saved websites are there. Also, the OneTab icon has disappeared. There is a space where it used to be and if I click on that space it goes to the description of OneTab so it is still (sort of) there, but... How do I get OneTab to work again. I don't want to lose the list of websites I saved. Thanks.

Asked by geri3 5 ezinsukwini ezidlule

Last reply by geri3 4 ezinsukwini ezidlule

zoom setting, Change Ramdomly from My Settings, 90 %

While Playing Elvenar, My Screen size will Randomly Change from my SET 90%... All of a Sudden i'm Trying to *SEE* the Screen... @50%.. WTH?? I Have to Switch outta the Ga… (funda kabanzi)

While Playing Elvenar, My Screen size will Randomly Change from my SET 90%... All of a Sudden i'm Trying to *SEE* the Screen... @50%.. WTH?? I Have to Switch outta the Game and Reset.. At some Point Later... It Switches again.. to 150% (Now I'm Looking at a BLADE of Grass on my Map Screen...) This Keeps Happening... I can't Figure out... WHY... am I BEING HACKED??

Asked by TnTiger61 4 ezinsukwini ezidlule

Last reply by TnTiger61 4 ezinsukwini ezidlule

How to stop Firefox "New Tab" screen from remembering my history.

I have cleared all my history in every way I can think off. Then I set Firefox to not remember anything. I really do intend for Firefox to not track and log my browsing h… (funda kabanzi)

I have cleared all my history in every way I can think off. Then I set Firefox to not remember anything. I really do intend for Firefox to not track and log my browsing habits. After these settings it appears to fix the "New Tab" screen (it now populates with generic icons) but if you dismiss one of the generic icons, Firefox will immediately populate the icons with my actual browsing history.

Asked by Serrano.Jo 4 ezinsukwini ezidlule

Last reply by Serrano.Jo 4 ezinsukwini ezidlule

Full Screen Pictures Not Showing

Hello. With FF 80.0.01 when going to this site: https://www.rvtrader.com/listing/2011-Four+Winds-Montecito+40J-5012888859 https://www.rvtrader.com/listing/2011-Four+Win… (funda kabanzi)

Hello. With FF 80.0.01 when going to this site: https://www.rvtrader.com/listing/2011-Four+Winds-Montecito+40J-5012888859 https://www.rvtrader.com/listing/2011-Four+Winds-Montecito+40J-5012888859 ... and clicking the pictures to scroll the pictures in full screen, FF wants to put the browser in fullscreen, not just the pictures. In Chrome, Edge, the pictures do go in full screen.

Is this a setting to toggle?

Thanks

Asked by Ron P 5 ezinsukwini ezidlule

Last reply by Ron P 5 ezinsukwini ezidlule