Kukhonjiswa imibuzo ethegiwe: Veza yonke imibuzo

firefox leaves fullscreen mode, when resized

Firefox leaves full-screen mode when window manager remaps window to be in a frame and re-sizable. In the window-manager that I use (KDE plasma), I can ask the window-man… (funda kabanzi)

Firefox leaves full-screen mode when window manager remaps window to be in a frame and re-sizable.

In the window-manager that I use (KDE plasma), I can ask the window-manager to exit full-screen mode, without telling the window. This allows me to tell a window to be in full-screen mode, while in a framed window. I have attached a screen-shot of chrome showing a youtube video. Both youtube and the chrome are in full screen mode, however the window manager has re-sized it and added decorations (title-bar&frame), and is allowing me to resize, move, minimize, maximize, etc.

This works for every program that I have used (that has a full-screen mode). However it is not working for Firefox. It seems that Firefox is triggering off of the wrong event.

My guess: the window-manager sets NET_WM_STATE_FULLSCREEN to enter full-screen, and would normally clear this attribute to exit full screen. When we exit full-screen, but stay in full-screen mode, the attribute is not cleared. However Firefox is triggering off of something else such as a re-size event.

Use-case: What I am trying to do

  1. Enter full screen mode: browser hiders tab-bar, and address bar, maybe web-page changes layout (e.g. you-tube resizes video player to fill window)
  2. Tell Window-manager to leave full-screen-mode, but not inform browser (or other app). Browser is now still hiding tab-bar, address-bar, site is till showing video in whole-window, but window can be moved and re-sized.

This works for every other app that I have user. (Some apps don't have full-screen-mode, so this does not apply to them. But it works for all that do have it.)

Asked by ctrl_alt_del 1 inyanga edlule

Last reply by ctrl_alt_del 2 emasontweni adlule

Oracle Client settings

I have the correct oracle client for this APP 8.144 installed on my HVD & Windoze 10E. Works with IE but not Moz? Presume there are settings preventing Moz from acce… (funda kabanzi)

I have the correct oracle client for this APP 8.144 installed on my HVD & Windoze 10E. Works with IE but not Moz? Presume there are settings preventing Moz from accessing the application I'm trying to reach.

Asked by sb9724 5 ezinsukwini ezidlule