Kukhonjiswa imibuzo ethegiwe: Veza yonke imibuzo

Firefox v122 --profile option is not working properly

Hi, I am running the latest Firefox v122 (firefox_122.0+build1-0ubuntu0.22.04.1~mt1_amd64.deb not snap) and when using the --profile option to specify the startup pr… (funda kabanzi)

Hi,

  I am running the latest Firefox v122 (firefox_122.0+build1-0ubuntu0.22.04.1~mt1_amd64.deb not snap)

and when using the --profile option to specify the startup profile it fails to start even on a NEW system that never ran Firefox if I give it a directory that resides on a mounted ext3 filesystem.

  All the permissions are OK and yet running strace I see an error and after a few second will get the

generic pop-up with the error message: (after a few seconds)

Firefox is already running, but is not responding. To use Firefox, you must first close the existing Firefox process, restart your device, or use a different profile.

 Running the SAME from /tmp works fine, but I need the profile to reside on a persistent storage area

so if the LIVE distro restarts then it can restore the previous session, bookmarks, options, etc...


============================================================
 The 2 directories were created identically and have the exact same permissions:

xubuntu@xubuntu:~$ mkdir /tmp/firefox3

xubuntu@xubuntu:~$ mkdir /media/xubuntu/sys_n01_home/mozilla/firefox3

xubuntu@xubuntu:~$ ls -ald /tmp/firefox3 drwxrwxr-x 17 xubuntu xubuntu 1080 Jan 21 22:05 /tmp/firefox3

xubuntu@xubuntu:~$ ls -ald /media/xubuntu/sys_n01_home/mozilla/firefox3 drwxrwxr-x 17 xubuntu xubuntu 4096 Jan 21 21:13 /media/xubuntu/sys_n01_home/mozilla/firefox3

============================================================

The only difference is that one is mounted on tmpfs and the other is on /dev/nvme0n1p2:

xubuntu@xubuntu:~$ df -k /tmp/firefox3 Filesystem 1K-blocks Used Available Use% Mounted on tmpfs 32560016 351528 32208488 2% /tmp

xubuntu@xubuntu:~$ df -k /media/xubuntu/sys_n01_home/mozilla/firefox3 Filesystem 1K-blocks Used Available Use% Mounted on /dev/nvme0n1p2 195751828 51056068 142695768 27% /media/xubuntu/sys_n01_home


============================================================

When starting firefox with the /tmp/firefox3 profile directory it works fine and starts up:

xubuntu@xubuntu:~$ firefox --profile /tmp/firefox3

newfstatat(AT_FDCWD, "/tmp/firefox3", {st_mode=S_IFDIR|0775, st_size=1040, ...}, 0) = 0 newfstatat(AT_FDCWD, "/tmp/firefox3/.parentlock", {st_mode=S_IFREG|0664, st_size=0, ...}, 0) = 0 openat(AT_FDCWD, "/tmp/firefox3/.parentlock", O_WRONLY|O_CREAT|O_TRUNC, 0666) = 11 fcntl(11, F_GETLK, {l_type=F_UNLCK, l_whence=SEEK_SET, l_start=0, l_len=0, l_pid=-487933736}) = 0 fcntl(11, F_SETLK, {l_type=F_WRLCK, l_whence=SEEK_SET, l_start=0, l_len=0}) = 0 uname({sysname="Linux", nodename="xubuntu", ...}) = 0


BUT when using the persistent storage on the real filesystem (but SAME exact permissions) it fails:

newfstatat(AT_FDCWD, "/media/xubuntu/sys_n01_home/mozilla/firefox3", {st_mode=S_IFDIR|0775, st_size=4096, ...}, 0) = 0 newfstatat(AT_FDCWD, "/media/xubuntu/sys_n01_home/mozilla/firefox3/.parentlock", {st_mode=S_IFREG|0664, st_size=0, ...}, 0) = 0 openat(AT_FDCWD, "/media/xubuntu/sys_n01_home/mozilla/firefox3/.parentlock", O_WRONLY|O_CREAT|O_TRUNC, 0666) = 11 fcntl(11, F_GETLK, {l_type=F_UNLCK, l_whence=SEEK_SET, l_start=0, l_len=0, l_pid=1519466008}) = 0 fcntl(11, F_SETLK, {l_type=F_WRLCK, l_whence=SEEK_SET, l_start=0, l_len=0}) = -1 EACCES (Permission denied) close(11) = 0

Am I doing anything wrong or is this some weird startup issue / race condition in the parentlock management?

Thank you for looking into this.

  -Sanjiyan

PS: I can upload the full strace file for both scenarios if needed. Thanks again.

     running on an xubuntu distribution "22.04.2 LTS (Jammy Jellyfish)"

Asked by Sanjiyan 2 izinyanga ezidlule

Last reply by zeroknight 2 izinyanga ezidlule

New Firefox GPC 120 setting causes problems on Xfinity community forum

I just updated to Firefox 120, and tried the new GPC setting (Tell websites not to sell or share my data). I ran into a problem when I went to the Xfinity community forum… (funda kabanzi)

I just updated to Firefox 120, and tried the new GPC setting (Tell websites not to sell or share my data). I ran into a problem when I went to the Xfinity community forums (https://forums.xfinity.com/) . It causes a banner on top showing they recognize the setting. There is an "X" in the corner, and some text that says "Hide this banner", but they are not active. Plus, I cannot make a new post or do a general reply (that weird forum software has both local replies to a particular post and general replies to the general thread.)

Is this a bug in Firefox, or a bug in their forum software? I attached a picture of the message it gives.

Asked by andyross 4 izinyanga ezidlule

Last reply by zeroknight 4 izinyanga ezidlule

Websites not working/loading because of CORS

Hello guys, so in the past 2-3 days i started facing Cross-Origin Request Blocked for a lot of websites lets take chatgpt for example, if i visit it i get: Content-Secu… (funda kabanzi)

Hello guys, so in the past 2-3 days i started facing Cross-Origin Request Blocked for a lot of websites lets take chatgpt for example, if i visit it i get:

Content-Security-Policy warnings 2 Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://cdn.oaistatic.com/_next/static/chunks/sso.74deac81d652476b.js?dpl=f90a861ef09abad575887be5d613ce15a4fdb6d9. (Reason: CORS request did not succeed). Status code: (null). The resource from “https://cdn.oaistatic.com/_next/static/chunks/sso.74deac81d652476b.js?dpl=f90a861ef09abad575887be5d613ce15a4fdb6d9” was blocked due to MIME type (“text/plain”) mismatch (X-Content-Type-Options: nosniff).

and its getting so annoying that its blocking a lot of websites, i tried chromium it works fine and works awesomely no cors no problems. I even tried to disable the firefox protection, dns over https on/off, change my main dns upstream, installed firefox developer, compete uninstall/reinstall, cache clear from installers and from firefox it self nothing is working. I will provide firefox developer edition troubleshooting information but keep in mind it doesnt work on both firefox normal and developer

Please any help would be appreciate it.

Firefox v124.0.2-1

Asked by TMU RecKLesS 1 isonto elidlule

Last reply by zeroknight 1 isonto elidlule

How do I add the new bookmarks at top of the list in their folder?

When you add a new bookmark to a folder it's added at the end of the existing list. Is there a way to make Firefox add it at the top of the list, instead? I found an ol… (funda kabanzi)

When you add a new bookmark to a folder it's added at the end of the existing list.

Is there a way to make Firefox add it at the top of the list, instead?

I found an old answer, but, sadly, the extension granting my wish is no longer.

Also, I already know about sorting, but it's not what I need, because I'm doing a lot of manual bookmarks reordering and sorting will nullify it.

Thank you :)

Asked by G 1 inyanga edlule

Last reply by jscher2000 - Support Volunteer 1 inyanga edlule

Firefox Developer Edition starts up at a fixed position and size

I am running Firefox Developer Edition (123.0b1) on Windows 11 and every time I start Firefox it maximises and then resizes to a set size with the maximise button set to … (funda kabanzi)

I am running Firefox Developer Edition (123.0b1) on Windows 11 and every time I start Firefox it maximises and then resizes to a set size with the maximise button set to restore size mode (I.e. the window thinks it is maximised). I have followed the steps detailed for this question: https://support.mozilla.org/en-US/questions/1411093 however that does not resolve my issue. This has only started recently after I turned the laptop into a tablet and back again. Once I "restore" the window and then I maximise the window it works as expected. However it is very annoying. Also if I start another instance of Firefox this new instance does not exhibit the same behavior.


Computer: HP Envy OS: Windows 11 with all current updates and as far as I can tell AI is turned off using a group policy.

Asked by graham.harris.1975 2 izinyanga ezidlule

Last reply by zeroknight 2 izinyanga ezidlule

can not play live streams at 1080p60

Only in Firefox freeze the live streams in YouTube , Twitch , etc if I set 1080p60 , however if a select 720p60 then the live stream play smoothly . ple… (funda kabanzi)

Only in Firefox freeze the live streams in YouTube , Twitch , etc if I set 1080p60 , however if a select 720p60 then the live stream play smoothly .

please someone can help me ?

I already try to change somethings in about:config , but nothing change. same issue .

Asked by Ed C:\ 1 inyanga edlule

Last reply by zeroknight 1 inyanga edlule

Highlighting in PDFs using native tools.

Hello, as of recently Firefox got the new tool to highlight text in the native PDF viewer, and I really enjoyed using it. As of today, I had not updated or changed versio… (funda kabanzi)

Hello, as of recently Firefox got the new tool to highlight text in the native PDF viewer, and I really enjoyed using it. As of today, I had not updated or changed versions, but I suddenly lost access to the highlight tool option. Refreshing the page didn't work, downloading a new PDF and opening it didn't work, restarting Firefox didn't work, and I haven't seen anybody else have this issue.


Firefox Version> Firefox Developer Edition 125.0 Beta 8 (20240403091602) OS> Windows 11

I don't know if this is just an issue due to it being in beta, or it being on beta 7 but not 8, but either way any solution is appreciated!

Asked by Missing 2 emasontweni adlule

Last reply by zeroknight 2 emasontweni adlule

Tab Grouping app replacement or work-around

I am trying to migrate from a very old version of Firefox (v. 55) to the current one, but there is an app that is more helpful to me that all the other features combined.… (funda kabanzi)

I am trying to migrate from a very old version of Firefox (v. 55) to the current one, but there is an app that is more helpful to me that all the other features combined. That is the "Tab Grouping" app that will not run in any version of FF higher than v. 55.

In my work, which often includes a tremendous amount of research, I need to be able to quickly go from one group of tabs to another. If I had to open all these sites manually, that would take the better part of the day and frankly I don't have near the mental capacity to remember the tremendous number of tabs. I have had a couple replies (Thanks!) to this question sometime back, but unfortunately none were even close in performance.

So, can anyone direct me to an app that will allow very quick movement from different sets of windows/tab groups (please see screen shots below)? Is there anyway that I can get this app to work in Legacy mode? I have several other old apps that work perfectly well in this mode.

Asked by Wolfgang Rotbart 4 izinyanga ezidlule

Last reply by Wolfgang 4 izinyanga ezidlule

why do my add-ons keep getting disabled?

why do my add-ons keep getting disabled? ff keeps disabling add-ons that i have used for years and even keep a v. 5 to use the older add-ons and use the latest ff develo… (funda kabanzi)

why do my add-ons keep getting disabled?

ff keeps disabling add-ons that i have used for years and even keep a v. 5 to use the older add-ons and use the latest ff developer to use w/ more modern websites. ff even disables add-ons that worked perfectly well in ff developer and does not even give me the opportunity to re-enable them like i could before.

is there any way to force my old version to let ME decide what i want disabled/enabled?

Asked by digirl 1 inyanga edlule

Last reply by cor-el 1 inyanga edlule

Passwords on phone not showing up on laptop

Hello, I use the Firefox browser on my phone and laptop, and have Lockwise on my phone where all the passwords are stored. Until yesterday, all these passwords would alw… (funda kabanzi)

Hello,

I use the Firefox browser on my phone and laptop, and have Lockwise on my phone where all the passwords are stored. Until yesterday, all these passwords would always appear in my Firefox browser stored passwords. Now, they only show up in Lockwise on my phone and do not show up in the phone or Laptop Firefox browser.

I have followed this guide: https://support.mozilla.org/en-US/kb/end-of-support-firefox-lockwise and am syncing passwords across devices, but this did not solve the problem.

Has anyone else encountered this and know how to fix it?

Thank you.

Asked by spampinatodesign 3 izinyanga ezidlule

Last reply by Paul 3 izinyanga ezidlule

Assistance with Tab Activation Order

Hello! Can you help me sort out a little problem? I am reaching out to seek assistance with a specific issue I am encountering in the Firefox browser. In my previous bro… (funda kabanzi)

Hello! Can you help me sort out a little problem? I am reaching out to seek assistance with a specific issue I am encountering in the Firefox browser.

In my previous browser, when opening new tabs, they were considered active even if I did not immediately switch to them. This behavior allowed me to open multiple tabs, for example, by using the mouse wheel to open several videos from the main YouTube page. Subsequently, when closing the main page, the videos would be available in the order they were opened, facilitating a seamless viewing experience.

Upon transitioning to Firefox, I have attempted to configure the browser to replicate this behavior using the Sidebery extension. However, even with the extension, new tabs are not recognized as active unless I explicitly switch to them, making it challenging to maintain the desired tab activation order.

I have explored various settings and experimented with the Sidebery extension but have not been successful in achieving the desired result. In contrast, the Yandex browser, with the "Switch to the previous active tab when closing a tab" option enabled, behaves in the manner I am accustomed to.

Could you please provide guidance on how I can configure Firefox to consider new tabs active immediately upon opening, regardless of whether I switch to them immediately?

I added pictures to make it clearer what I'm talking about.

Thank you for your time and assistance.

Asked by Vilian 1 inyanga edlule

Last reply by cor-el 1 inyanga edlule

Firefox reverted back a few years, need to install my old firefox data

After a update my browser was running very slow, I'm not sure what I did but my whole browser, including history and bookmarks and add ons reverted back years. But I have… (funda kabanzi)

After a update my browser was running very slow, I'm not sure what I did but my whole browser, including history and bookmarks and add ons reverted back years. But I have a whole folder of Old Firefox Data which is from today.

How do I get this back on there and get everything back to normal?

Asked by TheImmortalLowlife 4 izinyanga ezidlule

Last reply by cor-el 4 izinyanga ezidlule

Developer Edition switched to dark background and I cannot undo this setting

I change nothing in my settings and I am now on Dark background everywhere despite having: - forced the system settings (OS) to stay in light background - in about:prefer… (funda kabanzi)

I change nothing in my settings and I am now on Dark background everywhere despite having: - forced the system settings (OS) to stay in light background - in about:preferences appearance I've manually selected (forced) the light background - in about:config I've tried to switch the browser.theme.content-theme to "1" (instead of "0")

this is really frustrating, I would like to get a better "reading" of what happens, as an Engineer I am happy to also squint at logs if needed, please consider adding a preference / settings change log file

Asked by looeegee 3 izinyanga ezidlule

Last reply by cor-el 3 izinyanga ezidlule

Unable to Log in Google Accounts

Error Message: "Could'nt Sign You In: This Browser or APP May not be Sscure 1. Happened to Both Build 124 and 125 2. Virus Clean 3. Haved tried cleaning the cache and co… (funda kabanzi)

Error Message: "Could'nt Sign You In: This Browser or APP May not be Sscure 1. Happened to Both Build 124 and 125 2. Virus Clean 3. Haved tried cleaning the cache and cookies

Asked by Samson Z 1 isonto elidlule

Last reply by cor-el 1 isonto elidlule

Can't find downloaded file after closing the private window

Hey folks, I use the firefox developer edition and I downloaded a zip file in it's private and when the download was complete I closed the window and open the download fo… (funda kabanzi)

Hey folks, I use the firefox developer edition and I downloaded a zip file in it's private and when the download was complete I closed the window and open the download folder but the file was not there I haven't change the downloads folder location

Asked by Aditya 3 izinyanga ezidlule

Last reply by cor-el 3 izinyanga ezidlule

Firefox 122.0b9 stops responding when the file dialog is triggered

No crash report, no trace, no anything. I click "Save [insert] as...", and Firefox hangs and stops responding. Windows automatically shuts it off when clicking. Launching… (funda kabanzi)

No crash report, no trace, no anything. I click "Save [insert] as...", and Firefox hangs and stops responding. Windows automatically shuts it off when clicking. Launching Firefox again sometimes says there was a problem reloading the session, but that's not guaranteed.

Asked by TheTank20 3 izinyanga ezidlule

Last reply by zeroknight 3 izinyanga ezidlule