Kukhonjiswa imibuzo ethegiwe: Veza yonke imibuzo
  • Kusonjululiwe

Middle-Clicking on a hyperlink is no longer opening new windows and I would like it do so.

This is driving me nuts. My desired behavior is that, when I middle-mouse-click on a hyperlink, Firefox launches a new window (not a tab) with that URL. This is how it wa… (funda kabanzi)

This is driving me nuts.

My desired behavior is that, when I middle-mouse-click on a hyperlink, Firefox launches a new window (not a tab) with that URL.

This is how it was working before a power interruption forced my computer to restart tonight, and my desired behavior has gone away.

The middle mouse button works for other functions; and, middle-clicking on bookmarks in my bookmark bar does launch a new window with that bookmark as expected. However, middleclicking a hyperlink does nothing.

I have browser.tabs.opentabfor.middleclick = false and in the options menu, "open links in tabs instead of new windows" is unchecked. Additionally I have set browser.link.open_newwindow = 2.

Can anyone help me here? This is driving me slightly batty.

Asked by ShadowDragon8685 4 izinyanga ezidlule

Answered by jscher2000 3 izinyanga ezidlule

  • Okugcinwe kunqolobane

Tabs sometimes do not load pages when I middle-click on links from website or from bookmarks

At several occasions, but not in a reproducible manner, when I open pages' links (or bookmarks toolbar's links) using middle-click button (i.e. using "Open Link in a new … (funda kabanzi)

At several occasions, but not in a reproducible manner, when I open pages' links (or bookmarks toolbar's links) using middle-click button (i.e. using "Open Link in a new tab"), the tab opens up, shows the URL it should load, but seems to stop there and never actually loads the website. Sometimes, the URL won't even show up in the omnibar. When this happens, the "Reload current page" is grayed out, so I need to click the omnibar and hit enter to force the URL to load, or click the original link again. Most of the time, reclicking with middle button on the same link works fine again. I did not see any common pattern regarding which links generate this behavior or not, but I will keep trying to find out.

This behavior does occur even in safe-mode (all addons disabled).

Asked by simon.budin 6 izinyanga ezidlule

Last reply by gumby_dammit223 2 izinyanga ezidlule

Disable Middle Click Tab Bar FF76

[previous post] With the latest update, the CSS tweak to disable the creation of new tab when middle clicking the empty tab bar area no longer works. Is there another wo… (funda kabanzi)

[previous post]

With the latest update, the CSS tweak to disable the creation of new tab when middle clicking the empty tab bar area no longer works.

Is there another workaround for disabling this function or where the documentation for the tab bar CSS is?

I honestly don't get why Mozilla have to break the tweaks every few updates. This along with the non standard shortcut key combos such as creating a private window using [Win + Shift + P] instead of [Win + Shift + N] doesn't make much sense.

Asked by ZetiX 5 izinyanga ezidlule

Last reply by ZetiX 5 izinyanga ezidlule

  • Okugcinwe kunqolobane

autoopen when click to mouse3

Hello guys! when I click the mouse wheel on a bookmark, it immediately moves to the active window, how to make it open not in the active window, but next to the tab? (exa… (funda kabanzi)

Hello guys! when I click the mouse wheel on a bookmark, it immediately moves to the active window, how to make it open not in the active window, but next to the tab? (example chrome)

Asked by dime4 1 unyaka odlule

Last reply by FredMcD 1 unyaka odlule

  • Okugcinwe kunqolobane

Middle click opens a link in both the current and a new tab

When I browse the web (mostly on youtube), when I try to open a link with the middle mouse button click, in 50% of cases, it opens that link in both the current tab and i… (funda kabanzi)

When I browse the web (mostly on youtube), when I try to open a link with the middle mouse button click, in 50% of cases, it opens that link in both the current tab and in the new one, so I have to go back on the current tab to keep it on the page it was before (this also happens on other sites besides youtube). I have tried to run Firefox in SafeMode, and this continues to happen, but with a little lower rate (about 30% of the times).

I use Firefox 65.0.1 (64-bit) on Windows 7.

Best regards

Asked by Honix 1 unyaka odlule

Last reply by Pj 1 unyaka odlule