Kukhonjiswa imibuzo ethegiwe: Veza yonke imibuzo

Finding the Firefox upgrade download on my Macbook

Hi, I downloaded the Firefox upgrade to my Macbook, but now can't find it in my Applications folder and the icon has been deleted from the dock. I know it is somewhere,… (funda kabanzi)

Hi, I downloaded the Firefox upgrade to my Macbook, but now can't find it in my Applications folder and the icon has been deleted from the dock. I know it is somewhere, but how do I find it?

Asked by mjgrochala 1 inyanga edlule

Last reply by Hansi Gayathma 1 inyanga edlule

How can'I look on the content of a specific cookie ?

I'm working with Linux 4.15 and Firefox 64.0 mint 1.0 I can list the sites which have stored cookies on my PC but impossible to obtain the details of the cookies that a s… (funda kabanzi)

I'm working with Linux 4.15 and Firefox 64.0 mint 1.0 I can list the sites which have stored cookies on my PC but impossible to obtain the details of the cookies that a site contain I've read sommewhere that it is possible by double click or right click from the site list . But it doesnot work So I cannot check if the setcookie I write from my web site work. Thanks in advance for your help

Asked by Tarbé 1 inyanga edlule

Last reply by Dinushi Dhananjani 1 inyanga edlule

I had to reinstall Firefox. Where do I extract the zipped Firefox files?

Hi, I have two questions 1. I use Linux Debian. I had to reinstall Firefox, but I'm not sure where to extract the file to. I've been using my downloads folder, but when I… (funda kabanzi)

Hi, I have two questions 1. I use Linux Debian. I had to reinstall Firefox, but I'm not sure where to extract the file to. I've been using my downloads folder, but when I shutdown it wont start again and I have to reinstall. 2. This message appears often ( libavcodec may be vulnerable or is not supported and should be updated to play video) but I don't know where to find an update. Thanks

Asked by jpa949 4 izinyanga ezidlule

Last reply by cor-el 4 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Move tab bar below address bar

I know this question has been posed more than once in the past. The answer has always been: go back to school, learn computer programming, get master classes and practice… (funda kabanzi)

I know this question has been posed more than once in the past. The answer has always been: go back to school, learn computer programming, get master classes and practice with coding until you make it. I am using Watefox since when Firefox tab bar was moved close to the sky. I just decided to try Firefox again: I have installed it and the first thing I tried to do is moving the tab bar below the address bar. It seems that there's no easy way. How can it be?, I wondered. With Waterfox I use the Tabs on Bottom add-on and that's it. You may believe my need is frivolous, but for me that makes the difference between keeping or uninstalling Firefox. Bottom line: is still forbiddend to wish to get the tab bar where I believe it should be? Thanks,

Asked by Carb 1 unyaka odlule

Answered by jscher2000 1 unyaka odlule

  • Okugcinwe kunqolobane

Firefox Latest Update (v69) Prevents Facebook Games From Loading

With this latest update (this also happened with the previous update with Firefox 68), Firefox 69 (Quantum) refuses to load facebook games. The only thing that displays i… (funda kabanzi)

With this latest update (this also happened with the previous update with Firefox 68), Firefox 69 (Quantum) refuses to load facebook games. The only thing that displays is a black screen and it just hangs. Does anyone have a fix for this?

This problem happened when Firefox 68 (Quantum) was released as well. It was eventually fixed but this is irritating that Firefox updates are rolled out with bugs and glitches included. I'm just looking for a fix as I had to remove FF 69 and install a previous version.

Asked by tempest21 8 izinyanga ezidlule

Last reply by tempest21 8 izinyanga ezidlule

  • Okugcinwe kunqolobane

Firefox 69 Killed Bookmark Toolbar Multirow "Chrome.css Edit" For Firefox 68. Has there been an update for this?

I've tried looking around for this but the latest update to Firefox Quantum, version 69, killed the Multirow Bookmarks Toolbar "Chrome.css" edit that worked with Firefox … (funda kabanzi)

I've tried looking around for this but the latest update to Firefox Quantum, version 69, killed the Multirow Bookmarks Toolbar "Chrome.css" edit that worked with Firefox 68. Does anyone have an update for this yet or have a link to a working version of the code?

Asked by tempest21 8 izinyanga ezidlule

Last reply by tempest21 8 izinyanga ezidlule

  • Okugcinwe kunqolobane

I cannot delete bookmarks.

The "library" button only lists the bookmarks, not a left and right screen. Any clicking on bookmark just tries to open it. There is no delete option which works. I… (funda kabanzi)

The "library" button only lists the bookmarks, not a left and right screen. Any clicking on bookmark just tries to open it. There is no delete option which works. I use a Mac desktop.

Asked by Jon 9 izinyanga ezidlule

Last reply by McCoy 9 izinyanga ezidlule

  • Okugcinwe kunqolobane

Please let me know when you make it easy to put tabs on the bottom where the belong for heay users. I can not upgrade again until This is done.

I do not have the time to figure out the new way to put tabs on bottom every time you "downgrade" Firefox. I am sure many thousands are not "downgrading" for the same rea… (funda kabanzi)

I do not have the time to figure out the new way to put tabs on bottom every time you "downgrade" Firefox. I am sure many thousands are not "downgrading" for the same reason. If you want us to continue to utilize your product, please be user friendly. If it is too much trouble to put in the option, put the tabs on the bottom all the time and let those who want them on top (both of them) figure out how to do it.

Asked by dcarroll2046 1 unyaka odlule

Last reply by cor-el 9 izinyanga ezidlule

  • Okugcinwe kunqolobane

Fail compiling firefox with compiler toolchain in non-standard location

I am trying to build firefox version 68.0 from source using the following options: ``` Set up the config options export MOZCONFIG=`pwd`/mozconfig cat > mozconfig <… (funda kabanzi)

I am trying to build firefox version 68.0 from source using the following options: ```

  1. Set up the config options

export MOZCONFIG=`pwd`/mozconfig cat > mozconfig << EOF mk_add_options MOZ_MAKE_FLAGS="-j4"

  1. If you have installed dbus-glib, comment out this line:
  2. ac_add_options --disable-dbus
  1. If you have installed dbus-glib, and you have installed (or will install)
  2. wireless-tools, and you wish to use geolocation web services, comment out
  3. this line

ac_add_options --disable-necko-wifi

  1. API Keys for geolocation APIs - necko-wifi (above) is required for MLS
  2. Uncomment the following line if you wish to use Mozilla Location Service
  3. ac_add_options --with-mozilla-api-keyfile=$PWD/mozilla-key
  1. Uncomment the following line if you wish to use Google's geolocaton API
  2. (needed for use with saved maps with Google Maps)
  3. ac_add_options --with-google-api-keyfile=$PWD/google-key
  1. Uncomment this line if you have installed startup-notification:
  2. ac_add_options --enable-startup-notification
  1. Uncomment the following option if you have not installed PulseAudio

ac_add_options --disable-pulseaudio

  1. and uncomment this if you installed alsa-lib instead of PulseAudio

ac_add_options --enable-alsa

  1. If you have installed GConf, comment out this line

ac_add_options --disable-gconf

  1. The BLFS editors recommend not changing anything below this line:

ac_add_options --prefix=/scratch/local/firefox-68.0 ac_add_options --enable-application=browser

ac_add_options --disable-crashreporter ac_add_options --disable-updater

  1. enabling the tests will use a lot more space and significantly
  2. increase the build time, for no obvious benefit.

ac_add_options --disable-tests

  1. Optimization for size is broken with gcc7 and later

ac_add_options --enable-optimize="-O2"

ac_add_options --enable-official-branding

  1. From firefox-61 system cairo is not supported

ac_add_options --enable-system-ffi ac_add_options --enable-system-pixman

  1. From firefox-62 --with-pthreads is not recognized

ac_add_options --with-system-bz2

  1. ac_add_options --with-system-jpeg
  2. ac_add_options --with-system-png

ac_add_options --with-system-zlib

mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/firefox-build-dir EOF

```

./mach build failed with the errors:

``` 11:29.42 /home/linuxbrew/.linuxbrew/bin/clang++ -o Unified_cpp_js_src_jit7.o -c -I/scratch/Downloads/firefox-68.0/firefox-build-dir/dist/system_wrappers -include /scratch/Downloads/firefox-68.0/config/gcc_hidden.h -DNDEBUG=1 -DTRIMMED=1 -DWASM_HUGE_MEMORY -DJS_HAS_CTYPES -DEXPORT_JS_API -DMOZ_HAS_MOZGLUE -I/scratch/Downloads/firefox-68.0/js/src/jit -I/scratch/Downloads/firefox-68.0/firefox-build-dir/js/src/jit -I/scratch/Downloads/firefox-68.0/firefox-build-dir/js/src -I/scratch/Downloads/firefox-68.0/js/src -I/scratch/Downloads/firefox-68.0/firefox-build-dir/dist/include -I/scratch/Downloads/firefox-68.0/firefox-build-dir/dist/include/nspr -fPIC -DMOZILLA_CLIENT -include /scratch/Downloads/firefox-68.0/firefox-build-dir/js/src/js-confdefs.h -Qunused-arguments -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector-strong -Qunused-arguments -Wall -Wbitfield-enum-conversion -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wshadow-field-in-constructor-modified -Wsign-compare -Wtype-limits -Wunreachable-code -Wunreachable-code-return -Wwrite-strings -Wno-invalid-offsetof -Wclass-varargs -Wfloat-overflow-conversion -Wfloat-zero-conversion -Wloop-analysis -Wc++1z-compat -Wc++2a-compat -Wcomma -Wimplicit-fallthrough -Wstring-conversion -Wtautological-overlap-compare -Wtautological-unsigned-enum-zero-compare -Wtautological-unsigned-zero-compare -Wno-inline-new-delete -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wno-error=backend-plugin -Wno-error=return-std-move -Wno-error=atomic-alignment -Wformat -Wformat-security -Wno-gnu-zero-variadic-macro-arguments -Wno-noexcept-type -Wno-unknown-warning-option -Wno-return-type-c-linkage -fno-sized-deallocation -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector-strong -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -pthread -pipe -g -O2 -fomit-frame-pointer -funwind-tables -fno-strict-aliasing -Werror=format -Wno-shadow -MD -MP -MF .deps/Unified_cpp_js_src_jit7.o.pp /scratch/Downloads/firefox-68.0/firefox-build-dir/js/src/jit/Unified_cpp_js_src_jit7.cpp 11:30.32 [style 0.0.1] cargo:rerun-if-changed=build_gecko.rs 11:30.32 [style 0.0.1] cargo:rerun-if-changed=/scratch/Downloads/firefox-68.0/firefox-build-dir/layout/style/bindgen.toml 11:30.32 [style 0.0.1] cargo:rerun-if-changed=/scratch/Downloads/firefox-68.0/layout/style/ServoBindings.toml 11:32.51 [style 0.0.1] /scratch/Downloads/firefox-68.0/firefox-build-dir/dist/include/mozilla/mozalloc.h:127:1: warning: replacement function 'operator new' cannot be declared 'inline' [-Winline-new-delete] 11:32.51 [style 0.0.1] /scratch/Downloads/firefox-68.0/firefox-build-dir/dist/include/mozilla/mozalloc.h:130:5: error: exception specification in declaration does not match previous declaration 11:32.51 [style 0.0.1] /usr/lib/gcc/x86_64-redhat-linux/4.4.7/../../../../include/c++/4.4.7/new:91:7: note: previous declaration is here 11:32.51 [style 0.0.1] /scratch/Downloads/firefox-68.0/firefox-build-dir/dist/include/mozilla/mozalloc.h:134:21: warning: replacement function 'operator new' cannot be declared 'inline' [-Winline-new-delete] 11:32.51 [style 0.0.1] /scratch/Downloads/firefox-68.0/firefox-build-dir/dist/include/mozilla/mozalloc.h:139:21: warning: replacement function 'operator new[]' cannot be declared 'inline' [-Winline-new-delete] 11:32.51 [style 0.0.1] /scratch/Downloads/firefox-68.0/firefox-build-dir/dist/include/mozilla/mozalloc.h:139:56: error: exception specification in declaration does not match previous declaration 11:32.51 [style 0.0.1] /usr/lib/gcc/x86_64-redhat-linux/4.4.7/../../../../include/c++/4.4.7/new:92:7: note: previous declaration is here 11:32.51 [style 0.0.1] /scratch/Downloads/firefox-68.0/firefox-build-dir/dist/include/mozilla/mozalloc.h:144:21: warning: replacement function 'operator new[]' cannot be declared 'inline' [-Winline-new-delete] 11:32.51 [style 0.0.1] /scratch/Downloads/firefox-68.0/firefox-build-dir/dist/include/mozilla/mozalloc.h:149:21: warning: replacement function 'operator delete' cannot be declared 'inline' [-Winline-new-delete] 11:32.51 [style 0.0.1] /scratch/Downloads/firefox-68.0/firefox-build-dir/dist/include/mozilla/mozalloc.h:154:21: warning: replacement function 'operator delete' cannot be declared 'inline' [-Winline-new-delete] 11:32.51 [style 0.0.1] /scratch/Downloads/firefox-68.0/firefox-build-dir/dist/include/mozilla/mozalloc.h:159:21: warning: replacement function 'operator delete[]' cannot be declared 'inline' [-Winline-new-delete] 11:32.51 [style 0.0.1] /scratch/Downloads/firefox-68.0/firefox-build-dir/dist/include/mozilla/mozalloc.h:164:21: warning: replacement function 'operator delete[]' cannot be declared 'inline' [-Winline-new-delete] 11:32.51 [style 0.0.1] /scratch/Downloads/firefox-68.0/firefox-build-dir/dist/include/mozilla/Casting.h:49:22: error: no member named 'is_trivial' in namespace 'std' 11:32.51 [style 0.0.1] /scratch/Downloads/firefox-68.0/firefox-build-dir/dist/include/mozilla/Casting.h:49:33: error: 'From' does not refer to a value 11:32.51 [style 0.0.1] /scratch/Downloads/firefox-68.0/firefox-build-dir/dist/include/mozilla/Casting.h:42:33: note: declared here 11:32.51 [style 0.0.1] /scratch/Downloads/firefox-68.0/firefox-build-dir/dist/include/mozilla/Casting.h:49:40: error: no member named 'value' in the global namespace 11:32.51 [style 0.0.1] /scratch/Downloads/firefox-68.0/firefox-build-dir/dist/include/mozilla/Casting.h:52:22: error: no member named 'is_trivial' in namespace 'std' 11:32.51 [style 0.0.1] /scratch/Downloads/firefox-68.0/firefox-build-dir/dist/include/mozilla/Casting.h:52:33: error: 'To' does not refer to a value 11:32.52 [style 0.0.1] /scratch/Downloads/firefox-68.0/firefox-build-dir/dist/include/mozilla/Casting.h:42:20: note: declared here 11:32.52 [style 0.0.1] /scratch/Downloads/firefox-68.0/firefox-build-dir/dist/include/mozilla/Casting.h:52:38: error: no member named 'value' in the global namespace 11:32.52 [style 0.0.1] /scratch/Downloads/firefox-68.0/firefox-build-dir/dist/include/mozilla/Span.h:416:36: error: no type named 'nullptr_t' in namespace 'std' 11:32.52 [style 0.0.1] /scratch/Downloads/firefox-68.0/firefox-build-dir/dist/include/mozilla/Span.h:64:25: error: no matching function for call to 'forward' 11:32.52 [style 0.0.1] /scratch/Downloads/firefox-68.0/firefox-build-dir/dist/include/mozilla/Span.h:663:21: note: in instantiation of function template specialization 'mozilla::narrow_cast<unsigned long, unsigned long>' requested here 11:32.52 [style 0.0.1] /usr/lib/gcc/x86_64-redhat-linux/4.4.7/../../../../include/c++/4.4.7/bits/move.h:51:5: note: candidate function template not viable: no known conversion from 'unsigned long' to 'typename std::identity<unsigned long>::type &&' (aka 'unsigned long &&') for 1st argument 11:32.52 [style 0.0.1] /scratch/Downloads/firefox-68.0/firefox-build-dir/dist/include/mozilla/DbgMacro.h:30:48: error: no member named 'declval' in namespace 'std' 11:32.52 [style 0.0.1] /scratch/Downloads/firefox-68.0/firefox-build-dir/dist/include/mozilla/DbgMacro.h:30:68: error: expected '(' for function-style cast or type construction ... ``` I have all the dependecies installed in /home/linuxbrew/.linux and the build setting works previously with firefox 64.0. It seems the build system is looking for dependency in /usr/lib, which contains ancient version of compiler toolchain that can't build firefox. How do I tell the build system to exclude looking into /usr/lib at all?

Asked by treinz 9 izinyanga ezidlule

Last reply by JohannHan 9 izinyanga ezidlule

  • Okugcinwe kunqolobane

problem with addons

Cheers! I was experiencing problems with websites (couldn't scroll, for example) so, since I had just installed a few addons, I decided to eliminate some variables by re… (funda kabanzi)

Cheers!

I was experiencing problems with websites (couldn't scroll, for example) so, since I had just installed a few addons, I decided to eliminate some variables by removing an addon at a time. Problem is, when I click "addons" from the menu, no addons actually show up. I'm hoping there's a way around this--?

Asked by CHUD 9 izinyanga ezidlule

Last reply by Seburo 9 izinyanga ezidlule

  • Okugcinwe kunqolobane

Enable DNS over HTTPS option, custom?

In the enable DNS over HTTPS option on version 65 there is a "custom" option the help does not explain this field. Above custom the default URL is "https://cloudflare-dns… (funda kabanzi)

In the enable DNS over HTTPS option on version 65 there is a "custom" option the help does not explain this field.

Above custom the default URL is "https://cloudflare-dns.com/dns-query" but below it is custom how is this custom field used?

Asked by Mace2 1 unyaka odlule

Last reply by Mace2 9 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Trying to update my browser but when I did all my customizations were gone like changing my Top Sites to 24 and curved tabs so I can click in between them?

I also lost all my tools like the printer button. However I know how to configure it to get my tools back under Customization. I need to know if there is a way to update … (funda kabanzi)

I also lost all my tools like the printer button. However I know how to configure it to get my tools back under Customization. I need to know if there is a way to update where I don't have to redo everything especially customizing my tabs to be curved as someone sent me steps on here and I only did it once so I would need the steps again.

When you update you should not lose your settings and customization's.

Can someone help me update correctly where everything sync 's with what my current version has?

Asked by LisaMichelleS 11 izinyanga ezidlule

Answered by jscher2000 11 izinyanga ezidlule

  • Okugcinwe kunqolobane

Passwords not being saved

Greetings, Firefox isn't offering to save passwords for a site. Does it respect "autocomplete=off" in the password input field? Thanks, Shane. … (funda kabanzi)

Greetings,

Firefox isn't offering to save passwords for a site. Does it respect "autocomplete=off" in the password input field?

Thanks, Shane.

Asked by Shane 1 unyaka odlule

Last reply by arejfour 10 izinyanga ezidlule

  • Okugcinwe kunqolobane

How to zoom by default?

I have a (temporary?) visual impairment and need large fonts. If I increase the font size beyond 24dpi, it breaks the layout of most pages. Zoom doesn't affect page layou… (funda kabanzi)

I have a (temporary?) visual impairment and need large fonts. If I increase the font size beyond 24dpi, it breaks the layout of most pages. Zoom doesn't affect page layout, but I have to hit the key a bunch of times for every new tab.

Is there a way to save your zoom level?

Before someone points to zoom.minPercent and zoom.maxPercent, (contrary to several articles on the web) they do not save your zoom level. I still don't understand what browser.zoom.siteSpecific does, but it doesn't help either.

TIA, Dan

Asked by dhaskell 1 unyaka odlule

Last reply by cor-el 10 izinyanga ezidlule