Search Support

Lolu chungechunge lwavalwa lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Just updated to Firefox 29.01 it doesn't work at all. When i open it no sites will load it just shows the busy circle going around forever. It is unusable.

  • 20 uphendule
  • 58 zinale nkinga
  • 6826 views
  • Igcine ukuphendulwa ngu michaelclyde

more options

Firefox 28 was working fine, but when I was asked by a pop up upon opening firefox to update to 29.01 i found there were lots of security issues for 28 so i manually updated to 29.01 by going to "about, check for updates,etc." Once it downloaded 29.01, and told me to restart, I restarted firefox. When I opened it, I found it is unusable. It won't open a single website. It won't load my homepage. It has all my favorites from before on the favorites toolbar, but I can't go to anything. I closed it and tried to run cc cleaner as I always do, but I keep getting the message "firefox is taking too long to close would you like to force a shutdown" but the forced shut down doesn't close it either. I opened task manager to try and shut it from there, but firefox isn't showing up. I have no idea what to do. I am typing all this from Chrome b/c I cannot use the latest version of firefox.I've never had this happen before. I also ran it in safe mode and the same thing happened. Please help, and please answer in layman's terms, because I am not a computer expert. I took a couple screen shots I will attach. Actually i don't see anywhere to attach an image so I can't. I also don't understand the green "automatically add" button that is underneath this box on the mozilla support page. Also, when I went to the help, about page in the top corner of firefox just now to check the version it says "firefox is being updated by another instance." What the heck does that mean? Never seen that ever. Appreciate any help.

Okulungisiwe ngu assistme

Isisombululo esikhethiwe

Okay, so I can happily say that I am typing this on firefox yay!! I got it to work and here is how for everyone else who's having this problem (well at least this is the solution that finally worked for me). RESTART your computer. DO NOT just shut it down. That does not work (not for me at least). I initially restarted the computer a few min ago b/c my Norton was not scanning and I wanted it to scan the new "fresh install" i had gotten for FF. After restarting computer, my norton worked. So i said hey, maybe I'll give my updated FF 29.0.1 one last try before installing a whole new firefox, hoping that possibly restarting the computer would have worked. So i opened it and omg it loaded my homepage. It works!!! Also, one of the other first problems I encountered is no way to favorite a site. I figured out the solution. Just go to the right top menu (it has 3 horizontal lines) and right click the little star icon that we are accustomed to which means bookmarks. A little menu will pop up. Click "move to toolbar," and that should put it up on the top right of your browser so you can bookmark things. Hope the restart tip helps everyone who was having the same problem as I was of firefox being unusable! And if you run into the bookmark issue, hope it helps you also. Wow. I'm so happy I can finally use FF now! Also, I kept the setting of "no hardware acceleration off." Not sure precisely what that does, but leaving it off since this is working. Oh, one last thing: I closed FF and ran cc cleaner and had NO problems with it telling me FF wouldn't close. So restarting the computer has solved that as well. Yay!

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (20)

more options

Start Firefox in Safe Mode
While you are in safe mode;
Firefox Options > Advanced > General.
Look for and turn off Use Hardware Acceleration. Then restart.

more options

Thank you for replying but I had already tried that out of safe mode and i just tried it again in safe mode. Nothing changes. Last night I finally just started it in safe mode and hit the "reset" button, still does nothing. I may just go install firefox 29.01 from mozilla website and start over since updating my existing version (though it has always worked) isn't working with this version. sigh. Also when you say "then restart" do you just mean close firefox and open it again bc there is no restart button? I guess tons of people are having this issue. I was thinking maybe I would try and get firefox 29.0 bc i never was asked to update to that. But i see it has security issues, so idk. Off to get a "fresh copy" I guess as they call it , right? Maybe other ppl will have a suggestion or have figured out a way to solve it. I spent a number of hours repeatedly trying to get FF to work. It's frustrating. At least I have Chrome to use right now

more options

- Try uninstalling FF > Remove my Firefox personal data and customizations

- Try Portable Firefox : http://portableapps.com/apps/internet/firefox_portable

more options

Isisombululo Esikhethiwe

Okay, so I can happily say that I am typing this on firefox yay!! I got it to work and here is how for everyone else who's having this problem (well at least this is the solution that finally worked for me). RESTART your computer. DO NOT just shut it down. That does not work (not for me at least). I initially restarted the computer a few min ago b/c my Norton was not scanning and I wanted it to scan the new "fresh install" i had gotten for FF. After restarting computer, my norton worked. So i said hey, maybe I'll give my updated FF 29.0.1 one last try before installing a whole new firefox, hoping that possibly restarting the computer would have worked. So i opened it and omg it loaded my homepage. It works!!! Also, one of the other first problems I encountered is no way to favorite a site. I figured out the solution. Just go to the right top menu (it has 3 horizontal lines) and right click the little star icon that we are accustomed to which means bookmarks. A little menu will pop up. Click "move to toolbar," and that should put it up on the top right of your browser so you can bookmark things. Hope the restart tip helps everyone who was having the same problem as I was of firefox being unusable! And if you run into the bookmark issue, hope it helps you also. Wow. I'm so happy I can finally use FF now! Also, I kept the setting of "no hardware acceleration off." Not sure precisely what that does, but leaving it off since this is working. Oh, one last thing: I closed FF and ran cc cleaner and had NO problems with it telling me FF wouldn't close. So restarting the computer has solved that as well. Yay!

Okulungisiwe ngu assistme

more options

Good going. Every now and then, you should let the computer shut down. I don't mean every hour but every few days. This lets the system take care of things it can't do while it is running. And if there was a problem, restarting should restore / reset the program.

more options

Thank you Fred, I am pleased I can now use FF.  :) Should I still keep that "accelerate hardware" option off? Idk what that does.

more options

From the Firefox help files;

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

more options

I am also missing toolbars. The Navigation Bar is gone. And it takes forever for FF to load. I used to be abler to have several tabs open.no more. I have done system restore, restarted my computer. What do I do, please?

more options
  • For the toolbars;

Move your mouse to the top of the Firefox window, then right click. You will see a menu of the available toolbars. Select Customize. In the new window, you can choose what options you want and even move the icons around. It's very simple. Look for the icon. When you find it, hold down the left button on it, and move it to where you want it to be. You can move any of the icons you want from here, but some icons are locked in place.


Many of us are using

Classic Theme Restorer (Customize Australis)
Restore squared tabs, appmenu, add-ons bar, small button view and more on Australis UI (Windows/MacOSX/Linux + Fx 29+).

more options
  • As to the slow internet

Check with your internet provider to test your service.

It could be the work of one of your add-ons, or even add / mal-ware. Look thru your add-ons list and make sure you know what each one is there for. Also, Windows > Start > Control Panel > Uninstall Programs. Go thru the list and use a web search to check any that you don't know what they are.

Troubleshoot Firefox issues caused by malware

more options

Thanks for your help. I did that with the icons; had been doing it wrong. But since the update the background of the toolbars is gray; and there are several I can barely see.

more options

Take a Screen shot; Windows > Start > search box > Snipping Tool. Save the picture(s) to your desktop. Now look at the Reply box below. Do you see the button under it that says Browse? Click it and then select the screen shot(s) from the desktop.

more options

This is a part of the toolbars where I added. You can barely see the printer. Thanks for all your help. I do appreciate it,

more options

Somebody get me a flash light, I can't see a thing. :->

Go to the Mozilla Add-ons Web Page (There’s a lot of good stuff here).
Search for something that can change your window color.

more options

While you are at the Mozilla Add-ons Web Page check out Featured Themes

more options

Hi Fred, You have been so helpful. I did go to the add on page and am overwhelmed. All I want is the toolbars to be readable. Any thoughts as to which one? Thank you so much for all your help.

more options

That you will have to do on your own, About the Featured Themes, if you place your mouse on top of one of them, the browser will change so that you can see what it looks like. It is not downloaded, only displayed.

more options

Hi Fred, Most of them were too dark and complicated, but I did find one on the new link you provided. Thank you sooooo much~

more options

FF 29.0.1 was hanging on load for me in W7 64-bit. I ran the "compatibility checker" which advised running it in XP SP2 mode. After that, no problems, it runs fast and fine.

more options

@ fredmcd, you stated "Shut your system down every couple of days, this lets the system take care of things it can't do while it is running."

seriously fred... I do believe you've clicked your ruby slippers together 1 too many times. If the computer isn't running... it can't do anything. I don't care what Auntie Emm told you, if the computer isn't running it does not have the capability to perform one single task. Period. Don't believe me ¿ ASK TOTO.

MICHAEL CLYDE