Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox 29.0 opens new windows from clicking links that are in a smaller window, should open as maximized window. How to change?

  • 36 uphendule
  • 161 zinale nkinga
  • 5592 views
  • Igcine ukuphendulwa ngu cyberpainter

more options

How do I click a link on a web page, and not have to maximize the window every time? Firefox 29 seemed to add this additional click annoyance and I can't see how to change that. I do not want full screen mode which is what Firefox calls it when it removes an additional row of menu items. I mean maximizing the window so I don't have to do it each time! Please tell me how to change the settings and restore this normal feature.

Okulungisiwe ngu cyberpainter

All Replies (20)

more options

Hi there, I would like to thank you for keeping Firefox up to date. I am sorry to hear that you are having a problem with Firefox 29.

To change settings in Firefox 29 first you will click the icon with three horizontal lines. This is what replaced the Firefox button. Next you will click on options. That will bring up a small window. If this is the first time you will probably be in the "general" section. You can navigate like how you do with tabs. You will now click on the Tabs "tab". In there you should see an option that says open new windows in a new tab instead. Click on that box and close the window. This should fix the problem you have had.

more options

Thank you very much. However I do not want to use tabs. I want the window to open maximized like it did in the last version of Firefox.

more options

I'm sorry, I'm not sure I understand what you want to happen. If you have the window maximized and you open some thing in a new tab it will also be maximized. I don't mean full screen mode, just regular maximized window. As for having it open in a new window. I don't have much experience with that. I love tab browsing. What you can do is open it in a new tab and drag the tab out from where it is, to say the center of your screen, and it will open it in a new window. Maximized and all.

more options

I don't use tabs, I'm inquiring about the change in Firefox related to window browsing, not tabs. Thanks for your quick responses though.

Perhaps someone knows why this change occurred in 29, and if there will be a fix?

more options

Let's try this and see if it works. 1st Make sure No Other Windows are open Except the Main window. Close all other windows. Then, Do what you have been doing. When the Smaller Window opens, Maximize the smaller window. Next Close the 1st (main) Window. Next Close the 2nd Window that you had Maximized. (While it is Maximized).

Now Open a Fresh session and try again.

I hope this will work for you.

more options

My main window opens just fine but when I click on a link it opens in a slightly smaller window and I always have to click on the Firefox icon and choose Maximize. Tried Mr Remington's solution and it didnt work. Is there a way to make new windows open maximized automatically? THanks

more options

No that doesn't work, thank you for the good suggestion. In the past if you clicked out of a window not maximized, it might mean the next one is small too, I know.

But hold on! I think this is website specific (facebook). Most sites have links that just open in the same window. In fb the links open in a new window. This is when it happens. Perhaps it's a fb thing. If I right click a link to open in new window on any site, it opens maximized which is good.

It didn't do this before the upgrade, but appears to only happen when links open in a new window by themselves (in fb). Looking for other sites in which it happens. Thanks for your help.

more options

No it happens with other links too, just tried it. Probably links that go to other websites are more likely to open in new windows. That's when it happens.

more options

Any idea when this bug will be fixed?

more options

@aubbieed For some reason I have not been able to duplicate your problem. I have tried I get another large window.

more options

I can get a large window, but it is not maximized. I use multirow bookmarks and if the window is not maximized, it forces the rows to go out of alignment and become an ugly mess.

more options

Oh yes duh, I just realized I can make it as large as possible on the screen. Not maximized but large enough. If clicked shut at that size it opens that size next time. So really this is good enough for my purposes. Hopefully though, they will fix this.

more options

@aubbieed I am glad. I even asked friends to try it.

more options

What are you glad about? I don't understand your response to aubbieed.

Have you been able to get a separate maximized window yourself when left clicking a link to a different website?

more options

Crap!!!

I just got 29.0.1 and I'm still having the same problem!

more options

In the same boat with abbieed. The main window opens just fine (fully max'ed) but everytime I open a link/window the new window has to be max'ed everytime EVERYTIME and its getting annoying. Please address this Mozilla!

more options

If Mozilla isn't gonna fix, maybe someone can write an add-on that forces new windows to maximize.

more options

Go to About:Config Change browser.link.open_newwindow value from 2 to 1

Works for me now. Every new window is max size

more options

Well, that doesn't open a new window. It just redirects to the site.

I can live with it, but it will take some getting used to. I will probably be closing some windows by accident and having to re-run Firefox, but it's better than the alternative.

Anyhow, thanks...

more options

Shift + Click links or right click + open in new window. I just got in the habit or right click + open so everything opens in new.

  1. 1
  2. 2