Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox 29.0 on a Mac- Javascript and Cookies are enabled but I can't access my bank account?

  • 10 uphendule
  • 1 inale nkinga
  • 213 views
  • Igcine ukuphendulwa ngu cor-el

more options

Since arriving home from work I am unable to access my bank account; a pop-up says I need to enable javascript and cookies so I looked up how to do this and according to about:config mine are enabled and no other help forums for this issue have done anything. What can I do to solve this?

All Replies (10)

more options

In addition to the general settings in the Preferences dialog and about:config, Firefox lets you manage cookies on a site-by-site basis.

When you are on the bank's site, could you try the following:

click the padlock icon in the address bar > More Information

Click Permissions and then scroll down and make sure that "Set cookies" is effectively either "Allow" or "Allow for Session".

Click Security, then the "View Cookies" button.

In the dialog that opens, you can remove the site's cookies individually.

After closing that, reload the page using to get a fresh set of cookies and see whether the site works any better.


Extensions that improve privacy often modify Firefox's built-in cookie handling. In case one of your extensions is involved, could you test the page in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Diagnose Firefox issues using Troubleshoot Mode.

You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

Not all add-ons are disabled: Flash and other plugins still run

After Firefox shuts down, a small dialog should appear. Click "Start in Safe Mode" (not Reset).

Any difference?

more options

I tried all of those and it still doesn't work and I keep getting the same pop up. :(

more options

Would you be willing to post the URL of the bank site? A volunteer could try the site and see whether they get the same message.

more options

https://www.txn.banking.pcfinancial.ca/a/authentication/signOn.ams

That's the link. underneath card # and password it says " Please enter your President's Choice Financial card number." and "Please enter your password." with a little yellow square with an exclamation mark. This never happened before.

This is the exact pop-up message I get:

"In order to access all the functions of Online Banking, you need to modify your browser settings to enable cookies and JavaScript. For instructions on how to enable cookies, please see the Help section on the sign in page."

more options

Make sure that JavaScript is enabled (javascript.enabled should be true) and isn't blocked.

You can inspect and manage the permissions for the domain in the currently selected tab via these steps:

  • Click the "Site Identity Button" (globe/padlock) on the location bar
  • Click "More Information" to open "Tools > Page Info" with the Security tab selected
  • Go to the Permissions tab (Tools > Page Info > Permissions) to check the permissions for the domain in the currently selected tab

If clearing cookies didn't help then it is possible that the cookies.sqlite file that stores the cookies got corrupted.

  • Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookies files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.

You can use this button to go to the currently used Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
more options

I get the exclamation points either way, with JavaScript enabled or disabled. So I don't think JavaScript is the problem.

Oh, hold on, you have to check the box to "Save Bank Card" in order to trigger the message. I guess for now, don't do that and see whether you can log in.

more options

Ok, must be cookies then, but checking to save bank card does nothing either.

more options

When I unchecked the "Save Bank Card" box, I no longer got the error message. Instead I was told that my card number didn't have the correct number of digits. I guess 123123123123 isn't valid...

more options

I never have it checked. :/ and no, it has to start with 6018 to be valid. Thanks for trying though.

more options

It is this code that causes the alert:

function validateSignon(){
 if(clickedSignOn==false) 
{
       clickedSignOn = true;
if(document.SignOnForm.cardNumberSaved.options && document.SignOnForm.cardNumberSaved.options.length>0)
    var msg= 
             "In order to access all the functions of Online Banking,\n"+
             "you need to modify your browser settings to enable cookies and JavaScript.\n"+
             "For instructions on how to enable cookies, please see the Help section on the sign in page."
;
    if ( !false )
         {
        alert (msg);
        return false;
     }
    else
       {
         return  true;
     }
        }
     else 
        {
return false;
}
}

So once you have clicked then clickedSignOn = true; and you would have to set this variable to false to see this message once again.
They use if ( !false ), so this message is always displayed AFAICT as the Console shows that document.SignOnForm.cardNumberSaved.options.length is 1, so this test is always true.

<select name="cardNumberSaved" size="1" onchange="document.SignOnForm.password.focus();"><option value="">select &gt;&gt;</option></select>