X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwavalwa lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I move the Bookmarks Toolbar above the tabs in 29.0?

Kuphostiwe

Before the update, I was able to use Stylish to get this functionality. However, something is broken with how -moz-box-ordinal-group functions. The only valid entries are 0 (places it above the Menu Bar) or !0 (places it at the very bottom).

Neither of those two places are what I desire. Here is what I'm aiming for, from top to bottom:

Menu Bar
Bookmarks Toolbar
Tabs
Address Bar

See this Stylish for a picture of what I used to have:
http://userstyles.org/styles/46274/firefox-4-bookmarks-toolbar-above-tabs-enhanced

So, my question here is, how can I restore this functionality? Having bookmarks below the address bar does not follow logic, in my mind. And this "now things are easy to customize how you want it!" thing that Australis is supposed to allow... doesn't let me customize it how I want it.

Any help would be appreciated, be it a config setting, a plugin, or some CSS I can plug into Stylish.

Before the update, I was able to use Stylish to get this functionality. However, something is broken with how -moz-box-ordinal-group functions. The only valid entries are 0 (places it above the Menu Bar) or !0 (places it at the very bottom). Neither of those two places are what I desire. Here is what I'm aiming for, from top to bottom: Menu Bar Bookmarks Toolbar Tabs Address Bar See this Stylish for a picture of what I used to have:<br /> http://userstyles.org/styles/46274/firefox-4-bookmarks-toolbar-above-tabs-enhanced So, my question here is, how can I restore this functionality? Having bookmarks below the address bar does not follow logic, in my mind. And this "now things are easy to customize how you want it!" thing that Australis is supposed to allow... doesn't let me customize it how I want it. Any help would be appreciated, be it a config setting, a plugin, or some CSS I can plug into Stylish.

Okulungisiwe ngu cor-el

Isisombululo esikhethiwe

wyrenth wrote:

Menu Bar Bookmarks Toolbar Tabs Address Bar

The following will work, provided other user styles don't interfere.


@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);

#TabsToolbar { -moz-box-ordinal-group: 2 !important }
#nav-bar { -moz-box-ordinal-group: 3 !important }

Funda le mpendulo ngokuhambisana nalesi sihloko 3

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 13.0 r0
  • Next Generation Java Plug-in 10.55.2 for Mozilla browsers
  • PlayNow Plugin
  • Version 5.3.0.18358
  • Google Update
  • VLC media player Web Plugin 2.1.3
  • Facebook Video Calling Plugin
  • Foxit Reader Plug-In For Firefox and Netscape
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Nexon Game Controller
  • Pando Web Plugin
  • Plugin for Wacom tablets.
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0

Eminye Imininingwane

Gingerbread Man 403 izisombululo 1537 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

wyrenth wrote:

Menu Bar Bookmarks Toolbar Tabs Address Bar

The following will work, provided other user styles don't interfere.


@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);

#TabsToolbar { -moz-box-ordinal-group: 2 !important }
#nav-bar { -moz-box-ordinal-group: 3 !important }

''wyrenth wrote:'' Menu Bar Bookmarks Toolbar Tabs Address Bar The following will work, provided other user styles don't interfere. ---- <pre><nowiki>@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); #TabsToolbar { -moz-box-ordinal-group: 2 !important } #nav-bar { -moz-box-ordinal-group: 3 !important }</nowiki></pre> ----

Umnikazi wombuzo

Er, sorry, the post didn't parse what I was aiming for correctly and I can't edit posts, lemme try that again. From top to bottom, I want:

[Menu Bar]

[Bookmarks Toolbar]

[Tabs]

[Address Bar]

Er, sorry, the post didn't parse what I was aiming for correctly and I can't edit posts, lemme try that again. From top to bottom, I want: [Menu Bar] [Bookmarks Toolbar] [Tabs] [Address Bar]

Umnikazi wombuzo

Perfect! Thank you, with a little tweaking I was able to get Stylish to make it look exactly how it used to! I'll upload a new style shortly. Thank you so much!

Perfect! Thank you, with a little tweaking I was able to get Stylish to make it look exactly how it used to! I'll upload a new style shortly. Thank you so much!
jscher2000
  • Top 10 Contributor
8792 izisombululo 71898 izimpendulo
Kuphostiwe

Hi wyrenth, Gingerbread Man's recipe is a pair of custom style rules designed to be applied to Firefox's interface using either:

(1) userChrome.css file

(2) Stylish extension

Due to the late hour, I have to pause there without spelling out the details of those two methods, sorry.

Hi wyrenth, Gingerbread Man's recipe is a pair of custom style rules designed to be applied to Firefox's interface using either: (1) userChrome.css file (2) Stylish extension Due to the late hour, I have to pause there without spelling out the details of those two methods, sorry.

Umnikazi wombuzo

Hmm, now I'm having a second issue, though it has a workaround.

If neither the Menu Bar or Title Bar are enabled, the Bookmarks Toolbar overlaps parts at the top of the window.

When using Australis, this ends up underlapping the Minimize/Restore/Close buttons

When using Classic Theme Restorer, this ends up overlapping the Firefox button and underlapping the Minimize/Restore/Close buttons.

Is there a way to set a buffer if both of these are disabled?

Hmm, now I'm having a second issue, though it has a workaround. If neither the Menu Bar or Title Bar are enabled, the Bookmarks Toolbar overlaps parts at the top of the window. When using Australis, this ends up underlapping the Minimize/Restore/Close buttons When using Classic Theme Restorer, this ends up overlapping the Firefox button and underlapping the Minimize/Restore/Close buttons. Is there a way to set a buffer if both of these are disabled?
yzhang103 0 izisombululo 2 izimpendulo
Kuphostiwe

After updating to firefox 29, I can not move tabs under favorites bar by setting about:config:browser.tabs.onTop to false. What is going on?

After updating to firefox 29, I can not move tabs under favorites bar by setting about:config:browser.tabs.onTop to false. What is going on?
cor-el
  • Top 10 Contributor
  • Moderator
17574 izisombululo 158975 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Support to disable "Tabs on Top" has been removed from Firefox 29 and later and toggling the browser.tabs.onTop pref to false on the about:config page is no longer possible.

You can look at the "Tab on Bottom" extension instead.

Support to disable "Tabs on Top" has been removed from Firefox 29 and later and toggling the browser.tabs.onTop pref to false on the about:config page is no longer possible. You can look at the "Tab on Bottom" extension instead. *Tabs On Bottom: https://addons.mozilla.org/firefox/addon/tabs-on-bottom/ *Classic Theme Restorer: https://addons.mozilla.org/firefox/addon/classicthemerestorer/ *https://support.mozilla.org/kb/how-to-make-new-firefox-look-like-old-firefox
jscher2000
  • Top 10 Contributor
8792 izisombululo 71898 izimpendulo
Kuphostiwe

Hi wyrenth, I noticed that when experimenting with the style rule. I tried to figure out what makes the tab bar flex-to-fit and it was just too complicated for me to replicate without making the main toolbar permanently shorter or giving it a top margin that creates a gap when you do show the menu bar.

If you are using CTR, then I would remove the userChrome.css rule in case it conflicts with CTR's way of moving the bar.

Hi wyrenth, I noticed that when experimenting with the style rule. I tried to figure out what makes the tab bar flex-to-fit and it was just too complicated for me to replicate without making the main toolbar permanently shorter or giving it a top margin that creates a gap when you do show the menu bar. If you are using CTR, then I would remove the userChrome.css rule in case it conflicts with CTR's way of moving the bar.
yzhang103 0 izisombululo 2 izimpendulo
Kuphostiwe

Thanks a lot, cor-el, it is solved.

Thanks a lot, cor-el, it is solved.
cor-el
  • Top 10 Contributor
  • Moderator
17574 izisombululo 158975 izimpendulo
Kuphostiwe

CTR uses these style rules:

  • chrome://classic_theme_restorer/content/css/tabsontop_off.css
 /* toolbars above navigator-toolbox (only one at a time can visible anyway) */
 #print-preview-toolbar,
 #printedit-toolbar,
 #titlebar {
   -moz-box-ordinal-group: 0 !important;
 }
 
 /* START: navigator-toolbox toolbars */
 #toolbar-menubar {
   -moz-box-ordinal-group: 1 !important;
 }
 #nav-bar {
   -moz-box-ordinal-group: 2 !important;
 }
 #PersonalToolbar {
   -moz-box-ordinal-group: 3 !important;
 }
 /* other toolbars like google, amazon etc.*/
 toolbar {
   -moz-box-ordinal-group: 10 !important;
 }
 /*#ctr_extra-bar {
   -moz-box-ordinal-group: 98 !important;
 }*/
 #TabsToolbar {
   -moz-box-ordinal-group: 100 !important;
 }
 /* END: navigator-toolbox toolbars */
CTR uses these style rules: *chrome://classic_theme_restorer/content/css/tabsontop_off.css <pre><nowiki> /* toolbars above navigator-toolbox (only one at a time can visible anyway) */ #print-preview-toolbar, #printedit-toolbar, #titlebar { -moz-box-ordinal-group: 0 !important; } /* START: navigator-toolbox toolbars */ #toolbar-menubar { -moz-box-ordinal-group: 1 !important; } #nav-bar { -moz-box-ordinal-group: 2 !important; } #PersonalToolbar { -moz-box-ordinal-group: 3 !important; } /* other toolbars like google, amazon etc.*/ toolbar { -moz-box-ordinal-group: 10 !important; } /*#ctr_extra-bar { -moz-box-ordinal-group: 98 !important; }*/ #TabsToolbar { -moz-box-ordinal-group: 100 !important; } /* END: navigator-toolbox toolbars */</nowiki></pre>

Okulungisiwe ngu cor-el

Painterz 1 izisombululo 5 izimpendulo
Kuphostiwe

Tabs on bottom extension is working, but I now have a weird two-tone effect on my toolbar.

And the rounded tabs look pretty awful on the bottom.

Is there a better/easier way to get Firefox back to looking the way it did before yet? I'm very unhappy with this update to V29. Why on earth haven't software companies learnt yet that major changes to UI interfaces cause much unhappiness, and put in an option to default back to the old 'look'?

Tabs on bottom extension is working, but I now have a weird two-tone effect on my toolbar. And the rounded tabs look pretty awful on the bottom. Is there a better/easier way to get Firefox back to looking the way it did before yet? I'm very unhappy with this update to V29. Why on earth haven't software companies learnt yet that major changes to UI interfaces cause much unhappiness, and put in an option to default back to the old 'look'?
Gingerbread Man 403 izisombululo 1537 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Painterz wrote:

Is there a better/easier way to get Firefox back to looking the way it did before yet?

Yes.

  1. Uninstall the Tabs On Bottom add-on and remove any user styles you may have added.
  2. Install Classic Theme Restorer and restart Firefox when prompted.
  3. In the Add-ons Manager, Extensions category, click the Options button next to Classic Theme Restorer.
  4. Near the top left corner, choose either "Squared tabs (classic)" or "Squared tabs (classic) (v2)", and below that set "Tabs not on top".
''Painterz wrote:'' Is there a better/easier way to get Firefox back to looking the way it did before yet? Yes. # Uninstall the Tabs On Bottom add-on and remove any user styles you may have added. # [https://addons.mozilla.org/firefox/addon/classicthemerestorer/ Install Classic Theme Restorer] and restart Firefox when prompted. # In the Add-ons Manager, Extensions category, click the Options button next to Classic Theme Restorer. # Near the top left corner, choose either "Squared tabs (classic)" or "Squared tabs (classic) (v2)", and below that set "Tabs not on top".
Painterz 1 izisombululo 5 izimpendulo
Kuphostiwe

Brilliant. Thank you. That's put things more or less back the way they were before.

Brilliant. Thank you. That's put things more or less back the way they were before.
musicis 0 izisombululo 3 izimpendulo
Kuphostiwe

same exact issue! What is going on!!

same exact issue! What is going on!!
musicis 0 izisombululo 3 izimpendulo
Kuphostiwe

After updating to firefox 29, I can not move tabs under favorites bar by setting about:config:browser.tabs.onTop to false. What is going on?

X2

After updating to firefox 29, I can not move tabs under favorites bar by setting about:config:browser.tabs.onTop to false. What is going on? X2
PacoH 1 izisombululo 15 izimpendulo
Kuphostiwe

Although this add-on helps, I think of it as only a work-around, not a solution. I am outraged that my tabs just disappeared when I restarted FF. It was updated without my permission. This is what I wrote to the devs about this:

First off, FF updated my browser WITHOUT MY PERMISSION! I had 'Check for updates, but let me choose whether to install them' checked but was never given a choice. That is a violation of any ethical principle involved with using and updating any app.

I don't yet know what other damage this update did, but for openers, it made my hundreds of tabs in dozens of windows absolutely inaccessible. Just look at the two images:

http://i.imgur.com/BwU7onJ.png http://i.imgur.com/ASHnG8R.png

When window is maximized, tabs are completely gone. Even when minimized, tabs are cut off.

about:config->browser.tabs.onTop false no longer works. I now have to install an add-on just to get back this functionality.

What else did your egomaniacal, browser-hijacking little code thugs manage to damage? I can hardly wait to find out…

This is not an update, it is a desecration.

edited this posting to not show the offsite images inline

Although this add-on helps, I think of it as only a work-around, not a solution. I am outraged that my tabs just disappeared when I restarted FF. It was updated without my permission. This is what I wrote to the devs about this: ''First off, FF updated my browser WITHOUT MY PERMISSION! I had 'Check for updates, but let me choose whether to install them' checked but was never given a choice. That is a violation of any ethical principle involved with using and updating any app. '' ''I don't yet know what other damage this update did, but for openers, it made my hundreds of tabs in dozens of windows absolutely inaccessible. Just look at the two images: '' http://i.imgur.com/BwU7onJ.png http://i.imgur.com/ASHnG8R.png ''When window is maximized, tabs are completely gone. Even when minimized, tabs are cut off. '' ''about:config->browser.tabs.onTop false no longer works. '' ''I now have to install an add-on just to get back this functionality. '' ''What else did your egomaniacal, browser-hijacking little code thugs manage to damage? I can hardly wait to find out… '' This is not an update, it is a desecration. ''edited this posting to not show the offsite images inline''

Okulungisiwe ngu the-edmeister

Painterz 1 izisombululo 5 izimpendulo
Kuphostiwe

Actually now you mention it, it updated mine without permission too. I had it set to notify me when updates were available. But V29 just went ahead and auto-updated without informing me.

Actually now you mention it, it updated mine without permission too. I had it set to notify me when updates were available. But V29 just went ahead and auto-updated without informing me.
jscher2000
  • Top 10 Contributor
8792 izisombululo 71898 izimpendulo
Kuphostiwe

Hi PacoH and Painterz:

The "let me choose" setting still works for me with Firefox 29.

Some users have complained that when the dialog appears, pressing a key can approve the update, so it can happen quickly and accidentally if you didn't see the dialog appear on screen before typing. I don't know how common that is, but it could be one explanation for unexpected updates.

Regarding the tab bar layout, if you are using an extension to get multiple rows of tabs and/or resize them, please check for an update. By default, when the number of tabs exceeds the space available on the tab bar, arrows will appear on the ends to scroll horizontally, and the tabs should never stack up beyond what can be displayed vertically.

Hi PacoH and Painterz: The "let me choose" setting still works for me with Firefox 29. Some users have complained that when the dialog appears, pressing a key can approve the update, so it can happen quickly and accidentally if you didn't see the dialog appear on screen before typing. I don't know how common that is, but it could be one explanation for unexpected updates. Regarding the tab bar layout, if you are using an extension to get multiple rows of tabs and/or resize them, please check for an update. By default, when the number of tabs exceeds the space available on the tab bar, arrows will appear on the ends to scroll horizontally, and the tabs should never stack up beyond what can be displayed vertically.
PacoH 1 izisombululo 15 izimpendulo
Kuphostiwe

It is possible that I accidentally hit a key other than ESC when the pop-up appeared but making updating the default like that is unforgivable IMO. Making such a radical change to a program interface like that without warning and without any way to get back the original interface via program preferences is, IMO, downright arrogance and incompetence.

When you say to check for an update, do you mean for the add-on, which is very new, or for FF? If you meant FF, after this fiasco, I will never check for updates. I checked that button immediately.

Did you see my screenshot for a maximized window? There are no tabs, period, on any previously opened windows. They are beyond the screen boundary and are only partially visible even with the window minimized. Even when I drag the maximized window down, they are still not visible.

The add-on does work but it really pisses me off that an add-on is necessary now for what I consider just basic functionality. Yet another add-on to slow down performance and cause memory leaks… Castigation to the devs responsible for this debauchery!

It is possible that I accidentally hit a key other than ESC when the pop-up appeared but making updating the default like that is unforgivable IMO. Making such a radical change to a program interface like that without warning and without any way to get back the original interface via program preferences is, IMO, downright arrogance and incompetence. When you say to check for an update, do you mean for the add-on, which is very new, or for FF? If you meant FF, after this fiasco, I will never check for updates. I checked that button immediately. Did you see my screenshot for a maximized window? There are no tabs, period, on any previously opened windows. They are beyond the screen boundary and are only partially visible even with the window minimized. Even when I drag the maximized window down, they are still not visible. The add-on does work but it really pisses me off that an add-on is necessary now for what I consider just basic functionality. Yet another add-on to slow down performance and cause memory leaks… Castigation to the devs responsible for this debauchery!

Okulungisiwe ngu PacoH

jscher2000
  • Top 10 Contributor
8792 izisombululo 71898 izimpendulo
Kuphostiwe

Hi PacoH, your first screen shot looks like Firefox's full screen view instead of a regular maximized window. I'm not very familiar with the Mac UI, but on Windows, if you slide the mouse pointer to the top of a full screen window and right-click, you can turn toolbars on and off for full screen mode. But maximizing normally would simply compact the toolbar area and not eliminate it completely.

Your second screen shot was the one that prompted me to suggest updating any extensions related to tabs. Or if you have multiple interface-related extensions, try disabling some of the older ones that might not have been updated recently.

Hi PacoH, your first screen shot looks like Firefox's full screen view instead of a regular maximized window. I'm not very familiar with the Mac UI, but on Windows, if you slide the mouse pointer to the top of a full screen window and right-click, you can turn toolbars on and off for full screen mode. But maximizing normally would simply compact the toolbar area and not eliminate it completely. Your second screen shot was the one that prompted me to suggest updating any extensions related to tabs. Or if you have multiple interface-related extensions, try disabling some of the older ones that might not have been updated recently.