Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox will show PDF's but prints blank pages. Other browsers are fine, safe mode has no effect.

  • 15 uphendule
  • 167 zinale nkinga
  • 27816 views
  • Igcine ukuphendulwa ngu philipp

more options

Currently on an HP laptop, Win8, printing to a HP Color Laser, no previous problems; all of a sudden, PDF's are printing blank pages. I can see the page fine. Safe mode without any addons has no change. I printed my taxes out and had no problems.

I've used IE (shudder) an been able to print PDF's fine. I have no PDF software itself on the computer, just using the browsers native support. EXTREMELY FRUSTRATING. Searching shows problems loading PDF's, but my problem is printing PDF's. Using version 29 of Firefox. Anyone got any tips or clues how to hunt this down? Really close to introducing my computer to Mr. sledgehammer.

Isisombululo esikhethiwe

firefox 29.0.1 has just been released, which contains a fix for this issue - an update is recommended for everyone affected: Update Firefox to the latest release

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 6

All Replies (15)

more options

Fix printing problems in Firefox

Report us back if this help you .

more options

Already tried resetting and completely resetting the printer as mentioned in the help files. Still no resolution.

more options

You can use some free PDF printer drivers as alternatives :

See also

more options

Here's how I solved this issue on my installation today (Firefox 29, PC, Windows 7 Pro):

  1. Go to Options
  2. Click on the Applications tab
  3. Find and select Portable Document Format (PDF) in the Content Type column.
  4. In the corresponding Action column select "Use Adobe Acrobat (in Firefox)".
  5. Click on OK

You may need to restart Firefox, but I didn't. Before the change, my installation had "Preview in Firefox" as the action for PDFs.

more options

Thanks, but I have Win8. Regardless, I'm not using Acrobat, I am using Firefox's native support. It used to work fine and I can still see the PDF, it just prints blank pages.

more options

Thanks, appreciate the links for PDF driver add ons, this will be my last resort if nobody else can figure it out. I don't use Acrobat because of all their bloatware and hidden installs. I still would like to know why Firefox started printing blank pages in PDF's, but can still open the PDF's, very frustrating. Seems like a few other people are having the issue as well.

Okulungisiwe ngu anyuser256

more options

Fix for Firefox 29 printing blank PDF pages. While in Firefox, left click on Open Menu (three horizontal lines, upper right corner)/Options/Portable Document Format (PDF)/Action - change to: Use Adobe Acrobat (in Firefox)

Okulungisiwe ngu NightTrain

more options

hello anyuser256, there is currently a bug in the integrated firefox pdf viewer which produces the blank prints - this is something currently investigated by our developers. as a workaround in the meantime you could use a third-party pdf plugin like from adobe, like suggested by other respondents in the thread already: View PDF files in Firefox or choose another viewer

more options

Recommending the usage of the Adobe Reader is no solution. We use the internal PDF viewer intentionally due to the poor security of Adobe's Reader

more options

as mentioned before this is only meant as a temporary workaround.

more options

Our workaround is, to NOT change the original behavior and tell the users to use the download button and then open it in a third-party viewer. (which in the end is Adobe Reader, but this way, the website itself cannot start this buggy plugin unnoticed)

more options

you can follow the progress in getting this issue fixed in bug #1003707

more options

Use Internet Explorer or another Browser until Mozilla Firefox fixes the problem. It is most definitely a Mozilla Firefox problem with this new V. 29.

Actually, JUST found solution to this problem.

Go to tools go to options go to applications scroll down to Portable Document Format (PDF) change action to use Adobe Acrobat reader or whatever PDF program you prefer that is on your computer.

Okulungisiwe ngu cekfh

more options

Internet Explorer is NEVER a proper workaround for Firefox issues! Even if Firefox is completely dead, a proper workaround is using Chrome/Opera/lynx/telnet/...

more options

Isisombululo Esikhethiwe

firefox 29.0.1 has just been released, which contains a fix for this issue - an update is recommended for everyone affected: Update Firefox to the latest release