Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I want to clear my browsing history but can't access the Firefox window.

  • 6 uphendule
  • 2 zinale nkinga
  • 4053 views
  • Igcine ukuphendulwa ngu cor-el

more options

My Firefox was set up by an IT guy to take me directly to ATT/Yahoo email. I can't clear history nor access a Firefox Screen to set that up, as per the tutorial.

How do I do that in my setup? Everything I try takes me to Att/Yahoo.

Isisombululo esikhethiwe

Make sure that you do not run Firefox in permanent Private Browsing mode (Never remember history).

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"
  • Press the F10 key or tap the Alt key to bring up the hidden Menu bar.

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (6)

more options

Which Firefox is it? Your post is tagged with Firefox for Android, which doesn't really have a home page, so I'm not sure whether that is the one with the problem, or Firefox on a desktop operating system.

more options

I have a new Dell I 7 laptop running Windows 8. As I said, Firefox was set up to take me straight to ATT/Yahoo email and I can't clear history when browsing or access a Firefox window to follow the tutorial.

Any help here would be appreciated.

more options

Okay, some thoughts.

(1) On Firefox for Windows, you have a choice of two menu systems:

  • Compact menu accessed by an orange button that says Firefox
  • Traditional menu bar

To switch between them, you can right-click a blank area of the tab bar (or right-click the new tab "+" button on the tab bar) and check or uncheck Menu Bar.

If neither the menu button/bar or the tab bar is visible, Firefox might be in full screen mode. The F11 key switches between regular and full screen views.

(2) If you always get AT&T/Yahoo email when you open a new window (Ctrl+n) then it was set as your home page and you can change that. See:

(3) If you only get AT&T/Yahoo at startup, or you get it at startup even after you change your home page, it could be listed as the opening page in your Firefox shortcut. Right-click the icon > Properties > Shortcut tab. On the Target line, look for and remove any address after this:

"C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

Regarding clearing history, which method have you tried that isn't working?

more options

Thanks. Not being an IT guy, I'll need to study and think about these options. A bit more technical than I hoped.

I have not been able to try any clear history option, since I can't access a Firefox window. A "history" option it available at the top of my ATT/Yahoo window, but "clear history" is in grey and doesn't do anything.

Thanks again.

more options

Could you try opening a new Firefox window?

Normally you can press Ctrl+n for a normal new window or Ctrl+Shift+p for a new private window.

Here are a couple possible alternatives if Yahoo is intercepting those keyboard combinations:

One way would be using the "Run" dialog. I think this is available either on the "all apps" screen (if you have Windows 8.1) or if you hold down the window key and tap the R key. This should display a dialog where you can paste the following and run it:

firefox.exe "https://support.mozilla.org/questions/995650"

If Run isn't convenient, you could try pasting that into the search box on the Windows 8/8.1 charms bar and see whether it works. (In Windows 7, you could paste it into the search box on the Start menu, so I'm thinking maybe that's the equivalent on Windows 8+)

more options

Isisombululo Esikhethiwe

Make sure that you do not run Firefox in permanent Private Browsing mode (Never remember history).

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"
  • Press the F10 key or tap the Alt key to bring up the hidden Menu bar.

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.