X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Citrix server need extension installed for all users

Kuphostiwe

Been banging my head on this for a few days hoping for some help.

My main goal is to lockdown FF24.0ESR running on a Citrix 5.0 x32 server.

I have the mozlla.cfg setup and working however it doesn't change UI settings (remove help menu, remove google toolbar..etc)

I found a kiosk extension that will work great for this. However just to test to see if I can get an extension working I am using colorfultabs 28. If i can get that working then use that process for the kiosk extension.

I am unable to get the extension already installed for a existing user. Or any new users either.

I can put the extension in HKLM\SOFTWARE\Mozilla\Firefox\Extensions and it prompts the user to install the extension.

I want the extension already installed so the user doesn't have to (nor do they have permissions to) install plugins. We are using roaming profiles.

I have read several articles and moved the extension into the program folder,, move the extension to users\default and users\public , still with no success. Tried HKUsers default key as well.

Any ideas or pointers appreciated.

thx RR

Been banging my head on this for a few days hoping for some help. My main goal is to lockdown FF24.0ESR running on a Citrix 5.0 x32 server. I have the mozlla.cfg setup and working however it doesn't change UI settings (remove help menu, remove google toolbar..etc) I found a kiosk extension that will work great for this. However just to test to see if I can get an extension working I am using colorfultabs 28. If i can get that working then use that process for the kiosk extension. I am unable to get the extension already installed for a existing user. Or any new users either. I can put the extension in HKLM\SOFTWARE\Mozilla\Firefox\Extensions and it prompts the user to install the extension. I want the extension already installed so the user doesn't have to (nor do they have permissions to) install plugins. We are using roaming profiles. I have read several articles and moved the extension into the program folder,, move the extension to users\default and users\public , still with no success. Tried HKUsers default key as well. Any ideas or pointers appreciated. thx RR

Isisombululo esikhethiwe

cuesta wrote:

it prompts the user to install the extension.

Try locking the following preferences.


lockPref("extensions.autoDisableScopes", 0);
lockPref("extensions.shownSelectionUI", true);

cuesta wrote:

moved the extension into the program folder,, move the extension to users\default and users\public

Don't use multiple methods for the same extension. If you want to install an extension by placing it under the installation folder,

  1. It must be placed under <installation folder>\browser\extensions
  2. Its filename must be the extension ID. Unpack the extension (it's a simple ZIP file with an XPI file extension) and examine install.rdf which you can open with a text editor. Look for the em:id line. For example, the French language pack is originally named fr.xpi but it must be renamed to langpack-fr@firefox.mozilla.org.xpi
Funda le mpendulo ngokuhambisana nalesi sihloko 2

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/33.0.1750.146 Safari/537.36

Eminye Imininingwane

Gingerbread Man 403 izisombululo 1537 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

cuesta wrote:

it prompts the user to install the extension.

Try locking the following preferences.


lockPref("extensions.autoDisableScopes", 0);
lockPref("extensions.shownSelectionUI", true);

cuesta wrote:

moved the extension into the program folder,, move the extension to users\default and users\public

Don't use multiple methods for the same extension. If you want to install an extension by placing it under the installation folder,

  1. It must be placed under <installation folder>\browser\extensions
  2. Its filename must be the extension ID. Unpack the extension (it's a simple ZIP file with an XPI file extension) and examine install.rdf which you can open with a text editor. Look for the em:id line. For example, the French language pack is originally named fr.xpi but it must be renamed to langpack-fr@firefox.mozilla.org.xpi
''cuesta wrote:'' it prompts the user to install the extension. Try locking the following preferences. ---- <pre><nowiki>lockPref("extensions.autoDisableScopes", 0); lockPref("extensions.shownSelectionUI", true);</nowiki></pre> ---- * http://kb.mozillazine.org/Locking_preferences * https://developer.mozilla.org/Add-ons/Installing_extensions#Disabling_install_locations ''cuesta wrote:'' moved the extension into the program folder,, move the extension to users\default and users\public Don't use multiple methods for the same extension. If you want to install an extension by placing it under the installation folder, # It must be placed under '''<installation folder>\browser\extensions''' # Its filename must be the extension ID. Unpack the extension (it's a simple ZIP file with an XPI file extension) and examine ''install.rdf'' which you can open with a text editor. Look for the '''em:id''' line. For example, the French language pack is originally named ''fr.xpi'' but it must be renamed to ''langpack-fr@firefox.mozilla.org.xpi''

Okulungisiwe ngu Gingerbread Man

Umnikazi wombuzo

You know I have looked for days and never came across those settings, or at least tied to multi user extensions.

Your solution worked perfectly (the first time I might add.)

Added the expanded extension to the folder and put in the 2 entries in the mozilla.cfg and worked like a champ.

Now if I can only figure out how to remove the help menu.

Most excellent reply thanks much for taking the time. RR

You know I have looked for days and never came across those settings, or at least tied to multi user extensions. Your solution worked perfectly (the first time I might add.) Added the expanded extension to the folder and put in the 2 entries in the mozilla.cfg and worked like a champ. Now if I can only figure out how to remove the help menu. Most excellent reply thanks much for taking the time. RR