Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Xperia keyboard gesture typing input (Swipe) not functional in Awesome Bar

  • 4 uphendule
  • 31 zinale nkinga
  • 43 views
  • Igcine ukuphendulwa ngu rncross

more options

I recently got an Xperia Z1 compact (my first android phone) and Firefox was one of the first apps on it.

Annoyingly gesture typing (where you swipe from one letter to another without lifting your finger) does not seem functional within the Awesome Bar (address/search bar). However it works perfectly fine on input boxes/fields on websites being browsed.

Is there any way to allow gesture typing in the awesome bar?

Cheers.

Isisombululo esikhethiwe

I am also seeing this and have seen http://talk.sonymobile.com/t5/Xperia-Z-ZL-ZR/Keyboad-Swipe-Option-not-working-on-some-apps-After-Upgrading-to/td-p/502175 Unfortunately on my Xperia Z2 updating does not solve it although switching to Chinese keyboard does solve it. Using the above 'space character space' solution also works.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (4)

more options

Ideally it should work, and I could not find any other incidents of this. I searched bugzilla Search for Android xperia z1 awesome bar

If toggling the gesture typing does not resolve this, please file a bug with the steps you took and the version of FF Android you are using. I have no way to test, but someone in bugzilla might.

Can you toggle this setting: From your Home Screen:

  1. Press menu button then select "Settings"
  2. Scroll down to "Language & keyboard" and select it.
  3. This is a list of all available keyboards installed- select your keyboard (most likely the only keyboard available is "Android keyboard").
  4. Under "Android keyboard" (or "Swype"), deselect "Auto-complete" and/or "Quick fixes." Done.

Others will benefit from you reporting this issue. If you have any questions about this please do not hesitate to ask.

Okulungisiwe ngu guigs

more options

Cheers for looking in to it for me!

I have discovered something odd to add to this behaviour. Gesture functionality (swipe) is restored if I type the following in the awesome bar.

'random letter' [space] 'random letter' [space]

Gesture based typing kicks back in after this point! So I've been doing the above then deleting the random text and then gesture typing what I want.

Unfortunately I got a bit lost with your instructions. I have included a screenshot of where I got before I couldnt find "Autocomplete" or "Quick Fixes"

more options

Ok, these instructions look like they are outdated, perhaps there is an extended menu in the input settings of that menu you took a screenshot of?

Typing triggers the keyboard swype after there are letters already in the bar. I have asked about this in irc and will see if I can find more information.

What happens if you tap in the awesomebar, then try to swipe?

more options

Isisombululo Esikhethiwe

I am also seeing this and have seen http://talk.sonymobile.com/t5/Xperia-Z-ZL-ZR/Keyboad-Swipe-Option-not-working-on-some-apps-After-Upgrading-to/td-p/502175 Unfortunately on my Xperia Z2 updating does not solve it although switching to Chinese keyboard does solve it. Using the above 'space character space' solution also works.