Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Heard there were security fixes so hit 'about ff'. and it automatically loaded a horrific new version!!!!!

  • 9 uphendule
  • 4 zinale nkinga
  • 101 views
  • Igcine ukuphendulwa ngu Spamlet

more options

I was happily on FF28. I have spent a couple of years fine tuning with addons to maximise the space on my small letterbox notebook. I have Nav Bar on Title Bar so as to use that otherwise TOTALLY WASTED SPACE. I had loads of add on buttons up there with it, and more on the bar at the bottom of the screen. It took years to get it just right.

Then I heard there had been some security updates since last I used my notebook, so I hit 'about FF'. It then loaded a totally alien THING that destroyed the whole lot! And presented me with an interface that gives me no chance in hell of recreating what I had. There wasn't even a bar at the bottom of the screen any more; all the wasted space at the top was back; most of my buttons were gone; a wide chunky tool bar was wasting space, and my tabs were all round edged and too deep.

Ruined my browsing, when I had a lot of work to catch up on.

Could find nothing on how to get my settings back, so had to do a complete system restore, and then spend hours redoing all the windows updates since my last restore point.

Thanks a bunch Mozilla for dumping this on me without warning. It seems to have screwed up Mask Me as well, so I'm no longer being prompted with email addresses and passwords. God knows what else it's screwed up that I've not noticed yet.

If FF is going to keep this awful new format, I will have to prevent any more updates. Is there a way to get security updates without getting this horrible new version at the same time?

Isisombululo esikhethiwe

No, you can't change the update channel by changing the pref on the about:config page.

You can only change the update channel to release by installing a full Firefox release version or (not recommended) by editing the channel-prefs.js file in the defaults\pref folder.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 2

All Replies (9)

more options

Did you install the beta version of Firefox 29? There is a new UI coming, along with new extensions to restore the classic appearance...

Because UI preferences are so personal, I recommend capturing some screen shots of what you like to facilitate discussion about how to accomplish the same thing on Firefox 29 when it finally gets released.

Currently there are not separate security and feature releases.

more options

Sounds that you are on the Beta update channel and updated to Firefox 29.0beta that has the Australis appearance.

What update channel are you on?
You can check the value of the app.update.channel pref on the about:config page.

You may want to switch to the release channel by installing the full Firefox 28 release.


You can install the Classic Theme Restorer extension to restore some functionality that was lost with the arrival of Australis.

more options

Thanks jscher. I wish I'd had an email warning that this was coming.

I've done a screen shot. I notice that, with this tab open some of my buttons are hidden under the top right corner. It doesn't do that on other sites, as far as I've noticed!? I'll try and put a picture below, so that you can see how I've made the most of the space. Why this new version is still wasting all that space at the top of the screen, I can't imagine. Seems crazy when we are all using letterbox screens!

more options

Thank you Cor-el!

If any Mozilla people are reading: I absolutely DO NOT want to mess about with the crazy new layout! I do not want Aurora, or 'Australis'. You could do a lot worse than copy MY current layout. Your original, and the new version just waste buckets of space, and take a load of customizing to get right.

So please separate the security updates from the design updates and I will stay with my perfect FF28.

Cor-el: I've replaced 'beta' with 'release'. in about:config. I assume this is right.

I suspect that if I update to 29, I will have as much trouble getting my own design back, even with the restore classic add on, because mine is so modified from the standard appearance. I will have to try and stick with 28. This is a terrible shame, as all the updates have gone smoothly up until now. Whatever happened to 'if it ain't broke: don't fix it'!? :-(

If Mozilla won't separate the updates, there would appear to be an opening for someone to make an app to supply us with the security ones.


One side issue: How are you people seeing my posts? I can only get to this forum by going through all the faq's until I get to ask a question. How are you viewing all the questions that come in?

more options

Isisombululo Esikhethiwe

No, you can't change the update channel by changing the pref on the about:config page.

You can only change the update channel to release by installing a full Firefox release version or (not recommended) by editing the channel-prefs.js file in the defaults\pref folder.

more options

We use the forum index pages to see all questions.

The index pages have additional filter setting.

more options

Thanks again Cor-el,

I think I'll just leave it as it is and turn off the updates. Don't want to go back to scratch, and, if they are not going to separate the security updates from the programme updates, I can't use update any more any way.

Great shame, as I really liked FF. Can't imagine being able to recreate what I have in FF28 again :(

Thanks for the link to the main forum page. And thanks to you both for your very speedy help ! (y) (y)

more options

You're welcome

Which icons are hidden behind those window buttons?

Are that icons for social features or icon from an extension or regular toolbar items?

more options

Thanks again Cor-el

There is a screen shot of my layout, with add-on buttons hidden under the top right corner controls in my reply to jscher.

This hiding only seems to happen when there are fields to fill in on an open tab like this one. Ordinary pages and blank tabs do not cause the buttons to spread out under the corner controls. I don't know why this should be, but it is only a minor irritation.

I will attach a screen capture of the layout with a blank tab so that you can compare.