Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why can't we simply have an option to enable/disable Javascript on sites again in the settings for Firefox 27? Suddenly my Gmail attachments won't open. Gmail.

  • 12 uphendule
  • 8 zinale nkinga
  • 13 views
  • Igcine ukuphendulwa ngu cor-el

more options

Suddenly my Gmail attachments have stopped opening, and I receive the message: JavaScript must be enabled in order for you to use Gmail in standard view. However, it seems JavaScript is either disabled or not supported by your browser. To use standard view, enable JavaScript by changing your browser options, then try again.

I found a Mozilla support thread where it was explained that Javascript has been turned off for a while in FF. OK. Then there was a complicated answer about how you could still turn it back on by typing in a config code into the address bar. What? Or, you could download an extension to do that for you. Why?

Please-- if you really feel like users can't be trusted, and Javascript must be turned off, at least bring back the ability to enable/disable Javascript on a per site basis in options, without having to know code. It's Gmail.

Thank you.

Isisombululo esikhethiwe

Thanks, guys. OK, thinking about this didn't make sense. So I decided to troubleshoot all aspects. I now believe that several attachments sent to me by one client are corrupted from her end. Attachments from several other folks do open! So sorry to waste your time, and very sad that I wasted so much of mine. I think this thread should be deleted. Thanks again.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (12)

more options

Javascript has never been turned off for users by default. You may have read a thread saying Java has been disabled, which is correct, but Java and Javascript aren't related technologies at all.

If you want to turn Javascript on, please do the following:

  • Type about:support into your address bar, press Enter
  • Accept the warning
  • Search for javascript.enabled
  • Make sure the value is true. (Double click it if it is not)

If this fails to work, Reset Firefox Refresh Firefox - reset add-ons and settings

more options

Thanks, Tyler. I am indeed easily confused about tech things, but I was writing about JavaScript, not Java. Here is the thread I referenced saying it's turned off by default: https://support.mozilla.org/en-US/questions/990010?esab=a&s=javascript+gmail+standard+view&r=5&as=s

I have searched "JavaScript" and it is enabled. To try your easy solution, I Reset FF. Unfortunately it didn't work. JavaScript appears to be enabled, but Gmail attachments still won't open, still get that error message. (Also, just updated to FF 28.) Other suggestions? Thank you.

Also, why can't this be restored in an option instead of having to type in code?

Okulungisiwe ngu deffirefox

more options

There is nothing on that thread that says Javascript is turned off by default. to quote: "In Firefox 23, as part of an effort to simplify the Firefox options set and protect users from unintentially damaging their Firefox, the option to disable JavaScript was removed from the Firefox Options window.

However, the option to disable JavaScript was not removed from Firefox entirely. You can still access it from about:config or by installing an add-on. "

The UI checkbox to disable Javascript was removed, but the option still exists in about:config (which isn't code btw, it's just preferences), nor was Javascript turned off by default, in fact the opposite is true, it is enabled by default with the option to disable it made a little more difficult to find, as only advanced users need to disable Javascript.


Please try to clear the cache and cookies for gmail, let's see if those are causing problems. Clear cookies and site data in Firefox, How to clear the Firefox cache

more options

Diego, those solutions have either already been posted, or have no bearing on this user's problems.

more options

Isisombululo Esikhethiwe

Thanks, guys. OK, thinking about this didn't make sense. So I decided to troubleshoot all aspects. I now believe that several attachments sent to me by one client are corrupted from her end. Attachments from several other folks do open! So sorry to waste your time, and very sad that I wasted so much of mine. I think this thread should be deleted. Thanks again.

more options

No worries, glad you figured out the cause.

more options

One day I am watching videos on Amazon and am on FB and suddenly and mysteriously my javascript is disabled and not working the very next day. I did not do anything! So I end up here read your posts, tried the easy way out first, empty the cache and walla I am back in business. Thanks ya'll! KUDOS

more options

Tyler, your set of steps (prior to the 'Reset') do NOT work. There is no such option or section in FF 30 and higher as " javascript.enabled."

" Type about:support into your address bar, press Enter

   Accept the warning
   Search for javascript.enabled
   Make sure the value is true. (Double click it if it is not) "

I have not yet done a full Reset, so I'm not sure if that's the issue, or just that the option may be in a different place now. Anyway, some Javascript pages won't render, so I may try a Reset.

more options

hmfic, there should be such an option (in Firefox 31, 30, 29, 28, and so on). If you don't have it, I suggest a reset since something else is wrong with your profile then.

more options

hmfic are you typing in javascript.enabled or copy and pasting this as it could have a space before if not careful.

more options

No, you've just got the wrong line/command: You said, "Type about:support into your address bar, press Enter "

Instead, it should be: "about:config" and then you have to click on "I promise I will be careful." Maybe in earlier versions, it was "about:support," but in 30 and higher, it is not; you have to use "about:config" - FYI.