Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Do you want Firefox to save your tabs for the next time it starts?

  • 6 uphendule
  • 11 zinale nkinga
  • 5813 views
  • Igcine ukuphendulwa ngu BillM

more options

FF 27.0.1 on Linux Mint 16 XFCE, up to date.

I have my Preferences set to 'Show my home page'.

Every time I close FF with the X in the top left corner, it comes up and asks me "Do you want Firefox to save your tabs for the next time it starts?". I check the box not to be asked next time, and have tried both Save and Quit, and just Quit. When I open the browser again it seems to randomly decide whether to open all the tabs I had last time, or sometimes (rarely) just my home page tabs.

I don't want it to open all the tabs I had open, and I don't want the question every time I quit FF. I've used FF for years with XP, but I am new to Mint.

Isisombululo esikhethiwe

Does setting the "warnon" prefs on the about:config page to false has any effect?

  • browser.tabs.warnOnClose
  • browser.tabs.warnOnCloseOtherTabs
  • browser.warnOnQuit

Make sure that you do not run Firefox in full screen mode (press F11 or Fn + F11 to toggle; Mac: Command+Shift+F).

If you are in full screen mode then hover the mouse to the top of the screen to make the Navigation Toolbar and Tab bar appear.
Click the Maximize button (top right corner of the Navigation Toolbar) to leave full screen mode or right-click empty space on a toolbar and choose "Exit Full Screen Mode" or press the F11 key.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 3

All Replies (6)

more options

Hello, Sorry to know about this problem. you can set what Firefox will show when you open Firefox. For that, you can do this method > options > options > general > startup > When Firefox starts > show my home page.

For more instruction on how to do in your operating system, you can see this article [session restore]

Please let us know if this is helpful. Regards Safwan

more options

As I said in my original post, I have set my preferences to "Show my home page" under Start up.

It sometimes changes to "Show my windows and pages from last time" by itself, maybe because when I tell the annoying pop-up "Do you want Firefox to save your tabs for the next time it starts?" to save and quit I guess, which comes up every time I quit, even with the "Do not ask me nest time" box clicked.

Just setting my preference isn't working. I've used FF for many years, and have a fairly good idea how to use it. The "Do not ask me next time" does not work.

Okulungisiwe ngu kcaldwel9

more options

Glad to know you are using Firefox for many years. So the only easiest way is to reset your Firefox. for resetting instruction, please see this article Refresh Firefox - reset add-ons and settings.

Please let us know if this method can fix your problem. Regards

more options

Isisombululo Esikhethiwe

Does setting the "warnon" prefs on the about:config page to false has any effect?

  • browser.tabs.warnOnClose
  • browser.tabs.warnOnCloseOtherTabs
  • browser.warnOnQuit

Make sure that you do not run Firefox in full screen mode (press F11 or Fn + F11 to toggle; Mac: Command+Shift+F).

If you are in full screen mode then hover the mouse to the top of the screen to make the Navigation Toolbar and Tab bar appear.
Click the Maximize button (top right corner of the Navigation Toolbar) to leave full screen mode or right-click empty space on a toolbar and choose "Exit Full Screen Mode" or press the F11 key.

more options

Resetting Firefox didn't work, same behaviour.

Changing the settings in about:config as above worked! Thanks cor-el!

________________________________________________________________________________

It seemed to work for awhile. I do not have the annoying pop-up box any more, but this morning I had all my tabs from last night open when FF started.

I have "Show my home page" set in my Preferences, but it is still opening all my previous tabs.

Okulungisiwe ngu kcaldwel9

more options

Changing the about:config settings worked for me (so far). Thanks for the help.