Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Clicking email link opens Internet Explorer...

  • 16 uphendule
  • 18 zinale nkinga
  • 5236 views
  • Igcine ukuphendulwa ngu Steve Wyman

more options

This is a new issue, as of today. I have not changed any of my settings for email defaults.

When clicking on the reply link on Craigslist, a window opens, giving options. I always choose the anonymizer. Today, when I clicked on it, Internet Explorer opened. When I right-clicked on IE to close the window, it rapidly opened up numerous tabs, each of which had the message "Navigation cancelled". I was unable to click on "close all tabs" for more than 30 seconds, by which time more than 50 tabs had opened. It took multiple attempts to close all those tabs.

Now, before you tell me to check IE settings, keep in mind that: 1) I NEVER use IE and 2) I have never had this problem in the past and 3) I have not changed any email default settings. Also, 4) I had no problems accomplishing my task on Chrome.

Something is haywire in Firefox 27.0.1 and I am at a loss as to what it might be or how to fix it. None of the online help pages has been of any use, up to this point. I have restarted Firefox and I have rebooted my computer.

Any ideas would be welcome

Isisombululo esikhethiwe

After receiving this last recommendation, I walked away from it. I didn't have the time available to go through all those steps. It was easier to just not use Firefox when logging onto Craigslist.

So here we are, two weeks later. I still haven't done anything about it but the problem is now gone. Apparently Mozilla fixed whatever the problem was or perhaps it was a Window issue that was fixed with a recent update.

Whatever the case, the mystery was never solved but it no longer exists.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (16)

more options

You get this problem if you select the Firefox program to handle a file when you get an "Open With" dialog.

You can try rename (or delete) the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
more options

No "open with" dialog. In the past, I would click on the link and it would immediately open my default email client. In this case, AOL from the webpage, not stand alone software.

more options

You can check the network.protocol-handler.external.mailto prefs on the about:config page.

If network.protocol-handler.external.mailto prefs are user set (bold) then right-click and Reset them to the default value.

You can open the about:config page via the location bar.

more options

Not bold.

status = default, type = boolean, value = true

Okulungisiwe ngu Steve Wyman

more options

Still nothing, here. Should I just uninstall Firefox and reinstall it or won't that help? Can I save all my bookmarks someplace?

FWIW, I'm running into other weird behaviors like clicking links that don't do anything at all and email that won't open.

Okulungisiwe ngu Steve Wyman

more options

We have a support article for this https://support.mozilla.org/en-US/kb/Hyperlinks-in-Messages-Not-Working#w_firefox

Try resetting the default in Firefox as suggested in the article. The tools menu is ALT+T

I would also suggest you use a product like malware bytes to scan your system, the process of opening loads of tabs like that is often indicative of a malware infection. If you are using a Microsoft security product, scan your system with something else. Their products are only So-So when in comes to virus and malware.

It may also be that malware has reset your default browser as it is easy to do and gives the malware author a known platform to play their tricks on.

more options

Did you delete the mimeTypes.rdf file?

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
more options

Matt, I double checked and Firefox is still the default browser. A Malwarebytes scan did not clear up the problem.

Cor-el, I'll try to remove the mimeTypes.rdf file

more options

Cor-el, I removed the mimeTypes.rdf file and restarted the computer. The problem still persists.

more options

And it turns out that the "Navigation cancelled" error is on every tab except for the first one.

The first IE tab says: Could not perform this operation because the default mail client is not properly installed.

When I close that tab, the numerous other tabs open rapidly.

I've tried to figure out how to re-set the default mail client but I cannot find the option.

more options

I have tried the following steps... Tools, Options, Applications, emailto.

emailto shows the action: use handemailto (default).

When I click on that tab, it lists Always ask, Use handemailto (default), Use Yahoo! mail, Use Gmail, Use other.

Application details

Use AOL is not one of the options and clicking on Use other brings up a page with mailto 'undefined'. There's a blank area labeled "send this item to" but I cannot fill in the blank with mail.aol.com.

Clicking on Application details lists Yahoo! mail and GMail and I can remove either/or both of them on this page.

I feel like I should be able to add AOL mail on the Use other page but I'm unable to. Also, I have always used AOL so the whole problem is puzzling.

Okulungisiwe ngu Steve Wyman

more options

Still no luck on this end...

more options

i have problem too with this ask. still follow this answer


[link(s) removed by Moderator]

Okulungisiwe ngu cor-el

more options

Anyone? Anyone? Bueller? Bueller?

more options

Do a malware check with several malware scanning programs on the Windows computer.
Please scan with all programs because each program detects different malware.
All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

more options

Isisombululo Esikhethiwe

After receiving this last recommendation, I walked away from it. I didn't have the time available to go through all those steps. It was easier to just not use Firefox when logging onto Craigslist.

So here we are, two weeks later. I still haven't done anything about it but the problem is now gone. Apparently Mozilla fixed whatever the problem was or perhaps it was a Window issue that was fixed with a recent update.

Whatever the case, the mystery was never solved but it no longer exists.

Okulungisiwe ngu Steve Wyman