Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Fonts not rendering properly

  • 8 uphendule
  • 24 zinale nkinga
  • 1157 views
  • Igcine ukuphendulwa ngu cor-el

more options

Many sites I visit the fonts render, however they are 'crooked.' I have tried to load FireFox with a default profile, etc. It happens on all computers so I am assuming it some setting I am missing.

It does not happen on every site Screenshot: http://imgur.com/a/BE3It

Zooming in and out does not fix either.

Thanks in advance.

All Replies (8)

more options

That looks like some custom art font that I wouldn't expect to see on a lot of sites...

Could you give the address of a couple pages with this problem?


Do you have Firefox set to allow pages to use their choice of fonts (default setting) or did you set Firefox to always use your preferred fonts?

orange Firefox button (or Tools menu) > Options > Content

In the Fonts & Colors section, click the Advanced button and look about halfway down for that checkbox.

more options

www.kickstarter.com gamefaqs.com Are some pages that come to mind that have this issue.

Thanks!

more options

Also, checked mine, it is checked to allow sites to choose their own fonts. ALso made my settings mimic yours, still same issue.

more options

On those sites, my Firefox displays Arial. But if you have the "Helvetica Neue" font, then Firefox will use that as it is the preferred font on both sites. (See attached screen shots.)

I'm not sure what that font is supposed to look like, but either it is corrupted or Firefox can't handle it correctly.

Sometimes Firefox will display fonts poorly if it is not fully compatible with your graphics card drivers. As a test, you could disable Firefox's use of hardware acceleration for graphics.

orange Firefox button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

This will take effect after the next time you exit and restart Firefox.

Okulungisiwe ngu jscher2000

more options

Note that you can see what font Firefox uses for text if you right-click the text and go to the Font tab in the Inspector (Firefox/Tools > Web Developer).

more options

Helvetica Neue Bold system

Used as: "Helvetica Neue" Is what it is using I will try the suggestion to turn off hardware acceleration.

more options

Okay, turned off hardware acceleration, still did not fix :(

more options

Try to uninstall (remove) this font from the Fonts folder to see if that helps.

We have seen a lot of issues reported with Helvetica fonts on Windows over the past years, so it is worth to give this a try.