Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I get rid of "Hot Deals"?

  • 16 uphendule
  • 87 zinale nkinga
  • 11404 views
  • Igcine ukuphendulwa ngu tacticalogic

more options

I updated to the latest version of Firefox, and ever since I did, I keep getting a tab on my pages, called, "Hot Deals". How do I get rid of this, and how do I stop new windows from opening, when I click on a link, or email, it opens a new window, instead of a new tab! Please help!!

Thank you!

All Replies (16)

more options

You can open the about:config page via the location bar and search for prefs that refer to the "Hot Deals" website and reset related user set (bold) prefs via the right-click context menu to the default value.

more options

I recommend uninstalling Catalina Savings Printer and Coupon printer from your addons. They are likely behind these advertisements. Also, scan with Malwarebytes.

more options

I removed "Catalina Savings Printer", but I am still getting the separate pages, and "Hot Deals". How do I do Malwarebytes?

more options

Try the following:

  1. Disable or remove unrecognized or unwanted extensions
  2. Uninstall suspicious programs
  3. Mop up with some supplemental scans

For #1: Disable ALL nonessential or unrecognized extensions on the Add-ons page. Either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Extensions. Then, if in doubt, disable.

Usually a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

For #2: Open the Windows Control Panel to Add/Remove Programs, then click the "Installed on" column heading to view recent additions. This may help in spotting bundles that sneak unwanted add-ons into your Firefox. Remove everything suspicious.

For #3: See this article: Troubleshoot Firefox issues caused by malware

more options

Delete "web sparkle" from your installed programs list, it worked for me.

more options

To drawn out for those of us not too computer savvy, I just deleted "Web Sparkle" from my installed programs list (It must have installed with new version of firefox in update)... now its gone YAY.

more options

Hi NZCaz, official updates do not include "Web Sparkle".

If you see an update message in the future, consider canceling/closing it and using the following method to ensure you get the official version:

Help > About Firefox > "Check for Updates" button

more options

I've been up and down the list and can't find "prefs that refer to Hot Deals website." How about telling us exactly what to look for so we don't have to search the whole list? Or better still, why didn't the programmers simply add a Disable option to the pop-up/over/into, whatever? Very aggravating!

more options

Hi tacticalogic, there is a search box above the list of preferences that you can use to look for anything that contains, for example, deals. Does that bring up anything?

Also, please try the other responses in case you have a bad add-on, etc. The preferences might only be a symptom.

more options

Thanks, I tried the search for "Deals" but got no results with that. I also checked my addons but nothing there either. New development, now I am getting a similar popup at the bottom of my screen with more shopping deals. Has anyone determined if these additions were part of the last Firebox update? They have only started since the last update to V 28.O

more options

Hi tacticalogic, if you haven't already assessed whether one of your extensions is causing the issue, please try Firefox's Safe Mode. That's a standard diagnostic tool to deactivate extensions and some other advanced features. More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled (Flash and other plugins still run)

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

more options

The easiest way to fix this is to use the reset - see Refresh Firefox - reset add-ons and settings

more options

This did not disable Hot Deals. And now I have to reinstall all my add-ons and customizations. But it was worth a try.

more options

Say, Hot Deals is still there.

more options

Hi tacticalogic, after a reset, some extensions survive. In particular, when you install software, it can add an entry to the Windows registry that Firefox will use to find and activate that extension. You probably need to visit the Windows Control Panel and clean out some garbage that snuck in as part of a free software bundle. Then you can return to Firefox to complete the resuscitation.

I'm not sure which version of Windows you use, but assuming you can find "Uninstall a Program" or "Add/Remove Programs", click the "Installed on" column heading to group the additions by date. This can help surface bundled items you did intentionally install that can go unnoticed when the list is alphabetical.

more options

I don't know why I didn't think of it before, but I ran Malwarebytes and now the popups are gone.

Okulungisiwe ngu tacticalogic