Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox doesn't load google sites nor facebook

  • 10 uphendule
  • 17 zinale nkinga
  • 9191 views
  • Igcine ukuphendulwa ngu AliceWyman

more options

This is extremely frustrating and has been happening for months now. Sometimes the sites load, but then stop working after a few minutes, and then it's nearly impossible to get them to load again. It just hangs at "connecting" for ever until it either times out or just goes to a blank tab. Other sites work, but anything Google related such as search, gmail, finance, etc or Facebook simply don't work.

It appears that this is a common problem recurring every 6 months or so according to this board. I've tried clearing cookies/cash and then even reset Firefox and it still happens. Any suggestions to fix this problem?

Thank you very much!

Jeremy

Isisombululo esikhethiwe

All Replies (10)

more options

I see that you have Adblock Plus AND Adblock Edge installed. Can you try removing Adblock Edge and restarting Firefox to see if you are able to browse?

Adblock Edge is not needed since that is a fork into Adblock Plus version 2.x and basically no use to you since your version of Adblock Plus is 2.4.1

Okulungisiwe ngu Moses

more options

Thank you for the reply! I'm sorry, I posted this right after installing those add ins, but when I reset Firefox and started fresh I still got the problem. I'll be happy to uninstall all of those ad blocker plugins however as we troubleshoot this problem.

So, I uninstalled them and still am having the issue.

more options

Hmm, when you load the sites in Safari or Chrome, does it have the same issue or is it just in Firefox? Can you check for me?

Thanks!


Based on your detail of hanging on connection' it seems like it might be a connection problem. Follow above first.

Okulungisiwe ngu Moses

more options

I only have Safari to compare with, however it does solve the problem. I guess I could just use Safari, but I like the interface and features from Firefox better.

more options

No, no! I wouldn't want you to switch. I just wanted to see if it was reproducible in another browser. Well, then it is indeed a Firefox problem.

Hmm...you have no conflicting extensions, all of your plug-ins seems okay. Here are a few suggestions. If you previously did some of these things, do them again.


To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear. Click I'll be careful, I promise! to continue to the about:config page.
  2. In the Search field, type network.dns.disableIPv6.
  3. In the list of preferences, double-click network.dns.disableIPv6 to set its value to true.

If you see no difference, go ahead and set this value back to false


  1. In the Location bar, type about:config and press Enter.
  2. The about:config "This might void your warranty!" warning page may appear. Click I'll be careful, I promise! to continue to the about:config page.
  3. Right-click in the list of preferences, select New, and then select Boolean.
  4. In the Enter the preference name window, enter network.dns.disablePrefetch and click OK.
  5. Select true when prompted to set the value and click OK.

If you see no difference, delete the network.dns.disablePrefetch from there.


  1. Click the menu button New Fx Menu and choose Options
  2. Select the Advanced panel.
  3. Select the Network tab.
  4. In the Connection section, click Settings….
  5. Change your proxy settings:
    • If you don't connect to the Internet through a proxy (or don't know whether you connect through a proxy), select No Proxy.
    • If you connect to the Internet through a proxy, compare Firefox's settings tz another browser's (such as Internet Explorer — see Microsoft's guide to proxy settings).
    • Close the Connection Settings window.
  1. Click OK to close the Options window
more options

Isisombululo Esikhethiwe

Try to disable IPv6 (check other suggestions as well):

more options

So far the IPv6 change seems to have worked, thanks to both of you! Before I consider this case closed I want to give it a few days to be sure. Sometimes Firefox would work fine for a couple of sessions and then not.

Thanks again and I'll update in a couple of days. Just curious, why is this IPv6 potentially problematic?

more options

monkeychemist,

Is the problem still fixed by changing the network.dns.disableIPv6 preference from "false" to "true", which disables IPv6 DNS lookups?

You asked, Just curious, why is this IPv6 potentially problematic? See http://kb.mozillazine.org/Network.dns.disableIPv6 for the background.

more options

Hello everyone, it looks like the disabling of IPv6 did the trick, thank you!

more options

Thanks for the followup.

I marked the answer posted by cor-el here - to disable IPv6 - as the solution.