Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

"class not registered"

  • 22 uphendule
  • 92 zinale nkinga
  • Igcine ukuphendulwa ngu cor-el

more options

there is already another question with the same problem I am having, but to be able comment on it I needed to ask my own question to register. I am running windows 8. I was using firefox when the prompt came up "firefox needs to update... and will reopen in a few moments". Firefox never reopened Instead I received an error message "C:\Program Files (x86)\Mozilla Firefox class not registered". I have uninstalled, reinstalled, deleted C:\Program Files (x86)\Mozilla Firefox , reinstalled and still receive the same error message "C:\Program Files (x86)\Mozilla Firefox class not registered". When I reinstall firefox it never opens its always comes up with the error message. Any solutions?

All Replies (20)

more options

Hi diamond2x,
Sorry you are having problems.

Thanks for starting your own thread. It should make it easier for you to get an answer to your own problem.

I am not an expert on this but will at least make some comments and suggestions.

The problem is with how Windows is treating Firefox. Have you tried

  1. Setting Internet Explorer as the browser
  2. Then trying to start Firefox again to try to set that as the default browser.
  3. Start Firefox from the Windows Run command and use firefox.exe
    Winkey + R is one method of getting the Run option

Another thread including links to other articles

Someone else may well give a better answer but mean while what happens when you try my suggestions of changing the default browser then starting Firefox from the run option.

more options

I set IE as my default browser, but I am still unable to get firefox to open , I still get the same error message.

more options

Did you try to open Firefox by running it from the run option of Windows and manually typing in firefox.exe ?
NOT by using a startup icon or any other type of shortcut.

If that does work then try to set Firefox as the default browser.

Please attach a screenshot of the error message

If you try to open .html files or links to websites that you create on the Windows desktop do they open ok at present (Presumably opening in IE)

more options

Another thing want to add is, even though firefox doesn't open. When I unistall firefox my PC says firefox is still running even though it's not open. After a restart I can remove it and reinstall but I still get the same error message. Maybe this info might help someone give me some info.

more options

Yes I did try this way, but I get the same error message.

more options

I am not expert on Windows. These days I try to avoid using it.

From your screenshot I may have expected such a message to indicate all .exe class were unregistered but that clearly is not the case.

Should it indicate other file types or extensions do not associate with Firefox then that is understandable and expected when Firefox is not the default browser, but is no explanation for the error on starting Firefox from the run option.

I will get others involved by

  1. Linking this thread from another internal forum.
    Class not registered: Prevents starting of Firefox on Windows. /forums/support-forum-contributors/710008
  2. Tagging the post as escalate
more options

I have some info that might help me get to a solution. If I remove firefox, restart and install an older version (firefox 26). Firefox will actually open and work, but when I close firefox and click the icon to open it again I get the error message again. Also when I start firefox this way and it's running, the task manager does not show it as running even though it's up and running .

more options

The windows forum says this happens when dll files are missing: this can be helpful if you run a sfc scan or try to launch firefox in windows safe mode.

What is missing, I do not know if anything you see comes up, please let us know!

This is happening here as well

Okulungisiwe ngu guigs

more options

I think in some instances the error message comes up specifying a .dll &/0r is seen when a link is used. In this case it is specifically firefox.exe that is mentioned.

I am now suggesting ESR portable as an unofficial but secure workaround. Mozilla will not officially suggest that

  • Portable is not ours
  • ESR is not for private individuals

But there are precedents we have previously admitted ESR is secure and may work when a Release will not. To me that is a better workaround than saying use an alternative secure browser such as Chrome.

more options

I was able to sorta fix the problem. A friend suggested that I uninstall firefox, restart, download and run Waterfox 26. Waterfox 26 works with no error messages. I know it's not the solution I wanted, but it works.

guigs2 suggested looking for missing dll files. I ran an fsc scan and I came up with 4 Cannot repair member file [l:36{18}]"Amd64\CNBJ2530.DPB" ..... I am not confident if I can make these repairs myself. I will think about it for a day and see if I want to do this or not.

more options

Thanks for posting that diamond2x

I suppose Waterfox 26 is their standard release at present. I wonder when they update to 27 and if you then hit exactly the same problem ?
Or whether 64bit builds do not suffer from this issue ?
Did you notice did Waterfox identify and resolve this issue somehow ?

IMHO Firefox Portable ESR would be better as a temporary workaround.

Is anyone able to confirm that works please ?

Thinking aloud / Forum note
Helpdesk or a volunteer with Windows 8 will be hoping for information from users with this problem, We need to urgently

  • Identify who is affected & why
  • Figure out the presumably related Firefox Touch problem
  • Find the causes and what changes are involved.
    Windows updates ?
    Registry changes ?
    Firefox REGRESSION and when ?
  • Get it fixed properly.

Someone is going to need help with making sure we have STR & a Testcase then Get a proper regression range with mozregression. Either change the existing bug or more likely file a new one.

Obviously HelpDesk work office hours and may take a few days before being able to look again at this issue.


  • Is a third party build of Firefox with slightly different aims and features.
  • It may well have limitations as it is based on 64 bit builds of Firefox
    and that in itself is not fully supported developed, unlike the Mac & Linux builds where 64 bit is tier 1 supported and built by Mozilla
  • It requires a totaly new install and profile.
  • It obviously has no support on this forum.
    Having said that we will of course assist if we can with migration issues

Firefox Portable

  • Is based on standard Mozilla Firefox.
  • Is very easy to install and use as an additional maybe temporary browser
  • May even be installed and used form a memory stick
  • In this instance I am suggesting the ESR version.
    • That is fully secure.
    • Based on a version fully supported by Mozilla and provided with necessary security updates
    • But ESR not intended for use by individuals outside enterprise situations.
      ESR is however far safer than using an outdated Firefox, and I see no reason not to use it for troubleshooting, investigations and temporary work arounds of breaking issues.

Make use of Aurora Channel (NOT as a fix here and now)

   As I frequently point out If we had more users testing on Firefox Aurora channel day-to-day these sorts of breaking issue would not occur
   Incidents that are costly in terms of development & support time on Chemspills and fixes. 
  Damage to reputation. 
Nearly every new version, each six weeks, requiring a Chemspill point release. Often because of potentially avoidable or know problems.

</rant> Should any of the more advanced Firefox users reading this wish in future to make use of the Aurora channel note it is quite possible to install that as an additional browser. You will then see potential problems 12 weeks in advance. That gives you a chance to downgrade to supported and working Beta then Release channels. Any problem you notice and report should be fixed or otherwise satisfactorily resolved and never even noticed by the majority that use the standard Firefox Releases.

more options

I got the same problem, But I can start FF from my taskbar,

Pin firefox to taskbar > right click on pinned icon > open new tab

Hoping this could be useful to others.

more options

Thanks Yogendra,

Did you try my earlier suggestion of

  • Using the Windows Run option and keying in firefox.exe
  • If possible could you please try that and say whether that does work ?

It seems rather strange that a pinned icon should work. No doubt some expert on Windows will be able to explain why and infer something about the cause of this. Possibly it indicates the Desktop icon properties have become corrupt.

It may help if you

  • Attach a screenshot of the error message you get when starting using a desktop icon that is not pinned to the taskbar.
  • Check the properties of the desktop icon by right clicking it, and report what you discover.

If this sort of problem affected a large proportion of Windows 8 users we would probably had more complaints. We are not seeing that

What is the cause of this ? Some other software or malware maybe, but possibly only after also upgrading Firefox versions.

more options

Note in one thread this error was reportedly generated after conduit malware was removed

/questions/985851#answer-532791 /questions/985851#answer-532791
I figured out how to get Mozilla launched without the error "class is registered." (This all came about when I deleted the address bar with conduit in it.) I have windows 8.1. 

Okulungisiwe ngu John99

more options

Update---I have tried opening it from windows run and it works from there now, before I downloaded Waterfox it wouldn't run from windows run. I did what Yogendra suggested and it will open that way but Waterfox must be closed otherwise it opens a new tab on Waterfox and Firefox doesn't open. I will try a few more suggestions that have been posted and keep you updated.

Okulungisiwe ngu diamond2x

more options

Not sure exactly what changes will have occurred when you installed Waterfox.

I run 64 bit versions of Firefox on Linux, but have only ever tried 32bit versions on Windows.

I have no problem running multiple 32 bit versions of Firefox on Windows including having more than one instance or more than one version open simultaneously.

Using -no-remote on instances other than the default version, and using multiple profiles are necessary. see

more options

Well, I some how solved this problem,

Some Information

  • My problem started when I Upgraded/Degraded to FF 27.0.1(Stable) from FF 28 (Beta)
  • I have windows 8.1

My work-around :

  • As I posted, opening new tab from taskbar

Then by further digging

  • Yes FF starts from run>firefox.exe
  • As it worked I opened FF from program file directory C:\Program Files (x86)\Mozilla Firefox and firefox.exe and success
  • So I pinned it directly to taskbar and tried to open but it gave same error class not found
  • Sent the Forefox.exe to Desktop, thus creating new shortcut. and yep it worked.
  • And pinned this shortcut to taskbar and it worked too.

Now my shortcut and pinned Icon both works correctly.

About comparing shortcuts

  • Both the shortcuts have same value in target and Start In box.

Error screen was same as diamond2x posted above.

Hoping this could be same for others too.

Okulungisiwe ngu Yogendra

more options

So summing it up some of your shortcuts were probably corrupt.

So anyone still having this problem.

Run firefox.exe should work.
There is probably no need to involve the task bar.

Quite possibly malware is involved in these problems.

  1. Look using Windows Control Pane & uninstall any unwanted programs.
  2. Now scan with multiple and up to-date-tools.
  3. Please postback to say how you got on ?

Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one.

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

more options

Scanned my PC and no infections found so I don't think virus is causing this. I reinstalled firefox and it worked for a day but now error is back. Biggest problem is firefox no longer starts when I click on links so I had to switch default browser to IE until this is fixed.

more options

Hi F3real,
Sorry you are having problems. I assume that you have already scrolled and looked at this current thread and any help articles linked from it.

To get a good answer it is probably best to start your own thread
(As the guidelines suggest).

….  do not re-use existing threads started by others, even if they are seemingly on the same subject.   ….
  1. Please use /questions/new
  2. Please try to follow the prompts and include troubleshooting info when you do that. (There is a green button to automate the process. Use that, or if you encounter problems doing so mention that in the new thread.)
  3. You may wish to post back here; afterwards; to confirm you started a new thread. Others may wish to follow it.
  1. 1
  2. 2