X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox 27.0 fails to open print dialog

Kuphostiwe

I have firefox set to automatically update. All of a sudden, perhaps after the most recent update, I cannot print anything. If I try to print, I just get an windows error sound and nothing more. I do not get the print dialog. I have tried to reset the printer configuration, and I have tried reinstalling Firefox all together. Neither sovled the problem. Please advice.

Thank you.

I have firefox set to automatically update. All of a sudden, perhaps after the most recent update, I cannot print anything. If I try to print, I just get an windows error sound and nothing more. I do not get the print dialog. I have tried to reset the printer configuration, and I have tried reinstalling Firefox all together. Neither sovled the problem. Please advice. Thank you.

Isisombululo esikhethiwe

new information in the bug reports seems to link this to avast.

Funda le mpendulo ngokuhambisana nalesi sihloko 2

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 12.0 r0
  • Foxit Reader Plug-In For Firefox and Netscape
  • VLC media player Web Plugin 2.0.2
  • Citrix Receiver Plugin (Win32)
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Isisebenziso

  • Firefox 27.0
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Windows NT 5.1; rv:27.0) Gecko/20100101 Firefox/27.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/27.0/WINNT/nl/

Izandiso

  • Adblock Plus 2.4.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Bookmark All 1.3.2 ({a76cd07b-f0d7-4ef9-9566-8faef6e290e4})
  • Facebook Disconnect 2.1.3 (facebook@disconnect.me)
  • Ghostery 5.1.0 (firefox@ghostery.com)
  • Google Disconnect 2.4.2 (google@disconnect.me)
  • LeechBlock 0.6.6 ({a95d8332-e4b4-6e7f-98ac-20b733364387})
  • Toolbar Buttons 1.0 ({03B08592-E5B4-45ff-A0BE-C1D975458688})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • avast! Online Security 9.0.2011.70 (wrc@avast.com) (Akusebenzi)
  • BetterPrivacy 1.68 ({d40f5e7b-d2cf-4856-b441-cc613eeffbe3}) (Akusebenzi)
  • CookieSafe 3.0.5 ({9D23D0AA-D8F5-11DA-B3FC-0928ABF316DD}) (Akusebenzi)
  • DVDVideoSoft YouTube MP3 and Video Download 4.2.1.9 ({ACAA314B-EEBA-48e4-AD47-84E31C44796C}) (Akusebenzi)
  • Microsoft .NET Framework Assistant 1.2.1 ({20a82645-c095-46ed-80e3-08825760534b}) (Akusebenzi)
  • Multirow Bookmarks Toolbar 5.0.1 ({FBF6D7FB-F305-4445-BB3D-FEF66579A033}) (Akusebenzi)
  • New Tab Homepage 0.4.3 ({66E978CD-981F-47DF-AC42-E3CF417C1467}) (Akusebenzi)
  • RequestPolicy 0.5.28 (requestpolicy@requestpolicy.com) (Akusebenzi)
  • Skype Click to Call 6.11.0.13348 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}) (Akusebenzi)
  • Smart Bookmarks Bar 1.4.3 (smartbookmarksbar@remy.juteau) (Akusebenzi)
  • Tab Mix Plus 0.4.1.2.02 ({dc572301-7619-498c-a57d-39143191b318}) (Akusebenzi)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: Radeon X1300/X1550 Series
  • adapterDescription2:
  • adapterDeviceID: 0x7183
  • adapterDeviceID2:
  • adapterDrivers: ati2dvag
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'10.6']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 2-10-2010
  • driverDate2:
  • driverVersion: 8.593.100.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'9.6']
  • numTotalWindows: 1
  • webglRendererMessage: [u'tryNewerDriver', u'9.6']
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Okuthandwayo Okulungisiwe

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 184320
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.autostart: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140127194636
  • browser.startup.homepage: https://startpage.com/ned/advanced-search.html?&cat=web&query=
  • browser.startup.homepage_override.buildID: 20140127194636
  • browser.startup.homepage_override.mstone: 27.0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 27.0
  • font.internaluseonly.changed: True
  • network.cookie.cookieBehavior: 1
  • network.cookie.lifetimePolicy: 2
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1392054158
  • places.history.enabled: False
  • places.history.expiration.transient_current_max_pages: 62956
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.nppdf: 0
  • privacy.cpd.offlineApps: True
  • privacy.cpd.siteSettings: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1389716516

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
KUMARESAN.C.S
  • Locale Leader
3 izisombululo 76 izimpendulo
Kuphostiwe
Check this out :-https://support.mozilla.org/en-US/kb/fix-printing-problems-firefox?esab=a&s=print&r=0&as=s

Umnikazi wombuzo

Kumaresan.c.s, thank you for your response. Unfortunately, none of those fixes work for my problem.

Kumaresan.c.s, thank you for your response. Unfortunately, none of those fixes work for my problem.
philipp
  • Top 25 Contributor
  • Moderator
5324 izisombululo 23508 izimpendulo
Kuphostiwe

hello, a general reset of firefox would be the next thing to try that comes to my mind (this will keep your bookmarks and passwords)...

hello, a general [[Reset Firefox – easily fix most problems|reset of firefox]] would be the next thing to try that comes to my mind (this will keep your bookmarks and passwords)...

Umnikazi wombuzo

thank you, phillipp. Tried it. No effect.

thank you, phillipp. Tried it. No effect.

Umnikazi wombuzo

It seems to be a more general problem. I have also encountered that a button on a website (to upload a file) gives me a windows error or notification sound, but no file selection dialog. Also the button to upload a file on this forum page does not work (though it doesn't trigger the windows sound). It all seems very strange to me. Hope someone knows the solution.

It seems to be a more general problem. I have also encountered that a button on a website (to upload a file) gives me a windows error or notification sound, but no file selection dialog. Also the button to upload a file on this forum page does not work (though it doesn't trigger the windows sound). It all seems very strange to me. Hope someone knows the solution.
guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

Hey if there are errors not only in printing I would run a virus scan. ___________________


Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one.

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

Hey if there are errors not only in printing I would run a virus scan. ___________________ Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of. You can try these free programs to scan for malware, which work with your existing antivirus software: * [http://www.microsoft.com/security/scanner/default.aspx Microsoft Safety Scanner] * [http://www.malwarebytes.org/products/malwarebytes_free/ MalwareBytes' Anti-Malware] * [http://support.kaspersky.com/faq/?qid=208283363 TDSSKiller - AntiRootkit Utility] * [http://www.surfright.nl/en/hitmanpro/ Hitman Pro] * [http://www.eset.com/us/online-scanner/ ESET Online Scanner] [http://windows.microsoft.com/MSE Microsoft Security Essentials] is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one. Further information can be found in the [[Troubleshoot Firefox issues caused by malware]] article. Did this fix your problems? Please report back to us!

Okulungisiwe ngu guigs

Umnikazi wombuzo

I've run several malware scanners: found some unharmfull items (possible tracking cookies). But nothing serious. And most importantly: the problem still exists. Firefox will not open any dialog window (to print, download and ask for a location, upload).

Any ideas anyone?

I've run several malware scanners: found some unharmfull items (possible tracking cookies). But nothing serious. And most importantly: the problem still exists. Firefox will not open any dialog window (to print, download and ask for a location, upload). Any ideas anyone?
guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

Hey, there are some add ons that block, if you try safe mode it will eliminate the add ons being the issue.

These are the menus you can change the preferences to always ask what to do:

Hey, there are some add ons that block, if you try safe mode it will eliminate the add ons being the issue. These are the menus you can change the preferences to always ask what to do: *When downloading [https://support.mozilla.org/en-US/kb/change-firefox-behavior-when-open-file] *[[Reset Firefox preferences to troubleshoot and fix problems]]

Umnikazi wombuzo

Thanks for the suggestion. Unfortunately, the add-ons are not the problem. Firefox will not open the print dialog box (or any other dialog box) in safe-mode either.

Thanks for the suggestion. Unfortunately, the add-ons are not the problem. Firefox will not open the print dialog box (or any other dialog box) in safe-mode either.
philipp
  • Top 25 Contributor
  • Moderator
5324 izisombululo 23508 izimpendulo
Kuphostiwe

there's also bug 974301 for this issue. which kind of printer do you have and can you try to replicate the problem when you restart the whole windows in safemode once (with networking enabled): http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/boot_failsafe.mspx

there's also [https://bugzilla.mozilla.org/show_bug.cgi?id=974301 bug 974301] for this issue. which kind of printer do you have and can you try to replicate the problem when you restart the whole windows in safemode once (with networking enabled): http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/boot_failsafe.mspx

Umnikazi wombuzo

Hello Philipp, well in a sense it's a relief to know that I am not the only one experiencing this problem, and that the firefox team is working on a solution.

I restarted in safe mode with netwoking enabled. Trying to print gave a message saying that a printer should first be installed. I also tried uploading a file, this worked fine: the file selection dialogbox came up and I uploaded the file without a problem.

So, should I just wait for version 27.0.2? Thanks.

Hello Philipp, well in a sense it's a relief to know that I am not the only one experiencing this problem, and that the firefox team is working on a solution. I restarted in safe mode with netwoking enabled. Trying to print gave a message saying that a printer should first be installed. I also tried uploading a file, this worked fine: the file selection dialogbox came up and I uploaded the file without a problem. So, should I just wait for version 27.0.2? Thanks.
philipp
  • Top 25 Contributor
  • Moderator
5324 izisombululo 23508 izimpendulo
Kuphostiwe

hello, just so that you don't get any false impressions - this bug hasn't gained any traction and there aren't any devs working on it yet (so it's highly unlikely that this will be resolved by a 27.0.2 version). i have seen a handful of reports by windows xp users about this issue - considering that there should still be a few million xp users with firefox around, this only seems to affect a tiny fraction of you. and when it is working in windows safe mode this also suggests that some external software or a certain configuration in your system environment plays a role in that. in the german community forums i've even read that this exact problem was caused by malware for some-one.

so currently i think the best way to proceed is to gather more information about the problem, so that we can eventually pin-point it onto something specific - in case it is really something that is wrong with firefox, this will also help developers fixing the problem...

so i would be interested what kind of .dll-files are hooked into firefox when you run it normally (not in windows safemode). the simplest way to find that out is to analyse a crash report. please type about:crashes into the address-bar and in case you see a recently submitted crash report starting with bp- please copy that here into a forum reply. if you don't have any recent reports please install the "crashme" addon from https://code.google.com/p/crashme/ and manually trigger a crash from its settings under firefox > addons > extensions (afterwards you'd have to go to about:crashes again to find it - if it isn't starting with bp- click on the report once, then it will get submitted).

a log generated by hijackthis might be helpful too: http://sourceforge.net/projects/hjt/

hello, just so that you don't get any false impressions - this bug hasn't gained any traction and there aren't any devs working on it yet (so it's highly unlikely that this will be resolved by a 27.0.2 version). i have seen a handful of reports by windows xp users about this issue - considering that there should still be a few million xp users with firefox around, this only seems to affect a tiny fraction of you. and when it is working in windows safe mode this also suggests that some external software or a certain configuration in your system environment plays a role in that. in the german community forums i've even read that this exact problem was caused by malware for some-one. so currently i think the best way to proceed is to gather more information about the problem, so that we can eventually pin-point it onto something specific - in case it is really something that is wrong with firefox, this will also help developers fixing the problem... so i would be interested what kind of .dll-files are hooked into firefox when you run it normally (not in windows safemode). the simplest way to find that out is to analyse a crash report. please type '''about:crashes''' into the address-bar and in case you see a recently submitted crash report starting with '''bp-''' please copy that here into a forum reply. if you don't have any recent reports please install the "crashme" addon from https://code.google.com/p/crashme/ and manually trigger a crash from its settings under firefox > addons > extensions (afterwards you'd have to go to about:crashes again to find it - if it isn't starting with bp- click on the report once, then it will get submitted). a log generated by hijackthis might be helpful too: http://sourceforge.net/projects/hjt/
philipp
  • Top 25 Contributor
  • Moderator
5324 izisombululo 23508 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

new information in the bug reports seems to link this to avast.

new information in the bug reports seems to link this to avast.

Umnikazi wombuzo

Hello Phillip,

Thanks for the extensive information. I am about to upgrade to Windows 7 but I thought I would get this problem out of the way first.

Thanks also for the tip that it might be related to avast. I was using avast. I have now uninstalled avast and installed avira instead. With that the problem seems to have disappeared! So, thank you again.

Hello Phillip, Thanks for the extensive information. I am about to upgrade to Windows 7 but I thought I would get this problem out of the way first. Thanks also for the tip that it might be related to avast. I was using avast. I have now uninstalled avast and installed avira instead. With that the problem seems to have disappeared! So, thank you again.
sweepea 0 izisombululo 3 izimpendulo
Kuphostiwe

I have the same problem which started yesterday. I do have the newer version of firexfox 27.0.1. I am using Canon i860 and HP 8600 Premium printers. Neither is printer from this firefox only. I can print in IE8. I have been looking to find out when It went to this version; can anyone help me with this? I have check Add/Remove and it only shows version 21.0. I do have the new avast that was upgraded to 2014.9.0.2013 which it did last month. I had no problems printing at all. So i do not believe that it is avast that is causing the problem. Can someone help me out? Thanks

I have the same problem which started yesterday. I do have the newer version of firexfox 27.0.1. I am using Canon i860 and HP 8600 Premium printers. Neither is printer from this firefox only. I can print in IE8. I have been looking to find out when It went to this version; can anyone help me with this? I have check Add/Remove and it only shows version 21.0. I do have the new avast that was upgraded to 2014.9.0.2013 which it did last month. I had no problems printing at all. So i do not believe that it is avast that is causing the problem. Can someone help me out? Thanks
philipp
  • Top 25 Contributor
  • Moderator
5324 izisombululo 23508 izimpendulo
Kuphostiwe

sweepea, please try to uninstall avast for testing purposes.

sweepea, please try to uninstall avast for testing purposes.
reybie 0 izisombululo 1 izimpendulo
Kuphostiwe

Impendulo Ewusizo

I was scratching my head for a day trying to figure out why suddenly I cannot print or initiate any dialog in Firefox. Avast was the culprit. I uninstalled it and now everything is working again. Installed Bitdefender for now :)

I was scratching my head for a day trying to figure out why suddenly I cannot print or initiate any dialog in Firefox. Avast was the culprit. I uninstalled it and now everything is working again. Installed Bitdefender for now :)