Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I stop firefox from recreating unwanted Desktop directory?

  • 9 uphendule
  • 13 zinale nkinga
  • 428 views
  • Igcine ukuphendulwa ngu Ninguém

more options

I already have:

XDG_DESKTOP_DIR="$HOME"

on my ~/.config/user-dirs.dirs file. That's not it!

(Using firefox - iceweasel - 27 and debian wheezy with minimal gnome - some packages might be missing)

I already have: XDG_DESKTOP_DIR="$HOME" on my ~/.config/user-dirs.dirs file. That's not it! (Using firefox - iceweasel - 27 and debian wheezy with minimal gnome - some packages might be missing)

Okulungisiwe ngu Ninguém

Isisombululo esikhethiwe

Answering, a bit, my own question...

If I change the line I mentioned earlier from XDG_DESKTOP_DIR="$HOME" to XDG_DESKTOP_DIR="/home/username" solved the problem.

I still think this is a bug, since it was supposed to be the same. Maybe something is preventing firefox form interpreting "$HOME" as it should.

Thanks for all the help and effort.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (9)

more options

Hi can you elaborate on the DIR file? Where did you originally install Firefox? With this information I can better understand your setup. I look forward to your reply!!

more options

Dir file?... I'm not sure what you mean?...

I use debian GNU/Linux with gnome (default) desktop environment which is compliant with freedesktop.org directives. Gnome considers the desktop to be whatever is in that ~/.config/user-dirs.dirs file. I have configured it to consider the desktop to be my home directory, not any "Desktop" directory under my home directory as is comes preconfigured with.

I want my home directory with only a few well defined directoryes in it. No "Desktop", "Donwnloads" or "Video" or anything like that. If you come from a windows background, you can consider the home derectory to be the user's "documents and settings" folder (if I remember correctly) on windows machines.

I have installed firefox using the debian package manager, so it scatters the files all over the place in linux computers, the main being in /etc/iceweasel (configuration files) and /usr/lib/iceweasel/ and /usr/share/iceweasel/ for program files with a few other scattered around the system.

Hope this helps since I'm really needing some help here!

Ah! iceweasel is the name firefox gets in debian. It's just firefox with minimal changes because of licensing issues, like icons and the like.

more options

It suggests the file paths are stores in a desktop file, could you move these files and rename the file path http://techpatterns.com/forums/about1435.html It may also be useful to check out the forum link to the debian community in that article.

more options

Sorry, I could not understand completely what you meant. I'm not a native english speaker, so...

You mentioned a desktop file. I did not find anything wrong inside /usr/share/applications/iceweasel.desktop. Is that what you where refering to? (I don't think that file could make any program recreate the Desktop directory, anyway.)

By the way: I read all related to what you mentioned and couldn't find anything related to my problem except maybe the notion that debian breaks upstream firefox, so I did some extra experiments... downloaded firefox from mozilla, extracted to my home directory and called it manually (no desktop file envolved). Same result: a Desktop directory is created in my home derectory.

more options

Not a problem, I did some more research to narrow down a work around:

in the past the favi con is not displayed if this is false:

  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise!, to continue to the about:config page.
  3. browser.shell.shortcutFavicons

Better yet though there is a work around in the wikki. Apparently in the configuration file there is a preference that controls the desktop shortcut. However this would require changing the code and would only be a temporary work around for this version. SEE /INI switch requires full path

more options

I tryed changing the browser.shell.shortcutFavicons option to false and that did not work. As for the other option involving the /INI switch, I could not see a relation... It seems to me that it is meant for when you want to install firefox and wanto to control weather a shortcut is placed on your desktop... Sorry, I must not be seeing the obvious, but!...

more options

The browser.shell.shortcutFavicons pref is about creating a desktop shortcut to a web page by dragging a link on the desktop, so that wouldn't apply to you.


There is a reference XDG_DESKTOP_DIR -> sXDGDesktop in the Firefox source code.

more options

Hum... sadly I wouldn't know what to do with these!...

In the meantime, someone mentioned to me a bug from 2008 that almost matches my situation:

https://bugzilla.mozilla.org/show_bug.cgi?id=434327

more options

Isisombululo Esikhethiwe

Answering, a bit, my own question...

If I change the line I mentioned earlier from XDG_DESKTOP_DIR="$HOME" to XDG_DESKTOP_DIR="/home/username" solved the problem.

I still think this is a bug, since it was supposed to be the same. Maybe something is preventing firefox form interpreting "$HOME" as it should.

Thanks for all the help and effort.