Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox stopped displaying images

  • 22 uphendule
  • 16 zinale nkinga
  • 19455 views
  • Igcine ukuphendulwa ngu cor-el

more options

This is very frustrating. I've spent considerable time away from Firefox but decided to give it another try. In two weeks, this is the second problem I have. If there ever is a third problem, I'll go back to Chrome, Safari, and IE.

It all started last night, when I decided to clear the cache and history. Since then, Firefox has not been displaying any images on all the web sites I've tried.

Isisombululo esikhethiwe

Firefox on my Mac was still not displaying the images.

I use CoolPreviews a lot. I hovered over one link and the images started to display. It's working fine now. I believe that's the same thing I did with my Windows 7 PC earlier today.

Attention engineers: go figure!

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (20)

more options

This is how some sites look on Firefox.

more options

The sames sites on Chrome.

more options

Security settings for LinkedIn (for example).

more options

This is how I see this page on Chrome and on Firefox.

more options

By the way, I have tried all the suggestions given elsewhere. I even tried walking away from my desk backwards and skipping 3 times before turning on my PC again, all to no avail.

more options

Now onto something interesting: Google Search does display a handful of images.

more options

Hello,

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information.
Note: This will cause you to lose any Extensions and some Preferences.

  • Open websites will not be saved in Firefox versions lower than 25.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

Thank you.

more options

There is no such button.

more options

Now this is really creepy: about 15 minutes after posting my last reply I reloaded this page to see if there are any new responses, and suddenly the images began to appear!

What was I doing during these 15 minutes? On the PC: nothing. I was just talking on the phone.

I'm going to close Firefox and reopen it. Let's see what it does...

more options

Which version of the Firefox you are using .? May be the problem of the old version of the Firefox.

more options

Well... it came back displaying all images.

I was experiencing the very same problem on my Mac. I'll check it out tonight and report back on it.

more options

It's the latest one.

more options

Okay fine, that means now your Firefox working fine ? yeah.

Report us back if you need any help


Thank you using Firefox.

more options

It may be working fine, but I'm not satisfied with the solution.

As I said, I'll check my Mac later on today.

By the way, where is the reset button on the troubleshooting page? It did not display at all.

more options

Go with this one Refresh Firefox - reset add-ons and settings and you will see the, this one, have a look in the right up corner. (Reset Nightly)

Okulungisiwe ngu Meghraj Suthar

more options

Why can't I see the reset button?

more options

You can remove all the cookies and cache from your Firefox.

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

Thank you.

more options

That's exactly when the problems began: when I cleared all the history and cache, just like you outlined above.

Why can't I see the reset button?

This is becoming very frustrating... :-(

more options

Yeah really, problem is that i have not assist any Mac user so, Mention Our senior contributor will surely help you.

Sorry..! :(
more options

@Meghraj not your fault.

Right now I'm using a Windows 7 PC. Why can't I see the reset button on the troubleshooting page?

  1. 1
  2. 2