Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How to avoid a java applet redirecting to java.com instead of opening applet in FireFox

  • 4 uphendule
  • 2 zinale nkinga
  • 110 views
  • Igcine ukuphendulwa ngu aas82

more options

I have a weird problem with a java applet that has minimumVersion set to 1.6. It works absolutely fine in other browsers, but when I try to use the applet in FireFox it redirects me to java.com like I don't have java installed. However the problem is only with this specific applet as other java content still works in FireFox. I have the latest java and problem is in both FF 25.0.1 and FF 26.

Does anyone have any tips as to what can be causing this problem? It's obviously a combination of something in the applet and something with FireFox as it works fine in IE and other browsers.

BTW the applet also have the following params in console when running it in IE: security: SSV validation:

   running: 1.7.0_51
   requested: null
   range: null
   javaVersionParam: null
   Rule Set version: null

And this linie that may/may not mean anything:

Missing Application-Library-Allowable-Codebase manifest attribute for: https://<site>/resources/sei/applets/sei-applet-20140127.jar

Okulungisiwe ngu aas82

All Replies (4)

more options

Have you tried running it from a different pc? Please make sure that pc has latest Firefox and Java installed.

more options

Yes, we have the problem on some of our own machines and also on some costumer machines. Only similarity between machines is that they have Windows. It seems to work from Linux. And yes have tried different versions including the newest ones.

more options

Please answer these questions:

  • Is this problem happening on 64 bit systems only?
  • Did you install Java after installing Firefox?

Okulungisiwe ngu Manojit Ghosh

more options

Our systems it's happening on is 64bit. I don't know about the customer. Will try to test it from a 32bit machine. However we do have 32bit java installed and the IE we test in is 32bit as well.

Regarding install order, then yes java was installed after firefox. But remember that all other java content works fine including the java verify on java.com. Also java shows correctly on the plugin page.

Thx for responding btw.