X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How can I make it so that Firefox (26.0 Mac) never goes into fullscreen mode no matter what?

Kuphostiwe

From time to time, and unpredictably, Firefox opens in fullscreen mode. Even when it was not in fullscreen when I last quit Firefox. I want it to NEVER go into fullscreen mode. How can I achieve this?

From time to time, and unpredictably, Firefox opens in fullscreen mode. Even when it was not in fullscreen when I last quit Firefox. I want it to NEVER go into fullscreen mode. How can I achieve this?

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Provides information about the default web browser
  • Adobe® Acrobat® Plug-in for Web Browsers, Version 11.0.06
  • Shockwave Flash 11.9 r900
  • Facebook Video Calling by Skype
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Displays Java applet content, or a placeholder if Java is not installed.
  • iPhoto6
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • RealPlayer Plugin

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:26.0) Gecko/20100101 Firefox/26.0

Eminye Imininingwane

guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Hi macmozz, You can disable fullscreen from the about:config page, but to change it back you will have to follow the same instructions below:

  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise!, to continue to the about:config page.
  3. Please search for "fullscreen"
  4. Setting autohide to false

If firefox is not behaving it may be a corrupt localstore file. More information on this can be read on herehttp://kb.mozillazine.org/Corrupt_localstore.rdf

Hi macmozz, You can disable fullscreen from the about:config page, but to change it back you will have to follow the same instructions below: # In the [[Location bar autocomplete|Location bar]], type '''about:config''' and press '''Enter'''. The about:config "''This might void your warranty!''" warning page may appear. # Click '''I'll be careful, I promise!''', to continue to the about:config page. # Please search for "fullscreen" # Setting autohide to false If firefox is not behaving it may be a corrupt localstore file. More information on this can be read on here[http://kb.mozillazine.org/Corrupt_localstore.rdf]

Okulungisiwe ngu guigs

cor-el
  • Top 10 Contributor
  • Moderator
17580 izisombululo 159054 izimpendulo
Kuphostiwe

Impendulo Ewusizo

The browser.fullscreen.autohide pref merely control whether the toolbar are hidden (i.e. the check box in the right-click context menu: Hide toolbars) and has nothing to do with preventing full screen mode.

On Mac you toggle full screen mode with Command+Shift+F.

I'm don't know a reason why Firefox would switch to font size randomly or unintentionally either then via the hotkey or the View menu.

This can be caused by a problem with localstore.rdf as that file stores the full screen setting.

You can also check for issues with the Firefox plist file and remove this plist file (org.mozilla.firefox.plist).

Go to "~/Library/Preferences" and remove the plist file for Firefox (org.mozilla.firefox.plist)

The browser.fullscreen.autohide pref merely control whether the toolbar are hidden (i.e. the check box in the right-click context menu: Hide toolbars) and has nothing to do with preventing full screen mode. On Mac you toggle full screen mode with Command+Shift+F. *https://support.mozilla.org/kb/how-to-use-full-screen I'm don't know a reason why Firefox would switch to font size randomly or unintentionally either then via the hotkey or the View menu. This can be caused by a problem with localstore.rdf as that file stores the full screen setting. You can also check for issues with the Firefox plist file and remove this plist file (org.mozilla.firefox.plist). *http://www.macfixit.com/article.php?story=20060606082246983 How .plist files become corrupt and troubleshooting the results Go to "~/Library/Preferences" and remove the plist file for Firefox (org.mozilla.firefox.plist)
guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

^thank you cor-el I learned something.

^thank you cor-el I learned something.

Umnikazi wombuzo

Thanks for the answers. They made me realize I used inaccurate terminology.

It's not fullscreen mode that's the problem. It's that Firefox sometimes opens zoomed to its maximum size. Like using the "Zoom" command in the Window menu (on a Mac), except I hadn't used that command, and it wasn't previously zoomed to max.

Thanks for the answers. They made me realize I used inaccurate terminology. It's not fullscreen mode that's the problem. It's that Firefox sometimes opens zoomed to its maximum size. Like using the "Zoom" command in the Window menu (on a Mac), except I hadn't used that command, and it wasn't previously zoomed to max.
cor-el
  • Top 10 Contributor
  • Moderator
17580 izisombululo 159054 izimpendulo
Kuphostiwe

Reset the page zoom on pages that cause problems.

  • View > Zoom > Reset (Ctrl+0 (zero); Command+0 on Mac)
Reset the page zoom on pages that cause problems. *<b>View > Zoom > Reset</b> (Ctrl+0 (zero); Command+0 on Mac) *http://kb.mozillazine.org/Zoom_text_of_web_pages

Umnikazi wombuzo

Window zoom, not content zoom (i.e., on Window menu, not on View menu) Thanks

And fixing it when it happens is not the problem. The goal is to prevent it from happening unexpectedly and unpredictably.

Window zoom, not content zoom (i.e., on Window menu, not on View menu) Thanks And fixing it when it happens is not the problem. The goal is to prevent it from happening unexpectedly and unpredictably.
cor-el
  • Top 10 Contributor
  • Moderator
17580 izisombululo 159054 izimpendulo
Kuphostiwe

Try to remove the Firefox plist file (org.mozilla.firefox.plist).

Go to "~/Library/Preferences" and remove the plist file for Firefox (org.mozilla.firefox.plist)

Try to remove the Firefox plist file (org.mozilla.firefox.plist). *http://www.macfixit.com/article.php?story=20060606082246983 How .plist files become corrupt and troubleshooting the results Go to "~/Library/Preferences" and remove the plist file for Firefox (org.mozilla.firefox.plist)