X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

All my automatic Bookmark Backups have no data in them and the word undefined at the end

Kuphostiwe

All my automatic bookmark backups are listed with 0 bytes, contain no data and have the work "undefined" at the end. How do I ensure that my backups go back to saving as normal?

All my automatic bookmark backups are listed with 0 bytes, contain no data and have the work "undefined" at the end. How do I ensure that my backups go back to saving as normal?

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 11.9 r900

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0

Eminye Imininingwane

oboist1 0 izisombululo 20 izimpendulo
Kuphostiwe

I have not looked at the inner workings as thoroughly as Marco. However, the last time I was able to backup w/o experiencing 0 json was 12/28/13. i think there is a corruption issue in the bookmarks file that occurred around that date.

Is there a program to scan the bookmarks file for corruption markers and make corrections ?

Steve

I have not looked at the inner workings as thoroughly as Marco. However, the last time I was able to backup w/o experiencing 0 json was 12/28/13. i think there is a corruption issue in the bookmarks file that occurred around that date. Is there a program to scan the bookmarks file for corruption markers and make corrections ? Steve
jscher2000
  • Top 10 Contributor
8765 izisombululo 71703 izimpendulo
Kuphostiwe

Hi Steve, I think the problem at this point is understanding why Firefox 23 could work with these same files but Firefox 24+ or 25+ chokes on them. Until we know what characters or missing fields or other issue is causing the problem, we wouldn't know what to scan for.

Hi Steve, I think the problem at this point is understanding why Firefox 23 could work with these same files but Firefox 24+ or 25+ chokes on them. Until we know what characters or missing fields or other issue is causing the problem, we wouldn't know what to scan for.
oboist1 0 izisombululo 20 izimpendulo
Kuphostiwe

Hi j,

Got it, thanks. I still save my sessions and back up my places.sqlite periodically.

Steve

Hi j, Got it, thanks. I still save my sessions and back up my places.sqlite periodically. Steve

Umnikazi wombuzo

In my case there is also the lack of parity between automated bookmark backups saving with no data and the "undefined" file ID, but exporting html and json backups of bookmarks works just fine.

In my case there is also the lack of parity between automated bookmark backups saving with no data and the "undefined" file ID, but exporting html and json backups of bookmarks works just fine.

Umnikazi wombuzo

I tried Safe Mode with add-ons disabled and every time I did this it saved an automatic backup with a numeric, not dated, ending (eg "bookmarks-2014-01-12_361") but with data in it as usual instead of it being an empty file. When switched back with Addons enabled it continues to save empty files with "undefined" at the end.

This still doesn't seem to present full functionality as it should obviously be dated at the end and not just a 3 figure number, also I can't see how an Add-On could suddenly cause such significant issues with a core backup process as I don't have anything other than a few security Add-Ons and some for aesthetic adjustments to the interface?

I tried Safe Mode with add-ons disabled and every time I did this it saved an automatic backup with a numeric, not dated, ending (eg "bookmarks-2014-01-12_361") but with data in it as usual instead of it being an empty file. When switched back with Addons enabled it continues to save empty files with "undefined" at the end. This still doesn't seem to present full functionality as it should obviously be dated at the end and not just a 3 figure number, also I can't see how an Add-On could suddenly cause such significant issues with a core backup process as I don't have anything other than a few security Add-Ons and some for aesthetic adjustments to the interface?
jscher2000
  • Top 10 Contributor
8765 izisombululo 71703 izimpendulo
Kuphostiwe

Hi Marco, Safe Mode disables some other advanced features, including hardware acceleration of graphics and the JavaScript compilers. Could the JIT compilers be relevant?? You could try manually disabling them. I'm not 100% sure of the preferences for that, but I think they are the following:

  • javascript.options.baselinejit.chrome (default in Fx26: true)
  • javascript.options.baselinejit.content (default in Fx26: true)
  • javascript.options.ion.chrome (default in Fx26: false)
  • javascript.options.ion.content (default in Fx26: true)

These might be worth toggling if you keep the compilers enabled:

  • javascript.options.ion.parallel_compilation (default in Fx26: true)
  • javascript.options.parallel_parsing (default in Fx26: true)
Hi Marco, Safe Mode disables some other advanced features, including hardware acceleration of graphics and the JavaScript compilers. Could the JIT compilers be relevant?? You could try manually disabling them. I'm not 100% sure of the preferences for that, but I think they are the following: * javascript.options.baselinejit.chrome (default in Fx26: true) * javascript.options.baselinejit.content (default in Fx26: true) * javascript.options.ion.chrome (default in Fx26: false) * javascript.options.ion.content (default in Fx26: true) These might be worth toggling if you keep the compilers enabled: * javascript.options.ion.parallel_compilation (default in Fx26: true) * javascript.options.parallel_parsing (default in Fx26: true)

Umnikazi wombuzo

Thanks for those suggestions jscher2000, I gave it a try but I'm afraid that it did not affect the bookmark backups.

Thanks for those suggestions jscher2000, I gave it a try but I'm afraid that it did not affect the bookmark backups.
cor-el
  • Top 10 Contributor
  • Moderator
17531 izisombululo 158524 izimpendulo
Kuphostiwe

A possible cause can be that Firefox isn't closing properly for some reason and isn't able to write a correct sessionstore.js file.

Did you try a new profile?

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem.


In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected
A possible cause can be that Firefox isn't closing properly for some reason and isn't able to write a correct sessionstore.js file. Did you try a new profile? See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles If the new profile works then you can transfer some files from an existing profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox ---- In Firefox Safe mode these changes are effective: *all extensions are disabled (about:addons) *default theme is used (no persona) *userChrome.css and userContent.css are ignored (chrome folder) *default toolbar layout is used (file: localstore-safe.rdf) *Javascript JIT compilers are disabled (prefs: javascript.options.*jit) *hardware acceleration is disabled (Options > Advanced > General) *plugins are not affected *preferences are not affected