Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

PBS says "plug-in file not found". That's all. Can't stream Downton Abby. Could last season.

  • 8 uphendule
  • 20 zinale nkinga
  • Igcine ukuphendulwa ngu maceo_brown

more options

I don't know any more than that.

Isisombululo esikhethiwe

Workarounds are great but thanks so much for identifying and posting the actual problem.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 3

All Replies (8)

more options

Is it the player on this page:

When I right-click that it mentions using the Shockwave Flash plugin, which you do appear to have.

Could you check for a notification icon in the address bar that looks a bit like a piece of Lego, click it, and see whether it says Flash is blocked?

Are there any other notifications?

more options

Downloading and installing Adobe Flash Player 11.9.900.170 does not solve the problem.

Right-clicking on the screen area of the video that won't play ans shows the missing plug-in file also mentions the JW Player (formerly Longtail) 6.6.3932 but I don't want to download that because it is only a free trial.

more options

It works in Google Chrome.

more options

Hi Dan, you wouldn't need to install the JW Player or Longtail player. The site buys that and pushes it down to your browser.

Could you try this site instead:

(On the video site home page, I can't get the links to work with a single left click, but I can open them in a new tab or window using right-click.)

If Firefox still reports that Flash is missing, could you check the Flash permissions for the page? Call up the Page Info dialog using one of the following:

  • right-click and choose View Page Info > Permissions
  • Alt+t (open the classic Tools menu) > Page Info > Permissions

Look for the "Adobe Flash" line and make sure it is set to Allow. If you change it, reload the page and see whether that works.

Okulungisiwe ngu jscher2000

more options

Nothing you suggest works.

more options

Try playing the video in Firefox's Safe Mode, to bypass interference by extensions (and some custom settings). More info: Diagnose Firefox issues using Troubleshoot Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled (Plugins still work)

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

If you still get the message, please attach a screen shot to your reply showing the missing plugin error. This article has tips on that: How do I create a screenshot of my problem?

more options

You solved my problem. But FYI, I learned what the problem really was. I had installed the add-on HTTPS Everywhere. All I had to do was toggle it off.

more options

Isisombululo Esikhethiwe

Workarounds are great but thanks so much for identifying and posting the actual problem.