X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I cannot get the Menu Bar (File, Edit, Help, etc.) to show.

Kuphostiwe

Firefox Menu Bar

I am new to Linux but have been using Firefox for Windows for almost ten years. I now want to use Firefox Desktop, Version 26 (I think) in Linux (Ubuntu).

I cannot get the Menu Bar (File, Edit, Help, etc.) to show. In Firefox support, in the section “Customize Firefox controls, buttons and toolbars”, it states: “Most toolbars can be shown or hidden depending on your needs. To show or hide a toolbar, right-click on an empty section of the Tab Strip and check or uncheck it in the pop-up menu. Menu Bar: This toolbar at the top of the Firefox window contains the browser menus (File, Edit, Help, etc.). Hiding the Menu Bar will make the Firefox button appear which contains a simplified menu.”

When I right-click on an empty section of the Tab Strip, all I get is options for the Navigation Toolbar, the Bookmarks Toolbar, and the Add-on Bar; no Menu Bar option. Also, since my Menu Bar is “hidden,” I can't find the Firefox button which contains a simplified menu. What does the Firefox button look like?

When I go to support.mozilla.org/en-US/products/firefox and try to download Firefox 26 I'm told that "Congrats! You’re using the latest version of Firefox."

Since I presume my Linux distribution's packaged version of Firefox can be updated only when an updated package is released, I checked for distro updates and there were none at all. Do I have to wait for a Linux update?

I certainly will appreciate any help.

Firefox Menu Bar I am new to Linux but have been using Firefox for Windows for almost ten years. I now want to use Firefox Desktop, Version 26 (I think) in Linux (Ubuntu). I cannot get the Menu Bar (File, Edit, Help, etc.) to show. In Firefox support, in the section “Customize Firefox controls, buttons and toolbars”, it states: “Most toolbars can be shown or hidden depending on your needs. To show or hide a toolbar, right-click on an empty section of the Tab Strip and check or uncheck it in the pop-up menu. Menu Bar: This toolbar at the top of the Firefox window contains the browser menus (File, Edit, Help, etc.). Hiding the Menu Bar will make the Firefox button appear which contains a simplified menu.” When I right-click on an empty section of the Tab Strip, all I get is options for the Navigation Toolbar, the Bookmarks Toolbar, and the Add-on Bar; no Menu Bar option. Also, since my Menu Bar is “hidden,” I can't find the Firefox button which contains a simplified menu. What does the Firefox button look like? When I go to support.mozilla.org/en-US/products/firefox and try to download Firefox 26 I'm told that "Congrats! You’re using the latest version of Firefox." Since I presume my Linux distribution's packaged version of Firefox can be updated only when an updated package is released, I checked for distro updates and there were none at all. Do I have to wait for a Linux update? I certainly will appreciate any help.

Okulungisiwe ngu NewToLinux

Isisombululo esikhethiwe

I certainly appreciate all the help I received. I've summarized that help below, in case it can help someone else. I drafted this reply in Gedit, which I'd never used before, and the Alt and "move the mouse to the top" options worked there also.

For me, I will mark this problem as "Solved."

Here is the help I received from -

the-edmeister: "I don't use the Linux distro version, but try hitting the Alt key or F10 and see what happens." (For me Alt worked)

fredmcd-hotmail: "Left click the Firefox symbol, select Options, then STOP. Look at the options menu. You should see the toolbars listed near the bottom. Make sure the bars you want are checked." (I never could find the Firefox symbol!)

fredmcd-hotmail: "Go back to support.mozilla.org/en-US/products/firefox and press download. If the window says you have the latest, look at the bottom of the window where it says Download Anyway." (I had tried that but don't know how to extract and install. I'll ask about that later on.)

cor-el: "Ubuntu 11.xx and later displays window menus in the control bar at the top of the screen with the switch to the Unity window manager ... Try to move the mouse to the top to see if that makes the menu bar appear ... Make sure that you do not run Firefox in full screen mode (press F11 or Fn + F11 to toggle; Mac: Command+Shift+F)." (For me F11 worked; I was not in full screen mode but the F11 toggle was good to know.)

Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.
  • The Totem 3.0.1 plugin handles video and audio streams.
  • DivX Web Player version 1.4.0.233

Isisebenziso

  • Firefox 26.0
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/26.0/Linux/en-US/

Izandiso

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Ubuntu Firefox Modifications 2.7 (ubufox@ubuntu.com)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: X.Org -- Gallium 0.4 on AMD RV635
  • adapterDeviceID: Gallium 0.4 on AMD RV635
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: X.Org
  • driverDate:
  • driverVersion: 3.0 Mesa 9.1.7
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: X.Org -- Gallium 0.4 on AMD RV635
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Okuthandwayo Okulungisiwe

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131206152142
  • browser.startup.homepage_override.buildID: 20131206152142
  • browser.startup.homepage_override.mstone: 26.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 26.0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1388172395
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugins.notifyMissingFlash: False
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1388085677

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
the-edmeister
  • Top 25 Contributor
  • Moderator
5398 izisombululo 40147 izimpendulo
Kuphostiwe

I don't use the Linux distro version, but try hitting the Alt key or F10 and see what happens.

I don't use the Linux distro version, but try hitting the '''Alt''' key or '''F10''' and see what happens.

Umnikazi wombuzo

the-edmeister,

Alt worked but not F10. I also discovered that if I took the cursor to the extreme top of the screen, the Menu Bar appeared. I still prefer it to always be visible, but using Alt works just fine.

Although you have essentially solved my dilemma, I'd like to hold off a few days before marking my question solved, in case someone else can address the other items I mention in my original post.

the-edmeister, '''Alt''' worked but not '''F10'''. I also discovered that if I took the cursor to the extreme top of the screen, the Menu Bar appeared. I still prefer it to always be visible, but using '''Alt''' works just fine. Although you have essentially solved my dilemma, I'd like to hold off a few days before marking my question solved, in case someone else can address the other items I mention in my original post.
FredMcD
  • Top 10 Contributor
4246 izisombululo 59390 izimpendulo
Kuphostiwe

Left click the Firefox symbol, select Options, then STOP. Look at the options menu. You should see the toolbars listed near the bottom. Make sure the bars you want are checked.

Left click the '''''Firefox''''' symbol, select '''''Options''''', then '''STOP'''. Look at the options menu. You should see the toolbars listed near the bottom. Make sure the bars you want are checked.
FredMcD
  • Top 10 Contributor
4246 izisombululo 59390 izimpendulo
Kuphostiwe

Left click the Firefox symbol, select Options, then STOP. Look at the options menu. You should see the toolbars listed near the bottom. Make sure the bars you want are checked.

Left click the '''''Firefox''''' symbol, select '''''Options''''', then '''STOP'''. Look at the options menu. You should see the toolbars listed near the bottom. Make sure the bars you want are checked.

Impendulo Ewusizo

fredmcd-hotmail,

The only "Firefox symbol" I see is the one with the blue fox 'spanning" a red globe. Neither left or right click brings up options.

As I wrote initially: "When I right-click on an empty section of the Tab Strip, all I get is options for the Navigation Toolbar, the Bookmarks Toolbar, and the Add-on Bar; no Menu Bar option."

fredmcd-hotmail, The only "Firefox symbol" I see is the one with the blue fox 'spanning" a red globe. Neither left or right click brings up options. As I wrote initially: "When I right-click on an empty section of the Tab Strip, all I get is options for the Navigation Toolbar, the Bookmarks Toolbar, and the Add-on Bar; no Menu Bar option."
FredMcD
  • Top 10 Contributor
4246 izisombululo 59390 izimpendulo
Kuphostiwe

Go back to support.mozilla.org/en-US/products/firefox and press download. If the window says you have the latest, look at the bottom of the window where it says Download Anyway.

Go back to '''''support.mozilla.org/en-US/products/firefox''''' and press download. If the window says you have the latest, look at the bottom of the window where it says '''''Download Anyway'''''.
cor-el
  • Top 10 Contributor
  • Moderator
17472 izisombululo 157918 izimpendulo
Kuphostiwe

Ubuntu 11.xx and later displays window menus in the control bar at the top of the screen with the switch to the Unity window manager.

Try to move the mouse to the top to see if that makes the menu bar appear.

Make sure that you do not run Firefox in full screen mode (press F11 or Fn + F11 to toggle; Mac: Command+Shift+F).

Ubuntu 11.xx and later displays window menus in the control bar at the top of the screen with the switch to the Unity window manager. * http://en.wikipedia.org/wiki/Ubuntu_Unity Try to move the mouse to the top to see if that makes the menu bar appear. Make sure that you do not run Firefox in full screen mode (press F11 or Fn + F11 to toggle; Mac: Command+Shift+F). *https://support.mozilla.org/kb/how-to-use-full-screen

Isisombululo Esikhethiwe

I certainly appreciate all the help I received. I've summarized that help below, in case it can help someone else. I drafted this reply in Gedit, which I'd never used before, and the Alt and "move the mouse to the top" options worked there also.

For me, I will mark this problem as "Solved."

Here is the help I received from -

the-edmeister: "I don't use the Linux distro version, but try hitting the Alt key or F10 and see what happens." (For me Alt worked)

fredmcd-hotmail: "Left click the Firefox symbol, select Options, then STOP. Look at the options menu. You should see the toolbars listed near the bottom. Make sure the bars you want are checked." (I never could find the Firefox symbol!)

fredmcd-hotmail: "Go back to support.mozilla.org/en-US/products/firefox and press download. If the window says you have the latest, look at the bottom of the window where it says Download Anyway." (I had tried that but don't know how to extract and install. I'll ask about that later on.)

cor-el: "Ubuntu 11.xx and later displays window menus in the control bar at the top of the screen with the switch to the Unity window manager ... Try to move the mouse to the top to see if that makes the menu bar appear ... Make sure that you do not run Firefox in full screen mode (press F11 or Fn + F11 to toggle; Mac: Command+Shift+F)." (For me F11 worked; I was not in full screen mode but the F11 toggle was good to know.)

I certainly appreciate all the help I received. I've summarized that help below, in case it can help someone else. I drafted this reply in Gedit, which I'd never used before, and the Alt and "move the mouse to the top" options worked there also. For me, I will mark this problem as "Solved." Here is the help I received from - '''the-edmeister:''' "I don't use the Linux distro version, but try hitting the Alt key or F10 and see what happens." (For me Alt worked) '''fredmcd-hotmail:''' "Left click the Firefox symbol, select Options, then STOP. Look at the options menu. You should see the toolbars listed near the bottom. Make sure the bars you want are checked." (I never could find the Firefox symbol!) '''fredmcd-hotmail:''' "Go back to support.mozilla.org/en-US/products/firefox and press download. If the window says you have the latest, look at the bottom of the window where it says Download Anyway." (I had tried that but don't know how to extract and install. I'll ask about that later on.) '''cor-el:''' "Ubuntu 11.xx and later displays window menus in the control bar at the top of the screen with the switch to the Unity window manager ... Try to move the mouse to the top to see if that makes the menu bar appear ... Make sure that you do not run Firefox in full screen mode (press F11 or Fn + F11 to toggle; Mac: Command+Shift+F)." (For me F11 worked; I was not in full screen mode but the F11 toggle was good to know.)
nerdydad 0 izisombululo 1 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Hi, I had the exact same problem as NewToLinux. I'm using a freshly installed Ubuntu 12.04, which comes with Firefox 23.0, and no easy way to upgrade it.

Hitting ALT or F10 had no effect.

Moving the mouse to the top of screen, as suggested by cor-el, does work. But I find it really unintuitive, so I'd call it a workaround rather than a fix. So I'm still looking for a fix: Is there any way to move the Menu Bar to inside my Firefox window? Or is that bug, or should I say feature, of Ubuntu Unity?

Hi, I had the exact same problem as NewToLinux. I'm using a freshly installed Ubuntu 12.04, which comes with Firefox 23.0, and no easy way to upgrade it. Hitting ALT or F10 had no effect. Moving the mouse to the top of screen, as suggested by cor-el, does work. But I find it really unintuitive, so I'd call it a workaround rather than a fix. So I'm still looking for a fix: Is there any way to move the Menu Bar to inside my Firefox window? Or is that bug, or should I say feature, of Ubuntu Unity?
cor-el
  • Top 10 Contributor
  • Moderator
17472 izisombululo 157918 izimpendulo
Kuphostiwe

You would have to search the Ubuntu help files or try an Ubuntu oriented forum to ask how to disable the Unity feature.

You would have to search the Ubuntu help files or try an Ubuntu oriented forum to ask how to disable the Unity feature. * https://wiki.ubuntu.com/Unity * http://askubuntu.com/questions/29553/how-can-i-configure-unity