Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I am unable to log on to my Comcast e-mail account. When I do, it keeps reverting back to the sign-in page. Like it's in a loop of some sort.

  • 3 uphendule
  • 2 zinale nkinga
  • 1734 views
  • Igcine ukuphendulwa ngu cor-el

more options

Comcast has been making changes to their e-mail for several months. It has affected the way the e-mail works, but the issues are different for different browsers. I have had issues since August. At any rate, this morning I was unable to even log on to the e-mail system via Firefox, but I could get to it via IE.

If you're interested, here's what I posted on their 'internet forum' this morning:

http://forums.comcast.com/t5/E-Mail-and-Xfinity-Connect-Help/E-mail-and-Firefox/td-p/1963071

Isisombululo esikhethiwe

As of 12-21-2013 05:51 PM that Comcast support thread appears to be solved by clearing recent history in Firefox.


I am marking this thread as solved.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (3)

more options

what steps have you performed to resolve this issue so we don't request you to perform things that you already did.

more options

Isisombululo Esikhethiwe

As of 12-21-2013 05:51 PM that Comcast support thread appears to be solved by clearing recent history in Firefox.


I am marking this thread as solved.

Okulungisiwe ngu the-edmeister

more options

Note that such issues are usually caused by corrupted cookies or cookies that are blocked (check the permissions on the about:permissions page).


You can try these steps in case of issues with web pages:

Clear the cache and cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"