X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Hyperlinks problem

Kuphostiwe

All hyperlinks are now opened inside the current window, but not in a new tab. Though, I did not change any settings.

All hyperlinks are now opened inside the current window, but not in a new tab. Though, I did not change any settings.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Google Update
  • Shockwave Flash 11.9 r900
  • 5.1.20913.0
  • HttpWatch Basic - HTTP Viewer for Firefox
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • CryptoPro CAdES NPAPI Browser Plug-in
  • Shockwave Flash 11.4 r402
  • RTS Digital Signature plugin
  • PDF-XChange Viewer Netscape Gecko Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.448

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

Eminye Imininingwane

jscher2000
  • Top 10 Contributor
8583 izisombululo 70216 izimpendulo
Kuphostiwe

That sounds like Firefox's normal behavior. Some comments:

Google Search results There is an option you can set on Google so that results open in a new windows. Firefox will normally divert that into a new tab instead. If you cleared your cookies for Google, you may have lost that setting. More information: https://support.google.com/websearch/.../425.

Tab-related extensions If you were using Tab Mix Plus or another tab-related extension, could you check to see whether it got disabled? You can do that on the Add-ons page. Either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Extensions. Disabled extensions are sorted at the bottom on a gray background.

Sometimes you may need to update extensions manually. Use the "gear" button above the list and choose "Check for Updates".

Any luck?

That sounds like Firefox's normal behavior. Some comments: ''Google Search results'' There is an option you can set on Google so that results open in a new windows. Firefox will normally divert that into a new tab instead. If you cleared your cookies for Google, you may have lost that setting. More information: [https://support.google.com/websearch/answer/425]. ''Tab-related extensions'' If you were using Tab Mix Plus or another tab-related extension, could you check to see whether it got disabled? You can do that on the Add-ons page. Either: * Ctrl+Shift+a * orange Firefox button (or Tools menu) > Add-ons In the left column, click Extensions. Disabled extensions are sorted at the bottom on a gray background. Sometimes you may need to update extensions manually. Use the "gear" button above the list and choose "Check for Updates". Any luck?

Umnikazi wombuzo

Very strange. In google settings page I cheked the option to open search results in a new window. But, still results open inside the current window, what is really frustrating. As for Add-ons, I see there are no such extensions which are somehow connected with tabs.

Very strange. In google settings page I cheked the option to open search results in a new window. But, still results open inside the current window, what is really frustrating. As for Add-ons, I see there are no such extensions which are somehow connected with tabs.

Umnikazi wombuzo

I should have said "inside the current tab", not "inside the current window". So, I guess, what I experience now is not normal for Firefox.

I should have said "inside the current tab", not "inside the current window". So, I guess, what I experience now is not normal for Firefox.

Okulungisiwe ngu vicvolk87

jscher2000
  • Top 10 Contributor
8583 izisombululo 70216 izimpendulo
Kuphostiwe

Hmm, could you test in Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by all extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

Hmm, could you test in Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by all extensions (and some custom settings). More info: [[Troubleshoot Firefox issues using Safe Mode]]. You can restart Firefox in Safe Mode using Help > Restart with Add-ons Disabled In the dialog, click "Start in Safe Mode" (''not'' Reset) Any difference?

Umnikazi wombuzo

I checked it right now. It makes no difference.

I checked it right now. It makes no difference.

Umnikazi wombuzo

The version of FF, that I use, is 25.0.1

The version of FF, that I use, is 25.0.1
jscher2000
  • Top 10 Contributor
8583 izisombululo 70216 izimpendulo
Kuphostiwe

Okay, this is a little nerdy, but...

If you right-click a link in Google -- avoid the bolded part -- and choose Inspect Element (Q), a display should open in the lower part of the page with some HTML highlighted, usually starting with <a.

You can see if Google is properly setting the links to open in a new window because target="_blank" will appear somewhere in the <a> tag line. You might need to use the bottom horizontal scroll bar.

I've attached a screen shot as an example.

  • If the target is missing, either Google is not inserting it or something is stripping it off.
  • If the target is there, Firefox is at fault for not opening the link in a new window or tab. But why??

P.S. The block buttons are from an add-on, you can ignore those.

Okay, this is a little nerdy, but... If you right-click a link in Google -- avoid the bolded part -- and choose Inspect Element (Q), a display should open in the lower part of the page with some HTML highlighted, usually starting with &lt;a. You can see if Google is properly setting the links to open in a new window because '''target="_blank"''' will appear somewhere in the &lt;a> tag line. You might need to use the bottom horizontal scroll bar. I've attached a screen shot as an example. * If the target is missing, either Google is not inserting it or something is stripping it off. * If the target is there, Firefox is at fault for not opening the link in a new window or tab. But why?? ''P.S. The block buttons are from an add-on, you can ignore those.''

Okulungisiwe ngu jscher2000

Umnikazi wombuzo

Hm. There is no "target" property. This is what I get

Hm. There is no "target" property. This is what I get
jscher2000
  • Top 10 Contributor
8583 izisombululo 70216 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Hi vicvolk87, that would explain why Firefox just opens it in the same tab...

In case your Google cookies are corrupted and no longer update correctly, you might want to clear them. If you have any work pending in your Google account (Gmail, Google Docs, etc.), be sure to save that first.

While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Tools menu > Page Info > Security > "View Cookies"
  • click the padlock on the address bar > More Information > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page and going back into Search Settings to turn on "new window" again. Any luck?

Hi vicvolk87, that would explain why Firefox just opens it in the same tab... In case your Google cookies are corrupted and no longer update correctly, you might want to clear them. If you have any work pending in your Google account (Gmail, Google Docs, etc.), be sure to save that first. While viewing a page on the site, try either: * right-click and choose View Page Info > Security > "View Cookies" * Tools menu > Page Info > Security > "View Cookies" * click the padlock on the address bar > More Information > "View Cookies" In the dialog that opens, you can remove the site's cookies individually. Then try reloading the page and going back into Search Settings to turn on "new window" again. Any luck?

Impendulo Ewusizo

Thank you, jscher2000. I followed your advice step by step and got a desired result. Now links open in new tabs.

Thank you, jscher2000. I followed your advice step by step and got a desired result. Now links open in new tabs.