Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Google Play Music won't play songs in Firefox 26 - unresponsive script

  • 5 uphendule
  • 22 zinale nkinga
  • 828 views
  • Igcine ukuphendulwa ngu jesusjones

more options

I just updated to 26 right now. I'm running OSX Mavericks. When I load Google Play Music, I get this:

"A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: https://ssl.gstatic.com/play/music/fe/543c3c4d294e021ba3ec6d51521d224c/listen_extended_b2b52c8b0662c265914c044480fa698eebf4c811.js:474"

Whether I click stop or continue, it makes no difference. All my music shows up, and I can click play, but it doesn't actually play. I shows the equalizer bars or whatever going up and down, but the progress bar doesn't move, so it's not just that it isn't making a sound. I was listening to music twenty minutes ago on 25.1 or whatever the last version was and did not have this issue, so it's definitely a 26 problem. Loading Play Music also hangs the browser for ten seconds or so every time. This blows. Please help.

All Replies (5)

more options

Thank you for reporting this. You could try a little troubleshooting, and/or switch back to Firefox 25.0.1.

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. If you haven't already...

(1) Bypass Firefox's Cache

Use Command+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

Firefox menu > Preferences > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Tools menu > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?


Some privacy-related extensions like DoNotTrackMe may cause problems on sites that distribute content over multiple servers. Could you test in Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled (Flash still works, if applicable)

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?


If you need to install Firefox 25.0.1:

Okulungisiwe ngu jscher2000

more options

Thanks jscher2000. I did all of this to no avail. Reloaded from server, deleted cookies. I'm writing this from safe mode and Firefox still won't play anything from Play Music. I guess I'll go back to 25 for the time being. Hopefully a permanent solution can be found.

more options

Type in "about:config" in the url bar to get to the Firefox config. Use the search at the top of that page to find "media.webaudio.enabled" and click on it to disable it. However, there is a chance that it might break other things.

Otherwise, you might have to go back further than 25... For me it stopped working long before then. No, clearing cache doesn't help.

more options

that last tip solved my problem, everything above did not.

more options

Jgr9, this worked! Thank you!