X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why do I stay logged into Gmail even though browser.sessionstore.privacy_level is set to 1?

Kuphostiwe

When I close my browser I expect not to still be logged in to secure sites (e.g. Gmail) when I reopen it. I know FF stopped this behaviour by default in FF4, so I have set browser.sessionstore.privacy_level to 1 which I believe should enforce this behaviour. However of late Gmail is still logged in when I reopen FF even after a complete shutdown of the computer for a day or so.

I've checked the browser.sessionstore.privacy_level setting and it's still set to 1.

This is definitely happening in in FF 25.0.1 on Ubuntu 13.10. I think it's also happening on my Windows (XP and 7) machines, but don't have them to hand to check.

Any ideas what else I should check?

When I close my browser I expect not to still be logged in to secure sites (e.g. Gmail) when I reopen it. I know FF stopped this behaviour by default in FF4, so I have set browser.sessionstore.privacy_level to 1 which I believe should enforce this behaviour. However of late Gmail is still logged in when I reopen FF even after a complete shutdown of the computer for a day or so. I've checked the browser.sessionstore.privacy_level setting and it's still set to 1. This is definitely happening in in FF 25.0.1 on Ubuntu 13.10. I think it's also happening on my Windows (XP and 7) machines, but don't have them to hand to check. Any ideas what else I should check?

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 11.2 r202
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version: 4.9.1.0
  • DivX Web Player version 1.4.0.233
  • The Videos 3.8.2 plugin handles video and audio streams.
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.

Isisebenziso

  • Firefox 25.0.1
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:25.0) Gecko/20100101 Firefox/25.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/25.0.1/Linux/en-GB/

Izandiso

  • British English Dictionary 1.19.1 (en-GB@dictionaries.addons.mozilla.org)
  • LastPass 3.0.12 (support@lastpass.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Ubuntu Firefox Modifications 2.8 (ubufox@ubuntu.com)
  • Ubuntu Online Accounts 0.5 (online-accounts@lists.launchpad.net)
  • Unity Desktop Integration 2.4.8 (webapps-team@lists.launchpad.net)
  • Unity Websites integration 2013.09.20.beta ({2e1445b0-2682-11e1-bfc2-0800200c9a66})
  • Add to Search Bar 2.2 (add-to-searchbox@maltekraus.de) (Akusebenzi)
  • colorPicker 1.5 (colorPicker@colorPicker) (Akusebenzi)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: X.Org -- Gallium 0.4 on AMD RV620
  • adapterDeviceID: Gallium 0.4 on AMD RV620
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: X.Org
  • driverDate:
  • driverVersion: 3.0 Mesa 9.2.1
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: X.Org -- Gallium 0.4 on AMD RV620
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Okuthandwayo Okulungisiwe

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.privacy_level: 1
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131115105349
  • browser.startup.homepage: http://www.google.co.uk
  • browser.startup.homepage_override.buildID: 20131115105349
  • browser.startup.homepage_override.mstone: 25.0.1
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 25.0.1
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1386250988
  • places.history.expiration.transient_current_max_pages: 78878
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.cpd.downloads: False
  • privacy.cpd.formdata: False
  • privacy.cpd.history: False
  • privacy.cpd.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1384161067

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
titoxproxy 6 izisombululo 68 izimpendulo
Kuphostiwe

Hello Brimfulof,

if you dont want to stay logged in just turn off your history. You can turn it off by pressing Settings > privacy > do not save my history

Do not hesitate to contact us further.

Hello Brimfulof, if you dont want to stay logged in just turn off your history. You can turn it off by pressing ''Settings > privacy > do not save my history '' Do not hesitate to contact us further.
FredMcD
  • Top 10 Contributor
4334 izisombululo 60956 izimpendulo
Kuphostiwe

Unless you log out of a web site, you will remain logged in. Instead of just closing the browser, log out of the sites first.

Unless you log out of a web site, you will remain logged in. Instead of just closing the browser, log out of the sites first.
John99 971 izisombululo 13138 izimpendulo
Kuphostiwe

It appears this is the expected behaviour.

If you allow Firefox to reopen the tabs from last time and one of the https sites was open then regardless of the setting of browser.sessionstore.privacy_level the tab will reopen.

However IF you actually close the tab before closing down Firefox; and then if you re open Firefox and afterwards reopen a HTTPS tab that was open in the prior session then the setting of browser.sessionstore.privacy_level to 1 should have the effect you anticipated i.e you will need to login again.

This issue was discussed previously see

  • firefox is remembering passwords i tell it not to. browser reopens after computer restart and i can still login. it's really annoying.
    /questions/961175
It appears this is the expected behaviour. If you allow Firefox to reopen the tabs from last time and one of the https sites was open then regardless of the setting of browser.sessionstore.privacy_level the tab will reopen. However IF you actually close the tab before closing down Firefox; and then if you re open Firefox and afterwards reopen a HTTPS tab that was open in the prior session then the setting of ''browser.sessionstore.privacy_level'' to ''1'' should have the effect you anticipated i.e you will need to login again. This issue was discussed previously see * ''firefox is remembering passwords i tell it not to. browser reopens after computer restart and i can still login. it's really annoying.'' <br /> [/questions/961175]
cor-el
  • Top 10 Contributor
  • Moderator
17763 izisombululo 160635 izimpendulo
Kuphostiwe

Does setting the browser.sessionstore.privacy_level pref to 2 has the desired effect?

Did you delete all Google cookies after making this change?

What are the cookies settings for Google regarding when they expire and possible allow exceptions (about:permissions and Tools > Page Info > Permissions)?

Does setting the browser.sessionstore.privacy_level pref to 2 has the desired effect? Did you delete all Google cookies after making this change? What are the cookies settings for Google regarding when they expire and possible allow exceptions (about:permissions and Tools > Page Info > Permissions)? *https://support.mozilla.org/kb/how-do-i-manage-website-permissions
bjoern.rob 0 izisombululo 1 izimpendulo
Kuphostiwe

browser.sessionstore.privacy_level 2 does not work. People, please read before answering. Also, deleting the entire history every time is a hassle and rather unprofessional. Even if done automatically you remove functions from your trusty browser.

This issue was annoying me a lot. But there is one solution that worked for me: click your way in FF through tools>options>privacy

Under History there is a box "clear when FF closes" and a button to specify settings. Click that.

In the window click on: cookies, cache and active log-ins for auto-delete, when logged out.

If your system runs like mine this will do the trick until they Mozilla screws up the privacy again. Good luck!

browser.sessionstore.privacy_level 2 does not work. People, please read before answering. Also, deleting the entire history every time is a hassle and rather unprofessional. Even if done automatically you remove functions from your trusty browser. This issue was annoying me a lot. But there is one solution that worked for me: click your way in FF through tools>options>privacy Under History there is a box "clear when FF closes" and a button to specify settings. Click that. In the window click on: cookies, cache and active log-ins for auto-delete, when logged out. If your system runs like mine this will do the trick until they Mozilla screws up the privacy again. Good luck!
jscher2000
  • Top 10 Contributor
8875 izisombululo 72620 izimpendulo
Kuphostiwe

Impendulo Ewusizo

I think there is some confusion about how Google's cookies work and what browser.sessionstore.privacy_level does.

You can allow Google to set two different kinds of cookies:

(1) Persistent cookies ("Keep until: they expire")

These expire on a future date. These cookies are not at all affected by the session restore settings.

(2) Session cookies ("Keep until: I close Firefox")

These cookies expire from the cookie database when you exit Firefox but may be restored if you restore your previous session.

With the default setting of browser.sessionstore.privacy_level=0, these session cookies are kept in your previous session data so that you can return to your prior Google session without logging in again.

With browser.sessionstore.privacy_level=1, session cookies from secure sites are NOT kept in your previous session data. When you restore the Google tab, you should be logged out in that tab (for example, you may get the login screen instead of your inbox).


Rather than flush all your cookies at shutdown, another approach is to set your cookies to be session cookies by default, and then make exceptions for sites where you want to stay logged in from session to session (e.g., forums or other sites that aren't sensitive).

The general setting is on the Privacy tab of the Options/Preferences dialog. Enhanced Tracking Protection in Firefox for desktop.

To set site-specific exceptions, you can use the Exceptions button on the Privacy tab, or use the Page Info dialog while viewing a page on the site. Either:

  • right-click and choose View Page Info > Permissions
  • Tools menu > Page Info > Permissions
  • right the padlock icon in the address bar > More Information > Permissions
I think there is some confusion about how Google's cookies work and what browser.sessionstore.privacy_level does. You can allow Google to set two different kinds of cookies: (1) ''Persistent'' cookies ("Keep until: they expire") These expire on a future date. These cookies are not at all affected by the session restore settings. (2) ''Session'' cookies ("Keep until: I close Firefox") These cookies expire from the cookie database when you exit Firefox but may be restored if you restore your previous session. With the default setting of browser.sessionstore.privacy_level=0, these session cookies are kept in your previous session data so that you can return to your prior Google session without logging in again. With browser.sessionstore.privacy_level=1, session cookies from secure sites are NOT kept in your previous session data. When you restore the Google tab, you should be logged out in that tab (for example, you may get the login screen instead of your inbox). ---- Rather than flush ''all'' your cookies at shutdown, another approach is to set your cookies to be session cookies by default, and then make exceptions for sites where you want to stay logged in from session to session (e.g., forums or other sites that aren't sensitive). The general setting is on the Privacy tab of the Options/Preferences dialog. [[Enable and disable cookies that websites use to track your preferences]]. To set site-specific exceptions, you can use the Exceptions button on the Privacy tab, or use the Page Info dialog while viewing a page on the site. Either: * right-click and choose View Page Info > Permissions * Tools menu > Page Info > Permissions * right the padlock icon in the address bar > More Information > Permissions
cor-el
  • Top 10 Contributor
  • Moderator
17763 izisombululo 160635 izimpendulo
Kuphostiwe

The browser.sessionstore.privacy_level pref applies to storing cookies as part of session data in the sessionstore.js file, so all session data is in one place.
If cookies are stored in sessionstore.js then they will always be restored when tabs are reopened on the next start and you wont get logged off if you leave tabs open when you close Firefox.
It is best to log off and close tabs if you do not want to stay logged in.

The browser.sessionstore.privacy_level pref applies to storing cookies as part of session data in the sessionstore.js file, so all session data is in one place.<br /> If cookies are stored in sessionstore.js then they will always be restored when tabs are reopened on the next start and you wont get logged off if you leave tabs open when you close Firefox.<br /> It is best to log off and close tabs if you do not want to stay logged in.

Okulungisiwe ngu cor-el