X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I get rid of the spinner that appears on the left side on the tabs?

Kuphostiwe

(Firefox 25.0.1, Windows 8)

There's a little green spinner that appears to the left of "Connecting..." on the tabs while loading a page. Any way to get rid of it? It's been quite annoying me for a while.

(Firefox 25.0.1, Windows 8) There's a little green spinner that appears to the left of "Connecting..." on the tabs while loading a page. Any way to get rid of it? It's been quite annoying me for a while.

Okulungisiwe ngu CelticsFan25

Isisombululo esikhethiwe

Windows Explorer is the program used to show folder contents in Windows. It is the program that opened when you used the "Show Folder" button.


You could download the following file to your computer, then edit the file name to delete the -tab-throbber part. Because you are hiding the .css file extension, I think then the file will show as being named userChrome with a file type of CSS file (or similar) and you can move it into your chrome folder.

https://jeffersonscher.com/res/userChrome-tab-throbber.css

(right-click link > Save Link as)

Funda le mpendulo ngokuhambisana nalesi sihloko 1

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Google Update
  • Shockwave Flash 11.9 r900
  • GEPlugin
  • NPWLPG
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

Eminye Imininingwane

Umnikazi wombuzo

Maybe I suggest for the next version, in the Options, there's a preference to hide those spinners.

Maybe I suggest for the next version, in the Options, there's a preference to hide those spinners.
jscher2000
  • Top 10 Contributor
8792 izisombululo 71903 izimpendulo
Kuphostiwe

You can modify many aspects of the Firefox user interface by applying custom style rules. This thread is a bit old now, but most likely, the solution there should still work: FF 4 - Is there any way to disable the connecting/loading animation on the tabs?

You can modify many aspects of the Firefox user interface by applying custom style rules. This thread is a bit old now, but most likely, the solution there should still work: [https://support.mozilla.org/en-US/questions/803029 FF 4 - Is there any way to disable the connecting/loading animation on the tabs?]

Umnikazi wombuzo

I want to get rid of the spinner without ChromEdit Plus mentioned in that thread.

I want to get rid of the spinner '''without''' ChromEdit Plus mentioned in that thread.
jscher2000
  • Top 10 Contributor
8792 izisombululo 71903 izimpendulo
Kuphostiwe

You can manually create/edit the userChrome.css file. Here's how.

(1) Find (or create) the chrome folder. This is a folder in your currently active Firefox settings folder, also known as your Firefox profile folder.

  • Open the your profile folder using: Help > Troubleshooting Information
    • Windows: Click the "Show Folder" button
    • Mac: Click the "Show in Finder" button
  • Check for a chrome folder.
    • If it exists: double-click it to open it.
    • If it does not exist: create a chrome folder, then double-click it to open it.

(2) Create or Edit a userChrome.css file by adding your style rule.

  • Check for a userChrome.css file in the chrome folder.
    • If it exists: open it in a text editor. Check that it has this first line:

      @namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);

      Then add the following lines and save the file:

      .tab-throbber { display: none !important }
       
    • If it does not exist: create a new text file named userChrome.css. (In Windows, right-click and choose New > Text Document and change the name to userChrome.css.) Then see the previous step for what to place in the file.

The rule change should take effect the next time you start Firefox.

Note: I find it easier to use the Stylish extension, but if you don't want yet another extension, then userChrome.css makes the most sense.

You can manually create/edit the userChrome.css file. Here's how. (1) Find (or create) the chrome folder. This is a folder in your currently active Firefox settings folder, also known as your Firefox profile folder. * Open the your profile folder using: Help > Troubleshooting Information ** Windows: Click the "Show Folder" button ** Mac: Click the "Show in Finder" button * Check for a chrome folder. ** If it exists: double-click it to open it. ** If it does not exist: create a chrome folder, then double-click it to open it. (2) Create or Edit a userChrome.css file by adding your style rule. * Check for a userChrome.css file in the chrome folder. ** If it exists: open it in a text editor. Check that it has this first line:<br><br>@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);<br><br>Then add the following lines and save the file:<br><br>.tab-throbber { display: none !important }<br> &nbsp; ** If it does not exist: create a new text file named userChrome.css. (In Windows, right-click and choose New > Text Document and change the name to userChrome.css.) Then see the previous step for what to place in the file. The rule change should take effect the next time you start Firefox. Note: I find it easier to use the Stylish extension, but if you don't want yet another extension, then userChrome.css makes the most sense.
cor-el
  • Top 10 Contributor
  • Moderator
17575 izisombululo 158975 izimpendulo
Kuphostiwe

See also:

Make sure that Windows doesn't add a hidden .txt file extension, so use "All files" when saving the userChrome.css file.

See also: *http://kb.mozillazine.org/Editing_configuration Make sure that Windows doesn't add a hidden .txt file extension, so use "All files" when saving the userChrome.css file. *http://kb.mozillazine.org/Editing_configuration/Troubleshooting

Umnikazi wombuzo

Jscher2000, I tried your method but it didn't work even after restarting Firefox.

Jscher2000, I tried your method but it didn't work even after restarting Firefox.
cor-el
  • Top 10 Contributor
  • Moderator
17575 izisombululo 158975 izimpendulo
Kuphostiwe

Did you verify that the file is a CSS file and not a text file or other file type?

Note that Windows hides some file extensions by default.
Among them are .html and .ini and .js and .txt, so you may only see a name without file extension. You can see the real file extension (type) if you open the Properties of the file via the right-click context menu.

Also make sure that you save the file as plain text.

Can you post the content of the userChrome.css file?

Did you verify that the file is a CSS file and not a text file or other file type? Note that Windows hides some file extensions by default.<br /> Among them are .html and .ini and .js and .txt, so you may only see a name without file extension. You can see the real file extension (type) if you open the Properties of the file via the right-click context menu. Also make sure that you save the file as plain text. Can you post the content of the userChrome.css file?

Okulungisiwe ngu cor-el

Umnikazi wombuzo

Cor-El:

Content of userChrome.css:

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);
#throbber-box {
display: none !important;
}

rightclicking on userchrome.css, clicking properties, I found out it was a text (txt).

Cor-El: Content of userChrome.css: @namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); #throbber-box { display: none !important; } rightclicking on userchrome.css, clicking properties, I found out it was a text (txt).

Okulungisiwe ngu CelticsFan25

Umnikazi wombuzo

I also decided to download Chromedit plus and have

font-weight: normal;
font-size: 12px;
font-family: verdana;
color: #000000;
-moz-appearance: none !important;
background: #f5f5f5;
#throbber-box { display: none !important; }
I also decided to download Chromedit plus and have font-weight: normal; font-size: 12px; font-family: verdana; color: #000000; -moz-appearance: none !important; background: #f5f5f5; #throbber-box { display: none !important; }

Okulungisiwe ngu CelticsFan25

Umnikazi wombuzo

and plus, after Googling "Disable Throbber in Firefox", after visiting two or three unhelpful blogs, accidently clicking a link to URL: http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul , and creating those folders and files manually, I'm worried my computer might have a virus.

Windows 8 and Windows Defender would let me know if I have a virus, but just in case if it doesn't detect one, I'm worried.

and plus, after Googling "Disable Throbber in Firefox", after visiting two or three unhelpful blogs, accidently clicking a link to URL: http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul , and creating those folders and files manually, I'm worried my computer might have a virus. Windows 8 and Windows Defender would let me know if I have a virus, but just in case if it doesn't detect one, I'm worried.

Okulungisiwe ngu CelticsFan25

Umnikazi wombuzo

First, I manually created the folder "chrome" and text document "userChrome.css" .

After that, I deleted both and downloaded Chromedit plus. Then I recreated those files and folders, uninstalled and reinstalled Chromedit plus, copied and pasted the code to remove throbber, but it didn't work.

First, I manually created the folder "chrome" and text document "userChrome.css" . After that, I deleted both and downloaded Chromedit plus. Then I recreated those files and folders, uninstalled and reinstalled Chromedit plus, copied and pasted the code to remove throbber, but it didn't work.

Okulungisiwe ngu CelticsFan25

cor-el
  • Top 10 Contributor
  • Moderator
17575 izisombululo 158975 izimpendulo
Kuphostiwe

You need to use the code that is posted above and use .tab-throbber (it is a class name) for the selector.
The #throbber-box ID doesn't exist.

.tab-throbber { display: none !important }
You need to use the code that is posted above and use .tab-throbber (it is a class name) for the selector.<br /> The #throbber-box ID doesn't exist. <pre><nowiki>.tab-throbber { display: none !important }</nowiki></pre>

Umnikazi wombuzo

In the Chromedit plus it currently looks like:

font-weight: normal;
font-size: 12px;
font-family: verdana;
color: #000000;
-moz-appearance: none !important;
background: #f5f5f5;
.tab-throbber { display: none !important }

and in userChrome.css:

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);
.tab-throbber { display: none !important }

and the green throbber is still there.

In the Chromedit plus it currently looks like: font-weight: normal; font-size: 12px; font-family: verdana; color: #000000; -moz-appearance: none !important; background: #f5f5f5; .tab-throbber { display: none !important } and in userChrome.css: @namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); .tab-throbber { display: none !important } and the green throbber is still there.

Okulungisiwe ngu CelticsFan25

jscher2000
  • Top 10 Contributor
8792 izisombululo 71903 izimpendulo
Kuphostiwe

I personally have no patience with the edit, restart Firefox, edit, restart Firefox... cycle required to test rule changes in userChrome.css. I tested the rule in Stylish, and it worked in Stylish, so it should work in userChrome.css.

Could you double-check that you have the file name correct? It may help to unhide file extensions: http://support.microsoft.com/kb/865219

I personally have no patience with the edit, restart Firefox, edit, restart Firefox... cycle required to test rule changes in userChrome.css. I tested the rule in Stylish, and it worked in Stylish, so it should work in userChrome.css. Could you double-check that you have the file name correct? It may help to unhide file extensions: http://support.microsoft.com/kb/865219
cor-el
  • Top 10 Contributor
  • Moderator
17575 izisombululo 158975 izimpendulo
Kuphostiwe

When Chromedit Plus shows something different then what you have in userChrome.css then either the userChrome.css file is in the wrong folder or the file has a wrong file extension (i.e. is not a .css file).

Do you see both files in the chrome folder in the Firefox profile folder?

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)

What you see in Chromedit Plus is not correct as the first six lines are CSS properties that need to be enclosed between curly brackets {}, so you can remove all lines and replace them with the current of the not working userChrome.css file.

These lines are CSS properties:

font-weight: normal;
font-size: 12px;
font-family: verdana;
color: #000000;
-moz-appearance: none !important;
background: #f5f5f5;
When Chromedit Plus shows something different then what you have in userChrome.css then either the userChrome.css file is in the wrong folder or the file has a wrong file extension (i.e. is not a .css file). Do you see both files in the chrome folder in the Firefox profile folder? *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) ---- What you see in Chromedit Plus is not correct as the first six lines are CSS properties that need to be enclosed between curly brackets {}, so you can remove all lines and replace them with the current of the not working userChrome.css file. These lines are CSS properties: <pre><nowiki>font-weight: normal; font-size: 12px; font-family: verdana; color: #000000; -moz-appearance: none !important; background: #f5f5f5; </nowiki></pre>

Okulungisiwe ngu cor-el

Umnikazi wombuzo

I use Help - Troubleshooting Information - Show Folder and thats where chrome folder appears.

I use Help - Troubleshooting Information - Show Folder and thats where chrome folder appears.

Umnikazi wombuzo

Userchrome.css has currently:

font-weight: normal;
font-size: 12px;
font-family: verdana;
color: #000000;
-moz-appearance: none !important;
background: #f5f5f5;
.tab-throbber { display: none !important }

and it's still there. The Microsoft article provides help for Windows 7 and previous versions, and I use Windows 8.

Userchrome.css has currently: font-weight: normal; font-size: 12px; font-family: verdana; color: #000000; -moz-appearance: none !important; background: #f5f5f5; .tab-throbber { display: none !important } and it's still there. The Microsoft article provides help for Windows 7 and previous versions, and I use Windows 8.

Okulungisiwe ngu CelticsFan25

jscher2000
  • Top 10 Contributor
8792 izisombululo 71903 izimpendulo
Kuphostiwe

Hi CelticsFan25, you wrote:

The Microsoft article provides help for Windows 7 and previous versions, and I use Windows 8.

There are some differences, but are you sure you can't find either of these when viewing your chrome folder?

  • Organize button > Folder and search options
  • (tap the Alt key to show the classic menu bar) Tools > Folder Options

If not, I leave it to you to explore Microsoft's website for an updated article.


Also, Userchrome.css must be named userChrome.css and it's not valid to have a bunch of style rules sitting on their own lines without a selector showing what they apply to. Try deleting everything except the following:

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);
.tab-throbber { display: none !important }
Hi CelticsFan25, you wrote: <blockquote>The Microsoft article provides help for Windows 7 and previous versions, and I use Windows 8.</blockquote> There are some differences, but are you sure you can't find either of these when viewing your chrome folder? * Organize button > Folder and search options * (tap the Alt key to show the classic menu bar) Tools > Folder Options If not, I leave it to you to explore Microsoft's website for an updated article. ---- Also, Userchrome.css must be named userChrome.css and it's not valid to have a bunch of style rules sitting on their own lines without a selector showing what they apply to. Try deleting everything except the following: @namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); .tab-throbber { display: none !important }
cor-el
  • Top 10 Contributor
  • Moderator
17575 izisombululo 158975 izimpendulo
Kuphostiwe

The only thing that matters is that the file has the correct userChrome.css name (case sensitive) and that the file is in the correct location.

Did you check the Properties of the file via the right-click context menu to make sure that the type is Cascading Stylesheet?

The only thing that matters is that the file has the correct userChrome.css name (case sensitive) and that the file is in the correct location. Did you check the Properties of the file via the right-click context menu to make sure that the type is Cascading Stylesheet?

Umnikazi wombuzo

I used to have userChrome.css

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);
.tab-throbber { display: none !important }

and the throbber was still there.

I used Help - Troubleshooting Information - show Folder - chrome - userChrome.css - right click and choose Properties - it was a Text document not a CSS file.

I used to have userChrome.css @namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); .tab-throbber { display: none !important } and the throbber was still there. I used Help - Troubleshooting Information - show Folder - chrome - userChrome.css - right click and choose Properties - it was a Text document not a CSS file.