Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Video with JWPlayer does load, but won't play and no error message (as plug-in needed) apear. What's the problem?

  • 6 uphendule
  • 86 zinale nkinga
  • Igcine ukuphendulwa ngu cor-el

more options

video's with JWPlayer start loading but won't play and stay black with a rolling wheel. The player is shown and even full screen can be activated. There is no message for a missing plug-in.

All Replies (6)

more options

Is it site specific? Does the video on the JWPlayer home page work?

For me, the page uses a <video> tag to invoke the built-in HTML5 player, no plugin required. However, this presumably varies from browser to browser based on configuration.

more options

Thanks jsher. The video on the JWPlayer does work. So the bug is the website I'm visiting to view the video, I presume? In Safari all is doing well.

more options


I am glad to hear that your problem has been resolved.

If you have not already, please mark this thread as solved by marking the solution.
This will help other users experiencing similar problems find help faster and more efficiently.

I hope you continue using our products and thank you for contacting Mozilla Support.

more options

Hi aleid, thanks for testing that.

There might be an issue with the site, for example, not keeping up with changes in Firefox, or there might be a permission or extension setting in your Firefox that is blocking something needed to play the video. Often videos are hosted on different servers than the main web page, and information is transferred between the servers, so privacy-related settings (such as third party cookies) and add-ons (such as anti-tracking extensions) could be a factor.

Could you try the site in Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

more options

Hi jscher, it doesn't make any difference. I tried but the video won't play. In Safari however it does work.

more options

Do you see an error message about this in the Web Console (Firefox/Tools > Web Developer;Command+Shift+K)?

Is there a shield or other extra icon on the left end of the location bar indicating that content is blocked?