X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Fix downloaded files permissions on Windows 7

Kuphostiwe

Almost every time I download a file from various sources, Firefox adds a padlock to the downloaded file icon. This means that the file can only be accessed by the current user unless I change back the file permissions manually. Is there any way of stop the downloads from changing their file permissions? I've only noticed this happening for a week or so, currently I'm on Firefox beta 26.0

Almost every time I download a file from various sources, Firefox adds a padlock to the downloaded file icon. This means that the file can only be accessed by the current user unless I change back the file permissions manually. Is there any way of stop the downloads from changing their file permissions? I've only noticed this happening for a week or so, currently I'm on Firefox beta 26.0

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.9 r900
  • Next Generation Java Plug-in 10.40.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 5.1.20913.0
  • VLC media player Web Plugin 2.0.6
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.3"
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.8.638
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.7.637
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.6.636
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • NPWLPG
  • QUAKE LIVE
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • 6.0.12.448
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • Office Authorization plug-in for NPAPI browsers
  • Unity Player 2.6.1f3
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DivX® Web Player
  • np-mswmp
  • Yahoo! activeX Plug-in Bridge

Isisebenziso

  • Firefox 26.0
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Windows NT 6.1; rv:26.0) Gecko/20100101 Firefox/26.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/26.0/WINNT/es-MX/

Izandiso

  • Adblock Plus 2.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Greasemonkey 1.12 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Default Manager 2.2 ({3252b9ae-c69a-4eaf-9502-dc9c1f6c009e}) (Akusebenzi)
  • HP Smart Web Printing 4.0 (smartwebprinting@hp.com) (Akusebenzi)
  • Java Quick Starter 1.0 (jqs@sun.com) (Akusebenzi)
  • PC Sync 2 Synchronisation Extension 1.0.0.732 (bkmrksync@nokia.com) (Akusebenzi)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: ATI Radeon HD 4300/4500 Series
  • adapterDescription2:
  • adapterDeviceID: 0x954f
  • adapterDeviceID2:
  • adapterDrivers: aticfx32 aticfx32 atiumdag atidxx32 atiumdva
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 11-16-2012
  • driverDate2:
  • driverVersion: 8.970.100.7000
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Radeon HD 4300/4500 Series Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Okuthandwayo Okulungisiwe

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.search.openintab: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131114085019
  • browser.startup.homepage_override.buildID: 20131114085019
  • browser.startup.homepage_override.mstone: 26.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 26.0
  • gfx.direct3d.last_used_feature_level_idx: 0
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 40249
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
patrickmc
  • Administrator
  • Moderator
35 izisombululo 224 izimpendulo
Kuphostiwe

Hello ilovecookiez,

Thank you for contacting Mozilla Support. It sounds like you may have installed Firefox from a limited user account.

  • Navigate to C:\Program Files\Mozilla Firefox or C:\Program Files (x86)\Mozilla Firefox depending on where you installed it.
  • Right-click firefox.exe, click Properties and then the Security tab.

This should tell you which User has rights to Firefox.

  • Is this the user you're currently logged in as?
  • If you're logged in as the user who has permissions to firefox.exe, are that User's permissions limited in anyway?

I hope this helps identify what is causing the issue. Please let us know if you require more assistance.

Cheers, Patrick

Hello ilovecookiez, Thank you for contacting Mozilla Support. It sounds like you may have installed Firefox from a limited user account. * Navigate to C:\Program Files\Mozilla Firefox or C:\Program Files (x86)\Mozilla Firefox depending on where you installed it. * Right-click firefox.exe, click Properties and then the Security tab. This should tell you which User has rights to Firefox. * Is this the user you're currently logged in as? * If you're logged in as the user who has permissions to firefox.exe, are that User's permissions limited in anyway? I hope this helps identify what is causing the issue. Please let us know if you require more assistance. Cheers, Patrick
cor-el
  • Top 10 Contributor
  • Moderator
17687 izisombululo 160003 izimpendulo
Kuphostiwe

Impendulo Ewusizo

You can try to set the browser.download.manager.scanWhenDone pref to false on the about:config page to prevent Firefox from adding zone identifier data to the downloaded files.

See:

You can try to set the browser.download.manager.scanWhenDone pref to false on the <b>about:config</b> page to prevent Firefox from adding zone identifier data to the downloaded files. See: *http://kb.mozillazine.org/Unable_to_save_or_download_files

Umnikazi wombuzo

All the accounts on my computer are set as Administrator. I've tried both solutions but none of them did anything at all. What I tried doing was changing the default downloading folder from Desktop to the Downloads folder and the files stopped showing that darn padlock.

Still, I'm used to download my files directly to my Desktop since FF 1.6, and as I said this doesn't happen on IE so the issue must be (somehow) related to Firefox downloading files on my desktop.

All the accounts on my computer are set as Administrator. I've tried both solutions but none of them did anything at all. What I tried doing was changing the default downloading folder from Desktop to the Downloads folder and the files stopped showing that darn padlock. Still, I'm used to download my files directly to my Desktop since FF 1.6, and as I said this doesn't happen on IE so the issue must be (somehow) related to Firefox downloading files on my desktop.
vontood 0 izisombululo 2 izimpendulo
Kuphostiwe

Please post a fix for this problem. I removed the option where it asks to "always ask me where to save files" and made it save to my default test directory and I noticed that the files did not have a padlock on them and other users on my network could see them. I checked my shares on the directory where the padlock shows up and it is fine. Other users can see all other items in this directory except for the files I am saving from Firefox that have a padlock on them. Please post a fix for this asap or I am going to be forced to change browsers. This problem has already put me back an hours worth of work today.

Please post a fix for this problem. I removed the option where it asks to "always ask me where to save files" and made it save to my default test directory and I noticed that the files did not have a padlock on them and other users on my network could see them. I checked my shares on the directory where the padlock shows up and it is fine. Other users can see all other items in this directory except for the files I am saving from Firefox that have a padlock on them. Please post a fix for this asap or I am going to be forced to change browsers. This problem has already put me back an hours worth of work today.
vontood 0 izisombululo 2 izimpendulo
Kuphostiwe

In order to remove the padlock in windows 7, I went to windows explorer and highlighted all the files then right clicked and went to share. A side window opens up and that shows the padlock with nobody next to it and a couple other choices. I selected my homegroup with read and write access and then the padlock was removed. I still have no figured out how to tell firefox not to save it with a nobody share attribute which is what it is doing.

In order to remove the padlock in windows 7, I went to windows explorer and highlighted all the files then right clicked and went to share. A side window opens up and that shows the padlock with nobody next to it and a couple other choices. I selected my homegroup with read and write access and then the padlock was removed. I still have no figured out how to tell firefox not to save it with a nobody share attribute which is what it is doing.
jscher2000
  • Top 10 Contributor
8837 izisombululo 72222 izimpendulo
Kuphostiwe

Hi vontood, thank you for posting the results of your investigation. I've done some more research and filed new bug: Bug 953317 – File permissions not inherited for Firefox 26 downloads on Windows.

To help move this bug along, you can register on Bugzilla and "vote" for it. However, it's generally not helpful to add comments to bugs unless the developers put out a call for more information. See:

Hi vontood, thank you for posting the results of your investigation. I've done some more research and filed new bug: [https://bugzilla.mozilla.org/show_bug.cgi?id=953317 Bug 953317 – File permissions not inherited for Firefox 26 downloads on Windows]. To help move this bug along, you can register on Bugzilla and "vote" for it. However, it's generally not helpful to add comments to bugs unless the developers put out a call for more information. See: * [https://bugzilla.mozilla.org/page.cgi?id=etiquette.html Bugzilla Etiquette] * [https://bugzilla.mozilla.org/page.cgi?id=voting.html Voting]
jscher2000
  • Top 10 Contributor
8837 izisombululo 72222 izimpendulo
Kuphostiwe

Forgot to mention that a related bug thought to affect only Linux and Mac is supposed to be fixed in Firefox 27 (Firefox beta): Bug 919076 – Saved files permissions set incorrectly on Linux and Mac. I haven't tested whether that also fixes this problem on Windows. If anyone wants to try it...

Forgot to mention that a related bug thought to affect only Linux and Mac is supposed to be fixed in Firefox 27 (Firefox beta): [https://bugzilla.mozilla.org/show_bug.cgi?id=919076 Bug 919076 – Saved files permissions set incorrectly on Linux and Mac]. I haven't tested whether that also fixes this problem on Windows. If anyone wants to try it...