On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Solution to Flash crash that seems to work!

  • 25 uphendule
  • 632 zinale nkinga
  • Igcine ukuphendulwa ngu MauriceSnell

more options

Like others I am tearing my hair out over repeated Flash crashes (FF25.0, win 8.1).No matter what updates etc - you get the idea....

One solution deep in help is 'Re-initializing the plugins database'. This really works but I wonder is there some way I could run this each time I start up Firefox to pre-empt the problem with Flash?

Like others I am tearing my hair out over repeated Flash crashes (FF25.0, win 8.1).No matter what updates etc - you get the idea.... One solution deep in help is 'Re-initializing the plugins database'. This really works but I wonder is there some way I could run this each time I start up Firefox to pre-empt the problem with Flash?

All Replies (20)

more options

Recent crashes of certain multimedia contents (this includes Youtube videos, certain flash games and other applications) in conjunction with Firefox are most probably caused by a recent Flash update and/or a malfunctioning browser plugin such as Real Player.

In order to remedy the problem, please perform the steps mentioned in these Knowledge Base articles:

Other, more technical information about these issues can be found under these Links:

Please tell us if this helped!

more options

The above suggestions provide only a temporary solution. I can download latest flash, latest real player etc etc but the only solution is to delete the pluinreg.dat file as described in 'Re-initializing the plugins database'.

When the problem recurs I delete the file again. Perhaps this gives a clue to the origin of the problem which afflicts many of us?

more options

I have this problem in that whenever Flash runs, my browser (Firefox 25.0) becomes unresponsive. It unfreezes at maybe 5 second intervals for 0.2 seconds but that doesn't help me much. This is after the upgrade to Windows 8.1 (which BTW is otherwise a great upgrade!) that I did on 9th November. I believe I have been running Firefox 25.0 longer and didn't notice it before. This is the 64-bit version of Windows 8.1. I tried updating Flash (from 11_9_900_117 to 11_9_900_152), but that didn't help. I tried disabling Flash Player's Protected Mode as desribed here http://forums.adobe.com/thread/1018071?tstart=0 but that didn't help. I tried disabling HardwareAcceleration as desribed here http://forums.adobe.com/message/5808165 but that didn't help.

The problem is mitigated for me because I have NoScript installed and configured to not run Flash automatically even for trusted sites. So I only get the freeze when I click a flash object to get it to play. (I also tried disabling NoScript in case it was causing problems, but that only resulted in an immediate freeze on start-up as MSN's homepage has flash in it!)

I also tried re-initializing the plugins database as desribed here https://support.mozilla.org/en-US/kb/troubleshoot-issues-with-plugins-fix-problems#w_re-initializing-the-plugins-database, but that didn't make any difference for me.

Probably the only things I haven't tried are rebooting and downgrading Flash.

OK, I tried rebooting, Windows installed updates, I checked for more updates, and there was 1 more recommended one, so I installed that and rebooted and anyway, the problem is still there with Flash.

more options

P.S. Flash works fine in IE11.

My suggestion for now in Firefox is:

  1. Install NoScript from here: https://addons.mozilla.org/en-US/firefox/addon/noscript/
  2. Configure it like so: Enable Scripts Globally ('dangerous'), but less dangerous that not having NoScript installed... And on the Embeddings tab, enable 'Apply these restrictions to whitelisted sites too'.
  3. Now most flash objects will be visible on the page but you have to click them to play them. If something is not working check under Blocked Objects in the NoScript menu in the Addon-Bar and enable as appropriate.
more options

One more thing I noticed: In Task Manager, Details, the PID of plugin-container.exe keeps changing. It looks like it is crashing and then getting restarted automatically. This is perhaps what is causing the unresponsiveness in Firefox.

more options

I followed your helpful suggestion on NoScript. It solved the problem of running You Tube et al with latest Flash build/Firefox 25/win8.1 x64 upgrade but it caused so many other difficulties with Firefox that I disabled it. At the moment I am forced to use Chrome to view Flash movies where it works perfectly. However Firefox remains my browser of choice for other reasons so any other input welcome

more options

I've been dealing with this problem and various fixes for months. It affects a Vista Pro desktop and a couple of older XP laptops.

I believe that at this moment there is NO solution and all the instructions about downloading this, installing that, deleting various configuration related files, updating something else are useless and serious time wasters.

I have, however, found a workaround that is acceptable to me and my be acceptable to others. You set it up in seconds and have to do an extra couple of clicks now and then as you browse around.

I went to the Add-ons in Firefox and set Flash as "Ask to Activate." Then when a Flash opportunity comes up, you'll see a black box, the Lego-like icon, and an Activate Adobe Flash message. If it appears to be something you care to view, click the box, choose Activate Now. (I haven't tried Activate and Remember. That may be asking for trouble.)

Since doing this, I've had NO Flash vs Firefox crashes. My guess is that those may mostly be caused by crappily coded ads that I don't need or want to see anyway.

more options

bfotk - regretefully I have to conclude you are correct. As we British say, Firefox's relationship with Flash is c**p and cannot be fixed until Mozilla addresses an issue which has affected the Firefox browser for some considerable time.

I like the idea of Firefox as a self-help community but when it affects my ability to work and starts to impinge on other programs just because I open the Firefox browser then I'm off to Chrome.

Send me a mail when it's fixed. Meanwhile - hello Googgle!

more options

For users of Windows Vista, Windows 7, and Windows 8, make sure to disable the protected mode feature of the Flash Player plugin. While it has theoretical security benefits, it remains buggy.

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

More detailed steps if you run into permission issues editing the mms.cfg file:

(1) In a My Computer or Windows Explorer window, open this folder:


If that folder does not exist, then you are using 32-bit Windows, and you can open the following folder instead:


(Note: This folder exists on both 32-bit and 64-bit Windows, but on 64-bit Windows Firefox uses the Flash player in the SysWOW64 folder instead.)

(2) Check for a file named mms.cfg:

(A) If mms.cfg exists, drag it to your Documents folder where you can edit it without being bothered about administrator privileges

(B) If mms.cfg does not exist, open your Documents folder, right-click > New > Text File and name the new file "mms.cfg" (putting quotation marks around the file name help prevent Windows from tacking .txt onto the end)

(3) Open mms.cfg from Documents into a text editor such as Notepad. Add this on its own line (I put it last):


Save the file and close Notepad.

(4) Hold down the Ctrl key and drag the mms.cfg file back to the Flash folder to make a copy there, keeping the original in Documents

This change should take effect the next time you exit and restart Firefox.

more options

"This change should take effect..."

In other words, after going through the process, the changes made may or may not have any effect.

No thanks.

I know that for me the simple step above has not failed me. Perhaps it will someday. If it does, I might try another multi-step program. So far, I've worked through at least three of them with no effect.

more options

Thanks for your understanding words. Yes, perhaps someday the bug or bugs will be identified and fixed by Mozilla or Adobe or both. In the meantime, a pox on both their houses.

more options

Firefox is working again for me as before. I reverted both firefox (to 25.0b12) and Shockwave Flash (to 11.7.700.242) as a temporal solution until future updates fix the issue.

Revert Firefox:

1) Turn off automatic update in Firefox -> Options -> Advanced -> Update tab -> Firefox Update

2) Download 'Firefox Setup 25.0b12' (22M) from link below and install it as an update: https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/25.0b12/win32/en-US/

Revert Shockwave Flash:

3) Download flash "uninstaller" and uninstall currently installed flash player: http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html

4) Download and install "Flash Player 11.7.700.242 (140.32 MB) (Released 9/10/2013)" from: http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html

Hopefully this should work for you.

Okulungisiwe ngu MC_MC

more options

Thanks MC_MC this solution really works!

I know this because after following your instructions above I did not properly turn off automatic updates to Firefox and ver 26.0 was installed. Immediately Flash started crashing again. However, when I reverted to Firefox 25.0b12 as you recommended and reinstalled Flash Player 11.7.700.242 (140.32 MB) (Released 9/10/2013) everything started working again.

It's important to select the correct button to ensure Firefox will not install an update. On the Firefox orange tab -> Options -> Options ->Advanced -> Update tab -> Firefox Update->Never check for Updates

Let's hope Mozilla takes this on board and finds a solution quickly as although Flash works we are not benefiting from new security patches while this option is invoked

more options

I spoke too soon!

Flash crashed again using your combination and despite re-installing once more my only solution is to use Chrome for videos - wher it has always worked without fail.

Any other suggestions?

more options

Hi farci, when Flash crashes, Firefox usually records information about what was happening at that moment. You can submit that data to Mozilla and share it with forum volunteers to see whether it points to the solution. Please check the support article "Troubleshoot Firefox crashes (closing or quitting unexpectedly)" (especially the last section) for steps to get those crash IDs, and then post some of the recent ones here.

more options

I found a solution to the flash player crashes within Firefox, and have not had a single flash playser crash in 6 months at least. The solution involves creating a task to run at regular intervals to delete certain prefetch files. NOT all of them as it is NOT necessary to delete them all.

I have wrote a script that will create the folder structer in programdata/scripts/ and place the exe that actually does the deleting, and have successfully imported the task into task scheduler.

This should resolve all Flash player crashes within Firefox. I posted the information here, and a couple threads up: https://support.mozilla.org/en-US/questions/968190?page=6#answer-51113 2

That script is not 100% Automated in the above link, but will get you started.

I have one that i have been able to fully automate, You would just need to check task scheduler in Windows 7 to confirm it will successfully import on its own.

I am looking for testers to confirm this works. This should work on windows 7 64 and 32 bit. Not tested on Windows 8

link for fix available upon private message request

Best regards

Okulungisiwe ngu Carm

more options

I decided to go public with my solutions as they will work for some people. I outlined it all out.

Simply click my user name here and hen click the link to my blog where i lay it all out

more options

jscher200 This worked for me after I closed FF and opened again thank you very much. I can go back to to using my favorite browser. I will reboot and see if this solution continues to work. BTW here is the issue that I had and your solution corrected as of now. https://support.mozilla.org/en-US/search?a=1&asked_by=mghpgh&sortby=1&w=2

Should I post your solution to my question in the hope that it may help others with similar issues?

more options

Hi mghpgh, yes, it sounds weird, but please reply to yourself with the solution in the other thread. All are potentially equal in the eyes of Google, so if someone finds yours first, they'll have the complete package there. Or I guess could post it because I'm a little more familiar with how to do links on this site.

more options

jscher2000, I love you! Where do I send the check? The protected mode thingy was the problem!

Now why in the hell can't Firefox and Flash fix this simple problem after all these months/ years? This is total BS.

  1. 1
  2. 2